]> git.pld-linux.org Git - packages/amarok.git/blame - amarok.spec
- fix python search
[packages/amarok.git] / amarok.spec
CommitLineData
8d75a549 1#
948e9545 2# Conditional builds:
48801ec3 3%bcond_without arts # disable arts engine
8d75a549 4%bcond_without gstreamer # disable gstreamer
7dae3fc2 5%bcond_without xine # disable xine engine
48801ec3 6%bcond_without xmms # disable xmms wrapping
60b883ee 7%bcond_with mysql # enable mysql support
d4535bda 8#
60b883ee 9
3dce540f 10Summary: A KDE audio player
11Summary(pl): Odtwarzacz audio dla KDE
12Name: amarok
33577a3c 13Version: 1.2.3
f2f66851 14Release: 1
3dce540f 15License: GPL
16Group: X11/Applications/Multimedia
2f119dd8 17Source0: http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
33577a3c 18# Source0-md5: 0082f47cb4503afc7d8e671cfd5cb983
567ab89c 19URL: http://amarok.kde.org/
6fc2033f 20BuildRequires: SDL-devel
21BuildRequires: alsa-lib-devel
22BuildRequires: arts-qt-devel
23BuildRequires: automake
60b883ee
SP
24%{?with_gstreamer:BuildRequires: gstreamer-plugins-devel >= 0.8.1}
25BuildRequires: kdebase-devel
7e861195 26BuildRequires: kdemultimedia-akode
ac33bc29 27BuildRequires: kdemultimedia-devel >= 9:3.1.93
6fc2033f 28BuildRequires: libmusicbrainz-devel
29BuildRequires: libvisual-devel >= 0.2.0
30BuildRequires: pcre-devel
3022f84e 31BuildRequires: rpmbuild(macros) >= 1.129
43342c86 32BuildRequires: sed >= 4.0
48801ec3 33BuildRequires: sqlite3-devel
60b883ee
SP
34BuildRequires: taglib-devel >= 1.3.1
35#BuildRequires: unsermake >= 040511
36%{?with_xine:BuildRequires: xine-lib-devel >= 2:1.0-0.rc5.0}
37%{?with_xmms:BuildRequires: xmms-devel}
38%{?with_mysql:BuildRequires: mysql-devel}
39#BuildRequires: kdebindings-kjsembed-devel
48801ec3 40Requires: %{name}-plugin = %{version}-%{release}
3dce540f 41Requires: kdebase-core >= 9:3.1.93
60b883ee 42Requires: kdemultimedia-audiocd >= 9:3.1.93
3dce540f 43BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45%description
46A KDE audio player.
47
48%description -l pl
49Odtwarzacz audio dla KDE.
50
48801ec3 51%package arts
52Summary: Plugin arts
53Summary(pl): Wtyczka arts
54Group: X11/Applications/Multimedia
55Requires: %{name} = %{version}-%{release}
56Provides: %{name}-plugin = %{version}-%{release}
57
58%description arts
59Plugin arts.
60
61%description arts -l pl
62Wtyczka arts.
63
8d75a549 64%package gstreamer
d4535bda 65Summary: Plugin gstreamer
8d75a549 66Summary(pl): Wtyczka gstreamer
67Group: X11/Applications/Multimedia
4d1b1b41 68Requires: %{name} = %{version}-%{release}
48801ec3 69Provides: %{name}-plugin = %{version}-%{release}
8d75a549 70
71%description gstreamer
d4535bda 72Plugin gstreamer.
8d75a549 73
74%description gstreamer -l pl
75Wtyczka gstreamer.
76
7dae3fc2 77%package xine
78Summary: Plugin xine
79Summary(pl): Wtyczka xine
80Group: X11/Applications/Multimedia
1aff4314 81Requires: %{name} = %{version}-%{release}
48801ec3 82Provides: %{name}-plugin = %{version}-%{release}
7dae3fc2 83
84%description xine
85Plugin xine.
86
87%description xine -l pl
88Wtyczka xine.
89
3dce540f 90%prep
2f119dd8 91%setup -q
3dce540f 92
69409e85 93%{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
94 amarok/src/amarok.desktop \
95
3dce540f 96%build
2ec35f1d 97cp -f /usr/share/automake/config.sub admin
d3a55e61 98
2ec35f1d 99#export UNSERMAKE=/usr/share/unsermake/unsermake
d3a55e61 100
101%{__make} -f admin/Makefile.common cvs
102
3dce540f 103%configure \
104 --disable-rpath \
48801ec3 105 %{!?with_arts:--without-arts} \
7dae3fc2 106 %{!?with_xine:--without-xine} \
107 %{!?with_gstreamer:--without-gstreamer} \
60b883ee
SP
108 %{?with_mysql:--with-mysql} \
109 --disable-final \
f15a6325 110 --with-qt-libraries=%{_libdir} \
111 --without-included-sqlite
3dce540f 112
113%{__make}
114
115%install
116rm -rf $RPM_BUILD_ROOT
117
118%{__make} install \
119 DESTDIR=$RPM_BUILD_ROOT \
bd5fd9cb 120 kde_htmldir=%{_kdedocdir} \
121 kde_libs_htmldir=%{_kdedocdir}
43342c86 122
3248aa1e 123# remove bogus dir
124rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
125
4d1b1b41 126%find_lang amarok --all-name --with-kde
3dce540f 127
128%clean
129rm -rf $RPM_BUILD_ROOT
130
60b883ee
SP
131%post
132echo "Remember to install libvisual-plugins-* packages if you"
133echo "want to have a visualizations in amarok."
134
08133359 135%files -f %{name}.lang
3dce540f 136%defattr(644,root,root,755)
8d75a549 137%doc AUTHORS ChangeLog README TODO
d4535bda 138%attr(755,root,root) %{_bindir}/amarok
3fd16f2f 139%{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
d3a55e61 140%attr(755,root,root) %{_bindir}/amarokapp
7dae3fc2 141%attr(755,root,root) %{_bindir}/amarok_libvisual
f2f66851 142#%attr(755,root,root) %{_bindir}/release_amarok
60b883ee
SP
143%{_libdir}/kde3/konqsidebar_universalamarok.la
144%attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
7dae3fc2 145%{_libdir}/kde3/libamarok_void-engine_plugin.la
146%attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
3dce540f 147%{_datadir}/apps/amarok
7dae3fc2 148%{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
60b883ee
SP
149%{_datadir}/apps/konqsidebartng/add/amarok.desktop
150%{_datadir}/apps/profiles/amarok.profile.xml
151%{_datadir}/config/amarokrc
d3a55e61 152%{_datadir}/config.kcfg/amarok.kcfg
7dae3fc2 153%{_datadir}/services/amarok_void-engine_plugin.desktop
d3a55e61 154%{_datadir}/servicetypes/amarok_plugin.desktop
3dce540f 155%{_desktopdir}/kde/amarok.desktop
60b883ee 156%{_iconsdir}/*/*/apps/amarok.*
8d75a549 157
48801ec3 158%if %{with arts}
159%files arts
160%defattr(644,root,root,755)
161%{_libdir}/kde3/libamarok_artsengine_plugin.la
162%attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
163%{_libdir}/libamarokarts.la
164%attr(755,root,root) %{_libdir}/libamarokarts.so
165%{_libdir}/mcop/Amarok
166%{_libdir}/mcop/amarokarts.mcopclass
167%{_libdir}/mcop/amarokarts.mcoptype
168%{_datadir}/services/amarok_artsengine_plugin.desktop
169%endif
170
8d75a549 171%if %{with gstreamer}
172%files gstreamer
173%defattr(644,root,root,755)
174%{_libdir}/kde3/libamarok_gstengine_plugin.la
175%attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
7dae3fc2 176%{_datadir}/config.kcfg/gstconfig.kcfg
8d75a549 177%{_datadir}/services/amarok_gstengine_plugin.desktop
178%endif
7dae3fc2 179
180%if %{with xine}
181%files xine
182%defattr(644,root,root,755)
183%{_libdir}/kde3/libamarok_xine-engine.la
184%attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
185%{_datadir}/services/amarok_xine-engine.desktop
0047a4b2 186#%{_datadir}/services/amarok_xineengine_plugin.desktop
7dae3fc2 187%endif
This page took 0.052897 seconds and 4 git commands to generate.