]> git.pld-linux.org Git - packages/amarok.git/blame - amarok.spec
- No unsermake
[packages/amarok.git] / amarok.spec
CommitLineData
8d75a549 1#
948e9545 2# Conditional builds:
48801ec3 3%bcond_without arts # disable arts engine
8d75a549 4%bcond_without gstreamer # disable gstreamer
7dae3fc2 5%bcond_without xine # disable xine engine
48801ec3 6%bcond_without xmms # disable xmms wrapping
604d331d 7%bcond_with mysql # enable mysql support
d4535bda 8#
aeff1a8d 9
e577632c 10%define _beta beta4
3dce540f 11Summary: A KDE audio player
12Summary(pl): Odtwarzacz audio dla KDE
13Name: amarok
aeff1a8d
SP
14Version: 1.2.%{_beta}
15Release: 0.1
3dce540f 16License: GPL
17Group: X11/Applications/Multimedia
aeff1a8d 18Source0: http://dl.sourceforge.net/amarok/%{name}-1.2-%{_beta}.tar.bz2
e577632c 19# Source0-md5: 13e2256a2a19953289e52db66ef992b4
567ab89c 20URL: http://amarok.kde.org/
fc49b51e 21Buildrequires: alsa-lib-devel
3aa3d858 22Buildrequires: arts-qt-devel
3022f84e 23Buildrequires: automake
512f2835 24%{?with_gstreamer:BuildRequires: gstreamer-plugins-devel >= 0.8.1}
bb9faa6b 25BuildRequires: kdebase-devel
ac33bc29 26BuildRequires: kdemultimedia-devel >= 9:3.1.93
1aff4314 27Buildrequires: libmusicbrainz-devel
add3317f 28Buildrequires: libvisual-devel >= 0.2.0
1aff4314 29Buildrequires: pcre-devel
3022f84e 30BuildRequires: rpmbuild(macros) >= 1.129
43342c86 31BuildRequires: sed >= 4.0
48801ec3 32BuildRequires: sqlite3-devel
512f2835 33BuildRequires: taglib-devel >= 1.3.1
f96a59dd 34#BuildRequires: unsermake >= 040511
512f2835
SP
35%{?with_xine:BuildRequires: xine-lib-devel >= 2:1.0-0.rc5.0}
36%{?with_xmms:BuildRequires: xmms-devel}
37%{?with_mysql:BuildRequires: mysql-devel}
af820bda 38#BuildRequires: kdebindings-kjsembed-devel
48801ec3 39Requires: %{name}-plugin = %{version}-%{release}
3dce540f 40Requires: kdebase-core >= 9:3.1.93
50fa799e 41Requires: kdemultimedia-audiocd >= 9:3.1.93
3dce540f 42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44%description
45A KDE audio player.
46
47%description -l pl
48Odtwarzacz audio dla KDE.
49
48801ec3 50%package arts
51Summary: Plugin arts
52Summary(pl): Wtyczka arts
53Group: X11/Applications/Multimedia
54Requires: %{name} = %{version}-%{release}
55Provides: %{name}-plugin = %{version}-%{release}
56
57%description arts
58Plugin arts.
59
60%description arts -l pl
61Wtyczka arts.
62
8d75a549 63%package gstreamer
d4535bda 64Summary: Plugin gstreamer
8d75a549 65Summary(pl): Wtyczka gstreamer
66Group: X11/Applications/Multimedia
4d1b1b41 67Requires: %{name} = %{version}-%{release}
48801ec3 68Provides: %{name}-plugin = %{version}-%{release}
8d75a549 69
70%description gstreamer
d4535bda 71Plugin gstreamer.
8d75a549 72
73%description gstreamer -l pl
74Wtyczka gstreamer.
75
7dae3fc2 76%package xine
77Summary: Plugin xine
78Summary(pl): Wtyczka xine
79Group: X11/Applications/Multimedia
1aff4314 80Requires: %{name} = %{version}-%{release}
48801ec3 81Provides: %{name}-plugin = %{version}-%{release}
7dae3fc2 82
83%description xine
84Plugin xine.
85
86%description xine -l pl
87Wtyczka xine.
88
3dce540f 89%prep
aeff1a8d 90%setup -q -n %{name}-1.2-%{_beta}
3dce540f 91
69409e85 92%{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
93 amarok/src/amarok.desktop \
94
3dce540f 95%build
4d1b1b41 96cp -f %{_datadir}/automake/config.sub admin
d3a55e61 97
f96a59dd 98#export UNSERMAKE=%{_datadir}/unsermake/unsermake
d3a55e61 99
100%{__make} -f admin/Makefile.common cvs
101
3dce540f 102%configure \
103 --disable-rpath \
48801ec3 104 %{!?with_arts:--without-arts} \
7dae3fc2 105 %{!?with_xine:--without-xine} \
106 %{!?with_gstreamer:--without-gstreamer} \
f49f397f 107 %{?with_mysql:--with-mysql} \
bb9faa6b 108 --disable-final \
f15a6325 109 --with-qt-libraries=%{_libdir} \
110 --without-included-sqlite
3dce540f 111
112%{__make}
113
114%install
115rm -rf $RPM_BUILD_ROOT
116
117%{__make} install \
118 DESTDIR=$RPM_BUILD_ROOT \
bd5fd9cb 119 kde_htmldir=%{_kdedocdir} \
120 kde_libs_htmldir=%{_kdedocdir}
43342c86 121
3248aa1e 122# remove bogus dir
123rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
124
4d1b1b41 125%find_lang amarok --all-name --with-kde
3dce540f 126
127%clean
128rm -rf $RPM_BUILD_ROOT
129
af820bda
SP
130%post
131echo "Remember to install libvisual-plugins-* packages if you"
132echo "want to have a visualizations in amarok."
133
08133359 134%files -f %{name}.lang
3dce540f 135%defattr(644,root,root,755)
8d75a549 136%doc AUTHORS ChangeLog README TODO
d4535bda 137%attr(755,root,root) %{_bindir}/amarok
3fd16f2f 138%{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
d3a55e61 139%attr(755,root,root) %{_bindir}/amarokapp
add3317f 140%attr(755,root,root) %{_bindir}/amarok_libvisual
3fd16f2f 141%attr(755,root,root) %{_bindir}/release_amarok
7dae3fc2 142%{_libdir}/kde3/libamarok_void-engine_plugin.la
512f2835 143%{_libdir}/kde3/konqsidebar_universalamarok.la
7dae3fc2 144%attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
512f2835 145%attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
3dce540f 146%{_datadir}/apps/amarok
7dae3fc2 147%{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
d3a55e61 148%{_datadir}/config.kcfg/amarok.kcfg
7dae3fc2 149%{_datadir}/services/amarok_void-engine_plugin.desktop
d3a55e61 150%{_datadir}/servicetypes/amarok_plugin.desktop
3dce540f 151%{_desktopdir}/kde/amarok.desktop
7dae3fc2 152%{_iconsdir}/*/*/apps/amarok.png
3fd16f2f 153%{_iconsdir}/crystalsvg/*/*/player_playlist_2.png
3aa3d858 154%{_datadir}/config/*
8d75a549 155
48801ec3 156%if %{with arts}
157%files arts
158%defattr(644,root,root,755)
159%{_libdir}/kde3/libamarok_artsengine_plugin.la
160%attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
161%{_libdir}/libamarokarts.la
162%attr(755,root,root) %{_libdir}/libamarokarts.so
163%{_libdir}/mcop/Amarok
164%{_libdir}/mcop/amarokarts.mcopclass
165%{_libdir}/mcop/amarokarts.mcoptype
166%{_datadir}/services/amarok_artsengine_plugin.desktop
167%endif
168
8d75a549 169%if %{with gstreamer}
170%files gstreamer
171%defattr(644,root,root,755)
172%{_libdir}/kde3/libamarok_gstengine_plugin.la
173%attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
7dae3fc2 174%{_datadir}/config.kcfg/gstconfig.kcfg
8d75a549 175%{_datadir}/services/amarok_gstengine_plugin.desktop
176%endif
7dae3fc2 177
178%if %{with xine}
179%files xine
180%defattr(644,root,root,755)
181%{_libdir}/kde3/libamarok_xine-engine.la
182%attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
183%{_datadir}/services/amarok_xine-engine.desktop
184%{_datadir}/services/amarok_xineengine_plugin.desktop
185%endif
This page took 0.07511 seconds and 4 git commands to generate.