]> git.pld-linux.org Git - packages/amarok-script-wiki_lyrics.git/blob - amarok-script-wiki_lyrics.spec
- 0.13.4
[packages/amarok-script-wiki_lyrics.git] / amarok-script-wiki_lyrics.spec
1 # NOTE
2 # - could use QtRuby, Ruby/GTK or Ruby/Tk, but as only -tk was available on AC,
3 #   used that dependency.
4 %define         scriptname      wiki_lyrics
5 Summary:        A collection of lyrics scripts for amaroK
6 Summary(pl.UTF-8):      Zestaw skryptów do tekstów utworów dla amaroKa
7 Name:           amarok-script-wiki_lyrics
8 Version:        0.13.4
9 Release:        1
10 License:        GPL v2+
11 Group:          X11/Applications/Multimedia
12 Source0:        http://www.kde-apps.org/CONTENT/content-files/35151-wiki_lyrics-%{version}.amarokscript.tar.bz2
13 # Source0-md5:  1e4dd829737dae47e259056002c9a322
14 URL:            http://www.lyriki.com/Help:Wiki-Lyrics_Script
15 BuildRequires:  sed >= 4.0
16 Requires:       amarok-scripts >= 1.4
17 Requires:       ruby-modules >= 1.8
18 Requires:       ruby-tk
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _scriptdir %{_datadir}/apps/amarok/scripts
23
24 %description
25 A collection of lyrics scripts to interface with various sites and,
26 optionally, submit content to Lyriki.com or LyricWiki.org (wikis for
27 lyrics). All of these scripts can query the other ones when they can't
28 provide the lyrics for a song.
29
30 Supported sites:
31 - Lyriki <www.lyriki.com>
32 - LyricWiki <www.lyricwiki.org>
33 - AZ Lyrics <www.azlyrics.com>
34 - Baidu MP3 <mp3.baidu.com>
35 - Dark Lyrics <www.darklyrics.com>
36 - Giitaayan <www.giitaayan.com>
37 - Jamendo <www.jamendo.com>
38 - Leos Lyrics <www.leoslyrics.com>
39 - Lyrc <lyrc.com.ar>
40 - Lyrics Download <www.lyricsdownload.com>
41 - Lyrics Mania <www.lyricsmania.com>
42 - Not Popular <www.notpopular.com>
43 - Seek Lyrics <www.seeklyrics.com>
44 - Sing365 <www.sing365.com>
45 - Terra Letras <letras.terra.com.br>
46
47 %description -l pl.UTF-8
48 Zestaw współpracujących z różnymi serwisami skryptów do pobierania
49 tekstów utworów i opcjonalnie umieszczania treści na Lyriki.com lub
50 LyricWiki.org (wiki dla tekstów utworów). Wszystkie te skrypty mogą
51 odpytywać inne jeśli nie znajdą tekstu piosenki.
52
53 Obsługiwane serwisy:
54 - Lyriki <www.lyriki.com>
55 - LyricWiki <www.lyricwiki.org>
56 - AZ Lyrics <www.azlyrics.com>
57 - Baidu MP3 <mp3.baidu.com>
58 - Dark Lyrics <www.darklyrics.com>
59 - Giitaayan <www.giitaayan.com>
60 - Jamendo <www.jamendo.com>
61 - Leos Lyrics <www.leoslyrics.com>
62 - Lyrc <lyrc.com.ar>
63 - Lyrics Download <www.lyricsdownload.com>
64 - Lyrics Mania <www.lyricsmania.com>
65 - Not Popular <www.notpopular.com>
66 - Seek Lyrics <www.seeklyrics.com>
67 - Sing365 <www.sing365.com>
68 - Terra Letras <letras.terra.com.br>
69
70 %prep
71 %setup -q -n %{scriptname}
72 rm *.kdev*
73 rm -rf win tests
74 rm {docs,amarok}/COPYING # GPL v2
75 rm i18n/README # note about when editing files
76
77 %{__sed} -i -e '1s,#!/usr/bin/env ruby,#!%{_bindir}/ruby,' *.rb amarok/*.rb cli/*.rb
78
79 # ELF 32-bit LSB executable, Intel 80386
80 # TODO: package separately if it's really needed
81 rm -f itrans/itrans
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85 install -d $RPM_BUILD_ROOT%{_scriptdir}/%{scriptname}
86 cp -a . $RPM_BUILD_ROOT%{_scriptdir}/%{scriptname}
87 rm -rf $RPM_BUILD_ROOT%{_scriptdir}/%{scriptname}/docs
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %files
93 %defattr(644,root,root,755)
94 %doc docs/ChangeLog docs/TODO docs/HOWTO.txt docs/README
95 %dir %{_scriptdir}/%{scriptname}
96
97 %{_scriptdir}/%{scriptname}/*.rb
98
99 %dir %{_scriptdir}/%{scriptname}/cli
100 %{_scriptdir}/%{scriptname}/cli/*.rb
101
102 %dir %{_scriptdir}/%{scriptname}/gui
103 %{_scriptdir}/%{scriptname}/gui/*.rb
104
105 %dir %{_scriptdir}/%{scriptname}/i18n
106 %{_scriptdir}/%{scriptname}/i18n/*.rb
107
108 %dir %{_scriptdir}/%{scriptname}/utils
109 %{_scriptdir}/%{scriptname}/utils/*.rb
110
111 %dir %{_scriptdir}/%{scriptname}/itrans
112 %{_scriptdir}/%{scriptname}/itrans/*
113
114 %dir %{_scriptdir}/%{scriptname}/amarok
115 # README must be here in %files, not in %doc
116 # also only one script should be executable, or amarok will attempt to think the others are also plugins
117 %attr(755,root,root) %{_scriptdir}/%{scriptname}/amarok/wikilyrics.rb
118 %{_scriptdir}/%{scriptname}/amarok/README
119 %{_scriptdir}/%{scriptname}/amarok/amarok.rb
120 %{_scriptdir}/%{scriptname}/amarok/pluginadapter.rb
121 %{_scriptdir}/%{scriptname}/amarok/plugins.rb
122 %{_scriptdir}/%{scriptname}/amarok/wikipluginadapter.rb
123 %{_scriptdir}/%{scriptname}/amarok/*.spec
This page took 0.078986 seconds and 3 git commands to generate.