]> git.pld-linux.org Git - packages/amarok-script-wiki_lyrics.git/blame - amarok-script-wiki_lyrics.spec
- 0.13.4
[packages/amarok-script-wiki_lyrics.git] / amarok-script-wiki_lyrics.spec
CommitLineData
0d35f347
ER
1# NOTE
2# - could use QtRuby, Ruby/GTK or Ruby/Tk, but as only -tk was available on AC,
3# used that dependency.
4%define scriptname wiki_lyrics
5Summary: A collection of lyrics scripts for amaroK
08562c8e 6Summary(pl.UTF-8): Zestaw skryptów do tekstów utworów dla amaroKa
0d35f347 7Name: amarok-script-wiki_lyrics
1491e9ba 8Version: 0.13.4
0f0e0317 9Release: 1
1491e9ba 10License: GPL v2+
0d35f347 11Group: X11/Applications/Multimedia
0f10ed88 12Source0: http://www.kde-apps.org/CONTENT/content-files/35151-wiki_lyrics-%{version}.amarokscript.tar.bz2
1491e9ba 13# Source0-md5: 1e4dd829737dae47e259056002c9a322
0f10ed88 14URL: http://www.lyriki.com/Help:Wiki-Lyrics_Script
0d35f347 15BuildRequires: sed >= 4.0
1491e9ba 16Requires: amarok-scripts >= 1.4
0d35f347
ER
17Requires: ruby-modules >= 1.8
18Requires: ruby-tk
19BuildArch: noarch
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%define _scriptdir %{_datadir}/apps/amarok/scripts
23
24%description
25A collection of lyrics scripts to interface with various sites and,
26optionally, submit content to Lyriki.com or LyricWiki.org (wikis for
27lyrics). All of these scripts can query the other ones when they can't
28provide the lyrics for a song.
29
30Supported sites:
6457cff7
ER
31- Lyriki <www.lyriki.com>
32- LyricWiki <www.lyricwiki.org>
33- AZ Lyrics <www.azlyrics.com>
34- Baidu MP3 <mp3.baidu.com>
35- Dark Lyrics <www.darklyrics.com>
36- Giitaayan <www.giitaayan.com>
37- Jamendo <www.jamendo.com>
38- Leos Lyrics <www.leoslyrics.com>
39- Lyrc <lyrc.com.ar>
40- Lyrics Download <www.lyricsdownload.com>
41- Lyrics Mania <www.lyricsmania.com>
42- Not Popular <www.notpopular.com>
43- Seek Lyrics <www.seeklyrics.com>
44- Sing365 <www.sing365.com>
45- Terra Letras <letras.terra.com.br>
0d35f347 46
8a22d870
JR
47%description -l pl.UTF-8
48Zestaw współpracujących z różnymi serwisami skryptów do pobierania
49tekstów utworów i opcjonalnie umieszczania treści na Lyriki.com lub
50LyricWiki.org (wiki dla tekstów utworów). Wszystkie te skrypty mogą
51odpytywać inne jeśli nie znajdą tekstu piosenki.
1f65bda4 52
8a22d870 53Obsługiwane serwisy:
6457cff7
ER
54- Lyriki <www.lyriki.com>
55- LyricWiki <www.lyricwiki.org>
56- AZ Lyrics <www.azlyrics.com>
57- Baidu MP3 <mp3.baidu.com>
58- Dark Lyrics <www.darklyrics.com>
59- Giitaayan <www.giitaayan.com>
60- Jamendo <www.jamendo.com>
61- Leos Lyrics <www.leoslyrics.com>
62- Lyrc <lyrc.com.ar>
63- Lyrics Download <www.lyricsdownload.com>
64- Lyrics Mania <www.lyricsmania.com>
65- Not Popular <www.notpopular.com>
66- Seek Lyrics <www.seeklyrics.com>
67- Sing365 <www.sing365.com>
68- Terra Letras <letras.terra.com.br>
1f65bda4 69
0d35f347
ER
70%prep
71%setup -q -n %{scriptname}
0f10ed88
ER
72rm *.kdev*
73rm -rf win tests
74rm {docs,amarok}/COPYING # GPL v2
75rm i18n/README # note about when editing files
0d35f347 76
f3d552d3 77%{__sed} -i -e '1s,#!/usr/bin/env ruby,#!%{_bindir}/ruby,' *.rb amarok/*.rb cli/*.rb
0d35f347 78
9a510da0
ER
79# ELF 32-bit LSB executable, Intel 80386
80# TODO: package separately if it's really needed
81rm -f itrans/itrans
82
0d35f347
ER
83%install
84rm -rf $RPM_BUILD_ROOT
85install -d $RPM_BUILD_ROOT%{_scriptdir}/%{scriptname}
0f10ed88
ER
86cp -a . $RPM_BUILD_ROOT%{_scriptdir}/%{scriptname}
87rm -rf $RPM_BUILD_ROOT%{_scriptdir}/%{scriptname}/docs
0d35f347
ER
88
89%clean
90rm -rf $RPM_BUILD_ROOT
91
92%files
93%defattr(644,root,root,755)
0f10ed88 94%doc docs/ChangeLog docs/TODO docs/HOWTO.txt docs/README
0d35f347 95%dir %{_scriptdir}/%{scriptname}
0f10ed88 96
20504e7a 97%{_scriptdir}/%{scriptname}/*.rb
0f10ed88
ER
98
99%dir %{_scriptdir}/%{scriptname}/cli
20504e7a 100%{_scriptdir}/%{scriptname}/cli/*.rb
0f10ed88
ER
101
102%dir %{_scriptdir}/%{scriptname}/gui
20504e7a 103%{_scriptdir}/%{scriptname}/gui/*.rb
0f10ed88
ER
104
105%dir %{_scriptdir}/%{scriptname}/i18n
20504e7a 106%{_scriptdir}/%{scriptname}/i18n/*.rb
0f10ed88 107
0f10ed88 108%dir %{_scriptdir}/%{scriptname}/utils
20504e7a 109%{_scriptdir}/%{scriptname}/utils/*.rb
0f10ed88
ER
110
111%dir %{_scriptdir}/%{scriptname}/itrans
20504e7a 112%{_scriptdir}/%{scriptname}/itrans/*
0f10ed88
ER
113
114%dir %{_scriptdir}/%{scriptname}/amarok
115# README must be here in %files, not in %doc
a5eab1f0
ER
116# also only one script should be executable, or amarok will attempt to think the others are also plugins
117%attr(755,root,root) %{_scriptdir}/%{scriptname}/amarok/wikilyrics.rb
0f10ed88 118%{_scriptdir}/%{scriptname}/amarok/README
30e6da6b 119%{_scriptdir}/%{scriptname}/amarok/amarok.rb
30e6da6b
ER
120%{_scriptdir}/%{scriptname}/amarok/pluginadapter.rb
121%{_scriptdir}/%{scriptname}/amarok/plugins.rb
30e6da6b 122%{_scriptdir}/%{scriptname}/amarok/wikipluginadapter.rb
0f10ed88 123%{_scriptdir}/%{scriptname}/amarok/*.spec
This page took 0.098989 seconds and 4 git commands to generate.