]> git.pld-linux.org Git - packages/alsaplayer.git/commitdiff
- rel 3 auto/th/alsaplayer-0_99_80-3
authorJan Rękorajski <baggins@pld-linux.org>
Thu, 3 Jun 2010 15:00:38 +0000 (15:00 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- fix building with latest gcc/g++

Changed files:
    alsaplayer-g++.patch -> 1.1
    alsaplayer.spec -> 1.102

alsaplayer-g++.patch [new file with mode: 0644]
alsaplayer.spec

diff --git a/alsaplayer-g++.patch b/alsaplayer-g++.patch
new file mode 100644 (file)
index 0000000..f680ad6
--- /dev/null
@@ -0,0 +1,20 @@
+--- alsaplayer-0.99.80/input/flac/FlacPlugin.cpp.orig  2007-10-29 22:00:16.000000000 +0100
++++ alsaplayer-0.99.80/input/flac/FlacPlugin.cpp       2010-06-03 16:59:52.987826407 +0200
+@@ -239,7 +239,7 @@
+     else
+     {
+       // use stream name
+-      char * fname = strrchr (f->name ().c_str (), '/');
++      char * fname = (char *)strrchr (f->name ().c_str (), '/');
+       if (fname)
+       {
+           fname++;
+@@ -270,7 +270,7 @@
+       if (strncmp(name, "http://", 7) == 0) {
+               return 0.0;
+       }
+-      char *ext = strrchr(name, '.');
++      char *ext = (char *)strrchr(name, '.');
+       if (!ext)
+               return 0.0;
+       ext++;
index 4d9c376afcbb566c3619ed9d30a499a8ab2ae477..3ce36748d5556a572f5ae6c4b353317c513a5513 100644 (file)
@@ -10,7 +10,7 @@ Summary:      Alsaplayer - CD/FLAC/MOD/MP3/Ogg/WAV player
 Summary(pl.UTF-8):     Alsaplayer - odtwarzacz CD/FLAC/MOD/MP3/Ogg/WAV
 Name:          alsaplayer
 Version:       0.99.80
-Release:       2
+Release:       3
 License:       GPL v3+
 Group:         Applications/Sound
 Source0:       http://www.alsaplayer.org/%{name}-%{version}.tar.bz2
@@ -18,6 +18,7 @@ Source0:      http://www.alsaplayer.org/%{name}-%{version}.tar.bz2
 Source1:       %{name}.desktop
 Source2:       %{name}.png
 Patch0:                %{name}-docs.patch
+Patch1:                %{name}-g++.patch
 URL:           http://www.alsaplayer.org/
 BuildRequires: OpenGL-devel
 BuildRequires: alsa-lib-devel
@@ -378,6 +379,7 @@ Biblioteka statyczna Alsaplayera.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 rm -f missing
This page took 0.076834 seconds and 4 git commands to generate.