]> git.pld-linux.org Git - packages/alsaplayer.git/blob - alsaplayer.spec
- removed obsolete patch
[packages/alsaplayer.git] / alsaplayer.spec
1 #
2 # Conditional build
3 %bcond_without  esound          # build without esound plugin
4 %bcond_without  flac            # build without FLAC plugin
5 %bcond_without  jack            # build without jack plugin
6 %bcond_without  mikmod          # build without mikmod plugin
7 %bcond_without  nas             # build without nas plugin
8 #
9 Summary:        Alsaplayer - CD/FLAC/MOD/MP3/Ogg/WAV player
10 Summary(pl.UTF-8):      Alsaplayer - odtwarzacz CD/FLAC/MOD/MP3/Ogg/WAV
11 Name:           alsaplayer
12 Version:        0.99.80
13 %define pre     rc2
14 Release:        0.%{pre}.1
15 License:        GPLv3
16 Group:          Applications/Sound
17 Source0:        http://www.alsaplayer.org/%{name}-%{version}-%{pre}.tar.bz2
18 # Source0-md5:  bc8325c704f6cad167236055e1ff3ebb
19 Source1:        %{name}.desktop
20 Source2:        %{name}.png
21 Patch0:         %{name}-docs.patch
22 URL:            http://www.alsaplayer.org/
23 BuildRequires:  OpenGL-devel
24 BuildRequires:  alsa-lib-devel
25 BuildRequires:  audiofile-devel
26 BuildRequires:  autoconf
27 BuildRequires:  automake
28 %{?with_esound:BuildRequires:   esound-devel >= 0.2.4}
29 %{?with_flac:BuildRequires:     flac-c++-devel >= 1.2.0}
30 BuildRequires:  gtk+2-devel >= 1:2.0.3
31 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel >= 0.69.1}
32 %{?with_flac:BuildRequires:     libid3tag-devel}
33 BuildRequires:  libmad-devel
34 %{?with_mikmod:BuildRequires:   libmikmod-devel}
35 BuildRequires:  libsndfile-devel >= 1.0.4
36 BuildRequires:  libstdc++-devel
37 BuildRequires:  libtool
38 BuildRequires:  libvorbis-devel
39 %{?with_nas:BuildRequires:      nas-devel}
40 BuildRequires:  pkgconfig
41 BuildRequires:  xosd-devel
42 Requires(post): /sbin/ldconfig
43 Requires:       alsaplayer_output
44 Requires:       alsaplayer_ui
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
48 %define         _pkglibdir      %{_libdir}/%{name}
49
50 %description
51 AlsaPlayer is a new type of PCM player. It is heavily multi-threaded
52 and tries to exercise the ALSA library and driver quite a bit.
53 Features include:
54
55 Input addons:
56 - MP2 and MP3 support
57 - Ogg Vorbis support (subpackage)
58 - WAV support, 8-, 16-bit, mono, stereo, any sample rate
59 - CDDA support, CD Digital Audio playback! and thus USB ready :)
60 - Also plays files mapped by audiofs (CDDA)
61 - MAD MPEG audio
62 - Module support (mikmod) (subpcakage)
63 - FLAC support
64
65 Output addons:
66 - ALSA. Best supported of course :) (subpackage)
67 - OSS. Kernel native sound drivers
68 - Sparc. UltraSparc sound drivers
69 - SGI. SGI audio library driver
70 - ESD. Enlightened sound daemon support (subpackage)
71 - NAS. Network Audio System (subpakcage)
72 - low latency JACK output
73 - null :-)
74
75 Visual scopes:
76 - Stereoscope
77 - Monoscope
78 - Levelmeter
79 - Spacescope
80 - FFTscope
81 - FFTscope II
82 - Spectrum GL
83
84 General features:
85 - Full speed (pitch) control, positive *and* negative! (First Linux
86   player that does this!! MP3's and CD's do varispeed :)
87 - Queue (playlist) support
88 - Concurrent visual scopes (open as many as you want)
89 - Multi-threaded design for efficient/skip free playback (RT)
90 - GUI Interface based on GTK+
91 - NOGUI operation for shell script usage
92 - On-screen-display based on xosd
93 - Plug-in core architecture
94 - Low latency mode, as low as 5ms when scheduled RT
95 - Effects stream
96 - Software based volume/pan control
97 - Accurate scope/audio syncing using ALSA features
98
99 %description -l pl.UTF-8
100 AlsaPlayer to nowy rodzaj odtwarzacza PCM. Jest wielowątkowy i próbuje
101 solidnie przećwiczyć sterowniki i bibliotekę ALSA. Jego cechy to:
102
103 Wejście:
104 - obsługa MP2 i MP3
105 - obsługa Ogg Vorbis (w podpakiecie)
106 - obsługa WAV, 8 i 16-bitowych, mono, stereo o dowolnej częstotliwości
107 - obsługa CD Digital Audio
108 - odtwarzanie plików podmapowanych przez audiofs (CDDA)
109 - obsługa MAD - MPEG Audio
110 - obsługa modułów (mikmod) (w podpakiecie)
111 - obsług bezstratnej kompresji dźwięku FLAC
112
113 Wyjście:
114 - OSS - natywne sterowniki z jądra
115 - ALSA - oczywiście najlepiej obsługiwana :) (w podpakiecie)
116 - Sparc - sterowniki dźwięku dla UltraSparca
117 - SGI - biblioteka sterowników dźwięku SGI
118 - ESD - obsługa Oświeconego demona dźwięku (w podpakiecie)
119 - NAS - Sieciowego Systemu Audio (w podpakiecie)
120 - JACK - zestaw połączeń dźwięku o małych opóźnieniach (w podpakiecie)
121 - null :-)
122
123 Wizualizacja:
124 - Stereoskop
125 - Monoskop
126 - Wskaźnik poziomu dźwięku
127 - Wskaźniki oparte o analizę FFT
128 - analizator spektrum sygnału w oparciu o OpenGL
129
130 Ogólne cechy:
131 - Kontrola szybkości (w obie strony)
132 - obsługa kolejki (playlisty)
133 - obsługa wielu wskaźników naraz
134 - wielowątkowość
135 - interfejs graficzny bazujący na GTK+
136 - operacje bez GUI na potrzeby skryptów
137 - tryb Informacje-na-ekranie oparty o xosd
138 - architektura wtyczek
139 - tryb "czasu rzeczywistego" dający opóźnienia rzędu 5ms
140 - programowa kontrola głośności i balansu
141 - synchronizacja dźwięku i wskaźników przy użyciu możliwości ALSA
142
143 %package daemon
144 Summary:        Deamon interface for Alsaplayer
145 Summary(pl.UTF-8):      Interfejs demona alsaplayera
146 Group:          Applications/Sound
147 Requires:       %{name} = %{version}-%{release}
148
149 %description daemon
150 Deamon interface for Alsaplayer.
151
152 %description daemon -l pl.UTF-8
153 Interfejs demona alsaplayera.
154
155 %package input-audiofile
156 Summary:        Alsaplayer plugin for playing WAVE audio formats using audiofile
157 Summary(pl.UTF-8):      Wtyczka alsaplayera do odtwarzania plików audio typu WAVE przy użyciu audiofile
158 Group:          Applications/Sound
159 Requires:       %{name} = %{version}-%{release}
160
161 %description input-audiofile
162 Alsaplayer plugin for playing WAVE audio formats (like AIFF, AIFC,
163 WAVE, ...) using audiofile library.
164
165 %description input-audiofile -l pl.UTF-8
166 Wtyczka alsaplayera do odtwarzania plików audio typu WAVE (AIFF,
167 AIFC, WAVE, ...) przy użyciu biblioteki audiofile.
168
169 %package input-flac
170 Summary:        Alsaplayer plugin for playing FLAC files
171 Summary(pl.UTF-8):      Wtyczka alsaplayera do odtwarzania plików FLAC
172 Group:          Applications/Sound
173 Requires:       %{name} = %{version}-%{release}
174
175 %description input-flac
176 Alsaplayer plugin for playing FLAC files.
177
178 %description input-flac -l pl.UTF-8
179 Wtyczka alsaplayera do odtwarzania plików FLAC.
180
181 %package input-mad
182 Summary:        Alsaplayer plugin for playing MP3 files using MAD
183 Summary(pl.UTF-8):      Wtyczka alsaplayera do odtwarzania plików MP3 przy pomocy MAD
184 Group:          Applications/Sound
185 Requires:       %{name} = %{version}-%{release}
186
187 %description input-mad
188 Alsaplayer plugin for playing MP3 files using MAD.
189
190 %description input-mad -l pl.UTF-8
191 Wtyczka alsaplayera do odtwarzania plików MP3 przy pomocy MAD.
192
193 %package input-mikmod
194 Summary:        Alsaplayer plugin for playing mod files
195 Summary(pl.UTF-8):      Wtyczka alsaplayera do odtwarzania plików mod
196 Group:          Applications/Sound
197 Requires:       %{name} = %{version}-%{release}
198
199 %description input-mikmod
200 Alsaplayer plugin for playing mod files.
201
202 %description input-mikmod -l pl.UTF-8
203 Wtyczka alsaplayera do odtwarzania plików mod.
204
205 %package input-sndfile
206 Summary:        Alsaplayer plugin for playing WAVE audio formats using libsndfile
207 Summary(pl.UTF-8):      Wtyczka alsaplayera do odtwarzania plików audio typu WAVE przy użyciu libsndfile
208 Group:          Applications/Sound
209 Requires:       %{name} = %{version}-%{release}
210
211 %description input-sndfile
212 Alsaplayer plugin for playing WAVE audio formats (like AIFF, AIFC,
213 WAVE, ...) using libsndfile library.
214
215 %description input-sndfile -l pl.UTF-8
216 Wtyczka do alsaplayera do odtwarzania plików audio typu WAVE (AIFF,
217 AIFC, WAVE, ...) przy użyciu biblioteki libsndfile.
218
219 %package input-vorbis
220 Summary:        Alsaplayer plugin for playing Ogg/Vorbis files
221 Summary(pl.UTF-8):      Wtyczka alsaplayera do odtwarzania plików Ogg/Vorbis
222 Group:          Applications/Sound
223 Requires:       %{name} = %{version}-%{release}
224
225 %description input-vorbis
226 Alsaplayer plugin for playing Ogg/Vorbis files.
227
228 %description input-vorbis -l pl.UTF-8
229 Wtyczka alsaplayera do odtwarzania plików Ogg/Vorbis.
230
231 %package interface-gtk2
232 Summary:        GTK+ 2 interface for Alsaplayer
233 Summary(pl.UTF-8):      Interfejs GTK+ 2 alsaplayera
234 Group:          X11/Applications/Sound
235 Requires:       %{name} = %{version}-%{release}
236 Provides:       alsaplayer_ui
237
238 %description interface-gtk2
239 GTK+ 2 interface for Alsaplayer.
240
241 %description interface-gtk2 -l pl.UTF-8
242 Interfejs GTK+2 alsaplayera.
243
244 %package interface-text
245 Summary:        Text interface for Alsaplayer
246 Summary(pl.UTF-8):      Interfejs tekstowy alsaplayera
247 Group:          Applications/Sound
248 Requires:       %{name} = %{version}-%{release}
249 Provides:       alsaplayer_ui
250
251 %description interface-text
252 Text interface for Alsaplayer.
253
254 %description interface-text -l pl.UTF-8
255 Interfejs tekstowy alsaplayera.
256
257 %package interface-xosd
258 Summary:        xosd interface for Alsaplayer
259 Summary(pl.UTF-8):      Interfejs xosd alsaplayera
260 Group:          X11/Applications/Sound
261 Requires:       %{name} = %{version}-%{release}
262 Provides:       alsaplayer_ui
263
264 %description interface-xosd
265 xosd interface for Alsaplayer.
266
267 %description interface-xosd -l pl.UTF-8
268 Interfejs xosd alsaplayera.
269
270 %package output-alsa
271 Summary:        Alsaplayer plugin for playing through alsa drivers
272 Summary(pl.UTF-8):      Wtyczka alsaplayera do odtwarzania przez sterowniki alsa
273 Group:          Applications/Sound
274 Requires:       %{name} = %{version}-%{release}
275 Provides:       alsaplayer_output
276
277 %description output-alsa
278 Alsaplayer plugin for playing sound through alsa drivers.
279
280 %description output-alsa -l pl.UTF-8
281 Wtyczka alsaplayera do odtwarzania dźwięku przez sterowniki alsa.
282
283 %package output-esound
284 Summary:        Alsaplayer plugin for playing through esound daemon
285 Summary(pl.UTF-8):      Wtyczka alsaplayera do odtwarzania przez demona esound
286 Group:          Applications/Sound
287 Requires:       %{name} = %{version}-%{release}
288 Provides:       alsaplayer_output
289
290 %description output-esound
291 Alsaplayer plugin for playing sound through esound daemon.
292
293 %description output-esound -l pl.UTF-8
294 Wtyczka alsaplayera do odtwarzania dźwięku przez demona esound.
295
296 %package output-nas
297 Summary:        Alsaplayer plugin for playing through NAS daemon
298 Summary(pl.UTF-8):      Wtyczka do alsaplayera do odtwarzania przez demona NAS
299 Group:          Applications/Sound
300 Requires:       %{name} = %{version}-%{release}
301 Provides:       alsaplayer_output
302
303 %description output-nas
304 Alsaplayer plugin for playing sound through NAS (network audio system)
305 daemon.
306
307 %description output-nas -l pl.UTF-8
308 Wtyczka alsaplayera do odtwarzania dźwięku przez demona NAS (network
309 audio system).
310
311 %package output-jack
312 Summary:        Alsaplayer plugin for playing sound through JACK
313 Summary(pl.UTF-8):      Wtyczka alsaplayera do odtwarzania dźwięku przez JACK-a
314 Group:          Applications/Sound
315 Requires:       %{name} = %{version}-%{release}
316 Provides:       alsaplayer_output
317
318 %description output-jack
319 Alsaplayer plugin for sound through JACK system.
320
321 %description output-jack -l pl.UTF-8
322 Wtyczka alsaplayera do odtwarzania dźwięku przez system JACK.
323
324 %package scopes2-gtk
325 Summary:        Alsaplayer plugins for visualization
326 Summary(pl.UTF-8):      Wtyczki alsaplayera do wizualizacji
327 Group:          X11/Applications/Multimedia
328 Requires:       %{name} = %{version}-%{release}
329 Obsoletes:      alsaplayer-scopes-gtk
330
331 %description scopes2-gtk
332 Alsaplayer plugins for visualization.
333
334 %description scopes2-gtk -l pl.UTF-8
335 Wtyczki do alsaplayera do wizualizacji.
336
337 %package scopes2-opengl
338 Summary:        Alsaplayer plugin for visualization using OpenGL
339 Summary(pl.UTF-8):      Wtyczka alsaplayera do wizualizacji z użyciem OpenGL
340 Group:          X11/Applications/Multimedia
341 Requires:       %{name} = %{version}-%{release}
342 Requires:       OpenGL
343 Obsoletes:      alsaplayer-scopes-opengl
344
345 %description scopes2-opengl
346 Alsaplayer plugin for visualization using OpenGL.
347
348 %description scopes2-opengl -l pl.UTF-8
349 Wtyczka do alsaplayera do wizualizacji z użyciem OpenGL.
350
351 %package devel
352 Summary:        Alsaplayer header files
353 Summary(pl.UTF-8):      Pliki nagłówkowe Alsaplayera
354 Group:          Development/Libraries
355 Requires:       %{name} = %{version}-%{release}
356
357 %description devel
358 Header files for Alsaplayer library.
359
360 %description devel -l pl.UTF-8
361 Pliki nagłówkowe biblioteki Alsaplayera.
362
363 %package static
364 Summary:        Alsaplayer static library
365 Summary(pl.UTF-8):      Biblioteka statyczna Alsaplayera
366 Group:          Development/Libraries
367 Requires:       %{name}-devel = %{version}-%{release}
368
369 %description static
370 Alsaplayer static library.
371
372 %description static -l pl.UTF-8
373 Biblioteka statyczna Alsaplayera.
374
375 %prep
376 %setup -q -n %{name}-%{version}-%{pre}
377 %patch0 -p1
378
379 %build
380 rm -f missing
381 %{__libtoolize}
382 %{__aclocal}
383 %{__autoconf}
384 %{__automake}
385 CPPFLAGS=" -I/usr/X11R6/include"
386 LDFLAGS="%{rpmldflags} -L/usr/X11R6/lib"
387 export CPPFLAGS LDFLAGS
388 %configure \
389         %{?with_esound:--en}%{!?with_esound:--dis}able-esd \
390         %{?with_flac:--en}%{!?with_flac:--dis}able-flac \
391         %{?with_flac:--en}%{!?with_flac:--dis}able-oggflac \
392         %{?with_jack:--en}%{!?with_jack:--dis}able-jack \
393         %{?with_mikmod:--en}%{!?with_mikmod:--dis}able-mikmod \
394         %{?with_nas:--en}%{!?with_nas:--dis}able-nas \
395         %{?with_esound:--en}%{!?with_esound:--dis}able-esd \
396         --enable-alsa \
397         --enable-audiofile \
398         --enable-gtk2 \
399         --enable-oggflac \
400         --enable-oggvorbis \
401         --enable-opengl \
402         --enable-oss \
403         --enable-static
404
405 %{__make}
406
407 %install
408 rm -rf $RPM_BUILD_ROOT
409 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
410
411 %{__make} install \
412         DESTDIR=$RPM_BUILD_ROOT \
413         pkgconfigdir=%{_pkgconfigdir}
414
415 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
416 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
417
418 rm -f $RPM_BUILD_ROOT%{_pkglibdir}/input/*.{a,la}
419 rm -f $RPM_BUILD_ROOT%{_pkglibdir}/interface/*.{a,la}
420 rm -f $RPM_BUILD_ROOT%{_pkglibdir}/output/*.{a,la}
421 rm -f $RPM_BUILD_ROOT%{_pkglibdir}/reader/*.{a,la}
422 rm -f $RPM_BUILD_ROOT%{_pkglibdir}/scopes2/*.{a,la}
423
424 %{find_lang} %{name}
425
426 %clean
427 rm -rf $RPM_BUILD_ROOT
428
429 %post
430 /sbin/ldconfig
431 echo
432 echo "Remember to install appropriate alsaplayer-input-* plugins"
433 echo "for files you want to play, for example:"
434 echo "alsaplayer-input-mad to play MP3s."
435 echo
436
437 %postun -p /sbin/ldconfig
438
439 %files -f %{name}.lang
440 %defattr(644,root,root,755)
441 %doc AUTHORS README ChangeLog
442 %attr(755,root,root) %{_bindir}/alsaplayer
443 %attr(755,root,root) %{_libdir}/libalsaplayer.so.0.0.2
444 %dir %{_pkglibdir}
445 %dir %{_pkglibdir}/input
446 %dir %{_pkglibdir}/interface
447 %dir %{_pkglibdir}/output
448 %dir %{_pkglibdir}/reader
449 %dir %{_pkglibdir}/scopes2
450 %attr(755,root,root) %{_pkglibdir}/input/libcdda.so
451 %attr(755,root,root) %{_pkglibdir}/input/libwav.so
452 %attr(755,root,root) %{_pkglibdir}/output/liboss_out.so
453 %attr(755,root,root) %{_pkglibdir}/output/libnull_out.so
454 %attr(755,root,root) %{_pkglibdir}/reader/libfile.so
455 %attr(755,root,root) %{_pkglibdir}/reader/libhttp.so
456 %{_mandir}/man*/*
457 %{_desktopdir}/%{name}.desktop
458 %{_pixmapsdir}/%{name}.png
459
460 %files daemon
461 %defattr(644,root,root,755)
462 %attr(755,root,root) %{_pkglibdir}/interface/libdaemon_interface.so
463
464 %files interface-gtk2
465 %defattr(644,root,root,755)
466 %attr(755,root,root) %{_pkglibdir}/interface/libgtk2_interface.so
467
468 %files interface-text
469 %defattr(644,root,root,755)
470 %attr(755,root,root) %{_pkglibdir}/interface/libtext_interface.so
471
472 %files interface-xosd
473 %defattr(644,root,root,755)
474 %attr(755,root,root) %{_pkglibdir}/interface/libxosd_interface.so
475
476 %files input-audiofile
477 %defattr(644,root,root,755)
478 %attr(755,root,root) %{_pkglibdir}/input/libaf.so
479
480 %if %{with flac}
481 %files input-flac
482 %defattr(644,root,root,755)
483 %attr(755,root,root) %{_pkglibdir}/input/libflac_in.so
484 %endif
485
486 %files input-mad
487 %defattr(644,root,root,755)
488 %attr(755,root,root) %{_pkglibdir}/input/libmad_in.so
489
490 %if %{with mikmod}
491 %files input-mikmod
492 %defattr(644,root,root,755)
493 %attr(755,root,root) %{_pkglibdir}/input/libmod.so
494 %endif
495
496 %files input-sndfile
497 %defattr(644,root,root,755)
498 %attr(755,root,root) %{_pkglibdir}/input/libsndfile_in.so
499
500 %files input-vorbis
501 %defattr(644,root,root,755)
502 %attr(755,root,root) %{_pkglibdir}/input/libvorbis_in.so
503
504 %files output-alsa
505 %defattr(644,root,root,755)
506 %attr(755,root,root) %{_pkglibdir}/output/libalsa_out.so
507
508 %if %{with esound}
509 %files output-esound
510 %defattr(644,root,root,755)
511 %attr(755,root,root) %{_pkglibdir}/output/libesound_out.so
512 %endif
513
514 %if %{with jack}
515 %files output-jack
516 %defattr(644,root,root,755)
517 %attr(755,root,root) %{_pkglibdir}/output/libjack_out.so
518 %endif
519
520 %if %{with nas}
521 %files output-nas
522 %defattr(644,root,root,755)
523 %attr(755,root,root) %{_pkglibdir}/output/libnas_out.so
524 %endif
525
526 %files scopes2-gtk
527 %defattr(644,root,root,755)
528 %attr(755,root,root) %{_pkglibdir}/scopes2/libblurscope.so
529 %attr(755,root,root) %{_pkglibdir}/scopes2/liblevelmeter.so
530 %attr(755,root,root) %{_pkglibdir}/scopes2/liblogbarfft.so
531 %attr(755,root,root) %{_pkglibdir}/scopes2/libmonoscope.so
532 %attr(755,root,root) %{_pkglibdir}/scopes2/libspacescope.so
533 %attr(755,root,root) %{_pkglibdir}/scopes2/libsynaescope.so
534
535 %files scopes2-opengl
536 %defattr(644,root,root,755)
537 %attr(755,root,root) %{_pkglibdir}/scopes2/liboglspectrum.so
538
539 %files devel
540 %defattr(644,root,root,755)
541 %attr(755,root,root) %{_libdir}/libalsaplayer.so
542 %{_libdir}/libalsaplayer.la
543 %{_includedir}/alsaplayer
544 %{_pkgconfigdir}/alsaplayer.pc
545
546 %files static
547 %defattr(644,root,root,755)
548 %{_libdir}/libalsaplayer.a
This page took 0.11389 seconds and 3 git commands to generate.