]> git.pld-linux.org Git - packages/alsaplayer.git/blob - alsaplayer.spec
cd5a5920da06c020dae4aa0d8d263fe31ef4ed44
[packages/alsaplayer.git] / alsaplayer.spec
1 #
2 # Conditional build
3 %bcond_without  esound          # build without esound plugin
4 %bcond_without  flac            # build without FLAC plugin
5 %bcond_without  jack            # build without jack plugin
6 %bcond_without  mikmod          # build without mikmod plugin
7 %bcond_without  nas             # build without nas plugin
8 #
9 Summary:        Alsaplayer - CD/FLAC/MOD/MP3/Ogg/WAV player
10 Summary(pl.UTF-8):      Alsaplayer - odtwarzacz CD/FLAC/MOD/MP3/Ogg/WAV
11 Name:           alsaplayer
12 Version:        0.99.80
13 %define pre     rc2
14 Release:        0.%{pre}.1
15 License:        GPLv3
16 Group:          Applications/Sound
17 Source0:        http://www.alsaplayer.org/%{name}-%{version}-%{pre}.tar.bz2
18 # Source0-md5:  bc8325c704f6cad167236055e1ff3ebb
19 Source1:        %{name}.desktop
20 Source2:        %{name}.png
21 Patch0:         %{name}-docs.patch
22 Patch1:         %{name}-flac.patch
23 URL:            http://www.alsaplayer.org/
24 BuildRequires:  OpenGL-devel
25 BuildRequires:  alsa-lib-devel
26 BuildRequires:  audiofile-devel
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 %{?with_esound:BuildRequires:   esound-devel >= 0.2.4}
30 %{?with_flac:BuildRequires:     flac-devel >= 1.1.3}
31 BuildRequires:  gtk+2-devel >= 1:2.0.3
32 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel >= 0.69.1}
33 %{?with_flac:BuildRequires:     libid3tag-devel}
34 BuildRequires:  libmad-devel
35 %{?with_mikmod:BuildRequires:   libmikmod-devel}
36 BuildRequires:  libsndfile-devel >= 1.0.4
37 BuildRequires:  libstdc++-devel
38 BuildRequires:  libtool
39 BuildRequires:  libvorbis-devel
40 %{?with_nas:BuildRequires:      nas-devel}
41 BuildRequires:  pkgconfig
42 BuildRequires:  xosd-devel
43 Requires(post): /sbin/ldconfig
44 Requires:       alsaplayer_output
45 Requires:       alsaplayer_ui
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
49 %define         _pkglibdir      %{_libdir}/%{name}
50
51 %description
52 AlsaPlayer is a new type of PCM player. It is heavily multi-threaded
53 and tries to exercise the ALSA library and driver quite a bit.
54 Features include:
55
56 Input addons:
57 - MP2 and MP3 support
58 - Ogg Vorbis support (subpackage)
59 - WAV support, 8-, 16-bit, mono, stereo, any sample rate
60 - CDDA support, CD Digital Audio playback! and thus USB ready :)
61 - Also plays files mapped by audiofs (CDDA)
62 - MAD MPEG audio
63 - Module support (mikmod) (subpcakage)
64 - FLAC support
65
66 Output addons:
67 - ALSA. Best supported of course :) (subpackage)
68 - OSS. Kernel native sound drivers
69 - Sparc. UltraSparc sound drivers
70 - SGI. SGI audio library driver
71 - ESD. Enlightened sound daemon support (subpackage)
72 - NAS. Network Audio System (subpakcage)
73 - low latency JACK output
74 - null :-)
75
76 Visual scopes:
77 - Stereoscope
78 - Monoscope
79 - Levelmeter
80 - Spacescope
81 - FFTscope
82 - FFTscope II
83 - Spectrum GL
84
85 General features:
86 - Full speed (pitch) control, positive *and* negative! (First Linux
87   player that does this!! MP3's and CD's do varispeed :)
88 - Queue (playlist) support
89 - Concurrent visual scopes (open as many as you want)
90 - Multi-threaded design for efficient/skip free playback (RT)
91 - GUI Interface based on GTK+
92 - NOGUI operation for shell script usage
93 - On-screen-display based on xosd
94 - Plug-in core architecture
95 - Low latency mode, as low as 5ms when scheduled RT
96 - Effects stream
97 - Software based volume/pan control
98 - Accurate scope/audio syncing using ALSA features
99
100 %description -l pl.UTF-8
101 AlsaPlayer to nowy rodzaj odtwarzacza PCM. Jest wielowątkowy i próbuje
102 solidnie przećwiczyć sterowniki i bibliotekę ALSA. Jego cechy to:
103
104 Wejście:
105 - obsługa MP2 i MP3
106 - obsługa Ogg Vorbis (w podpakiecie)
107 - obsługa WAV, 8 i 16-bitowych, mono, stereo o dowolnej częstotliwości
108 - obsługa CD Digital Audio
109 - odtwarzanie plików podmapowanych przez audiofs (CDDA)
110 - obsługa MAD - MPEG Audio
111 - obsługa modułów (mikmod) (w podpakiecie)
112 - obsług bezstratnej kompresji dźwięku FLAC
113
114 Wyjście:
115 - OSS - natywne sterowniki z jądra
116 - ALSA - oczywiście najlepiej obsługiwana :) (w podpakiecie)
117 - Sparc - sterowniki dźwięku dla UltraSparca
118 - SGI - biblioteka sterowników dźwięku SGI
119 - ESD - obsługa Oświeconego demona dźwięku (w podpakiecie)
120 - NAS - Sieciowego Systemu Audio (w podpakiecie)
121 - JACK - zestaw połączeń dźwięku o małych opóźnieniach (w podpakiecie)
122 - null :-)
123
124 Wizualizacja:
125 - Stereoskop
126 - Monoskop
127 - Wskaźnik poziomu dźwięku
128 - Wskaźniki oparte o analizę FFT
129 - analizator spektrum sygnału w oparciu o OpenGL
130
131 Ogólne cechy:
132 - Kontrola szybkości (w obie strony)
133 - obsługa kolejki (playlisty)
134 - obsługa wielu wskaźników naraz
135 - wielowątkowość
136 - interfejs graficzny bazujący na GTK+
137 - operacje bez GUI na potrzeby skryptów
138 - tryb Informacje-na-ekranie oparty o xosd
139 - architektura wtyczek
140 - tryb "czasu rzeczywistego" dający opóźnienia rzędu 5ms
141 - programowa kontrola głośności i balansu
142 - synchronizacja dźwięku i wskaźników przy użyciu możliwości ALSA
143
144 %package daemon
145 Summary:        Deamon interface for Alsaplayer
146 Summary(pl.UTF-8):      Interfejs demona alsaplayera
147 Group:          Applications/Sound
148 Requires:       %{name} = %{version}-%{release}
149
150 %description daemon
151 Deamon interface for Alsaplayer.
152
153 %description daemon -l pl.UTF-8
154 Interfejs demona alsaplayera.
155
156 %package input-audiofile
157 Summary:        Alsaplayer plugin for playing WAVE audio formats using audiofile
158 Summary(pl.UTF-8):      Wtyczka alsaplayera do odtwarzania plików audio typu WAVE przy użyciu audiofile
159 Group:          Applications/Sound
160 Requires:       %{name} = %{version}-%{release}
161
162 %description input-audiofile
163 Alsaplayer plugin for playing WAVE audio formats (like AIFF, AIFC,
164 WAVE, ...) using audiofile library.
165
166 %description input-audiofile -l pl.UTF-8
167 Wtyczka alsaplayera do odtwarzania plików audio typu WAVE (AIFF,
168 AIFC, WAVE, ...) przy użyciu biblioteki audiofile.
169
170 %package input-flac
171 Summary:        Alsaplayer plugin for playing FLAC files
172 Summary(pl.UTF-8):      Wtyczka alsaplayera do odtwarzania plików FLAC
173 Group:          Applications/Sound
174 Requires:       %{name} = %{version}-%{release}
175
176 %description input-flac
177 Alsaplayer plugin for playing FLAC files.
178
179 %description input-flac -l pl.UTF-8
180 Wtyczka alsaplayera do odtwarzania plików FLAC.
181
182 %package input-mad
183 Summary:        Alsaplayer plugin for playing MP3 files using MAD
184 Summary(pl.UTF-8):      Wtyczka alsaplayera do odtwarzania plików MP3 przy pomocy MAD
185 Group:          Applications/Sound
186 Requires:       %{name} = %{version}-%{release}
187
188 %description input-mad
189 Alsaplayer plugin for playing MP3 files using MAD.
190
191 %description input-mad -l pl.UTF-8
192 Wtyczka alsaplayera do odtwarzania plików MP3 przy pomocy MAD.
193
194 %package input-mikmod
195 Summary:        Alsaplayer plugin for playing mod files
196 Summary(pl.UTF-8):      Wtyczka alsaplayera do odtwarzania plików mod
197 Group:          Applications/Sound
198 Requires:       %{name} = %{version}-%{release}
199
200 %description input-mikmod
201 Alsaplayer plugin for playing mod files.
202
203 %description input-mikmod -l pl.UTF-8
204 Wtyczka alsaplayera do odtwarzania plików mod.
205
206 %package input-sndfile
207 Summary:        Alsaplayer plugin for playing WAVE audio formats using libsndfile
208 Summary(pl.UTF-8):      Wtyczka alsaplayera do odtwarzania plików audio typu WAVE przy użyciu libsndfile
209 Group:          Applications/Sound
210 Requires:       %{name} = %{version}-%{release}
211
212 %description input-sndfile
213 Alsaplayer plugin for playing WAVE audio formats (like AIFF, AIFC,
214 WAVE, ...) using libsndfile library.
215
216 %description input-sndfile -l pl.UTF-8
217 Wtyczka do alsaplayera do odtwarzania plików audio typu WAVE (AIFF,
218 AIFC, WAVE, ...) przy użyciu biblioteki libsndfile.
219
220 %package input-vorbis
221 Summary:        Alsaplayer plugin for playing Ogg/Vorbis files
222 Summary(pl.UTF-8):      Wtyczka alsaplayera do odtwarzania plików Ogg/Vorbis
223 Group:          Applications/Sound
224 Requires:       %{name} = %{version}-%{release}
225
226 %description input-vorbis
227 Alsaplayer plugin for playing Ogg/Vorbis files.
228
229 %description input-vorbis -l pl.UTF-8
230 Wtyczka alsaplayera do odtwarzania plików Ogg/Vorbis.
231
232 %package interface-gtk2
233 Summary:        GTK+ 2 interface for Alsaplayer
234 Summary(pl.UTF-8):      Interfejs GTK+ 2 alsaplayera
235 Group:          X11/Applications/Sound
236 Requires:       %{name} = %{version}-%{release}
237 Provides:       alsaplayer_ui
238
239 %description interface-gtk2
240 GTK+ 2 interface for Alsaplayer.
241
242 %description interface-gtk2 -l pl.UTF-8
243 Interfejs GTK+2 alsaplayera.
244
245 %package interface-text
246 Summary:        Text interface for Alsaplayer
247 Summary(pl.UTF-8):      Interfejs tekstowy alsaplayera
248 Group:          Applications/Sound
249 Requires:       %{name} = %{version}-%{release}
250 Provides:       alsaplayer_ui
251
252 %description interface-text
253 Text interface for Alsaplayer.
254
255 %description interface-text -l pl.UTF-8
256 Interfejs tekstowy alsaplayera.
257
258 %package interface-xosd
259 Summary:        xosd interface for Alsaplayer
260 Summary(pl.UTF-8):      Interfejs xosd alsaplayera
261 Group:          X11/Applications/Sound
262 Requires:       %{name} = %{version}-%{release}
263 Provides:       alsaplayer_ui
264
265 %description interface-xosd
266 xosd interface for Alsaplayer.
267
268 %description interface-xosd -l pl.UTF-8
269 Interfejs xosd alsaplayera.
270
271 %package output-alsa
272 Summary:        Alsaplayer plugin for playing through alsa drivers
273 Summary(pl.UTF-8):      Wtyczka alsaplayera do odtwarzania przez sterowniki alsa
274 Group:          Applications/Sound
275 Requires:       %{name} = %{version}-%{release}
276 Provides:       alsaplayer_output
277
278 %description output-alsa
279 Alsaplayer plugin for playing sound through alsa drivers.
280
281 %description output-alsa -l pl.UTF-8
282 Wtyczka alsaplayera do odtwarzania dźwięku przez sterowniki alsa.
283
284 %package output-esound
285 Summary:        Alsaplayer plugin for playing through esound daemon
286 Summary(pl.UTF-8):      Wtyczka alsaplayera do odtwarzania przez demona esound
287 Group:          Applications/Sound
288 Requires:       %{name} = %{version}-%{release}
289 Provides:       alsaplayer_output
290
291 %description output-esound
292 Alsaplayer plugin for playing sound through esound daemon.
293
294 %description output-esound -l pl.UTF-8
295 Wtyczka alsaplayera do odtwarzania dźwięku przez demona esound.
296
297 %package output-nas
298 Summary:        Alsaplayer plugin for playing through NAS daemon
299 Summary(pl.UTF-8):      Wtyczka do alsaplayera do odtwarzania przez demona NAS
300 Group:          Applications/Sound
301 Requires:       %{name} = %{version}-%{release}
302 Provides:       alsaplayer_output
303
304 %description output-nas
305 Alsaplayer plugin for playing sound through NAS (network audio system)
306 daemon.
307
308 %description output-nas -l pl.UTF-8
309 Wtyczka alsaplayera do odtwarzania dźwięku przez demona NAS (network
310 audio system).
311
312 %package output-jack
313 Summary:        Alsaplayer plugin for playing sound through JACK
314 Summary(pl.UTF-8):      Wtyczka alsaplayera do odtwarzania dźwięku przez JACK-a
315 Group:          Applications/Sound
316 Requires:       %{name} = %{version}-%{release}
317 Provides:       alsaplayer_output
318
319 %description output-jack
320 Alsaplayer plugin for sound through JACK system.
321
322 %description output-jack -l pl.UTF-8
323 Wtyczka alsaplayera do odtwarzania dźwięku przez system JACK.
324
325 %package scopes2-gtk
326 Summary:        Alsaplayer plugins for visualization
327 Summary(pl.UTF-8):      Wtyczki alsaplayera do wizualizacji
328 Group:          X11/Applications/Multimedia
329 Requires:       %{name} = %{version}-%{release}
330 Obsoletes:      alsaplayer-scopes-gtk
331
332 %description scopes2-gtk
333 Alsaplayer plugins for visualization.
334
335 %description scopes2-gtk -l pl.UTF-8
336 Wtyczki do alsaplayera do wizualizacji.
337
338 %package scopes2-opengl
339 Summary:        Alsaplayer plugin for visualization using OpenGL
340 Summary(pl.UTF-8):      Wtyczka alsaplayera do wizualizacji z użyciem OpenGL
341 Group:          X11/Applications/Multimedia
342 Requires:       %{name} = %{version}-%{release}
343 Requires:       OpenGL
344 Obsoletes:      alsaplayer-scopes-opengl
345
346 %description scopes2-opengl
347 Alsaplayer plugin for visualization using OpenGL.
348
349 %description scopes2-opengl -l pl.UTF-8
350 Wtyczka do alsaplayera do wizualizacji z użyciem OpenGL.
351
352 %package devel
353 Summary:        Alsaplayer header files
354 Summary(pl.UTF-8):      Pliki nagłówkowe Alsaplayera
355 Group:          Development/Libraries
356 Requires:       %{name} = %{version}-%{release}
357
358 %description devel
359 Header files for Alsaplayer library.
360
361 %description devel -l pl.UTF-8
362 Pliki nagłówkowe biblioteki Alsaplayera.
363
364 %package static
365 Summary:        Alsaplayer static library
366 Summary(pl.UTF-8):      Biblioteka statyczna Alsaplayera
367 Group:          Development/Libraries
368 Requires:       %{name}-devel = %{version}-%{release}
369
370 %description static
371 Alsaplayer static library.
372
373 %description static -l pl.UTF-8
374 Biblioteka statyczna Alsaplayera.
375
376 %prep
377 %setup -q -n %{name}-%{version}-%{pre}
378 %patch0 -p1
379 #patch1 -p1
380
381 %build
382 rm -f missing
383 %{__libtoolize}
384 %{__aclocal}
385 %{__autoconf}
386 %{__automake}
387 CPPFLAGS=" -I/usr/X11R6/include"
388 LDFLAGS="%{rpmldflags} -L/usr/X11R6/lib"
389 export CPPFLAGS LDFLAGS
390 %configure \
391         %{?with_esound:--en}%{!?with_esound:--dis}able-esd \
392         %{?with_flac:--en}%{!?with_flac:--dis}able-flac \
393         %{?with_flac:--en}%{!?with_flac:--dis}able-oggflac \
394         %{?with_jack:--en}%{!?with_jack:--dis}able-jack \
395         %{?with_mikmod:--en}%{!?with_mikmod:--dis}able-mikmod \
396         %{?with_nas:--en}%{!?with_nas:--dis}able-nas \
397         %{?with_esound:--en}%{!?with_esound:--dis}able-esd \
398         --enable-alsa \
399         --enable-audiofile \
400         --enable-gtk2 \
401         --enable-oggflac \
402         --enable-oggvorbis \
403         --enable-opengl \
404         --enable-oss \
405         --enable-static
406
407 %{__make}
408
409 %install
410 rm -rf $RPM_BUILD_ROOT
411 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
412
413 %{__make} install \
414         DESTDIR=$RPM_BUILD_ROOT \
415         pkgconfigdir=%{_pkgconfigdir}
416
417 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
418 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
419
420 rm -f $RPM_BUILD_ROOT%{_pkglibdir}/input/*.{a,la}
421 rm -f $RPM_BUILD_ROOT%{_pkglibdir}/interface/*.{a,la}
422 rm -f $RPM_BUILD_ROOT%{_pkglibdir}/output/*.{a,la}
423 rm -f $RPM_BUILD_ROOT%{_pkglibdir}/reader/*.{a,la}
424 rm -f $RPM_BUILD_ROOT%{_pkglibdir}/scopes2/*.{a,la}
425
426 %{find_lang} %{name}
427
428 %clean
429 rm -rf $RPM_BUILD_ROOT
430
431 %post
432 /sbin/ldconfig
433 echo
434 echo "Remember to install appropriate alsaplayer-input-* plugins"
435 echo "for files you want to play, for example:"
436 echo "alsaplayer-input-mad to play MP3s."
437 echo
438
439 %postun -p /sbin/ldconfig
440
441 %files -f %{name}.lang
442 %defattr(644,root,root,755)
443 %doc AUTHORS README ChangeLog
444 %attr(755,root,root) %{_bindir}/alsaplayer
445 %attr(755,root,root) %{_libdir}/libalsaplayer.so.0.0.2
446 %dir %{_pkglibdir}
447 %dir %{_pkglibdir}/input
448 %dir %{_pkglibdir}/interface
449 %dir %{_pkglibdir}/output
450 %dir %{_pkglibdir}/reader
451 %dir %{_pkglibdir}/scopes2
452 %attr(755,root,root) %{_pkglibdir}/input/libcdda.so
453 %attr(755,root,root) %{_pkglibdir}/input/libwav.so
454 %attr(755,root,root) %{_pkglibdir}/output/liboss_out.so
455 %attr(755,root,root) %{_pkglibdir}/output/libnull_out.so
456 %attr(755,root,root) %{_pkglibdir}/reader/libfile.so
457 %attr(755,root,root) %{_pkglibdir}/reader/libhttp.so
458 %{_mandir}/man*/*
459 %{_desktopdir}/%{name}.desktop
460 %{_pixmapsdir}/%{name}.png
461
462 %files daemon
463 %defattr(644,root,root,755)
464 %attr(755,root,root) %{_pkglibdir}/interface/libdaemon_interface.so
465
466 %files interface-gtk2
467 %defattr(644,root,root,755)
468 %attr(755,root,root) %{_pkglibdir}/interface/libgtk2_interface.so
469
470 %files interface-text
471 %defattr(644,root,root,755)
472 %attr(755,root,root) %{_pkglibdir}/interface/libtext_interface.so
473
474 %files interface-xosd
475 %defattr(644,root,root,755)
476 %attr(755,root,root) %{_pkglibdir}/interface/libxosd_interface.so
477
478 %files input-audiofile
479 %defattr(644,root,root,755)
480 %attr(755,root,root) %{_pkglibdir}/input/libaf.so
481
482 %if %{with flac}
483 %files input-flac
484 %defattr(644,root,root,755)
485 %attr(755,root,root) %{_pkglibdir}/input/libflac_in.so
486 %endif
487
488 %files input-mad
489 %defattr(644,root,root,755)
490 %attr(755,root,root) %{_pkglibdir}/input/libmad_in.so
491
492 %if %{with mikmod}
493 %files input-mikmod
494 %defattr(644,root,root,755)
495 %attr(755,root,root) %{_pkglibdir}/input/libmod.so
496 %endif
497
498 %files input-sndfile
499 %defattr(644,root,root,755)
500 %attr(755,root,root) %{_pkglibdir}/input/libsndfile_in.so
501
502 %files input-vorbis
503 %defattr(644,root,root,755)
504 %attr(755,root,root) %{_pkglibdir}/input/libvorbis_in.so
505
506 %files output-alsa
507 %defattr(644,root,root,755)
508 %attr(755,root,root) %{_pkglibdir}/output/libalsa_out.so
509
510 %if %{with esound}
511 %files output-esound
512 %defattr(644,root,root,755)
513 %attr(755,root,root) %{_pkglibdir}/output/libesound_out.so
514 %endif
515
516 %if %{with jack}
517 %files output-jack
518 %defattr(644,root,root,755)
519 %attr(755,root,root) %{_pkglibdir}/output/libjack_out.so
520 %endif
521
522 %if %{with nas}
523 %files output-nas
524 %defattr(644,root,root,755)
525 %attr(755,root,root) %{_pkglibdir}/output/libnas_out.so
526 %endif
527
528 %files scopes2-gtk
529 %defattr(644,root,root,755)
530 %attr(755,root,root) %{_pkglibdir}/scopes2/libblurscope.so
531 %attr(755,root,root) %{_pkglibdir}/scopes2/liblevelmeter.so
532 %attr(755,root,root) %{_pkglibdir}/scopes2/liblogbarfft.so
533 %attr(755,root,root) %{_pkglibdir}/scopes2/libmonoscope.so
534 %attr(755,root,root) %{_pkglibdir}/scopes2/libspacescope.so
535 %attr(755,root,root) %{_pkglibdir}/scopes2/libsynaescope.so
536
537 %files scopes2-opengl
538 %defattr(644,root,root,755)
539 %attr(755,root,root) %{_pkglibdir}/scopes2/liboglspectrum.so
540
541 %files devel
542 %defattr(644,root,root,755)
543 %attr(755,root,root) %{_libdir}/libalsaplayer.so
544 %{_libdir}/libalsaplayer.la
545 %{_includedir}/alsaplayer
546 %{_pkgconfigdir}/alsaplayer.pc
547
548 %files static
549 %defattr(644,root,root,755)
550 %{_libdir}/libalsaplayer.a
This page took 0.078066 seconds and 2 git commands to generate.