]> git.pld-linux.org Git - packages/alpm.git/blob - alpm.spec
- up to 6.0.2
[packages/alpm.git] / alpm.spec
1 Summary:        Pacman - simple library-based package manager (from Arch Linux)
2 Summary(pl.UTF-8):      Pacman - prosty, oparty na bibliotece zarządca pakietów (z Arch Linuksa)
3 Name:           alpm
4 Version:        4.2.0
5 Release:        0.1
6 License:        GPL v2+
7 Group:          Libraries
8 Source0:        ftp://ftp.archlinux.org/other/pacman/pacman-%{version}.tar.gz
9 # Source0-md5:  184ce14f1f326fede72012cca51bba51
10 URL:            https://www.archlinux.org/pacman/
11 BuildRequires:  bash >= 4.1.0
12 BuildRequires:  autoconf >= 2.62
13 BuildRequires:  automake >= 1:1.11
14 BuildRequires:  curl-devel >= 7.19.4
15 BuildRequires:  gettext-devel >= 0.13.1
16 BuildRequires:  gpgme-devel >= 1.3.0
17 BuildRequires:  libarchive-devel >= 2.8.0
18 BuildRequires:  libtool >= 2:2
19 BuildRequires:  openssl-devel
20 BuildRequires:  perl-base >= 1:5.10.1
21 BuildRequires:  pkgconfig
22 BuildRequires:  python >= 1:2.7
23 Requires:       %{name}-libs = %{version}-%{release}
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Pacman is a simple library-based package manager, designed for Arch
28 Linux.
29
30 %description -l pl.UTF-8
31 Pacman to prosty, oparty na bibliotece zarządca pakietów, powstały dla
32 Arch Linuksa.
33
34 %package libs
35 Summary:        Arch Linux Package Management library
36 Summary(pl.UTF-8):      Biblioteka Arch Linux Package Management
37 Group:          Libraries
38
39 %description libs
40 Arch Linux Package Management library.
41
42 %description libs -l pl.UTF-8
43 Biblioteka Arch Linux Package Management, służąca do zarządzania
44 pakietami Arch Linuksa.
45
46 %package devel
47 Summary:        Header files for ALPM library
48 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki ALPM
49 Group:          Development/Libraries
50 Requires:       %{name}-libs = %{version}-%{release}
51 Requires:       curl-devel >= 7.19.4
52 Requires:       gpgme-devel >= 1.3.0
53 Requires:       libarchive-devel >= 2.8.0
54 Requires:       openssl-devel
55
56 %description devel
57 Header files for ALPM library.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe biblioteki ALPM.
61
62 %package static
63 Summary:        Static ALPM library
64 Summary(pl.UTF-8):      Statyczna biblioteka ALPM
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{version}-%{release}
67
68 %description static
69 Static ALPM library.
70
71 %description static -l pl.UTF-8
72 Statyczna biblioteka ALPM.
73
74 %prep
75 %setup -q -n pacman-%{version}
76
77 %build
78 %{__libtoolize}
79 %{__aclocal} -I m4
80 %{__autoconf}
81 %{__autoheader}
82 %{__automake}
83 %configure \
84         --disable-silent-rules
85
86 %{__make}
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 # obsoleted by pkg-config
95 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libalpm.la
96
97 # too generic names
98 %{__mv} $RPM_BUILD_ROOT%{_bindir}/{,pacman-}testdb
99 %{__mv} $RPM_BUILD_ROOT%{_bindir}/{,pacman-}vercmp
100 %{__mv} $RPM_BUILD_ROOT%{_mandir}/man8/{,pacman-}vercmp.8
101
102 # outdated version of ko
103 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ko_KR
104
105 %find_lang libalpm
106 %find_lang pacman
107 %find_lang pacman-scripts
108 cat pacman-scripts.lang >> pacman.lang
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post   libs -p /sbin/ldconfig
114 %postun libs -p /sbin/ldconfig
115
116 %files -f pacman.lang
117 %defattr(644,root,root,755)
118 %attr(755,root,root) %{_bindir}/cleanupdelta
119 %attr(755,root,root) %{_bindir}/makepkg
120 %attr(755,root,root) %{_bindir}/makepkg-template
121 %attr(755,root,root) %{_bindir}/pacman
122 %attr(755,root,root) %{_bindir}/pacman-db-upgrade
123 %attr(755,root,root) %{_bindir}/pacman-key
124 %attr(755,root,root) %{_bindir}/pacman-optimize
125 %attr(755,root,root) %{_bindir}/pacman-testdb
126 %attr(755,root,root) %{_bindir}/pacman-vercmp
127 %attr(755,root,root) %{_bindir}/pacsort
128 %attr(755,root,root) %{_bindir}/pactree
129 %attr(755,root,root) %{_bindir}/pkgdelta
130 %attr(755,root,root) %{_bindir}/repo-add
131 %attr(755,root,root) %{_bindir}/repo-elephant
132 %attr(755,root,root) %{_bindir}/repo-remove
133 %attr(755,root,root) %{_bindir}/testpkg
134 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/makepkg.conf
135 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pacman.conf
136 %{_datadir}/pacman
137 %{_mandir}/man1/makepkg-template.1*
138 %{_mandir}/man5/PKGBUILD.5*
139 %{_mandir}/man5/makepkg.conf.5*
140 %{_mandir}/man5/pacman.conf.5*
141 %{_mandir}/man8/makepkg.8*
142 %{_mandir}/man8/pacman.8*
143 %{_mandir}/man8/pacman-key.8*
144 %{_mandir}/man8/pacman-vercmp.8*
145 %{_mandir}/man8/pactree.8*
146 %{_mandir}/man8/pkgdelta.8*
147 %{_mandir}/man8/repo-add.8*
148 %{_mandir}/man8/repo-remove.8*
149
150 %files libs -f libalpm.lang
151 %defattr(644,root,root,755)
152 %doc AUTHORS NEWS README
153 %attr(755,root,root) %{_libdir}/libalpm.so.*.*.*
154 %attr(755,root,root) %ghost %{_libdir}/libalpm.so.9
155
156 %files devel
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{_libdir}/libalpm.so
159 %{_includedir}/alpm.h
160 %{_includedir}/alpm_list.h
161 %{_pkgconfigdir}/libalpm.pc
162 %{_mandir}/man3/libalpm.3*
163
164 %files static
165 %defattr(644,root,root,755)
166 %{_libdir}/libalpm.a
This page took 0.0831 seconds and 3 git commands to generate.