]> git.pld-linux.org Git - packages/alpine.git/blobdiff - alpine.spec
- patchlevel 38 - fixes crashes with some messages
[packages/alpine.git] / alpine.spec
index b1ac8b870c19c1f58c804305cfca8842e8df5033..d3f931d24f90d669e51e293e14d3ad08717e4cb0 100644 (file)
@@ -1,26 +1,39 @@
 # TODO:
 # - backport man-pages from pine.spec
 # - alpine should obsolete pine, link pine -> alpine should be made
-# - pine -> alpine config converter
 # - review patches from pine:
-#   - maildir support is missing - maybe some fixed patch from http://staff.washington.edu/chappa/pine/ ?
+#   - home_etc support
+#   - ....many more
+# - separate package with tcl web-frontend
 Summary:       University of Washington Pine mail user agent
 Summary(pl.UTF-8):     Klient pocztowy Pine z Uniwersytetu w Waszyngtonie
 Name:          alpine
-Version:       0.999
-Release:       0.2
+%define                ver             0.9999
+%define                patchlevel      38
+Version:       %{ver}.%{patchlevel}
+Release:       1
 Epoch:         1
 License:       Apache License 2.0
 Group:         Applications/Mail
-Source0:       ftp://ftp.cac.washington.edu/alpine/%{name}-%{version}.tar.gz
-# Source0-md5: 082de388a998c1faa2385ebdfd6800f5
+# Main site:
+#Source0:      ftp://ftp.cac.washington.edu/alpine/%{name}-%{version}.tar.gz
+# Source with applied patches from http://staff.washington.edu/chappa/alpine/ 
+Source0:       http://staff.washington.edu/chappa/alpine/patches/alpine-%{ver}/%{name}-%{ver}_%{patchlevel}.tar.gz
+# Source0-md5: 77953f8d0fc7f8b2d0aa3787bb0982de
 Source1:       pico.desktop
-URL:           http://www.washington.edu/alpine
+Source2:       %{name}.desktop
+Source3:       %{name}.png
+Patch0:                %{name}-thread_end.patch
+Patch1:                %{name}-index_display.patch
+URL:           http://www.washington.edu/alpine/
+BuildRequires: autoconf
+BuildRequires: automake
 BuildRequires: krb5-devel
 BuildRequires: ncurses-devel
 BuildRequires: openldap-devel
 BuildRequires: openssl-devel
 BuildRequires: pam-devel
+# Only for web-frontend
 BuildRequires: tcl-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -91,9 +104,14 @@ como no Pine, comandos são apresentados na parte de baixo da tela, e
 ajuda de acordo com o contexto está disponível.
 
 %prep
-%setup -q
+%setup -q -n %{name}-%{ver}
+%patch0 -p1
+%patch1 -p1
 
 %build
+%{__autoconf}
+%{__aclocal} -I m4
+%{__automake}
 %configure \
        --enable-quotas \
        --with-smtp-msa=%{_libdir}/sendmail \
@@ -107,12 +125,14 @@ ajuda de acordo com o contexto está disponível.
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{alpineconfdir},%{_desktopdir}}
+install -d $RPM_BUILD_ROOT{%{alpineconfdir},%{_desktopdir},%{_pixmapsdir}}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
+install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
+install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -121,15 +141,14 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc README doc/tech-notes.txt
 %dir %{alpineconfdir}
-%attr(755,root,root) %{_bindir}/alpine
+%attr(755,root,root) %{_bindir}/%{name}
 %attr(755,root,root) %{_bindir}/rpload
 %attr(755,root,root) %{_bindir}/rpdump
-#%attr(755,root,root) %{_bindir}/mailutil
-#%attr(2755,root,mail) %{_sbindir}/mlock
-%{_mandir}/man1/alpine.1*
-#%{_mandir}/man1/rpload.1*
-#%{_mandir}/man1/rpdump.1*
-#%{_mandir}/man1/mailutil.1*
+%{_mandir}/man1/%{name}.1*
+%{_mandir}/man1/rpload.1*
+%{_mandir}/man1/rpdump.1*
+%{_desktopdir}/%{name}.desktop
+%{_pixmapsdir}/%{name}.png
 
 %files -n pico
 %defattr(644,root,root,755)
This page took 0.097082 seconds and 4 git commands to generate.