]> git.pld-linux.org Git - packages/alpine.git/blobdiff - alpine.spec
- updated for 1.10
[packages/alpine.git] / alpine.spec
index 2539f9f8070baf3a3f026525246052e011bc19e2..b0c7e0afe6b632038d5d7588222b2bdb866d81ad 100644 (file)
@@ -2,21 +2,21 @@
 # - backport man-pages from pine.spec
 # - separate package with tcl web-frontend
 # - fix as-needed
+%define                ver             1.00
+%define                patchlevel      12
 Summary:       University of Washington Alpine mail user agent
 Summary(pl.UTF-8):     Klient pocztowy Alpine z Uniwersytetu w Waszyngtonie
 Name:          alpine
-%define                ver             1.00
-%define                patchlevel      3
 Version:       %{ver}.%{patchlevel}
 Release:       2
 Epoch:         1
-License:       Apache License 2.0
+License:       Apache v2.0
 Group:         Applications/Mail
 # Main site:
 #Source0:      ftp://ftp.cac.washington.edu/alpine/%{name}-%{version}.tar.gz
 # Source with applied patches from http://staff.washington.edu/chappa/alpine/
 Source0:       http://staff.washington.edu/chappa/alpine/patches/alpine-%{ver}/%{name}-%{ver}_%{patchlevel}.tar.gz
-# Source0-md5: 3937652526da1afe6310e05650ace80c
+# Source0-md5: eccde18b953df022d5e073b7de6b9c1a
 Source1:       pico.desktop
 Source2:       %{name}.desktop
 Source3:       %{name}.png
@@ -27,10 +27,9 @@ Patch3:              %{name}-quote.patch
 Patch4:                %{name}-fhs.patch
 Patch5:                %{name}-segfix.patch
 Patch6:                %{name}-libc-client.patch
-Patch7:                %{name}-fixhome.patch
-Patch8:                %{name}-ssl.patch
-Patch9:                %{name}-no_1777_warning.patch
-Patch10:       %{name}-home_etc.patch
+Patch7:                %{name}-ssl.patch
+Patch8:                %{name}-no_1777_warning.patch
+Patch9:                %{name}-home_etc.patch
 URL:           http://www.washington.edu/alpine/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -42,12 +41,12 @@ BuildRequires:      openssl-devel
 BuildRequires: pam-devel
 # Only for web-frontend:
 #BuildRequires:        tcl-devel
-Obsoletes:     pine
-Provides:      pine = 4.99
 Suggests:      aspell
+Provides:      pine = 5.00
+Obsoletes:     pine
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                alpineconfdir   /etc/%{name}
+%define                alpineconfdir   %{_sysconfdir}/%{name}
 %define                filterout_ld    -Wl,--as-needed
 
 %description
@@ -75,7 +74,7 @@ Summary:      Simple text editor in the style of the Pine Composer
 Summary(pl.UTF-8):     Prosty edytor tekstowy w stylu alpine
 Summary(pt_BR.UTF-8):  Editor de textos para terminal simples e fácil de usar
 Group:         Applications/Editors
-Provides:      pico = 4.99
+Provides:      pico = 5.00
 
 %description -n pico
 Pico is a simple, display-oriented text editor based on the Alpine
@@ -99,7 +98,7 @@ Summary:      Simple file system browser in the style of the Alpine Composer
 Summary(pl.UTF-8):     Prosta przeglądarka plików w stylu composera alpine
 Summary(pt_BR.UTF-8):  Navegador de sistemas de arquivos no estilo do compositor do Alpine
 Group:         Applications/Shells
-Provides:      pilot = 4.99
+Provides:      pilot = 5.00
 
 %description -n pilot
 Pilot is a simple, display-oriented file system browser based on the
@@ -128,7 +127,6 @@ ajuda de acordo com o contexto está disponível.
 %patch7 -p1
 %patch8 -p1
 %patch9 -p1
-%patch10 -p1
 
 %build
 rm -f libtool missing
@@ -142,8 +140,8 @@ rm -f libtool missing
        --without-tcl \
        --with-smtp-msa=%{_libdir}/sendmail \
        --with-simple-spellcheck=aspell \
-       --with-system-pinerc=%{alpineconfdir}/%{name}.conf \
-       --with-system-fixed-pinerc=%{alpineconfdir}/%{name}.conf.fixed \
+       --with-system-pinerc=%{_sysconfdir}/%{name}/%{name}.conf \
+       --with-system-fixed-pinerc=%{_sysconfdir}/%{name}/%{name}.conf.fixed \
        --with-krb5-dir=%{_prefix} \
        --with-ldap-dir=%{_prefix} \
        --with-system-mail-directory=/var/mail \
@@ -157,7 +155,7 @@ rm -f libtool missing
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{alpineconfdir},%{_desktopdir},%{_pixmapsdir}}
+install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_desktopdir},%{_pixmapsdir}}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
@@ -168,29 +166,35 @@ install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
 
 ln -s alpine $RPM_BUILD_ROOT%{_bindir}/pine
 
-$RPM_BUILD_ROOT%{_bindir}/alpine -conf > $RPM_BUILD_ROOT%{alpineconfdir}/alpine.conf
-cat <<EOF > $RPM_BUILD_ROOT%{alpineconfdir}/alpine.conf.fixed
+$RPM_BUILD_ROOT%{_bindir}/alpine -conf > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/alpine.conf
+cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/alpine.conf.fixed
 #
 # Alpine system-wide enforced configuration file - customize as needed
 #
 # This file holds the system-wide enforced values for alpine configuration
 # settings. Any values set in it will override values set in the
-# system-wide default configuration file (%{alpineconfdir}/alpine.conf) and
+# system-wide default configuration file (%{_sysconfdir}/%{name}/alpine.conf) and
 # the user's own configuration file (~/.pinerc).
 # For more information on the format of this file, read the
-# comments at the top of %{alpineconfdir}/alpine.conf
+# comments at the top of %{_sysconfdir}/%{name}/alpine.conf
 
 EOF
 
+%post
+if [ -f %{_sysconfdir}/%{name}/alpine.conf -a -f %{_sysconfdir}/%{name}/alpine.conf.rpmnew ]; then
+       cp -f %{_sysconfdir}/%{name}/alpine.conf{,.backup}
+       alpine -P %{_sysconfdir}/%{name}/alpine.conf.backup -conf > %{_sysconfdir}/%{name}/alpine.conf || :
+fi
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
 %doc README doc/tech-notes.txt
-%dir %{alpineconfdir}
-%config(noreplace) %verify(not md5 mtime size) %{alpineconfdir}/alpine.conf
-%config(noreplace) %verify(not md5 mtime size) %{alpineconfdir}/alpine.conf.fixed
+%dir %{_sysconfdir}/%{name}
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/alpine.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/alpine.conf.fixed
 %attr(755,root,root) %{_bindir}/%{name}
 %attr(755,root,root) %{_bindir}/pine
 %attr(755,root,root) %{_bindir}/rpload
This page took 0.065389 seconds and 4 git commands to generate.