]> git.pld-linux.org Git - packages/alpine.git/blobdiff - alpine.spec
- x86_64 fix: sendmail link always in /usr/lib; rel. 2
[packages/alpine.git] / alpine.spec
index 393f84f9e5e19dc37c106b40504674af667fb0d4..9dd660396a8ba58605c6ab367493b378defddefe 100644 (file)
@@ -1,52 +1,50 @@
-# TODO:
-# - backport man-pages from pine.spec
-# - separate package with tcl web-frontend
-# - fix as-needed
+%define                ver             2.00
+%define                patchlevel      50
 Summary:       University of Washington Alpine mail user agent
 Summary(pl.UTF-8):     Klient pocztowy Alpine z Uniwersytetu w Waszyngtonie
 Name:          alpine
-%define                ver             1.00
-%define                patchlevel      4
 Version:       %{ver}.%{patchlevel}
-Release:       1
+Release:       2
 Epoch:         1
-License:       Apache License 2.0
+License:       Apache v2.0
 Group:         Applications/Mail
 # Main site:
 #Source0:      ftp://ftp.cac.washington.edu/alpine/%{name}-%{version}.tar.gz
 # Source with applied patches from http://staff.washington.edu/chappa/alpine/
 Source0:       http://staff.washington.edu/chappa/alpine/patches/alpine-%{ver}/%{name}-%{ver}_%{patchlevel}.tar.gz
-# Source0-md5: 08c33c2c776f8729b7a6c1989487354d
+# Source0-md5: e5070b17952b369dec93fe3f3dd2f059
 Source1:       pico.desktop
 Source2:       %{name}.desktop
 Source3:       %{name}.png
 Patch0:                %{name}-index_display.patch
 Patch1:                %{name}-doc.patch
 Patch2:                %{name}-filter.patch
-Patch3:                %{name}-quote.patch
-Patch4:                %{name}-fhs.patch
-Patch5:                %{name}-segfix.patch
-Patch6:                %{name}-libc-client.patch
-Patch7:                %{name}-ssl.patch
-Patch8:                %{name}-no_1777_warning.patch
-Patch9:                %{name}-home_etc.patch
+Patch3:                %{name}-fhs.patch
+Patch4:                %{name}-libc-client.patch
+Patch5:                %{name}-ssl.patch
+Patch6:                %{name}-no_1777_warning.patch
+Patch7:                %{name}-home_etc.patch
 URL:           http://www.washington.edu/alpine/
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: home-etc-devel
-BuildRequires: krb5-devel
+%if "%{pld_release}" != "ac"
+BuildRequires: heimdal-devel
+%endif
 BuildRequires: ncurses-devel
-BuildRequires: openldap-devel >= 2.4.6
+BuildRequires: openldap-devel
 BuildRequires: openssl-devel
 BuildRequires: pam-devel
 # Only for web-frontend:
 #BuildRequires:        tcl-devel
-Obsoletes:     pine
-Provides:      pine = 5.00
 Suggests:      aspell
-BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+Suggests:      ca-certificates
+Conflicts:     ca-certificates < 20080809-4
+Provides:      pine = 6.00
+Obsoletes:     pine
+6c6cBuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                alpineconfdir   /etc/%{name}
+%define                alpineconfdir   %{_sysconfdir}/%{name}
 %define                filterout_ld    -Wl,--as-needed
 
 %description
@@ -59,7 +57,7 @@ features, and an ever-growing number of configuration and
 personal-preference options.
 
 %description -l pl.UTF-8
-Alpine, czyli Alternatively Licensed Program for Internet News & Email
+Alpi6c6cne, czyli Alternatively Licensed Program for Internet News & Email
 (alternatywnie licencjonowany program do newsów i poczty internetowej)
 to narzędzie do czytania, wysyłania i zarządzania wiadomościami
 elektronicznymi. Alpine jest następcą Pine'a i został napisany przez
@@ -74,7 +72,7 @@ Summary:      Simple text editor in the style of the Pine Composer
 Summary(pl.UTF-8):     Prosty edytor tekstowy w stylu alpine
 Summary(pt_BR.UTF-8):  Editor de textos para terminal simples e fácil de usar
 Group:         Applications/Editors
-Provides:      pico = 5.00
+Provides:      pico = 6.00
 
 %description -n pico
 Pico is a simple, display-oriented text editor based on the Alpine
@@ -98,7 +96,7 @@ Summary:      Simple file system browser in the style of the Alpine Composer
 Summary(pl.UTF-8):     Prosta przeglądarka plików w stylu composera alpine
 Summary(pt_BR.UTF-8):  Navegador de sistemas de arquivos no estilo do compositor do Alpine
 Group:         Applications/Shells
-Provides:      pilot = 5.00
+Provides:      pilot = 6.00
 
 %description -n pilot
 Pilot is a simple, display-oriented file system browser based on the
@@ -125,8 +123,6 @@ ajuda de acordo com o contexto está disponível.
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
-%patch8 -p1
-%patch9 -p1
 
 %build
 rm -f libtool missing
@@ -136,18 +132,24 @@ rm -f libtool missing
 %{__autoheader}
 %{__automake}
 %configure \
+       --%{?debug:en}%{!?debug:dis}able-debug \
        --enable-quotas \
        --without-tcl \
-       --with-smtp-msa=%{_libdir}/sendmail \
+       --with-smtp-msa=/usr/lib/sendmail \
        --with-simple-spellcheck=aspell \
-       --with-system-pinerc=%{alpineconfdir}/%{name}.conf \
-       --with-system-fixed-pinerc=%{alpineconfdir}/%{name}.conf.fixed \
+       --with-system-pinerc=%{_sysconfdir}/%{name}/%{name}.conf \
+       --with-system-fixed-pinerc=%{_sysconfdir}/%{name}/%{name}.conf.fixed \
        --with-krb5-dir=%{_prefix} \
        --with-ldap-dir=%{_prefix} \
        --with-system-mail-directory=/var/mail \
        --with-c-client-target=slx \
+%if "%{pld_release}" == "ti"
        --with-ssl-dir=/var/lib/openssl/certs \
        --with-ssl-certs-dir=/var/lib/openssl/certs \
+%else
+       --with-ssl-dir=/etc/openssl/certs \
+       --with-ssl-certs-dir=/etc/certs \
+%endif
        --with-passfile=.pine.pwd
 
 %{__make} \
@@ -155,7 +157,7 @@ rm -f libtool missing
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{alpineconfdir},%{_desktopdir},%{_pixmapsdir}}
+install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_desktopdir},%{_pixmapsdir}}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
@@ -166,35 +168,29 @@ install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
 
 ln -s alpine $RPM_BUILD_ROOT%{_bindir}/pine
 
-$RPM_BUILD_ROOT%{_bindir}/alpine -conf > $RPM_BUILD_ROOT%{alpineconfdir}/alpine.conf
-cat <<EOF > $RPM_BUILD_ROOT%{alpineconfdir}/alpine.conf.fixed
+$RPM_BUILD_ROOT%{_bindir}/alpine -conf > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/alpine.conf
+cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/alpine.conf.fixed
 #
 # Alpine system-wide enforced configuration file - customize as needed
 #
 # This file holds the system-wide enforced values for alpine configuration
 # settings. Any values set in it will override values set in the
-# system-wide default configuration file (%{alpineconfdir}/alpine.conf) and
+# system-wide default configuration file (%{_sysconfdir}/%{name}/alpine.conf) and
 # the user's own configuration file (~/.pinerc).
 # For more information on the format of this file, read the
-# comments at the top of %{alpineconfdir}/alpine.conf
+# comments at the top of %{_sysconfdir}/%{name}/alpine.conf
 
 EOF
 
-%post
-if [ -f "%{alpineconfdir}/alpine.conf" -a -f "%{alpineconfdir}/alpine.conf.rpmnew" ]; then
-       mv %{alpineconfdir}/alpine.conf %{alpineconfdir}/alpine.conf.backup
-       alpine -P %{alpineconfdir}/alpine.conf.backup -conf > /etc/alpine/alpine.conf || exit 0
-fi
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
 %doc README doc/tech-notes.txt
-%dir %{alpineconfdir}
-%config(noreplace) %verify(not md5 mtime size) %{alpineconfdir}/alpine.conf
-%config(noreplace) %verify(not md5 mtime size) %{alpineconfdir}/alpine.conf.fixed
+%dir %{_sysconfdir}/%{name}
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/alpine.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/alpine.conf.fixed
 %attr(755,root,root) %{_bindir}/%{name}
 %attr(755,root,root) %{_bindir}/pine
 %attr(755,root,root) %{_bindir}/rpload
This page took 0.087444 seconds and 4 git commands to generate.