]> git.pld-linux.org Git - packages/alpine.git/blobdiff - alpine.spec
- do automatic upgrade of default config
[packages/alpine.git] / alpine.spec
index 268136f7b6bd1e0a4ac0b0766009e35a5a38608e..4717c30ea95b1d511dc804f62f93407593829dd7 100644 (file)
@@ -8,7 +8,7 @@ Name:           alpine
 %define                ver             1.00
 %define                patchlevel      3
 Version:       %{ver}.%{patchlevel}
-Release:       1
+Release:       2
 Epoch:         1
 License:       Apache License 2.0
 Group:         Applications/Mail
@@ -182,6 +182,12 @@ cat <<EOF > $RPM_BUILD_ROOT%{alpineconfdir}/alpine.conf.fixed
 
 EOF
 
+%post
+if [ -f "%{alpineconfdir}/alpine.conf" -a -f "%{alpineconfdir}/alpine.conf.rpmnew" ]; then
+       mv %{alpineconfdir}/alpine.conf %{alpineconfdir}/alpine.conf.backup
+       alpine -P %{alpineconfdir}/alpine.conf.backup -conf > /etc/alpine/alpine.conf || exit 0
+fi
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
This page took 0.038056 seconds and 4 git commands to generate.