]> git.pld-linux.org Git - packages/alpine.git/blobdiff - alpine.spec
Release 4 (by relup.sh)
[packages/alpine.git] / alpine.spec
index ac724892409441a23caae55b9a5a8aa8a951d893..1e42fbd95078f16b71af054beaa02041e915c9d4 100644 (file)
@@ -2,52 +2,57 @@
 # - backport man-pages from pine.spec
 # - separate package with tcl web-frontend
 # - fix as-needed
+# - pico shouldn't link with kerberos, should it?
 Summary:       University of Washington Alpine mail user agent
 Summary(pl.UTF-8):     Klient pocztowy Alpine z Uniwersytetu w Waszyngtonie
 Name:          alpine
-%define                ver             0.999999
-%define                patchlevel      10
-Version:       %{ver}.%{patchlevel}
-Release:       1
+Version:       2.11
+Release:       4
 Epoch:         1
-License:       Apache License 2.0
+License:       Apache v2.0
 Group:         Applications/Mail
 # Main site:
 #Source0:      ftp://ftp.cac.washington.edu/alpine/%{name}-%{version}.tar.gz
-# Source with applied patches from http://staff.washington.edu/chappa/alpine/
-Source0:       http://staff.washington.edu/chappa/alpine/patches/alpine-%{ver}/%{name}-%{ver}_%{patchlevel}.tar.gz
-# Source0-md5: eb246f71450880b80f9775032b2b6842
+# Current source is from: http://patches.freeiz.com/alpine/
+Source0:       http://patches.freeiz.com/alpine/patches/%{name}-%{version}/%{name}-%{version}.tar.xz
+# Source0-md5: d2d9ca3716b9a23e5fa41ddf5ad06b6b
 Source1:       pico.desktop
 Source2:       %{name}.desktop
 Source3:       %{name}.png
 Patch0:                %{name}-index_display.patch
 Patch1:                %{name}-doc.patch
 Patch2:                %{name}-filter.patch
-Patch3:                %{name}-quote.patch
-Patch4:                %{name}-fhs.patch
-Patch5:                %{name}-segfix.patch
-Patch6:                %{name}-libc-client.patch
-Patch7:                %{name}-fixhome.patch
-Patch8:                %{name}-ssl.patch
-Patch9:                %{name}-no_1777_warning.patch
-Patch10:       %{name}-home_etc.patch
+Patch3:                %{name}-fhs.patch
+Patch4:                %{name}-libc-client.patch
+Patch5:                %{name}-ssl.patch
+Patch6:                %{name}-no_1777_warning.patch
+Patch7:                %{name}-home_etc.patch
+Patch8:                %{name}-RFC1522_MAXW.patch
+Patch9:                mimedesc.patch
 URL:           http://www.washington.edu/alpine/
-BuildRequires: autoconf
+BuildRequires: autoconf >= 2.69
 BuildRequires: automake
 BuildRequires: home-etc-devel
-BuildRequires: krb5-devel
+BuildRequires: libtool
 BuildRequires: ncurses-devel
-BuildRequires: openldap-devel >= 2.4.6
-BuildRequires: openssl-devel
+BuildRequires: openldap-devel
+BuildRequires: openssl-devel >= 1.0.1c
 BuildRequires: pam-devel
+BuildRequires: tar >= 1:1.22
+BuildRequires: xz
 # Only for web-frontend:
 #BuildRequires:        tcl-devel
-Obsoletes:     pine
-Provides:      pine = 4.99
+%if "%{pld_release}" != "ac"
+BuildRequires: heimdal-devel
+%endif
 Suggests:      aspell
+Suggests:      ca-certificates
+Provides:      pine = 6.00
+Obsoletes:     pine
+Conflicts:     ca-certificates < 20080809-4
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                alpineconfdir   /etc/%{name}
+%define                alpineconfdir   %{_sysconfdir}/%{name}
 %define                filterout_ld    -Wl,--as-needed
 
 %description
@@ -75,7 +80,7 @@ Summary:      Simple text editor in the style of the Pine Composer
 Summary(pl.UTF-8):     Prosty edytor tekstowy w stylu alpine
 Summary(pt_BR.UTF-8):  Editor de textos para terminal simples e fácil de usar
 Group:         Applications/Editors
-Provides:      pico = 4.99
+Provides:      pico = 6.00
 
 %description -n pico
 Pico is a simple, display-oriented text editor based on the Alpine
@@ -90,16 +95,16 @@ dostępna jest pomoc kontekstowa. Wpisywane znaki są natychmiast
 włączane do tekstu.
 
 %description -n pico -l pt_BR.UTF-8
-Pico é um editor de texto baseado no compositor de mensagens do Alpine.
-Assim como no Pine, comandos são mostrados na parte de baixo da tela,
-e ajuda de acordo com o contexto está disponível.
+Pico é um editor de texto baseado no compositor de mensagens do
+Alpine. Assim como no Pine, comandos são mostrados na parte de baixo
+da tela, e ajuda de acordo com o contexto está disponível.
 
 %package -n pilot
 Summary:       Simple file system browser in the style of the Alpine Composer
 Summary(pl.UTF-8):     Prosta przeglądarka plików w stylu composera alpine
 Summary(pt_BR.UTF-8):  Navegador de sistemas de arquivos no estilo do compositor do Alpine
 Group:         Applications/Shells
-Provides:      pilot = 4.99
+Provides:      pilot = 6.00
 
 %description -n pilot
 Pilot is a simple, display-oriented file system browser based on the
@@ -117,7 +122,7 @@ como no Pine, comandos são apresentados na parte de baixo da tela, e
 ajuda de acordo com o contexto está disponível.
 
 %prep
-%setup -q -n %{name}-%{ver}
+%setup -q
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
@@ -128,7 +133,6 @@ ajuda de acordo com o contexto está disponível.
 %patch7 -p1
 %patch8 -p1
 %patch9 -p1
-%patch10 -p1
 
 %build
 rm -f libtool missing
@@ -138,18 +142,25 @@ rm -f libtool missing
 %{__autoheader}
 %{__automake}
 %configure \
+       --%{?debug:en}%{!?debug:dis}able-debug \
        --enable-quotas \
        --without-tcl \
-       --with-smtp-msa=%{_libdir}/sendmail \
+       --with-smtp-msa=/usr/lib/sendmail \
        --with-simple-spellcheck=aspell \
-       --with-system-pinerc=%{alpineconfdir}/%{name}.conf \
-       --with-system-fixed-pinerc=%{alpineconfdir}/%{name}.conf.fixed \
+       --with-system-pinerc=%{_sysconfdir}/%{name}/%{name}.conf \
+       --with-system-fixed-pinerc=%{_sysconfdir}/%{name}/%{name}.conf.fixed \
        --with-krb5-dir=%{_prefix} \
        --with-ldap-dir=%{_prefix} \
        --with-system-mail-directory=/var/mail \
        --with-c-client-target=slx \
+%if "%{pld_release}" == "ti"
        --with-ssl-dir=/var/lib/openssl/certs \
        --with-ssl-certs-dir=/var/lib/openssl/certs \
+%else
+       --with-ssl-dir=/etc/openssl/certs \
+       --with-ssl-certs-dir=/etc/certs \
+       --with-ssl-lib-dir=%{_libdir} \
+%endif
        --with-passfile=.pine.pwd
 
 %{__make} \
@@ -157,28 +168,28 @@ rm -f libtool missing
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{alpineconfdir},%{_desktopdir},%{_pixmapsdir}}
+install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_desktopdir},%{_pixmapsdir}}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
-install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
-install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
+cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
+cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
+cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
 
 ln -s alpine $RPM_BUILD_ROOT%{_bindir}/pine
 
-$RPM_BUILD_ROOT%{_bindir}/alpine -conf > $RPM_BUILD_ROOT%{alpineconfdir}/alpine.conf
-cat <<EOF > $RPM_BUILD_ROOT%{alpineconfdir}/alpine.conf.fixed
+$RPM_BUILD_ROOT%{_bindir}/alpine -conf > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/alpine.conf
+cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/alpine.conf.fixed
 #
 # Alpine system-wide enforced configuration file - customize as needed
 #
 # This file holds the system-wide enforced values for alpine configuration
 # settings. Any values set in it will override values set in the
-# system-wide default configuration file (%{alpineconfdir}/alpine.conf) and
+# system-wide default configuration file (%{_sysconfdir}/%{name}/alpine.conf) and
 # the user's own configuration file (~/.pinerc).
 # For more information on the format of this file, read the
-# comments at the top of %{alpineconfdir}/alpine.conf
+# comments at the top of %{_sysconfdir}/%{name}/alpine.conf
 
 EOF
 
@@ -188,9 +199,9 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc README doc/tech-notes.txt
-%dir %{alpineconfdir}
-%config(noreplace) %verify(not md5 mtime size) %{alpineconfdir}/alpine.conf
-%config(noreplace) %verify(not md5 mtime size) %{alpineconfdir}/alpine.conf.fixed
+%dir %{_sysconfdir}/%{name}
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/alpine.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/alpine.conf.fixed
 %attr(755,root,root) %{_bindir}/%{name}
 %attr(755,root,root) %{_bindir}/pine
 %attr(755,root,root) %{_bindir}/rpload
This page took 0.171344 seconds and 4 git commands to generate.