]> git.pld-linux.org Git - packages/alpine.git/blobdiff - alpine.spec
Release 4 (by relup.sh)
[packages/alpine.git] / alpine.spec
index 580c718c21159a8ebd8e3672e8c12aa0a7c21e66..1e42fbd95078f16b71af054beaa02041e915c9d4 100644 (file)
@@ -2,21 +2,20 @@
 # - backport man-pages from pine.spec
 # - separate package with tcl web-frontend
 # - fix as-needed
-%define                ver             2.00
-%define                patchlevel      11
+# - pico shouldn't link with kerberos, should it?
 Summary:       University of Washington Alpine mail user agent
 Summary(pl.UTF-8):     Klient pocztowy Alpine z Uniwersytetu w Waszyngtonie
 Name:          alpine
-Version:       %{ver}.%{patchlevel}
-Release:       2
+Version:       2.11
+Release:       4
 Epoch:         1
 License:       Apache v2.0
 Group:         Applications/Mail
 # Main site:
 #Source0:      ftp://ftp.cac.washington.edu/alpine/%{name}-%{version}.tar.gz
-# Source with applied patches from http://staff.washington.edu/chappa/alpine/
-Source0:       http://staff.washington.edu/chappa/alpine/patches/alpine-%{ver}/%{name}-%{ver}_%{patchlevel}.tar.gz
-# Source0-md5: 6f4f8dc8e6b3107358769b322e1f1ea0
+# Current source is from: http://patches.freeiz.com/alpine/
+Source0:       http://patches.freeiz.com/alpine/patches/%{name}-%{version}/%{name}-%{version}.tar.xz
+# Source0-md5: d2d9ca3716b9a23e5fa41ddf5ad06b6b
 Source1:       pico.desktop
 Source2:       %{name}.desktop
 Source3:       %{name}.png
@@ -28,20 +27,29 @@ Patch4:             %{name}-libc-client.patch
 Patch5:                %{name}-ssl.patch
 Patch6:                %{name}-no_1777_warning.patch
 Patch7:                %{name}-home_etc.patch
+Patch8:                %{name}-RFC1522_MAXW.patch
+Patch9:                mimedesc.patch
 URL:           http://www.washington.edu/alpine/
-BuildRequires: autoconf
+BuildRequires: autoconf >= 2.69
 BuildRequires: automake
 BuildRequires: home-etc-devel
-BuildRequires: krb5-devel
+BuildRequires: libtool
 BuildRequires: ncurses-devel
-BuildRequires: openldap-devel >= 2.4.6
-BuildRequires: openssl-devel
+BuildRequires: openldap-devel
+BuildRequires: openssl-devel >= 1.0.1c
 BuildRequires: pam-devel
+BuildRequires: tar >= 1:1.22
+BuildRequires: xz
 # Only for web-frontend:
 #BuildRequires:        tcl-devel
+%if "%{pld_release}" != "ac"
+BuildRequires: heimdal-devel
+%endif
 Suggests:      aspell
+Suggests:      ca-certificates
 Provides:      pine = 6.00
 Obsoletes:     pine
+Conflicts:     ca-certificates < 20080809-4
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                alpineconfdir   %{_sysconfdir}/%{name}
@@ -87,9 +95,9 @@ dostępna jest pomoc kontekstowa. Wpisywane znaki są natychmiast
 włączane do tekstu.
 
 %description -n pico -l pt_BR.UTF-8
-Pico é um editor de texto baseado no compositor de mensagens do Alpine.
-Assim como no Pine, comandos são mostrados na parte de baixo da tela,
-e ajuda de acordo com o contexto está disponível.
+Pico é um editor de texto baseado no compositor de mensagens do
+Alpine. Assim como no Pine, comandos são mostrados na parte de baixo
+da tela, e ajuda de acordo com o contexto está disponível.
 
 %package -n pilot
 Summary:       Simple file system browser in the style of the Alpine Composer
@@ -114,7 +122,7 @@ como no Pine, comandos são apresentados na parte de baixo da tela, e
 ajuda de acordo com o contexto está disponível.
 
 %prep
-%setup -q -n %{name}-%{ver}
+%setup -q
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
@@ -123,6 +131,8 @@ ajuda de acordo com o contexto está disponível.
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
+%patch8 -p1
+%patch9 -p1
 
 %build
 rm -f libtool missing
@@ -135,7 +145,7 @@ rm -f libtool missing
        --%{?debug:en}%{!?debug:dis}able-debug \
        --enable-quotas \
        --without-tcl \
-       --with-smtp-msa=%{_libdir}/sendmail \
+       --with-smtp-msa=/usr/lib/sendmail \
        --with-simple-spellcheck=aspell \
        --with-system-pinerc=%{_sysconfdir}/%{name}/%{name}.conf \
        --with-system-fixed-pinerc=%{_sysconfdir}/%{name}/%{name}.conf.fixed \
@@ -143,8 +153,14 @@ rm -f libtool missing
        --with-ldap-dir=%{_prefix} \
        --with-system-mail-directory=/var/mail \
        --with-c-client-target=slx \
+%if "%{pld_release}" == "ti"
        --with-ssl-dir=/var/lib/openssl/certs \
        --with-ssl-certs-dir=/var/lib/openssl/certs \
+%else
+       --with-ssl-dir=/etc/openssl/certs \
+       --with-ssl-certs-dir=/etc/certs \
+       --with-ssl-lib-dir=%{_libdir} \
+%endif
        --with-passfile=.pine.pwd
 
 %{__make} \
@@ -157,9 +173,9 @@ install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_desktopdir},%{_pixmapsdir}}
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
-install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
-install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
+cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
+cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
+cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
 
 ln -s alpine $RPM_BUILD_ROOT%{_bindir}/pine
 
This page took 0.104434 seconds and 4 git commands to generate.