]> git.pld-linux.org Git - packages/alpine.git/blob - alpine.spec
- patchlevel 38 - fixes crashes with some messages
[packages/alpine.git] / alpine.spec
1 # TODO:
2 # - backport man-pages from pine.spec
3 # - alpine should obsolete pine, link pine -> alpine should be made
4 # - review patches from pine:
5 #   - home_etc support
6 #   - ....many more
7 # - separate package with tcl web-frontend
8 Summary:        University of Washington Pine mail user agent
9 Summary(pl.UTF-8):      Klient pocztowy Pine z Uniwersytetu w Waszyngtonie
10 Name:           alpine
11 %define         ver             0.9999
12 %define         patchlevel      38
13 Version:        %{ver}.%{patchlevel}
14 Release:        1
15 Epoch:          1
16 License:        Apache License 2.0
17 Group:          Applications/Mail
18 # Main site:
19 #Source0:       ftp://ftp.cac.washington.edu/alpine/%{name}-%{version}.tar.gz
20 # Source with applied patches from http://staff.washington.edu/chappa/alpine/ 
21 Source0:        http://staff.washington.edu/chappa/alpine/patches/alpine-%{ver}/%{name}-%{ver}_%{patchlevel}.tar.gz
22 # Source0-md5:  77953f8d0fc7f8b2d0aa3787bb0982de
23 Source1:        pico.desktop
24 Source2:        %{name}.desktop
25 Source3:        %{name}.png
26 Patch0:         %{name}-thread_end.patch
27 Patch1:         %{name}-index_display.patch
28 URL:            http://www.washington.edu/alpine/
29 BuildRequires:  autoconf
30 BuildRequires:  automake
31 BuildRequires:  krb5-devel
32 BuildRequires:  ncurses-devel
33 BuildRequires:  openldap-devel
34 BuildRequires:  openssl-devel
35 BuildRequires:  pam-devel
36 # Only for web-frontend
37 BuildRequires:  tcl-devel
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %define         alpineconfdir   /etc/%{name}
41
42 %description
43 Alpine -- an Alternatively Licensed Program for Internet News & Email
44 -- is a tool for reading, sending, and managing electronic messages.
45 Alpine is the successor to Pine and was developed by Computing &
46 Communications at the University of Washington. Though originally
47 designed for inexperienced email users, Alpine supports many advanced
48 features, and an ever-growing number of configuration and
49 personal-preference options.
50
51 %description -l pl.UTF-8
52 Alpine, czyli Alternatively Licensed Program for Internet News & Email
53 (alternatywnie licencjonowany program do newsów i poczty internetowej)
54 to narzędzie do czytania, wysyłania i zarządzania wiadomościami
55 elektronicznymi. Alpine jest następcą Pine'a i został napisany przez
56 wydział Computing & Communications (Obliczeń i komunikacji) na
57 Uniwersytecie w Waszyngtonie. Mimo że Alpine pierwotnie został
58 zaprojektowany dla niedoświadczonych użytkowników poczty, obsługuje
59 wiele zaawansowanych możliwości, a liczba opcji konfiguracyjnych
60 ciągle rośnie.
61
62 %package -n pico
63 Summary:        Simple text editor in the style of the Pine Composer
64 Summary(pl.UTF-8):      Prosty edytor tekstowy w stylu alpine
65 Summary(pt_BR.UTF-8):   Editor de textos para terminal simples e fácil de usar
66 Group:          Applications/Editors
67
68 %description -n pico
69 Pico is a simple, display-oriented text editor based on the Alpine
70 message system composer. As with Pine, commands are displayed at the
71 bottom of the screen, and context-sensitive help is provided. As
72 characters are typed they are immediately inserted into the text.
73
74 %description -n pico -l pl.UTF-8
75 Pico jest prostym, zorientowanym na wyświetlanie edytorem bazującym na
76 alpine. Tak jak w pine komendy są wyświetlane na dole ekranu oraz
77 dostępna jest pomoc konteksowa. Wpisywane znaki są natychmiast
78 włączane do tekstu.
79
80 %description -n pico -l pt_BR.UTF-8
81 Pico é um editor de texto baseado no compositor de mensagens do Alpine.
82 Assim como no Pine, comandos são mostrados na parte de baixo da tela,
83 e ajuda de acordo com o contexto está disponível.
84
85 %package -n pilot
86 Summary:        Simple file system browser in the style of the Alpine Composer
87 Summary(pl.UTF-8):      Prosta przeglądarka plików w stylu composera alpine
88 Summary(pt_BR.UTF-8):   Navegador de sistemas de arquivos no estilo do compositor do Alpine
89 Group:          Applications/Shells
90
91 %description -n pilot
92 Pilot is a simple, display-oriented file system browser based on the
93 Alpine message system composer. As with Alpine, commands are displayed at
94 the bottom of the screen, and context-sensitive help is provided.
95
96 %description -n pilot -l pl.UTF-8
97 Pilot jest prostą, zorientowaną na wyświetlanie przeglądarką plików w
98 stylu compsera pine. Podobnie jak w alpine polecenia sa wyświetlane na
99 dole ekranu oraz jest dostępna pomoc kontekstowa.
100
101 %description -n pilot -l pt_BR.UTF-8
102 Pilot é um navegador de sistemas de arquivos baseado no Pine. Assim
103 como no Pine, comandos são apresentados na parte de baixo da tela, e
104 ajuda de acordo com o contexto está disponível.
105
106 %prep
107 %setup -q -n %{name}-%{ver}
108 %patch0 -p1
109 %patch1 -p1
110
111 %build
112 %{__autoconf}
113 %{__aclocal} -I m4
114 %{__automake}
115 %configure \
116         --enable-quotas \
117         --with-smtp-msa=%{_libdir}/sendmail \
118         --with-spellcheck-prog=aspell \
119         --with-system-pinerc=%{alpineconfdir}/%{name}.conf \
120         --with-system-fixed-pinerc=%{alpineconfdir}/%{name}.conf.fixed \
121         --with-krb5-dir=%{_prefix} \
122         --with-ldap-dir=%{_prefix} \
123         --with-system-mail-directory=/var/mail
124 %{__make}
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128 install -d $RPM_BUILD_ROOT{%{alpineconfdir},%{_desktopdir},%{_pixmapsdir}}
129
130 %{__make} install \
131         DESTDIR=$RPM_BUILD_ROOT
132
133 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
134 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
135 install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %files
141 %defattr(644,root,root,755)
142 %doc README doc/tech-notes.txt
143 %dir %{alpineconfdir}
144 %attr(755,root,root) %{_bindir}/%{name}
145 %attr(755,root,root) %{_bindir}/rpload
146 %attr(755,root,root) %{_bindir}/rpdump
147 %{_mandir}/man1/%{name}.1*
148 %{_mandir}/man1/rpload.1*
149 %{_mandir}/man1/rpdump.1*
150 %{_desktopdir}/%{name}.desktop
151 %{_pixmapsdir}/%{name}.png
152
153 %files -n pico
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_bindir}/pico
156 %{_desktopdir}/pico.desktop
157 %{_mandir}/man1/pico*
158
159 %files -n pilot
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_bindir}/pilot
162 %{_mandir}/man1/pilot*
This page took 0.039023 seconds and 4 git commands to generate.