]> git.pld-linux.org Git - packages/alpine.git/blob - alpine.spec
tar.xz deps
[packages/alpine.git] / alpine.spec
1 # TODO:
2 # - backport man-pages from pine.spec
3 # - separate package with tcl web-frontend
4 # - fix as-needed
5 # - pico shouldn't link with kerberos, should it?
6 Summary:        University of Washington Alpine mail user agent
7 Summary(pl.UTF-8):      Klient pocztowy Alpine z Uniwersytetu w Waszyngtonie
8 Name:           alpine
9 Version:        2.11
10 Release:        1
11 Epoch:          1
12 License:        Apache v2.0
13 Group:          Applications/Mail
14 # Main site:
15 #Source0:       ftp://ftp.cac.washington.edu/alpine/%{name}-%{version}.tar.gz
16 # Current source is from: http://patches.freeiz.com/alpine/
17 Source0:        http://patches.freeiz.com/alpine/patches/%{name}-%{version}/%{name}-%{version}.tar.xz
18 # Source0-md5:  d2d9ca3716b9a23e5fa41ddf5ad06b6b
19 Source1:        pico.desktop
20 Source2:        %{name}.desktop
21 Source3:        %{name}.png
22 Patch0:         %{name}-index_display.patch
23 Patch1:         %{name}-doc.patch
24 Patch2:         %{name}-filter.patch
25 Patch3:         %{name}-fhs.patch
26 Patch4:         %{name}-libc-client.patch
27 Patch5:         %{name}-ssl.patch
28 Patch6:         %{name}-no_1777_warning.patch
29 Patch7:         %{name}-home_etc.patch
30 Patch8:         %{name}-RFC1522_MAXW.patch
31 Patch9:         mimedesc.patch
32 URL:            http://www.washington.edu/alpine/
33 BuildRequires:  autoconf >= 2.69
34 BuildRequires:  automake
35 BuildRequires:  home-etc-devel
36 BuildRequires:  libtool
37 BuildRequires:  ncurses-devel
38 BuildRequires:  openldap-devel
39 BuildRequires:  openssl-devel >= 1.0.1c
40 BuildRequires:  pam-devel
41 BuildRequires:  tar >= 1:1.22
42 BuildRequires:  xz
43 # Only for web-frontend:
44 #BuildRequires: tcl-devel
45 %if "%{pld_release}" != "ac"
46 BuildRequires:  heimdal-devel
47 %endif
48 Suggests:       aspell
49 Suggests:       ca-certificates
50 Provides:       pine = 6.00
51 Obsoletes:      pine
52 Conflicts:      ca-certificates < 20080809-4
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %define         alpineconfdir   %{_sysconfdir}/%{name}
56 %define         filterout_ld    -Wl,--as-needed
57
58 %description
59 Alpine -- an Alternatively Licensed Program for Internet News & Email
60 -- is a tool for reading, sending, and managing electronic messages.
61 Alpine is the successor to Pine and was developed by Computing &
62 Communications at the University of Washington. Though originally
63 designed for inexperienced email users, Alpine supports many advanced
64 features, and an ever-growing number of configuration and
65 personal-preference options.
66
67 %description -l pl.UTF-8
68 Alpine, czyli Alternatively Licensed Program for Internet News & Email
69 (alternatywnie licencjonowany program do newsów i poczty internetowej)
70 to narzędzie do czytania, wysyłania i zarządzania wiadomościami
71 elektronicznymi. Alpine jest następcą Pine'a i został napisany przez
72 wydział Computing & Communications (Obliczeń i komunikacji) na
73 Uniwersytecie w Waszyngtonie. Mimo że Alpine pierwotnie został
74 zaprojektowany dla niedoświadczonych użytkowników poczty, obsługuje
75 wiele zaawansowanych możliwości, a liczba opcji konfiguracyjnych
76 ciągle rośnie.
77
78 %package -n pico
79 Summary:        Simple text editor in the style of the Pine Composer
80 Summary(pl.UTF-8):      Prosty edytor tekstowy w stylu alpine
81 Summary(pt_BR.UTF-8):   Editor de textos para terminal simples e fácil de usar
82 Group:          Applications/Editors
83 Provides:       pico = 6.00
84
85 %description -n pico
86 Pico is a simple, display-oriented text editor based on the Alpine
87 message system composer. As with Pine, commands are displayed at the
88 bottom of the screen, and context-sensitive help is provided. As
89 characters are typed they are immediately inserted into the text.
90
91 %description -n pico -l pl.UTF-8
92 Pico jest prostym, zorientowanym na wyświetlanie edytorem bazującym na
93 alpine. Tak jak w pine komendy są wyświetlane na dole ekranu oraz
94 dostępna jest pomoc kontekstowa. Wpisywane znaki są natychmiast
95 włączane do tekstu.
96
97 %description -n pico -l pt_BR.UTF-8
98 Pico é um editor de texto baseado no compositor de mensagens do
99 Alpine. Assim como no Pine, comandos são mostrados na parte de baixo
100 da tela, e ajuda de acordo com o contexto está disponível.
101
102 %package -n pilot
103 Summary:        Simple file system browser in the style of the Alpine Composer
104 Summary(pl.UTF-8):      Prosta przeglądarka plików w stylu composera alpine
105 Summary(pt_BR.UTF-8):   Navegador de sistemas de arquivos no estilo do compositor do Alpine
106 Group:          Applications/Shells
107 Provides:       pilot = 6.00
108
109 %description -n pilot
110 Pilot is a simple, display-oriented file system browser based on the
111 Alpine message system composer. As with Alpine, commands are displayed
112 at the bottom of the screen, and context-sensitive help is provided.
113
114 %description -n pilot -l pl.UTF-8
115 Pilot jest prostą, zorientowaną na wyświetlanie przeglądarką plików w
116 stylu composera pine. Podobnie jak w alpine polecenia są wyświetlane
117 na dole ekranu oraz jest dostępna pomoc kontekstowa.
118
119 %description -n pilot -l pt_BR.UTF-8
120 Pilot é um navegador de sistemas de arquivos baseado no Pine. Assim
121 como no Pine, comandos são apresentados na parte de baixo da tela, e
122 ajuda de acordo com o contexto está disponível.
123
124 %prep
125 %setup -q
126 %patch0 -p1
127 %patch1 -p1
128 %patch2 -p1
129 %patch3 -p1
130 %patch4 -p1
131 %patch5 -p1
132 %patch6 -p1
133 %patch7 -p1
134 %patch8 -p1
135 %patch9 -p1
136
137 %build
138 rm -f libtool missing
139 %{__libtoolize}
140 %{__aclocal} -I m4
141 %{__autoconf}
142 %{__autoheader}
143 %{__automake}
144 %configure \
145         --%{?debug:en}%{!?debug:dis}able-debug \
146         --enable-quotas \
147         --without-tcl \
148         --with-smtp-msa=/usr/lib/sendmail \
149         --with-simple-spellcheck=aspell \
150         --with-system-pinerc=%{_sysconfdir}/%{name}/%{name}.conf \
151         --with-system-fixed-pinerc=%{_sysconfdir}/%{name}/%{name}.conf.fixed \
152         --with-krb5-dir=%{_prefix} \
153         --with-ldap-dir=%{_prefix} \
154         --with-system-mail-directory=/var/mail \
155         --with-c-client-target=slx \
156 %if "%{pld_release}" == "ti"
157         --with-ssl-dir=/var/lib/openssl/certs \
158         --with-ssl-certs-dir=/var/lib/openssl/certs \
159 %else
160         --with-ssl-dir=/etc/openssl/certs \
161         --with-ssl-certs-dir=/etc/certs \
162         --with-ssl-lib-dir=%{_libdir} \
163 %endif
164         --with-passfile=.pine.pwd
165
166 %{__make} \
167         GCCOPTLEVEL="%{rpmcflags}"
168
169 %install
170 rm -rf $RPM_BUILD_ROOT
171 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_desktopdir},%{_pixmapsdir}}
172
173 %{__make} install \
174         DESTDIR=$RPM_BUILD_ROOT
175
176 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
177 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
178 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
179
180 ln -s alpine $RPM_BUILD_ROOT%{_bindir}/pine
181
182 $RPM_BUILD_ROOT%{_bindir}/alpine -conf > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/alpine.conf
183 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/alpine.conf.fixed
184 #
185 # Alpine system-wide enforced configuration file - customize as needed
186 #
187 # This file holds the system-wide enforced values for alpine configuration
188 # settings. Any values set in it will override values set in the
189 # system-wide default configuration file (%{_sysconfdir}/%{name}/alpine.conf) and
190 # the user's own configuration file (~/.pinerc).
191 # For more information on the format of this file, read the
192 # comments at the top of %{_sysconfdir}/%{name}/alpine.conf
193
194 EOF
195
196 %clean
197 rm -rf $RPM_BUILD_ROOT
198
199 %files
200 %defattr(644,root,root,755)
201 %doc README doc/tech-notes.txt
202 %dir %{_sysconfdir}/%{name}
203 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/alpine.conf
204 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/alpine.conf.fixed
205 %attr(755,root,root) %{_bindir}/%{name}
206 %attr(755,root,root) %{_bindir}/pine
207 %attr(755,root,root) %{_bindir}/rpload
208 %attr(755,root,root) %{_bindir}/rpdump
209 %{_mandir}/man1/%{name}.1*
210 %{_mandir}/man1/rpload.1*
211 %{_mandir}/man1/rpdump.1*
212 %{_desktopdir}/%{name}.desktop
213 %{_pixmapsdir}/%{name}.png
214
215 %files -n pico
216 %defattr(644,root,root,755)
217 %attr(755,root,root) %{_bindir}/pico
218 %{_desktopdir}/pico.desktop
219 %{_mandir}/man1/pico*
220
221 %files -n pilot
222 %defattr(644,root,root,755)
223 %attr(755,root,root) %{_bindir}/pilot
224 %{_mandir}/man1/pilot*
This page took 0.083166 seconds and 3 git commands to generate.