]> git.pld-linux.org Git - packages/alpine.git/blob - alpine.spec
- patchlevel 57: fix ignore the day of the week on index tokens like
[packages/alpine.git] / alpine.spec
1 # TODO:
2 # - backport man-pages from pine.spec
3 # - separate package with tcl web-frontend
4 # - fix as-needed
5 # - pico shouldn't link with kerberos, should it?
6 %define         ver             2.00
7 %define         patchlevel      57
8 Summary:        University of Washington Alpine mail user agent
9 Summary(pl.UTF-8):      Klient pocztowy Alpine z Uniwersytetu w Waszyngtonie
10 Name:           alpine
11 Version:        %{ver}.%{patchlevel}
12 Release:        1
13 Epoch:          1
14 License:        Apache v2.0
15 Group:          Applications/Mail
16 # Main site:
17 #Source0:       ftp://ftp.cac.washington.edu/alpine/%{name}-%{version}.tar.gz
18 # Source with applied patches from http://staff.washington.edu/chappa/alpine/
19 Source0:        http://staff.washington.edu/chappa/alpine/patches/alpine-%{ver}/%{name}-%{ver}_%{patchlevel}.tar.gz
20 # Source0-md5:  adbc52248639abe1944ca23800f6faee
21 Source1:        pico.desktop
22 Source2:        %{name}.desktop
23 Source3:        %{name}.png
24 Patch0:         %{name}-index_display.patch
25 Patch1:         %{name}-doc.patch
26 Patch2:         %{name}-filter.patch
27 Patch3:         %{name}-fhs.patch
28 Patch4:         %{name}-libc-client.patch
29 Patch5:         %{name}-ssl.patch
30 Patch6:         %{name}-no_1777_warning.patch
31 Patch7:         %{name}-home_etc.patch
32 URL:            http://www.washington.edu/alpine/
33 BuildRequires:  autoconf
34 BuildRequires:  automake
35 BuildRequires:  home-etc-devel
36 %if "%{pld_release}" != "ac"
37 BuildRequires:  heimdal-devel
38 %endif
39 BuildRequires:  libtool
40 BuildRequires:  ncurses-devel
41 BuildRequires:  openldap-devel
42 BuildRequires:  openssl-devel
43 BuildRequires:  pam-devel
44 # Only for web-frontend:
45 #BuildRequires: tcl-devel
46 Suggests:       aspell
47 Suggests:       ca-certificates
48 Conflicts:      ca-certificates < 20080809-4
49 Provides:       pine = 6.00
50 Obsoletes:      pine
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %define         alpineconfdir   %{_sysconfdir}/%{name}
54 %define         filterout_ld    -Wl,--as-needed
55
56 %description
57 Alpine -- an Alternatively Licensed Program for Internet News & Email
58 -- is a tool for reading, sending, and managing electronic messages.
59 Alpine is the successor to Pine and was developed by Computing &
60 Communications at the University of Washington. Though originally
61 designed for inexperienced email users, Alpine supports many advanced
62 features, and an ever-growing number of configuration and
63 personal-preference options.
64
65 %description -l pl.UTF-8
66 Alpine, czyli Alternatively Licensed Program for Internet News & Email
67 (alternatywnie licencjonowany program do newsów i poczty internetowej)
68 to narzędzie do czytania, wysyłania i zarządzania wiadomościami
69 elektronicznymi. Alpine jest następcą Pine'a i został napisany przez
70 wydział Computing & Communications (Obliczeń i komunikacji) na
71 Uniwersytecie w Waszyngtonie. Mimo że Alpine pierwotnie został
72 zaprojektowany dla niedoświadczonych użytkowników poczty, obsługuje
73 wiele zaawansowanych możliwości, a liczba opcji konfiguracyjnych
74 ciągle rośnie.
75
76 %package -n pico
77 Summary:        Simple text editor in the style of the Pine Composer
78 Summary(pl.UTF-8):      Prosty edytor tekstowy w stylu alpine
79 Summary(pt_BR.UTF-8):   Editor de textos para terminal simples e fácil de usar
80 Group:          Applications/Editors
81 Provides:       pico = 6.00
82
83 %description -n pico
84 Pico is a simple, display-oriented text editor based on the Alpine
85 message system composer. As with Pine, commands are displayed at the
86 bottom of the screen, and context-sensitive help is provided. As
87 characters are typed they are immediately inserted into the text.
88
89 %description -n pico -l pl.UTF-8
90 Pico jest prostym, zorientowanym na wyświetlanie edytorem bazującym na
91 alpine. Tak jak w pine komendy są wyświetlane na dole ekranu oraz
92 dostępna jest pomoc kontekstowa. Wpisywane znaki są natychmiast
93 włączane do tekstu.
94
95 %description -n pico -l pt_BR.UTF-8
96 Pico é um editor de texto baseado no compositor de mensagens do Alpine.
97 Assim como no Pine, comandos são mostrados na parte de baixo da tela,
98 e ajuda de acordo com o contexto está disponível.
99
100 %package -n pilot
101 Summary:        Simple file system browser in the style of the Alpine Composer
102 Summary(pl.UTF-8):      Prosta przeglądarka plików w stylu composera alpine
103 Summary(pt_BR.UTF-8):   Navegador de sistemas de arquivos no estilo do compositor do Alpine
104 Group:          Applications/Shells
105 Provides:       pilot = 6.00
106
107 %description -n pilot
108 Pilot is a simple, display-oriented file system browser based on the
109 Alpine message system composer. As with Alpine, commands are displayed
110 at the bottom of the screen, and context-sensitive help is provided.
111
112 %description -n pilot -l pl.UTF-8
113 Pilot jest prostą, zorientowaną na wyświetlanie przeglądarką plików w
114 stylu composera pine. Podobnie jak w alpine polecenia są wyświetlane
115 na dole ekranu oraz jest dostępna pomoc kontekstowa.
116
117 %description -n pilot -l pt_BR.UTF-8
118 Pilot é um navegador de sistemas de arquivos baseado no Pine. Assim
119 como no Pine, comandos são apresentados na parte de baixo da tela, e
120 ajuda de acordo com o contexto está disponível.
121
122 %prep
123 %setup -q -n %{name}-%{ver}
124 %patch0 -p1
125 %patch1 -p1
126 %patch2 -p1
127 %patch3 -p1
128 %patch4 -p1
129 %patch5 -p1
130 %patch6 -p1
131 %patch7 -p1
132
133 %build
134 rm -f libtool missing
135 %{__libtoolize}
136 %{__aclocal} -I m4
137 %{__autoconf}
138 %{__autoheader}
139 %{__automake}
140 %configure \
141         --%{?debug:en}%{!?debug:dis}able-debug \
142         --enable-quotas \
143         --without-tcl \
144         --with-smtp-msa=/usr/lib/sendmail \
145         --with-simple-spellcheck=aspell \
146         --with-system-pinerc=%{_sysconfdir}/%{name}/%{name}.conf \
147         --with-system-fixed-pinerc=%{_sysconfdir}/%{name}/%{name}.conf.fixed \
148         --with-krb5-dir=%{_prefix} \
149         --with-ldap-dir=%{_prefix} \
150         --with-system-mail-directory=/var/mail \
151         --with-c-client-target=slx \
152 %if "%{pld_release}" == "ti"
153         --with-ssl-dir=/var/lib/openssl/certs \
154         --with-ssl-certs-dir=/var/lib/openssl/certs \
155 %else
156         --with-ssl-dir=/etc/openssl/certs \
157         --with-ssl-certs-dir=/etc/certs \
158 %endif
159         --with-passfile=.pine.pwd
160
161 %{__make} \
162         GCCOPTLEVEL="%{rpmcflags}"
163
164 %install
165 rm -rf $RPM_BUILD_ROOT
166 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_desktopdir},%{_pixmapsdir}}
167
168 %{__make} install \
169         DESTDIR=$RPM_BUILD_ROOT
170
171 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
172 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
173 install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
174
175 ln -s alpine $RPM_BUILD_ROOT%{_bindir}/pine
176
177 $RPM_BUILD_ROOT%{_bindir}/alpine -conf > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/alpine.conf
178 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/alpine.conf.fixed
179 #
180 # Alpine system-wide enforced configuration file - customize as needed
181 #
182 # This file holds the system-wide enforced values for alpine configuration
183 # settings. Any values set in it will override values set in the
184 # system-wide default configuration file (%{_sysconfdir}/%{name}/alpine.conf) and
185 # the user's own configuration file (~/.pinerc).
186 # For more information on the format of this file, read the
187 # comments at the top of %{_sysconfdir}/%{name}/alpine.conf
188
189 EOF
190
191 %clean
192 rm -rf $RPM_BUILD_ROOT
193
194 %files
195 %defattr(644,root,root,755)
196 %doc README doc/tech-notes.txt
197 %dir %{_sysconfdir}/%{name}
198 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/alpine.conf
199 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/alpine.conf.fixed
200 %attr(755,root,root) %{_bindir}/%{name}
201 %attr(755,root,root) %{_bindir}/pine
202 %attr(755,root,root) %{_bindir}/rpload
203 %attr(755,root,root) %{_bindir}/rpdump
204 %{_mandir}/man1/%{name}.1*
205 %{_mandir}/man1/rpload.1*
206 %{_mandir}/man1/rpdump.1*
207 %{_desktopdir}/%{name}.desktop
208 %{_pixmapsdir}/%{name}.png
209
210 %files -n pico
211 %defattr(644,root,root,755)
212 %attr(755,root,root) %{_bindir}/pico
213 %{_desktopdir}/pico.desktop
214 %{_mandir}/man1/pico*
215
216 %files -n pilot
217 %defattr(644,root,root,755)
218 %attr(755,root,root) %{_bindir}/pilot
219 %{_mandir}/man1/pilot*
This page took 0.084365 seconds and 3 git commands to generate.