]> git.pld-linux.org Git - packages/alpine.git/blob - alpine.spec
- patchlevel 50 - multiline URLs
[packages/alpine.git] / alpine.spec
1 %define         ver             2.00
2 %define         patchlevel      50
3 Summary:        University of Washington Alpine mail user agent
4 Summary(pl.UTF-8):      Klient pocztowy Alpine z Uniwersytetu w Waszyngtonie
5 Name:           alpine
6 Version:        %{ver}.%{patchlevel}
7 Release:        1
8 Epoch:          1
9 License:        Apache v2.0
10 Group:          Applications/Mail
11 # Main site:
12 #Source0:       ftp://ftp.cac.washington.edu/alpine/%{name}-%{version}.tar.gz
13 # Source with applied patches from http://staff.washington.edu/chappa/alpine/
14 Source0:        http://staff.washington.edu/chappa/alpine/patches/alpine-%{ver}/%{name}-%{ver}_%{patchlevel}.tar.gz
15 # Source0-md5:  e5070b17952b369dec93fe3f3dd2f059
16 Source1:        pico.desktop
17 Source2:        %{name}.desktop
18 Source3:        %{name}.png
19 Patch0:         %{name}-index_display.patch
20 Patch1:         %{name}-doc.patch
21 Patch2:         %{name}-filter.patch
22 Patch3:         %{name}-fhs.patch
23 Patch4:         %{name}-libc-client.patch
24 Patch5:         %{name}-ssl.patch
25 Patch6:         %{name}-no_1777_warning.patch
26 Patch7:         %{name}-home_etc.patch
27 URL:            http://www.washington.edu/alpine/
28 BuildRequires:  autoconf
29 BuildRequires:  automake
30 BuildRequires:  home-etc-devel
31 %if "%{pld_release}" != "ac"
32 BuildRequires:  heimdal-devel
33 %endif
34 BuildRequires:  ncurses-devel
35 BuildRequires:  openldap-devel
36 BuildRequires:  openssl-devel
37 BuildRequires:  pam-devel
38 # Only for web-frontend:
39 #BuildRequires: tcl-devel
40 Suggests:       aspell
41 Suggests:       ca-certificates
42 Conflicts:      ca-certificates < 20080809-4
43 Provides:       pine = 6.00
44 Obsoletes:      pine
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %define         alpineconfdir   %{_sysconfdir}/%{name}
48 %define         filterout_ld    -Wl,--as-needed
49
50 %description
51 Alpine -- an Alternatively Licensed Program for Internet News & Email
52 -- is a tool for reading, sending, and managing electronic messages.
53 Alpine is the successor to Pine and was developed by Computing &
54 Communications at the University of Washington. Though originally
55 designed for inexperienced email users, Alpine supports many advanced
56 features, and an ever-growing number of configuration and
57 personal-preference options.
58
59 %description -l pl.UTF-8
60 Alpine, czyli Alternatively Licensed Program for Internet News & Email
61 (alternatywnie licencjonowany program do newsów i poczty internetowej)
62 to narzędzie do czytania, wysyłania i zarządzania wiadomościami
63 elektronicznymi. Alpine jest następcą Pine'a i został napisany przez
64 wydział Computing & Communications (Obliczeń i komunikacji) na
65 Uniwersytecie w Waszyngtonie. Mimo że Alpine pierwotnie został
66 zaprojektowany dla niedoświadczonych użytkowników poczty, obsługuje
67 wiele zaawansowanych możliwości, a liczba opcji konfiguracyjnych
68 ciągle rośnie.
69
70 %package -n pico
71 Summary:        Simple text editor in the style of the Pine Composer
72 Summary(pl.UTF-8):      Prosty edytor tekstowy w stylu alpine
73 Summary(pt_BR.UTF-8):   Editor de textos para terminal simples e fácil de usar
74 Group:          Applications/Editors
75 Provides:       pico = 6.00
76
77 %description -n pico
78 Pico is a simple, display-oriented text editor based on the Alpine
79 message system composer. As with Pine, commands are displayed at the
80 bottom of the screen, and context-sensitive help is provided. As
81 characters are typed they are immediately inserted into the text.
82
83 %description -n pico -l pl.UTF-8
84 Pico jest prostym, zorientowanym na wyświetlanie edytorem bazującym na
85 alpine. Tak jak w pine komendy są wyświetlane na dole ekranu oraz
86 dostępna jest pomoc kontekstowa. Wpisywane znaki są natychmiast
87 włączane do tekstu.
88
89 %description -n pico -l pt_BR.UTF-8
90 Pico é um editor de texto baseado no compositor de mensagens do Alpine.
91 Assim como no Pine, comandos são mostrados na parte de baixo da tela,
92 e ajuda de acordo com o contexto está disponível.
93
94 %package -n pilot
95 Summary:        Simple file system browser in the style of the Alpine Composer
96 Summary(pl.UTF-8):      Prosta przeglądarka plików w stylu composera alpine
97 Summary(pt_BR.UTF-8):   Navegador de sistemas de arquivos no estilo do compositor do Alpine
98 Group:          Applications/Shells
99 Provides:       pilot = 6.00
100
101 %description -n pilot
102 Pilot is a simple, display-oriented file system browser based on the
103 Alpine message system composer. As with Alpine, commands are displayed
104 at the bottom of the screen, and context-sensitive help is provided.
105
106 %description -n pilot -l pl.UTF-8
107 Pilot jest prostą, zorientowaną na wyświetlanie przeglądarką plików w
108 stylu composera pine. Podobnie jak w alpine polecenia są wyświetlane
109 na dole ekranu oraz jest dostępna pomoc kontekstowa.
110
111 %description -n pilot -l pt_BR.UTF-8
112 Pilot é um navegador de sistemas de arquivos baseado no Pine. Assim
113 como no Pine, comandos são apresentados na parte de baixo da tela, e
114 ajuda de acordo com o contexto está disponível.
115
116 %prep
117 %setup -q -n %{name}-%{ver}
118 %patch0 -p1
119 %patch1 -p1
120 %patch2 -p1
121 %patch3 -p1
122 %patch4 -p1
123 %patch5 -p1
124 %patch6 -p1
125 %patch7 -p1
126
127 %build
128 rm -f libtool missing
129 %{__libtoolize}
130 %{__aclocal} -I m4
131 %{__autoconf}
132 %{__autoheader}
133 %{__automake}
134 %configure \
135         --%{?debug:en}%{!?debug:dis}able-debug \
136         --enable-quotas \
137         --without-tcl \
138         --with-smtp-msa=%{_libdir}/sendmail \
139         --with-simple-spellcheck=aspell \
140         --with-system-pinerc=%{_sysconfdir}/%{name}/%{name}.conf \
141         --with-system-fixed-pinerc=%{_sysconfdir}/%{name}/%{name}.conf.fixed \
142         --with-krb5-dir=%{_prefix} \
143         --with-ldap-dir=%{_prefix} \
144         --with-system-mail-directory=/var/mail \
145         --with-c-client-target=slx \
146 %if "%{pld_release}" == "ti"
147         --with-ssl-dir=/var/lib/openssl/certs \
148         --with-ssl-certs-dir=/var/lib/openssl/certs \
149 %else
150         --with-ssl-dir=/etc/openssl/certs \
151         --with-ssl-certs-dir=/etc/certs \
152 %endif
153         --with-passfile=.pine.pwd
154
155 %{__make} \
156         GCCOPTLEVEL="%{rpmcflags}"
157
158 %install
159 rm -rf $RPM_BUILD_ROOT
160 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_desktopdir},%{_pixmapsdir}}
161
162 %{__make} install \
163         DESTDIR=$RPM_BUILD_ROOT
164
165 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
166 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
167 install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
168
169 ln -s alpine $RPM_BUILD_ROOT%{_bindir}/pine
170
171 $RPM_BUILD_ROOT%{_bindir}/alpine -conf > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/alpine.conf
172 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/alpine.conf.fixed
173 #
174 # Alpine system-wide enforced configuration file - customize as needed
175 #
176 # This file holds the system-wide enforced values for alpine configuration
177 # settings. Any values set in it will override values set in the
178 # system-wide default configuration file (%{_sysconfdir}/%{name}/alpine.conf) and
179 # the user's own configuration file (~/.pinerc).
180 # For more information on the format of this file, read the
181 # comments at the top of %{_sysconfdir}/%{name}/alpine.conf
182
183 EOF
184
185 %clean
186 rm -rf $RPM_BUILD_ROOT
187
188 %files
189 %defattr(644,root,root,755)
190 %doc README doc/tech-notes.txt
191 %dir %{_sysconfdir}/%{name}
192 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/alpine.conf
193 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/alpine.conf.fixed
194 %attr(755,root,root) %{_bindir}/%{name}
195 %attr(755,root,root) %{_bindir}/pine
196 %attr(755,root,root) %{_bindir}/rpload
197 %attr(755,root,root) %{_bindir}/rpdump
198 %{_mandir}/man1/%{name}.1*
199 %{_mandir}/man1/rpload.1*
200 %{_mandir}/man1/rpdump.1*
201 %{_desktopdir}/%{name}.desktop
202 %{_pixmapsdir}/%{name}.png
203
204 %files -n pico
205 %defattr(644,root,root,755)
206 %attr(755,root,root) %{_bindir}/pico
207 %{_desktopdir}/pico.desktop
208 %{_mandir}/man1/pico*
209
210 %files -n pilot
211 %defattr(644,root,root,755)
212 %attr(755,root,root) %{_bindir}/pilot
213 %{_mandir}/man1/pilot*
This page took 0.045576 seconds and 3 git commands to generate.