]> git.pld-linux.org Git - packages/alpine.git/blob - alpine.spec
- rel.6
[packages/alpine.git] / alpine.spec
1 # TODO:
2 # - backport man-pages from pine.spec
3 # - separate package with tcl web-frontend
4 # - fix as-needed
5 # - pico shouldn't link with kerberos, should it?
6 # - switch to http://re-alpine.sourceforge.net/ - RIP alpine
7 %define         ver             2.00
8 %define         patchlevel      84
9 Summary:        University of Washington Alpine mail user agent
10 Summary(pl.UTF-8):      Klient pocztowy Alpine z Uniwersytetu w Waszyngtonie
11 Name:           alpine
12 Version:        %{ver}.%{patchlevel}
13 Release:        6
14 Epoch:          1
15 License:        Apache v2.0
16 Group:          Applications/Mail
17 # Main site:
18 #Source0:       ftp://ftp.cac.washington.edu/alpine/%{name}-%{version}.tar.gz
19 # Source with applied patches from http://staff.washington.edu/chappa/alpine/
20 Source0:        http://staff.washington.edu/chappa/alpine/patches/alpine-%{ver}/%{name}-%{ver}_%{patchlevel}.tar.gz
21 # Source0-md5:  70ba4281354f1ba2d341038ec0e323c7
22 Source1:        pico.desktop
23 Source2:        %{name}.desktop
24 Source3:        %{name}.png
25 Patch0:         %{name}-index_display.patch
26 Patch1:         %{name}-doc.patch
27 Patch2:         %{name}-filter.patch
28 Patch3:         %{name}-fhs.patch
29 Patch4:         %{name}-libc-client.patch
30 Patch5:         %{name}-ssl.patch
31 Patch6:         %{name}-no_1777_warning.patch
32 Patch7:         %{name}-home_etc.patch
33 Patch8:         %{name}-RFC1522_MAXW.patch
34 URL:            http://www.washington.edu/alpine/
35 BuildRequires:  autoconf
36 BuildRequires:  automake
37 BuildRequires:  home-etc-devel
38 %if "%{pld_release}" != "ac"
39 BuildRequires:  heimdal-devel
40 %endif
41 BuildRequires:  libtool
42 BuildRequires:  ncurses-devel
43 BuildRequires:  openldap-devel
44 BuildRequires:  openssl-devel
45 BuildRequires:  pam-devel
46 # Only for web-frontend:
47 #BuildRequires: tcl-devel
48 Suggests:       aspell
49 Suggests:       ca-certificates
50 Conflicts:      ca-certificates < 20080809-4
51 Provides:       pine = 6.00
52 Obsoletes:      pine
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %define         alpineconfdir   %{_sysconfdir}/%{name}
56 %define         filterout_ld    -Wl,--as-needed
57
58 %description
59 Alpine -- an Alternatively Licensed Program for Internet News & Email
60 -- is a tool for reading, sending, and managing electronic messages.
61 Alpine is the successor to Pine and was developed by Computing &
62 Communications at the University of Washington. Though originally
63 designed for inexperienced email users, Alpine supports many advanced
64 features, and an ever-growing number of configuration and
65 personal-preference options.
66
67 %description -l pl.UTF-8
68 Alpine, czyli Alternatively Licensed Program for Internet News & Email
69 (alternatywnie licencjonowany program do newsów i poczty internetowej)
70 to narzędzie do czytania, wysyłania i zarządzania wiadomościami
71 elektronicznymi. Alpine jest następcą Pine'a i został napisany przez
72 wydział Computing & Communications (Obliczeń i komunikacji) na
73 Uniwersytecie w Waszyngtonie. Mimo że Alpine pierwotnie został
74 zaprojektowany dla niedoświadczonych użytkowników poczty, obsługuje
75 wiele zaawansowanych możliwości, a liczba opcji konfiguracyjnych
76 ciągle rośnie.
77
78 %package -n pico
79 Summary:        Simple text editor in the style of the Pine Composer
80 Summary(pl.UTF-8):      Prosty edytor tekstowy w stylu alpine
81 Summary(pt_BR.UTF-8):   Editor de textos para terminal simples e fácil de usar
82 Group:          Applications/Editors
83 Provides:       pico = 6.00
84
85 %description -n pico
86 Pico is a simple, display-oriented text editor based on the Alpine
87 message system composer. As with Pine, commands are displayed at the
88 bottom of the screen, and context-sensitive help is provided. As
89 characters are typed they are immediately inserted into the text.
90
91 %description -n pico -l pl.UTF-8
92 Pico jest prostym, zorientowanym na wyświetlanie edytorem bazującym na
93 alpine. Tak jak w pine komendy są wyświetlane na dole ekranu oraz
94 dostępna jest pomoc kontekstowa. Wpisywane znaki są natychmiast
95 włączane do tekstu.
96
97 %description -n pico -l pt_BR.UTF-8
98 Pico é um editor de texto baseado no compositor de mensagens do Alpine.
99 Assim como no Pine, comandos são mostrados na parte de baixo da tela,
100 e ajuda de acordo com o contexto está disponível.
101
102 %package -n pilot
103 Summary:        Simple file system browser in the style of the Alpine Composer
104 Summary(pl.UTF-8):      Prosta przeglądarka plików w stylu composera alpine
105 Summary(pt_BR.UTF-8):   Navegador de sistemas de arquivos no estilo do compositor do Alpine
106 Group:          Applications/Shells
107 Provides:       pilot = 6.00
108
109 %description -n pilot
110 Pilot is a simple, display-oriented file system browser based on the
111 Alpine message system composer. As with Alpine, commands are displayed
112 at the bottom of the screen, and context-sensitive help is provided.
113
114 %description -n pilot -l pl.UTF-8
115 Pilot jest prostą, zorientowaną na wyświetlanie przeglądarką plików w
116 stylu composera pine. Podobnie jak w alpine polecenia są wyświetlane
117 na dole ekranu oraz jest dostępna pomoc kontekstowa.
118
119 %description -n pilot -l pt_BR.UTF-8
120 Pilot é um navegador de sistemas de arquivos baseado no Pine. Assim
121 como no Pine, comandos são apresentados na parte de baixo da tela, e
122 ajuda de acordo com o contexto está disponível.
123
124 %prep
125 %setup -q -n %{name}-%{ver}
126 %patch0 -p1
127 %patch1 -p1
128 %patch2 -p1
129 %patch3 -p1
130 %patch4 -p1
131 %patch5 -p1
132 %patch6 -p1
133 %patch7 -p1
134 %patch8 -p1
135
136 %build
137 rm -f libtool missing
138 %{__libtoolize}
139 %{__aclocal} -I m4
140 %{__autoconf}
141 %{__autoheader}
142 %{__automake}
143 %configure \
144         --%{?debug:en}%{!?debug:dis}able-debug \
145         --enable-quotas \
146         --without-tcl \
147         --with-smtp-msa=/usr/lib/sendmail \
148         --with-simple-spellcheck=aspell \
149         --with-system-pinerc=%{_sysconfdir}/%{name}/%{name}.conf \
150         --with-system-fixed-pinerc=%{_sysconfdir}/%{name}/%{name}.conf.fixed \
151         --with-krb5-dir=%{_prefix} \
152         --with-ldap-dir=%{_prefix} \
153         --with-system-mail-directory=/var/mail \
154         --with-c-client-target=slx \
155 %if "%{pld_release}" == "ti"
156         --with-ssl-dir=/var/lib/openssl/certs \
157         --with-ssl-certs-dir=/var/lib/openssl/certs \
158 %else
159         --with-ssl-dir=/etc/openssl/certs \
160         --with-ssl-certs-dir=/etc/certs \
161         --with-ssl-lib-dir=%{_libdir} \
162 %endif
163         --with-passfile=.pine.pwd
164
165 %{__make} \
166         GCCOPTLEVEL="%{rpmcflags}"
167
168 %install
169 rm -rf $RPM_BUILD_ROOT
170 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_desktopdir},%{_pixmapsdir}}
171
172 %{__make} install \
173         DESTDIR=$RPM_BUILD_ROOT
174
175 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
176 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
177 install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
178
179 ln -s alpine $RPM_BUILD_ROOT%{_bindir}/pine
180
181 $RPM_BUILD_ROOT%{_bindir}/alpine -conf > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/alpine.conf
182 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/alpine.conf.fixed
183 #
184 # Alpine system-wide enforced configuration file - customize as needed
185 #
186 # This file holds the system-wide enforced values for alpine configuration
187 # settings. Any values set in it will override values set in the
188 # system-wide default configuration file (%{_sysconfdir}/%{name}/alpine.conf) and
189 # the user's own configuration file (~/.pinerc).
190 # For more information on the format of this file, read the
191 # comments at the top of %{_sysconfdir}/%{name}/alpine.conf
192
193 EOF
194
195 %clean
196 rm -rf $RPM_BUILD_ROOT
197
198 %files
199 %defattr(644,root,root,755)
200 %doc README doc/tech-notes.txt
201 %dir %{_sysconfdir}/%{name}
202 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/alpine.conf
203 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/alpine.conf.fixed
204 %attr(755,root,root) %{_bindir}/%{name}
205 %attr(755,root,root) %{_bindir}/pine
206 %attr(755,root,root) %{_bindir}/rpload
207 %attr(755,root,root) %{_bindir}/rpdump
208 %{_mandir}/man1/%{name}.1*
209 %{_mandir}/man1/rpload.1*
210 %{_mandir}/man1/rpdump.1*
211 %{_desktopdir}/%{name}.desktop
212 %{_pixmapsdir}/%{name}.png
213
214 %files -n pico
215 %defattr(644,root,root,755)
216 %attr(755,root,root) %{_bindir}/pico
217 %{_desktopdir}/pico.desktop
218 %{_mandir}/man1/pico*
219
220 %files -n pilot
221 %defattr(644,root,root,755)
222 %attr(755,root,root) %{_bindir}/pilot
223 %{_mandir}/man1/pilot*
This page took 0.035915 seconds and 3 git commands to generate.