]> git.pld-linux.org Git - packages/alpine.git/blob - alpine.spec
- patchlevel 20
[packages/alpine.git] / alpine.spec
1 # TODO:
2 # - backport man-pages from pine.spec
3 # - separate package with tcl web-frontend
4 # - fix as-needed
5 %define         ver             2.00
6 %define         patchlevel      20
7 Summary:        University of Washington Alpine mail user agent
8 Summary(pl.UTF-8):      Klient pocztowy Alpine z Uniwersytetu w Waszyngtonie
9 Name:           alpine
10 Version:        %{ver}.%{patchlevel}
11 Release:        1
12 Epoch:          1
13 License:        Apache v2.0
14 Group:          Applications/Mail
15 # Main site:
16 #Source0:       ftp://ftp.cac.washington.edu/alpine/%{name}-%{version}.tar.gz
17 # Source with applied patches from http://staff.washington.edu/chappa/alpine/
18 Source0:        http://staff.washington.edu/chappa/alpine/patches/alpine-%{ver}/%{name}-%{ver}_%{patchlevel}.tar.gz
19 # Source0-md5:  113367a8ddfcb162305cad5f24d0103a
20 Source1:        pico.desktop
21 Source2:        %{name}.desktop
22 Source3:        %{name}.png
23 Patch0:         %{name}-index_display.patch
24 Patch1:         %{name}-doc.patch
25 Patch2:         %{name}-filter.patch
26 Patch3:         %{name}-fhs.patch
27 Patch4:         %{name}-libc-client.patch
28 Patch5:         %{name}-ssl.patch
29 Patch6:         %{name}-no_1777_warning.patch
30 Patch7:         %{name}-home_etc.patch
31 URL:            http://www.washington.edu/alpine/
32 BuildRequires:  autoconf
33 BuildRequires:  automake
34 BuildRequires:  home-etc-devel
35 %if "%{pld_release}" != "ac"
36 BuildRequires:  krb5-devel
37 %endif
38 BuildRequires:  ncurses-devel
39 BuildRequires:  openldap-devel
40 BuildRequires:  openssl-devel
41 BuildRequires:  pam-devel
42 # Only for web-frontend:
43 #BuildRequires: tcl-devel
44 Suggests:       aspell
45 Suggests:       ca-certificates
46 Conflicts:      ca-certificates < 20080809-4
47 Provides:       pine = 6.00
48 Obsoletes:      pine
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %define         alpineconfdir   %{_sysconfdir}/%{name}
52 %define         filterout_ld    -Wl,--as-needed
53
54 %description
55 Alpine -- an Alternatively Licensed Program for Internet News & Email
56 -- is a tool for reading, sending, and managing electronic messages.
57 Alpine is the successor to Pine and was developed by Computing &
58 Communications at the University of Washington. Though originally
59 designed for inexperienced email users, Alpine supports many advanced
60 features, and an ever-growing number of configuration and
61 personal-preference options.
62
63 %description -l pl.UTF-8
64 Alpine, czyli Alternatively Licensed Program for Internet News & Email
65 (alternatywnie licencjonowany program do newsów i poczty internetowej)
66 to narzędzie do czytania, wysyłania i zarządzania wiadomościami
67 elektronicznymi. Alpine jest następcą Pine'a i został napisany przez
68 wydział Computing & Communications (Obliczeń i komunikacji) na
69 Uniwersytecie w Waszyngtonie. Mimo że Alpine pierwotnie został
70 zaprojektowany dla niedoświadczonych użytkowników poczty, obsługuje
71 wiele zaawansowanych możliwości, a liczba opcji konfiguracyjnych
72 ciągle rośnie.
73
74 %package -n pico
75 Summary:        Simple text editor in the style of the Pine Composer
76 Summary(pl.UTF-8):      Prosty edytor tekstowy w stylu alpine
77 Summary(pt_BR.UTF-8):   Editor de textos para terminal simples e fácil de usar
78 Group:          Applications/Editors
79 Provides:       pico = 6.00
80
81 %description -n pico
82 Pico is a simple, display-oriented text editor based on the Alpine
83 message system composer. As with Pine, commands are displayed at the
84 bottom of the screen, and context-sensitive help is provided. As
85 characters are typed they are immediately inserted into the text.
86
87 %description -n pico -l pl.UTF-8
88 Pico jest prostym, zorientowanym na wyświetlanie edytorem bazującym na
89 alpine. Tak jak w pine komendy są wyświetlane na dole ekranu oraz
90 dostępna jest pomoc kontekstowa. Wpisywane znaki są natychmiast
91 włączane do tekstu.
92
93 %description -n pico -l pt_BR.UTF-8
94 Pico é um editor de texto baseado no compositor de mensagens do Alpine.
95 Assim como no Pine, comandos são mostrados na parte de baixo da tela,
96 e ajuda de acordo com o contexto está disponível.
97
98 %package -n pilot
99 Summary:        Simple file system browser in the style of the Alpine Composer
100 Summary(pl.UTF-8):      Prosta przeglądarka plików w stylu composera alpine
101 Summary(pt_BR.UTF-8):   Navegador de sistemas de arquivos no estilo do compositor do Alpine
102 Group:          Applications/Shells
103 Provides:       pilot = 6.00
104
105 %description -n pilot
106 Pilot is a simple, display-oriented file system browser based on the
107 Alpine message system composer. As with Alpine, commands are displayed
108 at the bottom of the screen, and context-sensitive help is provided.
109
110 %description -n pilot -l pl.UTF-8
111 Pilot jest prostą, zorientowaną na wyświetlanie przeglądarką plików w
112 stylu composera pine. Podobnie jak w alpine polecenia są wyświetlane
113 na dole ekranu oraz jest dostępna pomoc kontekstowa.
114
115 %description -n pilot -l pt_BR.UTF-8
116 Pilot é um navegador de sistemas de arquivos baseado no Pine. Assim
117 como no Pine, comandos são apresentados na parte de baixo da tela, e
118 ajuda de acordo com o contexto está disponível.
119
120 %prep
121 %setup -q -n %{name}-%{ver}
122 %patch0 -p1
123 %patch1 -p1
124 %patch2 -p1
125 %patch3 -p1
126 %patch4 -p1
127 %patch5 -p1
128 %patch6 -p1
129 %patch7 -p1
130
131 %build
132 rm -f libtool missing
133 %{__libtoolize}
134 %{__aclocal} -I m4
135 %{__autoconf}
136 %{__autoheader}
137 %{__automake}
138 %configure \
139         --%{?debug:en}%{!?debug:dis}able-debug \
140         --enable-quotas \
141         --without-tcl \
142         --with-smtp-msa=%{_libdir}/sendmail \
143         --with-simple-spellcheck=aspell \
144         --with-system-pinerc=%{_sysconfdir}/%{name}/%{name}.conf \
145         --with-system-fixed-pinerc=%{_sysconfdir}/%{name}/%{name}.conf.fixed \
146         --with-krb5-dir=%{_prefix} \
147         --with-ldap-dir=%{_prefix} \
148         --with-system-mail-directory=/var/mail \
149         --with-c-client-target=slx \
150 %if "%{pld_release}" == "ti"
151         --with-ssl-dir=/var/lib/openssl/certs \
152         --with-ssl-certs-dir=/var/lib/openssl/certs \
153 %else
154         --with-ssl-dir=/etc/openssl/certs \
155         --with-ssl-certs-dir=/etc/certs \
156 %endif
157         --with-passfile=.pine.pwd
158
159 %{__make} \
160         GCCOPTLEVEL="%{rpmcflags}"
161
162 %install
163 rm -rf $RPM_BUILD_ROOT
164 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_desktopdir},%{_pixmapsdir}}
165
166 %{__make} install \
167         DESTDIR=$RPM_BUILD_ROOT
168
169 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
170 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
171 install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
172
173 ln -s alpine $RPM_BUILD_ROOT%{_bindir}/pine
174
175 $RPM_BUILD_ROOT%{_bindir}/alpine -conf > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/alpine.conf
176 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/alpine.conf.fixed
177 #
178 # Alpine system-wide enforced configuration file - customize as needed
179 #
180 # This file holds the system-wide enforced values for alpine configuration
181 # settings. Any values set in it will override values set in the
182 # system-wide default configuration file (%{_sysconfdir}/%{name}/alpine.conf) and
183 # the user's own configuration file (~/.pinerc).
184 # For more information on the format of this file, read the
185 # comments at the top of %{_sysconfdir}/%{name}/alpine.conf
186
187 EOF
188
189 %clean
190 rm -rf $RPM_BUILD_ROOT
191
192 %files
193 %defattr(644,root,root,755)
194 %doc README doc/tech-notes.txt
195 %dir %{_sysconfdir}/%{name}
196 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/alpine.conf
197 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/alpine.conf.fixed
198 %attr(755,root,root) %{_bindir}/%{name}
199 %attr(755,root,root) %{_bindir}/pine
200 %attr(755,root,root) %{_bindir}/rpload
201 %attr(755,root,root) %{_bindir}/rpdump
202 %{_mandir}/man1/%{name}.1*
203 %{_mandir}/man1/rpload.1*
204 %{_mandir}/man1/rpdump.1*
205 %{_desktopdir}/%{name}.desktop
206 %{_pixmapsdir}/%{name}.png
207
208 %files -n pico
209 %defattr(644,root,root,755)
210 %attr(755,root,root) %{_bindir}/pico
211 %{_desktopdir}/pico.desktop
212 %{_mandir}/man1/pico*
213
214 %files -n pilot
215 %defattr(644,root,root,755)
216 %attr(755,root,root) %{_bindir}/pilot
217 %{_mandir}/man1/pilot*
This page took 0.085139 seconds and 3 git commands to generate.