]> git.pld-linux.org Git - packages/alpine.git/blob - alpine.spec
- rel.2 (rel.1 for AC)
[packages/alpine.git] / alpine.spec
1 # TODO:
2 # - backport man-pages from pine.spec
3 # - separate package with tcl web-frontend
4 # - fix as-needed
5 Summary:        University of Washington Alpine mail user agent
6 Summary(pl.UTF-8):      Klient pocztowy Alpine z Uniwersytetu w Waszyngtonie
7 Name:           alpine
8 %define         ver             1.00
9 %define         patchlevel      3
10 Version:        %{ver}.%{patchlevel}
11 Release:        2
12 Epoch:          1
13 License:        Apache License 2.0
14 Group:          Applications/Mail
15 # Main site:
16 #Source0:       ftp://ftp.cac.washington.edu/alpine/%{name}-%{version}.tar.gz
17 # Source with applied patches from http://staff.washington.edu/chappa/alpine/
18 Source0:        http://staff.washington.edu/chappa/alpine/patches/alpine-%{ver}/%{name}-%{ver}_%{patchlevel}.tar.gz
19 # Source0-md5:  3937652526da1afe6310e05650ace80c
20 Source1:        pico.desktop
21 Source2:        %{name}.desktop
22 Source3:        %{name}.png
23 Patch0:         %{name}-index_display.patch
24 Patch1:         %{name}-doc.patch
25 Patch2:         %{name}-filter.patch
26 Patch3:         %{name}-quote.patch
27 Patch4:         %{name}-fhs.patch
28 Patch5:         %{name}-segfix.patch
29 Patch6:         %{name}-libc-client.patch
30 Patch7:         %{name}-fixhome.patch
31 Patch8:         %{name}-ssl.patch
32 Patch9:         %{name}-no_1777_warning.patch
33 Patch10:        %{name}-home_etc.patch
34 URL:            http://www.washington.edu/alpine/
35 BuildRequires:  autoconf
36 BuildRequires:  automake
37 BuildRequires:  home-etc-devel
38 BuildRequires:  krb5-devel
39 BuildRequires:  ncurses-devel
40 BuildRequires:  openldap-devel >= 2.4.6
41 BuildRequires:  openssl-devel
42 BuildRequires:  pam-devel
43 # Only for web-frontend:
44 #BuildRequires: tcl-devel
45 Obsoletes:      pine
46 Provides:       pine = 4.99
47 Suggests:       aspell
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %define         alpineconfdir   /etc/%{name}
51 %define         filterout_ld    -Wl,--as-needed
52
53 %description
54 Alpine -- an Alternatively Licensed Program for Internet News & Email
55 -- is a tool for reading, sending, and managing electronic messages.
56 Alpine is the successor to Pine and was developed by Computing &
57 Communications at the University of Washington. Though originally
58 designed for inexperienced email users, Alpine supports many advanced
59 features, and an ever-growing number of configuration and
60 personal-preference options.
61
62 %description -l pl.UTF-8
63 Alpine, czyli Alternatively Licensed Program for Internet News & Email
64 (alternatywnie licencjonowany program do newsów i poczty internetowej)
65 to narzędzie do czytania, wysyłania i zarządzania wiadomościami
66 elektronicznymi. Alpine jest następcą Pine'a i został napisany przez
67 wydział Computing & Communications (Obliczeń i komunikacji) na
68 Uniwersytecie w Waszyngtonie. Mimo że Alpine pierwotnie został
69 zaprojektowany dla niedoświadczonych użytkowników poczty, obsługuje
70 wiele zaawansowanych możliwości, a liczba opcji konfiguracyjnych
71 ciągle rośnie.
72
73 %package -n pico
74 Summary:        Simple text editor in the style of the Pine Composer
75 Summary(pl.UTF-8):      Prosty edytor tekstowy w stylu alpine
76 Summary(pt_BR.UTF-8):   Editor de textos para terminal simples e fácil de usar
77 Group:          Applications/Editors
78 Provides:       pico = 4.99
79
80 %description -n pico
81 Pico is a simple, display-oriented text editor based on the Alpine
82 message system composer. As with Pine, commands are displayed at the
83 bottom of the screen, and context-sensitive help is provided. As
84 characters are typed they are immediately inserted into the text.
85
86 %description -n pico -l pl.UTF-8
87 Pico jest prostym, zorientowanym na wyświetlanie edytorem bazującym na
88 alpine. Tak jak w pine komendy są wyświetlane na dole ekranu oraz
89 dostępna jest pomoc kontekstowa. Wpisywane znaki są natychmiast
90 włączane do tekstu.
91
92 %description -n pico -l pt_BR.UTF-8
93 Pico é um editor de texto baseado no compositor de mensagens do Alpine.
94 Assim como no Pine, comandos são mostrados na parte de baixo da tela,
95 e ajuda de acordo com o contexto está disponível.
96
97 %package -n pilot
98 Summary:        Simple file system browser in the style of the Alpine Composer
99 Summary(pl.UTF-8):      Prosta przeglądarka plików w stylu composera alpine
100 Summary(pt_BR.UTF-8):   Navegador de sistemas de arquivos no estilo do compositor do Alpine
101 Group:          Applications/Shells
102 Provides:       pilot = 4.99
103
104 %description -n pilot
105 Pilot is a simple, display-oriented file system browser based on the
106 Alpine message system composer. As with Alpine, commands are displayed
107 at the bottom of the screen, and context-sensitive help is provided.
108
109 %description -n pilot -l pl.UTF-8
110 Pilot jest prostą, zorientowaną na wyświetlanie przeglądarką plików w
111 stylu composera pine. Podobnie jak w alpine polecenia są wyświetlane
112 na dole ekranu oraz jest dostępna pomoc kontekstowa.
113
114 %description -n pilot -l pt_BR.UTF-8
115 Pilot é um navegador de sistemas de arquivos baseado no Pine. Assim
116 como no Pine, comandos são apresentados na parte de baixo da tela, e
117 ajuda de acordo com o contexto está disponível.
118
119 %prep
120 %setup -q -n %{name}-%{ver}
121 %patch0 -p1
122 %patch1 -p1
123 %patch2 -p1
124 %patch3 -p1
125 %patch4 -p1
126 %patch5 -p1
127 %patch6 -p1
128 %patch7 -p1
129 %patch8 -p1
130 %patch9 -p1
131 %patch10 -p1
132
133 %build
134 rm -f libtool missing
135 %{__libtoolize}
136 %{__aclocal} -I m4
137 %{__autoconf}
138 %{__autoheader}
139 %{__automake}
140 %configure \
141         --enable-quotas \
142         --without-tcl \
143         --with-smtp-msa=%{_libdir}/sendmail \
144         --with-simple-spellcheck=aspell \
145         --with-system-pinerc=%{alpineconfdir}/%{name}.conf \
146         --with-system-fixed-pinerc=%{alpineconfdir}/%{name}.conf.fixed \
147         --with-krb5-dir=%{_prefix} \
148         --with-ldap-dir=%{_prefix} \
149         --with-system-mail-directory=/var/mail \
150         --with-c-client-target=slx \
151         --with-ssl-dir=/var/lib/openssl/certs \
152         --with-ssl-certs-dir=/var/lib/openssl/certs \
153         --with-passfile=.pine.pwd
154
155 %{__make} \
156         GCCOPTLEVEL="%{rpmcflags}"
157
158 %install
159 rm -rf $RPM_BUILD_ROOT
160 install -d $RPM_BUILD_ROOT{%{alpineconfdir},%{_desktopdir},%{_pixmapsdir}}
161
162 %{__make} install \
163         DESTDIR=$RPM_BUILD_ROOT
164
165 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
166 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
167 install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
168
169 ln -s alpine $RPM_BUILD_ROOT%{_bindir}/pine
170
171 $RPM_BUILD_ROOT%{_bindir}/alpine -conf > $RPM_BUILD_ROOT%{alpineconfdir}/alpine.conf
172 cat <<EOF > $RPM_BUILD_ROOT%{alpineconfdir}/alpine.conf.fixed
173 #
174 # Alpine system-wide enforced configuration file - customize as needed
175 #
176 # This file holds the system-wide enforced values for alpine configuration
177 # settings. Any values set in it will override values set in the
178 # system-wide default configuration file (%{alpineconfdir}/alpine.conf) and
179 # the user's own configuration file (~/.pinerc).
180 # For more information on the format of this file, read the
181 # comments at the top of %{alpineconfdir}/alpine.conf
182
183 EOF
184
185 %clean
186 rm -rf $RPM_BUILD_ROOT
187
188 %files
189 %defattr(644,root,root,755)
190 %doc README doc/tech-notes.txt
191 %dir %{alpineconfdir}
192 %config(noreplace) %verify(not md5 mtime size) %{alpineconfdir}/alpine.conf
193 %config(noreplace) %verify(not md5 mtime size) %{alpineconfdir}/alpine.conf.fixed
194 %attr(755,root,root) %{_bindir}/%{name}
195 %attr(755,root,root) %{_bindir}/pine
196 %attr(755,root,root) %{_bindir}/rpload
197 %attr(755,root,root) %{_bindir}/rpdump
198 %{_mandir}/man1/%{name}.1*
199 %{_mandir}/man1/rpload.1*
200 %{_mandir}/man1/rpdump.1*
201 %{_desktopdir}/%{name}.desktop
202 %{_pixmapsdir}/%{name}.png
203
204 %files -n pico
205 %defattr(644,root,root,755)
206 %attr(755,root,root) %{_bindir}/pico
207 %{_desktopdir}/pico.desktop
208 %{_mandir}/man1/pico*
209
210 %files -n pilot
211 %defattr(644,root,root,755)
212 %attr(755,root,root) %{_bindir}/pilot
213 %{_mandir}/man1/pilot*
This page took 0.065837 seconds and 3 git commands to generate.