]> git.pld-linux.org Git - packages/alpine.git/blame_incremental - alpine.spec
- rel.2 - added index_display patch
[packages/alpine.git] / alpine.spec
... / ...
CommitLineData
1# TODO:
2# - backport man-pages from pine.spec
3# - alpine should obsolete pine, link pine -> alpine should be made
4# - review patches from pine:
5# - home_etc support
6# - ....many more
7Summary: University of Washington Pine mail user agent
8Summary(pl.UTF-8): Klient pocztowy Pine z Uniwersytetu w Waszyngtonie
9Name: alpine
10%define ver 0.9999
11%define patchlevel 18
12Version: %{ver}.%{patchlevel}
13Release: 2
14Epoch: 1
15License: Apache License 2.0
16Group: Applications/Mail
17# Main site:
18#Source0: ftp://ftp.cac.washington.edu/alpine/%{name}-%{version}.tar.gz
19# Source with applied patches from http://staff.washington.edu/chappa/alpine/
20Source0: http://staff.washington.edu/chappa/alpine/patches/alpine-%{ver}/%{name}-%{ver}_%{patchlevel}.tar.gz
21# Source0-md5: 888ecef4d50e15e4237f7a7a55793f68
22Source1: pico.desktop
23Source2: %{name}.desktop
24Source3: %{name}.png
25Patch0: %{name}-thread_end.patch
26Patch1: %{name}-index_display.patch
27URL: http://www.washington.edu/alpine
28BuildRequires: autoconf
29BuildRequires: automake
30BuildRequires: krb5-devel
31BuildRequires: ncurses-devel
32BuildRequires: openldap-devel
33BuildRequires: openssl-devel
34BuildRequires: pam-devel
35BuildRequires: tcl-devel
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38%define alpineconfdir /etc/%{name}
39
40%description
41Alpine -- an Alternatively Licensed Program for Internet News & Email
42-- is a tool for reading, sending, and managing electronic messages.
43Alpine is the successor to Pine and was developed by Computing &
44Communications at the University of Washington. Though originally
45designed for inexperienced email users, Alpine supports many advanced
46features, and an ever-growing number of configuration and
47personal-preference options.
48
49%description -l pl.UTF-8
50Alpine, czyli Alternatively Licensed Program for Internet News & Email
51(alternatywnie licencjonowany program do newsów i poczty internetowej)
52to narzędzie do czytania, wysyłania i zarządzania wiadomościami
53elektronicznymi. Alpine jest następcą Pine'a i został napisany przez
54wydział Computing & Communications (Obliczeń i komunikacji) na
55Uniwersytecie w Waszyngtonie. Mimo że Alpine pierwotnie został
56zaprojektowany dla niedoświadczonych użytkowników poczty, obsługuje
57wiele zaawansowanych możliwości, a liczba opcji konfiguracyjnych
58ciągle rośnie.
59
60%package -n pico
61Summary: Simple text editor in the style of the Pine Composer
62Summary(pl.UTF-8): Prosty edytor tekstowy w stylu alpine
63Summary(pt_BR.UTF-8): Editor de textos para terminal simples e fácil de usar
64Group: Applications/Editors
65
66%description -n pico
67Pico is a simple, display-oriented text editor based on the Alpine
68message system composer. As with Pine, commands are displayed at the
69bottom of the screen, and context-sensitive help is provided. As
70characters are typed they are immediately inserted into the text.
71
72%description -n pico -l pl.UTF-8
73Pico jest prostym, zorientowanym na wyświetlanie edytorem bazującym na
74alpine. Tak jak w pine komendy są wyświetlane na dole ekranu oraz
75dostępna jest pomoc konteksowa. Wpisywane znaki są natychmiast
76włączane do tekstu.
77
78%description -n pico -l pt_BR.UTF-8
79Pico é um editor de texto baseado no compositor de mensagens do Alpine.
80Assim como no Pine, comandos são mostrados na parte de baixo da tela,
81e ajuda de acordo com o contexto está disponível.
82
83%package -n pilot
84Summary: Simple file system browser in the style of the Alpine Composer
85Summary(pl.UTF-8): Prosta przeglądarka plików w stylu composera alpine
86Summary(pt_BR.UTF-8): Navegador de sistemas de arquivos no estilo do compositor do Alpine
87Group: Applications/Shells
88
89%description -n pilot
90Pilot is a simple, display-oriented file system browser based on the
91Alpine message system composer. As with Alpine, commands are displayed at
92the bottom of the screen, and context-sensitive help is provided.
93
94%description -n pilot -l pl.UTF-8
95Pilot jest prostą, zorientowaną na wyświetlanie przeglądarką plików w
96stylu compsera pine. Podobnie jak w alpine polecenia sa wyświetlane na
97dole ekranu oraz jest dostępna pomoc kontekstowa.
98
99%description -n pilot -l pt_BR.UTF-8
100Pilot é um navegador de sistemas de arquivos baseado no Pine. Assim
101como no Pine, comandos são apresentados na parte de baixo da tela, e
102ajuda de acordo com o contexto está disponível.
103
104%prep
105%setup -q -n %{name}-%{ver}
106%patch0 -p1
107%patch1 -p1
108
109%build
110%{__autoconf}
111%{__aclocal} -I m4
112%{__automake}
113%configure \
114 --enable-quotas \
115 --with-smtp-msa=%{_libdir}/sendmail \
116 --with-spellcheck-prog=aspell \
117 --with-system-pinerc=%{alpineconfdir}/%{name}.conf \
118 --with-system-fixed-pinerc=%{alpineconfdir}/%{name}.conf.fixed \
119 --with-krb5-dir=%{_prefix} \
120 --with-ldap-dir=%{_prefix} \
121 --with-system-mail-directory=/var/mail
122%{__make}
123
124%install
125rm -rf $RPM_BUILD_ROOT
126install -d $RPM_BUILD_ROOT{%{alpineconfdir},%{_desktopdir},%{_pixmapsdir}}
127
128%{__make} install \
129 DESTDIR=$RPM_BUILD_ROOT
130
131install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
132install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
133install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
134
135
136%clean
137rm -rf $RPM_BUILD_ROOT
138
139%files
140%defattr(644,root,root,755)
141%doc README doc/tech-notes.txt
142%dir %{alpineconfdir}
143%attr(755,root,root) %{_bindir}/%{name}
144%attr(755,root,root) %{_bindir}/rpload
145%attr(755,root,root) %{_bindir}/rpdump
146#%attr(755,root,root) %{_bindir}/mailutil
147#%attr(2755,root,mail) %{_sbindir}/mlock
148%{_mandir}/man1/%{name}.1*
149#%{_mandir}/man1/rpload.1*
150#%{_mandir}/man1/rpdump.1*
151#%{_mandir}/man1/mailutil.1*
152%{_desktopdir}/%{name}.desktop
153%{_pixmapsdir}/%{name}.png
154
155%files -n pico
156%defattr(644,root,root,755)
157%attr(755,root,root) %{_bindir}/pico
158%{_desktopdir}/pico.desktop
159%{_mandir}/man1/pico*
160
161%files -n pilot
162%defattr(644,root,root,755)
163%attr(755,root,root) %{_bindir}/pilot
164%{_mandir}/man1/pilot*
This page took 0.059185 seconds and 4 git commands to generate.