]> git.pld-linux.org Git - packages/alpine.git/blame_incremental - alpine.spec
- ldap ver bump was only due bulders limitation
[packages/alpine.git] / alpine.spec
... / ...
CommitLineData
1# TODO:
2# - backport man-pages from pine.spec
3# - separate package with tcl web-frontend
4# - fix as-needed
5%define ver 2.00
6%define patchlevel 17
7Summary: University of Washington Alpine mail user agent
8Summary(pl.UTF-8): Klient pocztowy Alpine z Uniwersytetu w Waszyngtonie
9Name: alpine
10Version: %{ver}.%{patchlevel}
11Release: 1
12Epoch: 1
13License: Apache v2.0
14Group: Applications/Mail
15# Main site:
16#Source0: ftp://ftp.cac.washington.edu/alpine/%{name}-%{version}.tar.gz
17# Source with applied patches from http://staff.washington.edu/chappa/alpine/
18Source0: http://staff.washington.edu/chappa/alpine/patches/alpine-%{ver}/%{name}-%{ver}_%{patchlevel}.tar.gz
19# Source0-md5: 68e0164c9f74c89f074b48271cf57daf
20Source1: pico.desktop
21Source2: %{name}.desktop
22Source3: %{name}.png
23Patch0: %{name}-index_display.patch
24Patch1: %{name}-doc.patch
25Patch2: %{name}-filter.patch
26Patch3: %{name}-fhs.patch
27Patch4: %{name}-libc-client.patch
28Patch5: %{name}-ssl.patch
29Patch6: %{name}-no_1777_warning.patch
30Patch7: %{name}-home_etc.patch
31URL: http://www.washington.edu/alpine/
32BuildRequires: autoconf
33BuildRequires: automake
34BuildRequires: home-etc-devel
35%if "%{pld_release}" != "ac"
36BuildRequires: krb5-devel
37%endif
38BuildRequires: ncurses-devel
39BuildRequires: openldap-devel
40BuildRequires: openssl-devel
41BuildRequires: pam-devel
42# Only for web-frontend:
43#BuildRequires: tcl-devel
44Suggests: aspell
45Suggests: ca-certificates
46Conflicts: ca-certificates < 20080809-4
47Provides: pine = 6.00
48Obsoletes: pine
49BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51%define alpineconfdir %{_sysconfdir}/%{name}
52%define filterout_ld -Wl,--as-needed
53
54%description
55Alpine -- an Alternatively Licensed Program for Internet News & Email
56-- is a tool for reading, sending, and managing electronic messages.
57Alpine is the successor to Pine and was developed by Computing &
58Communications at the University of Washington. Though originally
59designed for inexperienced email users, Alpine supports many advanced
60features, and an ever-growing number of configuration and
61personal-preference options.
62
63%description -l pl.UTF-8
64Alpine, czyli Alternatively Licensed Program for Internet News & Email
65(alternatywnie licencjonowany program do newsów i poczty internetowej)
66to narzędzie do czytania, wysyłania i zarządzania wiadomościami
67elektronicznymi. Alpine jest następcą Pine'a i został napisany przez
68wydział Computing & Communications (Obliczeń i komunikacji) na
69Uniwersytecie w Waszyngtonie. Mimo że Alpine pierwotnie został
70zaprojektowany dla niedoświadczonych użytkowników poczty, obsługuje
71wiele zaawansowanych możliwości, a liczba opcji konfiguracyjnych
72ciągle rośnie.
73
74%package -n pico
75Summary: Simple text editor in the style of the Pine Composer
76Summary(pl.UTF-8): Prosty edytor tekstowy w stylu alpine
77Summary(pt_BR.UTF-8): Editor de textos para terminal simples e fácil de usar
78Group: Applications/Editors
79Provides: pico = 6.00
80
81%description -n pico
82Pico is a simple, display-oriented text editor based on the Alpine
83message system composer. As with Pine, commands are displayed at the
84bottom of the screen, and context-sensitive help is provided. As
85characters are typed they are immediately inserted into the text.
86
87%description -n pico -l pl.UTF-8
88Pico jest prostym, zorientowanym na wyświetlanie edytorem bazującym na
89alpine. Tak jak w pine komendy są wyświetlane na dole ekranu oraz
90dostępna jest pomoc kontekstowa. Wpisywane znaki są natychmiast
91włączane do tekstu.
92
93%description -n pico -l pt_BR.UTF-8
94Pico é um editor de texto baseado no compositor de mensagens do Alpine.
95Assim como no Pine, comandos são mostrados na parte de baixo da tela,
96e ajuda de acordo com o contexto está disponível.
97
98%package -n pilot
99Summary: Simple file system browser in the style of the Alpine Composer
100Summary(pl.UTF-8): Prosta przeglądarka plików w stylu composera alpine
101Summary(pt_BR.UTF-8): Navegador de sistemas de arquivos no estilo do compositor do Alpine
102Group: Applications/Shells
103Provides: pilot = 6.00
104
105%description -n pilot
106Pilot is a simple, display-oriented file system browser based on the
107Alpine message system composer. As with Alpine, commands are displayed
108at the bottom of the screen, and context-sensitive help is provided.
109
110%description -n pilot -l pl.UTF-8
111Pilot jest prostą, zorientowaną na wyświetlanie przeglądarką plików w
112stylu composera pine. Podobnie jak w alpine polecenia są wyświetlane
113na dole ekranu oraz jest dostępna pomoc kontekstowa.
114
115%description -n pilot -l pt_BR.UTF-8
116Pilot é um navegador de sistemas de arquivos baseado no Pine. Assim
117como no Pine, comandos são apresentados na parte de baixo da tela, e
118ajuda de acordo com o contexto está disponível.
119
120%prep
121%setup -q -n %{name}-%{ver}
122%patch0 -p1
123%patch1 -p1
124%patch2 -p1
125%patch3 -p1
126%patch4 -p1
127%patch5 -p1
128%patch6 -p1
129%patch7 -p1
130
131%build
132rm -f libtool missing
133%{__libtoolize}
134%{__aclocal} -I m4
135%{__autoconf}
136%{__autoheader}
137%{__automake}
138%configure \
139 --%{?debug:en}%{!?debug:dis}able-debug \
140 --enable-quotas \
141 --without-tcl \
142 --with-smtp-msa=%{_libdir}/sendmail \
143 --with-simple-spellcheck=aspell \
144 --with-system-pinerc=%{_sysconfdir}/%{name}/%{name}.conf \
145 --with-system-fixed-pinerc=%{_sysconfdir}/%{name}/%{name}.conf.fixed \
146 --with-krb5-dir=%{_prefix} \
147 --with-ldap-dir=%{_prefix} \
148 --with-system-mail-directory=/var/mail \
149 --with-c-client-target=slx \
150 --with-ssl-dir=/var/lib/openssl/certs \
151 --with-ssl-certs-dir=/etc/certs \
152 --with-passfile=.pine.pwd
153
154%{__make} \
155 GCCOPTLEVEL="%{rpmcflags}"
156
157%install
158rm -rf $RPM_BUILD_ROOT
159install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_desktopdir},%{_pixmapsdir}}
160
161%{__make} install \
162 DESTDIR=$RPM_BUILD_ROOT
163
164install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
165install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
166install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
167
168ln -s alpine $RPM_BUILD_ROOT%{_bindir}/pine
169
170$RPM_BUILD_ROOT%{_bindir}/alpine -conf > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/alpine.conf
171cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/alpine.conf.fixed
172#
173# Alpine system-wide enforced configuration file - customize as needed
174#
175# This file holds the system-wide enforced values for alpine configuration
176# settings. Any values set in it will override values set in the
177# system-wide default configuration file (%{_sysconfdir}/%{name}/alpine.conf) and
178# the user's own configuration file (~/.pinerc).
179# For more information on the format of this file, read the
180# comments at the top of %{_sysconfdir}/%{name}/alpine.conf
181
182EOF
183
184%clean
185rm -rf $RPM_BUILD_ROOT
186
187%files
188%defattr(644,root,root,755)
189%doc README doc/tech-notes.txt
190%dir %{_sysconfdir}/%{name}
191%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/alpine.conf
192%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/alpine.conf.fixed
193%attr(755,root,root) %{_bindir}/%{name}
194%attr(755,root,root) %{_bindir}/pine
195%attr(755,root,root) %{_bindir}/rpload
196%attr(755,root,root) %{_bindir}/rpdump
197%{_mandir}/man1/%{name}.1*
198%{_mandir}/man1/rpload.1*
199%{_mandir}/man1/rpdump.1*
200%{_desktopdir}/%{name}.desktop
201%{_pixmapsdir}/%{name}.png
202
203%files -n pico
204%defattr(644,root,root,755)
205%attr(755,root,root) %{_bindir}/pico
206%{_desktopdir}/pico.desktop
207%{_mandir}/man1/pico*
208
209%files -n pilot
210%defattr(644,root,root,755)
211%attr(755,root,root) %{_bindir}/pilot
212%{_mandir}/man1/pilot*
This page took 0.077549 seconds and 4 git commands to generate.