]> git.pld-linux.org Git - packages/alpine.git/blame_incremental - alpine.spec
- rel.2
[packages/alpine.git] / alpine.spec
... / ...
CommitLineData
1# TODO:
2# - backport man-pages from pine.spec
3# - separate package with tcl web-frontend
4# - fix as-needed
5Summary: University of Washington Alpine mail user agent
6Summary(pl.UTF-8): Klient pocztowy Alpine z Uniwersytetu w Waszyngtonie
7Name: alpine
8%define ver 1.00
9%define patchlevel 12
10Version: %{ver}.%{patchlevel}
11Release: 2
12Epoch: 1
13License: Apache License 2.0
14Group: Applications/Mail
15# Main site:
16#Source0: ftp://ftp.cac.washington.edu/alpine/%{name}-%{version}.tar.gz
17# Source with applied patches from http://staff.washington.edu/chappa/alpine/
18Source0: http://staff.washington.edu/chappa/alpine/patches/alpine-%{ver}/%{name}-%{ver}_%{patchlevel}.tar.gz
19# Source0-md5: eccde18b953df022d5e073b7de6b9c1a
20Source1: pico.desktop
21Source2: %{name}.desktop
22Source3: %{name}.png
23Patch0: %{name}-index_display.patch
24Patch1: %{name}-doc.patch
25Patch2: %{name}-filter.patch
26Patch3: %{name}-quote.patch
27Patch4: %{name}-fhs.patch
28Patch5: %{name}-segfix.patch
29Patch6: %{name}-libc-client.patch
30Patch7: %{name}-ssl.patch
31Patch8: %{name}-no_1777_warning.patch
32Patch9: %{name}-home_etc.patch
33URL: http://www.washington.edu/alpine/
34BuildRequires: autoconf
35BuildRequires: automake
36BuildRequires: home-etc-devel
37BuildRequires: krb5-devel
38BuildRequires: ncurses-devel
39BuildRequires: openldap-devel >= 2.4.6
40BuildRequires: openssl-devel
41BuildRequires: pam-devel
42# Only for web-frontend:
43#BuildRequires: tcl-devel
44Obsoletes: pine
45Provides: pine = 5.00
46Suggests: aspell
47BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49%define alpineconfdir /etc/%{name}
50%define filterout_ld -Wl,--as-needed
51
52%description
53Alpine -- an Alternatively Licensed Program for Internet News & Email
54-- is a tool for reading, sending, and managing electronic messages.
55Alpine is the successor to Pine and was developed by Computing &
56Communications at the University of Washington. Though originally
57designed for inexperienced email users, Alpine supports many advanced
58features, and an ever-growing number of configuration and
59personal-preference options.
60
61%description -l pl.UTF-8
62Alpine, czyli Alternatively Licensed Program for Internet News & Email
63(alternatywnie licencjonowany program do newsów i poczty internetowej)
64to narzędzie do czytania, wysyłania i zarządzania wiadomościami
65elektronicznymi. Alpine jest następcą Pine'a i został napisany przez
66wydział Computing & Communications (Obliczeń i komunikacji) na
67Uniwersytecie w Waszyngtonie. Mimo że Alpine pierwotnie został
68zaprojektowany dla niedoświadczonych użytkowników poczty, obsługuje
69wiele zaawansowanych możliwości, a liczba opcji konfiguracyjnych
70ciągle rośnie.
71
72%package -n pico
73Summary: Simple text editor in the style of the Pine Composer
74Summary(pl.UTF-8): Prosty edytor tekstowy w stylu alpine
75Summary(pt_BR.UTF-8): Editor de textos para terminal simples e fácil de usar
76Group: Applications/Editors
77Provides: pico = 5.00
78
79%description -n pico
80Pico is a simple, display-oriented text editor based on the Alpine
81message system composer. As with Pine, commands are displayed at the
82bottom of the screen, and context-sensitive help is provided. As
83characters are typed they are immediately inserted into the text.
84
85%description -n pico -l pl.UTF-8
86Pico jest prostym, zorientowanym na wyświetlanie edytorem bazującym na
87alpine. Tak jak w pine komendy są wyświetlane na dole ekranu oraz
88dostępna jest pomoc kontekstowa. Wpisywane znaki są natychmiast
89włączane do tekstu.
90
91%description -n pico -l pt_BR.UTF-8
92Pico é um editor de texto baseado no compositor de mensagens do Alpine.
93Assim como no Pine, comandos são mostrados na parte de baixo da tela,
94e ajuda de acordo com o contexto está disponível.
95
96%package -n pilot
97Summary: Simple file system browser in the style of the Alpine Composer
98Summary(pl.UTF-8): Prosta przeglądarka plików w stylu composera alpine
99Summary(pt_BR.UTF-8): Navegador de sistemas de arquivos no estilo do compositor do Alpine
100Group: Applications/Shells
101Provides: pilot = 5.00
102
103%description -n pilot
104Pilot is a simple, display-oriented file system browser based on the
105Alpine message system composer. As with Alpine, commands are displayed
106at the bottom of the screen, and context-sensitive help is provided.
107
108%description -n pilot -l pl.UTF-8
109Pilot jest prostą, zorientowaną na wyświetlanie przeglądarką plików w
110stylu composera pine. Podobnie jak w alpine polecenia są wyświetlane
111na dole ekranu oraz jest dostępna pomoc kontekstowa.
112
113%description -n pilot -l pt_BR.UTF-8
114Pilot é um navegador de sistemas de arquivos baseado no Pine. Assim
115como no Pine, comandos são apresentados na parte de baixo da tela, e
116ajuda de acordo com o contexto está disponível.
117
118%prep
119%setup -q -n %{name}-%{ver}
120%patch0 -p1
121%patch1 -p1
122%patch2 -p1
123%patch3 -p1
124%patch4 -p1
125%patch5 -p1
126%patch6 -p1
127%patch7 -p1
128%patch8 -p1
129%patch9 -p1
130
131%build
132rm -f libtool missing
133%{__libtoolize}
134%{__aclocal} -I m4
135%{__autoconf}
136%{__autoheader}
137%{__automake}
138%configure \
139 --enable-quotas \
140 --without-tcl \
141 --with-smtp-msa=%{_libdir}/sendmail \
142 --with-simple-spellcheck=aspell \
143 --with-system-pinerc=%{alpineconfdir}/%{name}.conf \
144 --with-system-fixed-pinerc=%{alpineconfdir}/%{name}.conf.fixed \
145 --with-krb5-dir=%{_prefix} \
146 --with-ldap-dir=%{_prefix} \
147 --with-system-mail-directory=/var/mail \
148 --with-c-client-target=slx \
149 --with-ssl-dir=/var/lib/openssl/certs \
150 --with-ssl-certs-dir=/var/lib/openssl/certs \
151 --with-passfile=.pine.pwd
152
153%{__make} \
154 GCCOPTLEVEL="%{rpmcflags}"
155
156%install
157rm -rf $RPM_BUILD_ROOT
158install -d $RPM_BUILD_ROOT{%{alpineconfdir},%{_desktopdir},%{_pixmapsdir}}
159
160%{__make} install \
161 DESTDIR=$RPM_BUILD_ROOT
162
163install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
164install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
165install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
166
167ln -s alpine $RPM_BUILD_ROOT%{_bindir}/pine
168
169$RPM_BUILD_ROOT%{_bindir}/alpine -conf > $RPM_BUILD_ROOT%{alpineconfdir}/alpine.conf
170cat <<EOF > $RPM_BUILD_ROOT%{alpineconfdir}/alpine.conf.fixed
171#
172# Alpine system-wide enforced configuration file - customize as needed
173#
174# This file holds the system-wide enforced values for alpine configuration
175# settings. Any values set in it will override values set in the
176# system-wide default configuration file (%{alpineconfdir}/alpine.conf) and
177# the user's own configuration file (~/.pinerc).
178# For more information on the format of this file, read the
179# comments at the top of %{alpineconfdir}/alpine.conf
180
181EOF
182
183%post
184if [ -f "%{alpineconfdir}/alpine.conf" -a -f "%{alpineconfdir}/alpine.conf.rpmnew" ]; then
185 mv %{alpineconfdir}/alpine.conf %{alpineconfdir}/alpine.conf.backup
186 alpine -P %{alpineconfdir}/alpine.conf.backup -conf > /etc/alpine/alpine.conf || exit 0
187fi
188
189%clean
190rm -rf $RPM_BUILD_ROOT
191
192%files
193%defattr(644,root,root,755)
194%doc README doc/tech-notes.txt
195%dir %{alpineconfdir}
196%config(noreplace) %verify(not md5 mtime size) %{alpineconfdir}/alpine.conf
197%config(noreplace) %verify(not md5 mtime size) %{alpineconfdir}/alpine.conf.fixed
198%attr(755,root,root) %{_bindir}/%{name}
199%attr(755,root,root) %{_bindir}/pine
200%attr(755,root,root) %{_bindir}/rpload
201%attr(755,root,root) %{_bindir}/rpdump
202%{_mandir}/man1/%{name}.1*
203%{_mandir}/man1/rpload.1*
204%{_mandir}/man1/rpdump.1*
205%{_desktopdir}/%{name}.desktop
206%{_pixmapsdir}/%{name}.png
207
208%files -n pico
209%defattr(644,root,root,755)
210%attr(755,root,root) %{_bindir}/pico
211%{_desktopdir}/pico.desktop
212%{_mandir}/man1/pico*
213
214%files -n pilot
215%defattr(644,root,root,755)
216%attr(755,root,root) %{_bindir}/pilot
217%{_mandir}/man1/pilot*
This page took 0.083426 seconds and 4 git commands to generate.