]> git.pld-linux.org Git - packages/alpine.git/blame_incremental - alpine.spec
- CVE refs too
[packages/alpine.git] / alpine.spec
... / ...
CommitLineData
1# TODO:
2# - backport man-pages from pine.spec
3# - separate package with tcl web-frontend
4# - fix as-needed
5%define ver 2.00
6%define patchlevel 13
7Summary: University of Washington Alpine mail user agent
8Summary(pl.UTF-8): Klient pocztowy Alpine z Uniwersytetu w Waszyngtonie
9Name: alpine
10Version: %{ver}.%{patchlevel}
11Release: 1
12Epoch: 1
13License: Apache v2.0
14Group: Applications/Mail
15# Main site:
16#Source0: ftp://ftp.cac.washington.edu/alpine/%{name}-%{version}.tar.gz
17# Source with applied patches from http://staff.washington.edu/chappa/alpine/
18Source0: http://staff.washington.edu/chappa/alpine/patches/alpine-%{ver}/%{name}-%{ver}_%{patchlevel}.tar.gz
19# Source0-md5: e78fb53acaa23a6fc09ab6d848edc72b
20Source1: pico.desktop
21Source2: %{name}.desktop
22Source3: %{name}.png
23Patch0: %{name}-index_display.patch
24Patch1: %{name}-doc.patch
25Patch2: %{name}-filter.patch
26Patch3: %{name}-fhs.patch
27Patch4: %{name}-libc-client.patch
28Patch5: %{name}-ssl.patch
29Patch6: %{name}-no_1777_warning.patch
30Patch7: %{name}-home_etc.patch
31URL: http://www.washington.edu/alpine/
32BuildRequires: autoconf
33BuildRequires: automake
34BuildRequires: home-etc-devel
35BuildRequires: krb5-devel
36BuildRequires: ncurses-devel
37BuildRequires: openldap-devel >= 2.4.6
38BuildRequires: openssl-devel
39BuildRequires: pam-devel
40# Only for web-frontend:
41#BuildRequires: tcl-devel
42Suggests: aspell
43Provides: pine = 6.00
44Obsoletes: pine
45BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47%define alpineconfdir %{_sysconfdir}/%{name}
48%define filterout_ld -Wl,--as-needed
49
50%description
51Alpine -- an Alternatively Licensed Program for Internet News & Email
52-- is a tool for reading, sending, and managing electronic messages.
53Alpine is the successor to Pine and was developed by Computing &
54Communications at the University of Washington. Though originally
55designed for inexperienced email users, Alpine supports many advanced
56features, and an ever-growing number of configuration and
57personal-preference options.
58
59%description -l pl.UTF-8
60Alpine, czyli Alternatively Licensed Program for Internet News & Email
61(alternatywnie licencjonowany program do newsów i poczty internetowej)
62to narzędzie do czytania, wysyłania i zarządzania wiadomościami
63elektronicznymi. Alpine jest następcą Pine'a i został napisany przez
64wydział Computing & Communications (Obliczeń i komunikacji) na
65Uniwersytecie w Waszyngtonie. Mimo że Alpine pierwotnie został
66zaprojektowany dla niedoświadczonych użytkowników poczty, obsługuje
67wiele zaawansowanych możliwości, a liczba opcji konfiguracyjnych
68ciągle rośnie.
69
70%package -n pico
71Summary: Simple text editor in the style of the Pine Composer
72Summary(pl.UTF-8): Prosty edytor tekstowy w stylu alpine
73Summary(pt_BR.UTF-8): Editor de textos para terminal simples e fácil de usar
74Group: Applications/Editors
75Provides: pico = 6.00
76
77%description -n pico
78Pico is a simple, display-oriented text editor based on the Alpine
79message system composer. As with Pine, commands are displayed at the
80bottom of the screen, and context-sensitive help is provided. As
81characters are typed they are immediately inserted into the text.
82
83%description -n pico -l pl.UTF-8
84Pico jest prostym, zorientowanym na wyświetlanie edytorem bazującym na
85alpine. Tak jak w pine komendy są wyświetlane na dole ekranu oraz
86dostępna jest pomoc kontekstowa. Wpisywane znaki są natychmiast
87włączane do tekstu.
88
89%description -n pico -l pt_BR.UTF-8
90Pico é um editor de texto baseado no compositor de mensagens do Alpine.
91Assim como no Pine, comandos são mostrados na parte de baixo da tela,
92e ajuda de acordo com o contexto está disponível.
93
94%package -n pilot
95Summary: Simple file system browser in the style of the Alpine Composer
96Summary(pl.UTF-8): Prosta przeglądarka plików w stylu composera alpine
97Summary(pt_BR.UTF-8): Navegador de sistemas de arquivos no estilo do compositor do Alpine
98Group: Applications/Shells
99Provides: pilot = 6.00
100
101%description -n pilot
102Pilot is a simple, display-oriented file system browser based on the
103Alpine message system composer. As with Alpine, commands are displayed
104at the bottom of the screen, and context-sensitive help is provided.
105
106%description -n pilot -l pl.UTF-8
107Pilot jest prostą, zorientowaną na wyświetlanie przeglądarką plików w
108stylu composera pine. Podobnie jak w alpine polecenia są wyświetlane
109na dole ekranu oraz jest dostępna pomoc kontekstowa.
110
111%description -n pilot -l pt_BR.UTF-8
112Pilot é um navegador de sistemas de arquivos baseado no Pine. Assim
113como no Pine, comandos são apresentados na parte de baixo da tela, e
114ajuda de acordo com o contexto está disponível.
115
116%prep
117%setup -q -n %{name}-%{ver}
118%patch0 -p1
119%patch1 -p1
120%patch2 -p1
121%patch3 -p1
122%patch4 -p1
123%patch5 -p1
124%patch6 -p1
125%patch7 -p1
126
127%build
128rm -f libtool missing
129%{__libtoolize}
130%{__aclocal} -I m4
131%{__autoconf}
132%{__autoheader}
133%{__automake}
134%configure \
135 --%{?debug:en}%{!?debug:dis}able-debug \
136 --enable-quotas \
137 --without-tcl \
138 --with-smtp-msa=%{_libdir}/sendmail \
139 --with-simple-spellcheck=aspell \
140 --with-system-pinerc=%{_sysconfdir}/%{name}/%{name}.conf \
141 --with-system-fixed-pinerc=%{_sysconfdir}/%{name}/%{name}.conf.fixed \
142 --with-krb5-dir=%{_prefix} \
143 --with-ldap-dir=%{_prefix} \
144 --with-system-mail-directory=/var/mail \
145 --with-c-client-target=slx \
146 --with-ssl-dir=/var/lib/openssl/certs \
147 --with-ssl-certs-dir=/var/lib/openssl/certs \
148 --with-passfile=.pine.pwd
149
150%{__make} \
151 GCCOPTLEVEL="%{rpmcflags}"
152
153%install
154rm -rf $RPM_BUILD_ROOT
155install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_desktopdir},%{_pixmapsdir}}
156
157%{__make} install \
158 DESTDIR=$RPM_BUILD_ROOT
159
160install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
161install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
162install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
163
164ln -s alpine $RPM_BUILD_ROOT%{_bindir}/pine
165
166$RPM_BUILD_ROOT%{_bindir}/alpine -conf > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/alpine.conf
167cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/alpine.conf.fixed
168#
169# Alpine system-wide enforced configuration file - customize as needed
170#
171# This file holds the system-wide enforced values for alpine configuration
172# settings. Any values set in it will override values set in the
173# system-wide default configuration file (%{_sysconfdir}/%{name}/alpine.conf) and
174# the user's own configuration file (~/.pinerc).
175# For more information on the format of this file, read the
176# comments at the top of %{_sysconfdir}/%{name}/alpine.conf
177
178EOF
179
180%clean
181rm -rf $RPM_BUILD_ROOT
182
183%files
184%defattr(644,root,root,755)
185%doc README doc/tech-notes.txt
186%dir %{_sysconfdir}/%{name}
187%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/alpine.conf
188%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/alpine.conf.fixed
189%attr(755,root,root) %{_bindir}/%{name}
190%attr(755,root,root) %{_bindir}/pine
191%attr(755,root,root) %{_bindir}/rpload
192%attr(755,root,root) %{_bindir}/rpdump
193%{_mandir}/man1/%{name}.1*
194%{_mandir}/man1/rpload.1*
195%{_mandir}/man1/rpdump.1*
196%{_desktopdir}/%{name}.desktop
197%{_pixmapsdir}/%{name}.png
198
199%files -n pico
200%defattr(644,root,root,755)
201%attr(755,root,root) %{_bindir}/pico
202%{_desktopdir}/pico.desktop
203%{_mandir}/man1/pico*
204
205%files -n pilot
206%defattr(644,root,root,755)
207%attr(755,root,root) %{_bindir}/pilot
208%{_mandir}/man1/pilot*
This page took 0.082828 seconds and 4 git commands to generate.