]> git.pld-linux.org Git - packages/alpine.git/blame_incremental - alpine.spec
- rel 3
[packages/alpine.git] / alpine.spec
... / ...
CommitLineData
1# TODO:
2#- backport man-pages from pine.spec
3#- separate package with tcl web-frontend
4#- fix as-needed
5%define ver 2.00
6%define patchlevel 53
7Summary: University of Washington Alpine mail user agent
8Summary(pl.UTF-8): Klient pocztowy Alpine z Uniwersytetu w Waszyngtonie
9Name: alpine
10Version: %{ver}.%{patchlevel}
11Release: 3
12Epoch: 1
13License: Apache v2.0
14Group: Applications/Mail
15# Main site:
16#Source0: ftp://ftp.cac.washington.edu/alpine/%{name}-%{version}.tar.gz
17# Source with applied patches from http://staff.washington.edu/chappa/alpine/
18Source0: http://staff.washington.edu/chappa/alpine/patches/alpine-%{ver}/%{name}-%{ver}_%{patchlevel}.tar.gz
19# Source0-md5: 69b1f9cc9c4e06d31a44b0e6bf10283e
20Source1: pico.desktop
21Source2: %{name}.desktop
22Source3: %{name}.png
23Patch0: %{name}-index_display.patch
24Patch1: %{name}-doc.patch
25Patch2: %{name}-filter.patch
26Patch3: %{name}-fhs.patch
27Patch4: %{name}-libc-client.patch
28Patch5: %{name}-ssl.patch
29Patch6: %{name}-no_1777_warning.patch
30Patch7: %{name}-home_etc.patch
31URL: http://www.washington.edu/alpine/
32BuildRequires: autoconf
33BuildRequires: automake
34BuildRequires: home-etc-devel
35%if "%{pld_release}" != "ac"
36BuildRequires: heimdal-devel
37%endif
38BuildRequires: libtool
39BuildRequires: ncurses-devel
40BuildRequires: openldap-devel
41BuildRequires: openssl-devel
42BuildRequires: pam-devel
43# Only for web-frontend:
44#BuildRequires: tcl-devel
45Suggests: aspell
46Suggests: ca-certificates
47Conflicts: ca-certificates < 20080809-4
48Provides: pine = 6.00
49Obsoletes: pine
50BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52%define alpineconfdir %{_sysconfdir}/%{name}
53%define filterout_ld -Wl,--as-needed
54
55%description
56Alpine -- an Alternatively Licensed Program for Internet News & Email
57-- is a tool for reading, sending, and managing electronic messages.
58Alpine is the successor to Pine and was developed by Computing &
59Communications at the University of Washington. Though originally
60designed for inexperienced email users, Alpine supports many advanced
61features, and an ever-growing number of configuration and
62personal-preference options.
63
64%description -l pl.UTF-8
65Alpine, czyli Alternatively Licensed Program for Internet News & Email
66(alternatywnie licencjonowany program do newsów i poczty internetowej)
67to narzędzie do czytania, wysyłania i zarządzania wiadomościami
68elektronicznymi. Alpine jest następcą Pine'a i został napisany przez
69wydział Computing & Communications (Obliczeń i komunikacji) na
70Uniwersytecie w Waszyngtonie. Mimo że Alpine pierwotnie został
71zaprojektowany dla niedoświadczonych użytkowników poczty, obsługuje
72wiele zaawansowanych możliwości, a liczba opcji konfiguracyjnych
73ciągle rośnie.
74
75%package -n pico
76Summary: Simple text editor in the style of the Pine Composer
77Summary(pl.UTF-8): Prosty edytor tekstowy w stylu alpine
78Summary(pt_BR.UTF-8): Editor de textos para terminal simples e fácil de usar
79Group: Applications/Editors
80Provides: pico = 6.00
81
82%description -n pico
83Pico is a simple, display-oriented text editor based on the Alpine
84message system composer. As with Pine, commands are displayed at the
85bottom of the screen, and context-sensitive help is provided. As
86characters are typed they are immediately inserted into the text.
87
88%description -n pico -l pl.UTF-8
89Pico jest prostym, zorientowanym na wyświetlanie edytorem bazującym na
90alpine. Tak jak w pine komendy są wyświetlane na dole ekranu oraz
91dostępna jest pomoc kontekstowa. Wpisywane znaki są natychmiast
92włączane do tekstu.
93
94%description -n pico -l pt_BR.UTF-8
95Pico é um editor de texto baseado no compositor de mensagens do Alpine.
96Assim como no Pine, comandos são mostrados na parte de baixo da tela,
97e ajuda de acordo com o contexto está disponível.
98
99%package -n pilot
100Summary: Simple file system browser in the style of the Alpine Composer
101Summary(pl.UTF-8): Prosta przeglądarka plików w stylu composera alpine
102Summary(pt_BR.UTF-8): Navegador de sistemas de arquivos no estilo do compositor do Alpine
103Group: Applications/Shells
104Provides: pilot = 6.00
105
106%description -n pilot
107Pilot is a simple, display-oriented file system browser based on the
108Alpine message system composer. As with Alpine, commands are displayed
109at the bottom of the screen, and context-sensitive help is provided.
110
111%description -n pilot -l pl.UTF-8
112Pilot jest prostą, zorientowaną na wyświetlanie przeglądarką plików w
113stylu composera pine. Podobnie jak w alpine polecenia są wyświetlane
114na dole ekranu oraz jest dostępna pomoc kontekstowa.
115
116%description -n pilot -l pt_BR.UTF-8
117Pilot é um navegador de sistemas de arquivos baseado no Pine. Assim
118como no Pine, comandos são apresentados na parte de baixo da tela, e
119ajuda de acordo com o contexto está disponível.
120
121%prep
122%setup -q -n %{name}-%{ver}
123%patch0 -p1
124%patch1 -p1
125%patch2 -p1
126%patch3 -p1
127%patch4 -p1
128%patch5 -p1
129%patch6 -p1
130%patch7 -p1
131
132%build
133rm -f libtool missing
134%{__libtoolize}
135%{__aclocal} -I m4
136%{__autoconf}
137%{__autoheader}
138%{__automake}
139%configure \
140 --%{?debug:en}%{!?debug:dis}able-debug \
141 --enable-quotas \
142 --without-tcl \
143 --with-smtp-msa=/usr/lib/sendmail \
144 --with-simple-spellcheck=aspell \
145 --with-system-pinerc=%{_sysconfdir}/%{name}/%{name}.conf \
146 --with-system-fixed-pinerc=%{_sysconfdir}/%{name}/%{name}.conf.fixed \
147 --with-krb5-dir=%{_prefix} \
148 --with-ldap-dir=%{_prefix} \
149 --with-system-mail-directory=/var/mail \
150 --with-c-client-target=slx \
151%if "%{pld_release}" == "ti"
152 --with-ssl-dir=/var/lib/openssl/certs \
153 --with-ssl-certs-dir=/var/lib/openssl/certs \
154%else
155 --with-ssl-dir=/etc/openssl/certs \
156 --with-ssl-certs-dir=/etc/certs \
157%endif
158 --with-passfile=.pine.pwd
159
160%{__make} \
161 GCCOPTLEVEL="%{rpmcflags}"
162
163%install
164rm -rf $RPM_BUILD_ROOT
165install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_desktopdir},%{_pixmapsdir}}
166
167%{__make} install \
168 DESTDIR=$RPM_BUILD_ROOT
169
170install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
171install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
172install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
173
174ln -s alpine $RPM_BUILD_ROOT%{_bindir}/pine
175
176$RPM_BUILD_ROOT%{_bindir}/alpine -conf > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/alpine.conf
177cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/alpine.conf.fixed
178#
179# Alpine system-wide enforced configuration file - customize as needed
180#
181# This file holds the system-wide enforced values for alpine configuration
182# settings. Any values set in it will override values set in the
183# system-wide default configuration file (%{_sysconfdir}/%{name}/alpine.conf) and
184# the user's own configuration file (~/.pinerc).
185# For more information on the format of this file, read the
186# comments at the top of %{_sysconfdir}/%{name}/alpine.conf
187
188EOF
189
190%clean
191rm -rf $RPM_BUILD_ROOT
192
193%files
194%defattr(644,root,root,755)
195%doc README doc/tech-notes.txt
196%dir %{_sysconfdir}/%{name}
197%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/alpine.conf
198%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/alpine.conf.fixed
199%attr(755,root,root) %{_bindir}/%{name}
200%attr(755,root,root) %{_bindir}/pine
201%attr(755,root,root) %{_bindir}/rpload
202%attr(755,root,root) %{_bindir}/rpdump
203%{_mandir}/man1/%{name}.1*
204%{_mandir}/man1/rpload.1*
205%{_mandir}/man1/rpdump.1*
206%{_desktopdir}/%{name}.desktop
207%{_pixmapsdir}/%{name}.png
208
209%files -n pico
210%defattr(644,root,root,755)
211%attr(755,root,root) %{_bindir}/pico
212%{_desktopdir}/pico.desktop
213%{_mandir}/man1/pico*
214
215%files -n pilot
216%defattr(644,root,root,755)
217%attr(755,root,root) %{_bindir}/pilot
218%{_mandir}/man1/pilot*
This page took 0.023155 seconds and 4 git commands to generate.