]> git.pld-linux.org Git - packages/alpine.git/blame_incremental - alpine.spec
- patchlevel 7
[packages/alpine.git] / alpine.spec
... / ...
CommitLineData
1# TODO:
2# - backport man-pages from pine.spec
3# - separate package with tcl web-frontend
4# - fix as-needed
5Summary: University of Washington Pine mail user agent
6Summary(pl.UTF-8): Klient pocztowy Pine z Uniwersytetu w Waszyngtonie
7Name: alpine
8%define ver 0.99999
9%define patchlevel 7
10Version: %{ver}.%{patchlevel}
11Release: 1
12Epoch: 1
13License: Apache License 2.0
14Group: Applications/Mail
15# Main site:
16#Source0: ftp://ftp.cac.washington.edu/alpine/%{name}-%{version}.tar.gz
17# Source with applied patches from http://staff.washington.edu/chappa/alpine/
18Source0: http://staff.washington.edu/chappa/alpine/patches/alpine-%{ver}/%{name}-%{ver}_%{patchlevel}.tar.gz
19# Source0-md5: ac3f0bf23bd2f675c76a4e26e9db161b
20Source1: pico.desktop
21Source2: %{name}.desktop
22Source3: %{name}.png
23Patch0: %{name}-index_display.patch
24Patch1: %{name}-doc.patch
25Patch2: %{name}-filter.patch
26Patch3: %{name}-quote.patch
27Patch4: %{name}-fhs.patch
28Patch5: %{name}-segfix.patch
29Patch6: %{name}-libc-client.patch
30Patch7: %{name}-fixhome.patch
31Patch8: %{name}-ssl.patch
32Patch9: %{name}-no_1777_warning.patch
33Patch10: %{name}-home_etc.patch
34URL: http://www.washington.edu/alpine/
35BuildRequires: autoconf
36BuildRequires: automake
37BuildRequires: home-etc-devel
38BuildRequires: krb5-devel
39BuildRequires: ncurses-devel
40BuildRequires: openldap-devel >= 2.4.6
41BuildRequires: openssl-devel
42BuildRequires: pam-devel
43# Only for web-frontend:
44#BuildRequires: tcl-devel
45Obsoletes: pine
46Provides: pine = 4.98
47BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49%define alpineconfdir /etc/%{name}
50%define filterout_ld -Wl,--as-needed
51
52%description
53Alpine -- an Alternatively Licensed Program for Internet News & Email
54-- is a tool for reading, sending, and managing electronic messages.
55Alpine is the successor to Pine and was developed by Computing &
56Communications at the University of Washington. Though originally
57designed for inexperienced email users, Alpine supports many advanced
58features, and an ever-growing number of configuration and
59personal-preference options.
60
61%description -l pl.UTF-8
62Alpine, czyli Alternatively Licensed Program for Internet News & Email
63(alternatywnie licencjonowany program do newsów i poczty internetowej)
64to narzędzie do czytania, wysyłania i zarządzania wiadomościami
65elektronicznymi. Alpine jest następcą Pine'a i został napisany przez
66wydział Computing & Communications (Obliczeń i komunikacji) na
67Uniwersytecie w Waszyngtonie. Mimo że Alpine pierwotnie został
68zaprojektowany dla niedoświadczonych użytkowników poczty, obsługuje
69wiele zaawansowanych możliwości, a liczba opcji konfiguracyjnych
70ciągle rośnie.
71
72%package -n pico
73Summary: Simple text editor in the style of the Pine Composer
74Summary(pl.UTF-8): Prosty edytor tekstowy w stylu alpine
75Summary(pt_BR.UTF-8): Editor de textos para terminal simples e fácil de usar
76Group: Applications/Editors
77
78%description -n pico
79Pico is a simple, display-oriented text editor based on the Alpine
80message system composer. As with Pine, commands are displayed at the
81bottom of the screen, and context-sensitive help is provided. As
82characters are typed they are immediately inserted into the text.
83
84%description -n pico -l pl.UTF-8
85Pico jest prostym, zorientowanym na wyświetlanie edytorem bazującym na
86alpine. Tak jak w pine komendy są wyświetlane na dole ekranu oraz
87dostępna jest pomoc konteksowa. Wpisywane znaki są natychmiast
88włączane do tekstu.
89
90%description -n pico -l pt_BR.UTF-8
91Pico é um editor de texto baseado no compositor de mensagens do Alpine.
92Assim como no Pine, comandos são mostrados na parte de baixo da tela,
93e ajuda de acordo com o contexto está disponível.
94
95%package -n pilot
96Summary: Simple file system browser in the style of the Alpine Composer
97Summary(pl.UTF-8): Prosta przeglądarka plików w stylu composera alpine
98Summary(pt_BR.UTF-8): Navegador de sistemas de arquivos no estilo do compositor do Alpine
99Group: Applications/Shells
100
101%description -n pilot
102Pilot is a simple, display-oriented file system browser based on the
103Alpine message system composer. As with Alpine, commands are displayed at
104the bottom of the screen, and context-sensitive help is provided.
105
106%description -n pilot -l pl.UTF-8
107Pilot jest prostą, zorientowaną na wyświetlanie przeglądarką plików w
108stylu compsera pine. Podobnie jak w alpine polecenia sa wyświetlane na
109dole ekranu oraz jest dostępna pomoc kontekstowa.
110
111%description -n pilot -l pt_BR.UTF-8
112Pilot é um navegador de sistemas de arquivos baseado no Pine. Assim
113como no Pine, comandos são apresentados na parte de baixo da tela, e
114ajuda de acordo com o contexto está disponível.
115
116%prep
117%setup -q -n %{name}-%{ver}
118%patch0 -p1
119%patch1 -p1
120%patch2 -p1
121%patch3 -p1
122%patch4 -p1
123%patch5 -p1
124%patch6 -p1
125%patch7 -p1
126%patch8 -p1
127%patch9 -p1
128%patch10 -p1
129
130%build
131rm -f libtool missing
132%{__libtoolize}
133%{__aclocal} -I m4
134%{__autoconf}
135%{__autoheader}
136%{__automake}
137%configure \
138 --enable-quotas \
139 --without-tcl \
140 --with-smtp-msa=%{_libdir}/sendmail \
141 --with-spellcheck-prog=aspell \
142 --with-system-pinerc=%{alpineconfdir}/%{name}.conf \
143 --with-system-fixed-pinerc=%{alpineconfdir}/%{name}.conf.fixed \
144 --with-krb5-dir=%{_prefix} \
145 --with-ldap-dir=%{_prefix} \
146 --with-system-mail-directory=/var/mail \
147 --with-passfile=.pine.pwd
148
149%{__make} \
150 GCCOPTLEVEL="%{rpmcflags}"
151
152%install
153rm -rf $RPM_BUILD_ROOT
154install -d $RPM_BUILD_ROOT{%{alpineconfdir},%{_desktopdir},%{_pixmapsdir}}
155
156%{__make} install \
157 DESTDIR=$RPM_BUILD_ROOT
158
159install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
160install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
161install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
162
163ln -s alpine $RPM_BUILD_ROOT%{_bindir}/pine
164
165$RPM_BUILD_ROOT%{_bindir}/alpine -conf > $RPM_BUILD_ROOT%{alpineconfdir}/alpine.conf
166cat <<EOF > $RPM_BUILD_ROOT%{alpineconfdir}/alpine.conf.fixed
167#
168# Alpine system-wide enforced configuration file - customize as needed
169#
170# This file holds the system-wide enforced values for alpine configuration
171# settings. Any values set in it will override values set in the
172# system-wide default configuration file (%{alpineconfdir}/alpine.conf) and
173# the user's own configuration file (~/.pinerc).
174# For more information on the format of this file, read the
175# comments at the top of %{alpineconfdir}/alpine.conf
176
177EOF
178
179%clean
180rm -rf $RPM_BUILD_ROOT
181
182%files
183%defattr(644,root,root,755)
184%doc README doc/tech-notes.txt
185%dir %{alpineconfdir}
186%config(noreplace) %verify(not md5 mtime size) %{alpineconfdir}/alpine.conf
187%config(noreplace) %verify(not md5 mtime size) %{alpineconfdir}/alpine.conf.fixed
188%attr(755,root,root) %{_bindir}/%{name}
189%attr(755,root,root) %{_bindir}/pine
190%attr(755,root,root) %{_bindir}/rpload
191%attr(755,root,root) %{_bindir}/rpdump
192%{_mandir}/man1/%{name}.1*
193%{_mandir}/man1/rpload.1*
194%{_mandir}/man1/rpdump.1*
195%{_desktopdir}/%{name}.desktop
196%{_pixmapsdir}/%{name}.png
197
198%files -n pico
199%defattr(644,root,root,755)
200%attr(755,root,root) %{_bindir}/pico
201%{_desktopdir}/pico.desktop
202%{_mandir}/man1/pico*
203
204%files -n pilot
205%defattr(644,root,root,755)
206%attr(755,root,root) %{_bindir}/pilot
207%{_mandir}/man1/pilot*
This page took 0.031802 seconds and 4 git commands to generate.