]> git.pld-linux.org Git - packages/alpine.git/blame_incremental - alpine.spec
- patchlevel 59 - fixes memleak
[packages/alpine.git] / alpine.spec
... / ...
CommitLineData
1# TODO:
2# - backport man-pages from pine.spec
3# - alpine should obsolete pine, link pine -> alpine should be made
4# - review patches from pine:
5# - home_etc support
6# - ....many more
7# - separate package with tcl web-frontend
8Summary: University of Washington Pine mail user agent
9Summary(pl.UTF-8): Klient pocztowy Pine z Uniwersytetu w Waszyngtonie
10Name: alpine
11%define ver 0.9999
12%define patchlevel 59
13Version: %{ver}.%{patchlevel}
14Release: 1
15Epoch: 1
16License: Apache License 2.0
17Group: Applications/Mail
18# Main site:
19#Source0: ftp://ftp.cac.washington.edu/alpine/%{name}-%{version}.tar.gz
20# Source with applied patches from http://staff.washington.edu/chappa/alpine/
21Source0: http://staff.washington.edu/chappa/alpine/patches/alpine-%{ver}/%{name}-%{ver}_%{patchlevel}.tar.gz
22# Source0-md5: f61491228f34e1cfb56f2dc9f1265694
23Source1: pico.desktop
24Source2: %{name}.desktop
25Source3: %{name}.png
26Patch0: %{name}-thread_end.patch
27Patch1: %{name}-index_display.patch
28URL: http://www.washington.edu/alpine/
29BuildRequires: autoconf
30BuildRequires: automake
31BuildRequires: krb5-devel
32BuildRequires: ncurses-devel
33BuildRequires: openldap-devel
34BuildRequires: openssl-devel
35BuildRequires: pam-devel
36# Only for web-frontend:
37#BuildRequires: tcl-devel
38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40%define alpineconfdir /etc/%{name}
41
42%description
43Alpine -- an Alternatively Licensed Program for Internet News & Email
44-- is a tool for reading, sending, and managing electronic messages.
45Alpine is the successor to Pine and was developed by Computing &
46Communications at the University of Washington. Though originally
47designed for inexperienced email users, Alpine supports many advanced
48features, and an ever-growing number of configuration and
49personal-preference options.
50
51%description -l pl.UTF-8
52Alpine, czyli Alternatively Licensed Program for Internet News & Email
53(alternatywnie licencjonowany program do newsów i poczty internetowej)
54to narzędzie do czytania, wysyłania i zarządzania wiadomościami
55elektronicznymi. Alpine jest następcą Pine'a i został napisany przez
56wydział Computing & Communications (Obliczeń i komunikacji) na
57Uniwersytecie w Waszyngtonie. Mimo że Alpine pierwotnie został
58zaprojektowany dla niedoświadczonych użytkowników poczty, obsługuje
59wiele zaawansowanych możliwości, a liczba opcji konfiguracyjnych
60ciągle rośnie.
61
62%package -n pico
63Summary: Simple text editor in the style of the Pine Composer
64Summary(pl.UTF-8): Prosty edytor tekstowy w stylu alpine
65Summary(pt_BR.UTF-8): Editor de textos para terminal simples e fácil de usar
66Group: Applications/Editors
67
68%description -n pico
69Pico is a simple, display-oriented text editor based on the Alpine
70message system composer. As with Pine, commands are displayed at the
71bottom of the screen, and context-sensitive help is provided. As
72characters are typed they are immediately inserted into the text.
73
74%description -n pico -l pl.UTF-8
75Pico jest prostym, zorientowanym na wyświetlanie edytorem bazującym na
76alpine. Tak jak w pine komendy są wyświetlane na dole ekranu oraz
77dostępna jest pomoc konteksowa. Wpisywane znaki są natychmiast
78włączane do tekstu.
79
80%description -n pico -l pt_BR.UTF-8
81Pico é um editor de texto baseado no compositor de mensagens do Alpine.
82Assim como no Pine, comandos são mostrados na parte de baixo da tela,
83e ajuda de acordo com o contexto está disponível.
84
85%package -n pilot
86Summary: Simple file system browser in the style of the Alpine Composer
87Summary(pl.UTF-8): Prosta przeglądarka plików w stylu composera alpine
88Summary(pt_BR.UTF-8): Navegador de sistemas de arquivos no estilo do compositor do Alpine
89Group: Applications/Shells
90
91%description -n pilot
92Pilot is a simple, display-oriented file system browser based on the
93Alpine message system composer. As with Alpine, commands are displayed at
94the bottom of the screen, and context-sensitive help is provided.
95
96%description -n pilot -l pl.UTF-8
97Pilot jest prostą, zorientowaną na wyświetlanie przeglądarką plików w
98stylu compsera pine. Podobnie jak w alpine polecenia sa wyświetlane na
99dole ekranu oraz jest dostępna pomoc kontekstowa.
100
101%description -n pilot -l pt_BR.UTF-8
102Pilot é um navegador de sistemas de arquivos baseado no Pine. Assim
103como no Pine, comandos são apresentados na parte de baixo da tela, e
104ajuda de acordo com o contexto está disponível.
105
106%prep
107%setup -q -n %{name}-%{ver}
108%patch0 -p1
109%patch1 -p1
110
111%build
112%{__autoconf}
113%{__aclocal} -I m4
114%{__automake}
115%configure \
116 --enable-quotas \
117 --without-tcl \
118 --with-smtp-msa=%{_libdir}/sendmail \
119 --with-spellcheck-prog=aspell \
120 --with-system-pinerc=%{alpineconfdir}/%{name}.conf \
121 --with-system-fixed-pinerc=%{alpineconfdir}/%{name}.conf.fixed \
122 --with-krb5-dir=%{_prefix} \
123 --with-ldap-dir=%{_prefix} \
124 --with-system-mail-directory=/var/mail
125%{__make}
126
127%install
128rm -rf $RPM_BUILD_ROOT
129install -d $RPM_BUILD_ROOT{%{alpineconfdir},%{_desktopdir},%{_pixmapsdir}}
130
131%{__make} install \
132 DESTDIR=$RPM_BUILD_ROOT
133
134install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
135install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
136install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
137
138%clean
139rm -rf $RPM_BUILD_ROOT
140
141%files
142%defattr(644,root,root,755)
143%doc README doc/tech-notes.txt
144%dir %{alpineconfdir}
145%attr(755,root,root) %{_bindir}/%{name}
146%attr(755,root,root) %{_bindir}/rpload
147%attr(755,root,root) %{_bindir}/rpdump
148%{_mandir}/man1/%{name}.1*
149%{_mandir}/man1/rpload.1*
150%{_mandir}/man1/rpdump.1*
151%{_desktopdir}/%{name}.desktop
152%{_pixmapsdir}/%{name}.png
153
154%files -n pico
155%defattr(644,root,root,755)
156%attr(755,root,root) %{_bindir}/pico
157%{_desktopdir}/pico.desktop
158%{_mandir}/man1/pico*
159
160%files -n pilot
161%defattr(644,root,root,755)
162%attr(755,root,root) %{_bindir}/pilot
163%{_mandir}/man1/pilot*
This page took 0.066977 seconds and 4 git commands to generate.