]> git.pld-linux.org Git - packages/alpine.git/blame_incremental - alpine.spec
- unoficial 0.9999 release (with applied chappa's all.patch). Works nice.
[packages/alpine.git] / alpine.spec
... / ...
CommitLineData
1# TODO:
2# - backport man-pages from pine.spec
3# - alpine should obsolete pine, link pine -> alpine should be made
4# - review patches from pine:
5# - home_etc support
6# - ....many more
7Summary: University of Washington Pine mail user agent
8Summary(pl.UTF-8): Klient pocztowy Pine z Uniwersytetu w Waszyngtonie
9Name: alpine
10Version: 0.9999
11Release: 1
12Epoch: 1
13License: Apache License 2.0
14Group: Applications/Mail
15# Main site:
16#Source0: ftp://ftp.cac.washington.edu/alpine/%{name}-%{version}.tar.gz
17# Source with applied patches from http://staff.washington.edu/chappa/alpine/
18Source0: http://staff.washington.edu/chappa/alpine/patches/alpine-%{version}/%{name}-%{version}.tar.gz
19# Source0-md5: e095c1689d6c0fc6fd610464ba9c3cf8
20Source1: pico.desktop
21# http://staff.washington.edu/chappa/alpine/info/all.html
22#Patch0: http://staff.washington.edu/chappa/alpine/patches/%{name}-%{version}/all.patch.gz
23URL: http://www.washington.edu/alpine
24BuildRequires: autoconf
25BuildRequires: automake
26BuildRequires: krb5-devel
27BuildRequires: ncurses-devel
28BuildRequires: openldap-devel
29BuildRequires: openssl-devel
30BuildRequires: pam-devel
31BuildRequires: tcl-devel
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%define alpineconfdir /etc/%{name}
35
36%description
37Alpine -- an Alternatively Licensed Program for Internet News & Email
38-- is a tool for reading, sending, and managing electronic messages.
39Alpine is the successor to Pine and was developed by Computing &
40Communications at the University of Washington. Though originally
41designed for inexperienced email users, Alpine supports many advanced
42features, and an ever-growing number of configuration and
43personal-preference options.
44
45%description -l pl.UTF-8
46Alpine, czyli Alternatively Licensed Program for Internet News & Email
47(alternatywnie licencjonowany program do newsów i poczty internetowej)
48to narzędzie do czytania, wysyłania i zarządzania wiadomościami
49elektronicznymi. Alpine jest następcą Pine'a i został napisany przez
50wydział Computing & Communications (Obliczeń i komunikacji) na
51Uniwersytecie w Waszyngtonie. Mimo że Alpine pierwotnie został
52zaprojektowany dla niedoświadczonych użytkowników poczty, obsługuje
53wiele zaawansowanych możliwości, a liczba opcji konfiguracyjnych
54ciągle rośnie.
55
56%package -n pico
57Summary: Simple text editor in the style of the Pine Composer
58Summary(pl.UTF-8): Prosty edytor tekstowy w stylu alpine
59Summary(pt_BR.UTF-8): Editor de textos para terminal simples e fácil de usar
60Group: Applications/Editors
61
62%description -n pico
63Pico is a simple, display-oriented text editor based on the Alpine
64message system composer. As with Pine, commands are displayed at the
65bottom of the screen, and context-sensitive help is provided. As
66characters are typed they are immediately inserted into the text.
67
68%description -n pico -l pl.UTF-8
69Pico jest prostym, zorientowanym na wyświetlanie edytorem bazującym na
70alpine. Tak jak w pine komendy są wyświetlane na dole ekranu oraz
71dostępna jest pomoc konteksowa. Wpisywane znaki są natychmiast
72włączane do tekstu.
73
74%description -n pico -l pt_BR.UTF-8
75Pico é um editor de texto baseado no compositor de mensagens do Alpine.
76Assim como no Pine, comandos são mostrados na parte de baixo da tela,
77e ajuda de acordo com o contexto está disponível.
78
79%package -n pilot
80Summary: Simple file system browser in the style of the Alpine Composer
81Summary(pl.UTF-8): Prosta przeglądarka plików w stylu composera alpine
82Summary(pt_BR.UTF-8): Navegador de sistemas de arquivos no estilo do compositor do Alpine
83Group: Applications/Shells
84
85%description -n pilot
86Pilot is a simple, display-oriented file system browser based on the
87Alpine message system composer. As with Alpine, commands are displayed at
88the bottom of the screen, and context-sensitive help is provided.
89
90%description -n pilot -l pl.UTF-8
91Pilot jest prostą, zorientowaną na wyświetlanie przeglądarką plików w
92stylu compsera pine. Podobnie jak w alpine polecenia sa wyświetlane na
93dole ekranu oraz jest dostępna pomoc kontekstowa.
94
95%description -n pilot -l pt_BR.UTF-8
96Pilot é um navegador de sistemas de arquivos baseado no Pine. Assim
97como no Pine, comandos são apresentados na parte de baixo da tela, e
98ajuda de acordo com o contexto está disponível.
99
100%prep
101%setup -q
102
103%build
104%{__autoconf}
105%{__aclocal} -I m4
106%{__automake}
107%configure \
108 --enable-quotas \
109 --with-smtp-msa=%{_libdir}/sendmail \
110 --with-spellcheck-prog=aspell \
111 --with-system-pinerc=%{alpineconfdir}/%{name}.conf \
112 --with-system-fixed-pinerc=%{alpineconfdir}/%{name}.conf.fixed \
113 --with-krb5-dir=%{_prefix} \
114 --with-ldap-dir=%{_prefix} \
115 --with-system-mail-directory=/var/mail
116%{__make}
117
118%install
119rm -rf $RPM_BUILD_ROOT
120install -d $RPM_BUILD_ROOT{%{alpineconfdir},%{_desktopdir}}
121
122%{__make} install \
123 DESTDIR=$RPM_BUILD_ROOT
124
125install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
126
127%clean
128rm -rf $RPM_BUILD_ROOT
129
130%files
131%defattr(644,root,root,755)
132%doc README doc/tech-notes.txt
133%dir %{alpineconfdir}
134%attr(755,root,root) %{_bindir}/alpine
135%attr(755,root,root) %{_bindir}/rpload
136%attr(755,root,root) %{_bindir}/rpdump
137#%attr(755,root,root) %{_bindir}/mailutil
138#%attr(2755,root,mail) %{_sbindir}/mlock
139%{_mandir}/man1/alpine.1*
140#%{_mandir}/man1/rpload.1*
141#%{_mandir}/man1/rpdump.1*
142#%{_mandir}/man1/mailutil.1*
143
144%files -n pico
145%defattr(644,root,root,755)
146%attr(755,root,root) %{_bindir}/pico
147%{_desktopdir}/pico.desktop
148%{_mandir}/man1/pico*
149
150%files -n pilot
151%defattr(644,root,root,755)
152%attr(755,root,root) %{_bindir}/pilot
153%{_mandir}/man1/pilot*
This page took 0.082377 seconds and 4 git commands to generate.