]> git.pld-linux.org Git - packages/allegro5.git/blobdiff - allegro5.spec
- up to 5.0.2.1
[packages/allegro5.git] / allegro5.spec
index addcb7f0da33e30924035577fd3bd8d98c415dda..7f759f21b1e37e12ae63e986c29bdd7899070dfb 100644 (file)
@@ -1,6 +1,7 @@
 #
 # TODO: - Handle situations when there are no modules (most bconds turned off)
 #      - make bconds work again or remove
+#      - make it usable
 #
 # Conditional build:
 %bcond_without alsa    # without ALSA modules
@@ -12,7 +13,6 @@
 #%%bcond_without       jack    # without JACK module
 #%%bcond_without       proflib # don't debug profiling versions of library
 #%%bcond_without       sse     # build without sse
-%bcond_without static  # don't build static versions of library
 #%%bcond_without       svga    # without svgalib module
 #%%bcond_without       vga     # without vga module
 #
@@ -23,12 +23,12 @@ Summary(fr.UTF-8):  Une librairie de programmation de jeux
 Summary(it.UTF-8):     Una libreria per la programmazione di videogiochi
 Summary(pl.UTF-8):     Biblioteka do programowania gier
 Name:          allegro5
-Version:       4.9.21
+Version:       5.0.2.1
 Release:       0.1
 License:       Giftware
 Group:         Libraries
 Source0:       http://downloads.sourceforge.net/alleg/allegro-%{version}.tar.gz
-# Source0-md5: 82cc21ee26ffc2b88f5bfcbbb17a8f0c
+# Source0-md5: b92276fb9bf47555476d7c1ed39634a9
 Patch0:                %{name}-info.patch
 Patch1:                %{name}-examples.patch
 Patch2:                %{name}-opt.patch
@@ -46,6 +46,7 @@ BuildRequires:        curl-devel
 #BuildRequires:        physfs-devel
 #BuildRequires:        pkgconfig
 #%%endif
+BuildRequires: rpmbuild(macros) >= 1.600
 #BuildRequires:        sed >= 4.0
 #%%{?with_svga:BuildRequires:  svgalib-devel}
 #BuildRequires:        texinfo
@@ -125,32 +126,6 @@ grach komputerowych i innych rodzajach oprogramowania multimedialnego.
 Ten pakiet zawiera pliki nagłówkowe niezbędne do kompilowania
 aplikacji wykorzystujących bibliotekę allegro.
 
-%package static
-Summary:       A game programming library - static libraries
-Summary(pl.UTF-8):     Biblioteka do programowania gier - biblioteki statyczne
-Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}-%{release}
-Requires:      xorg-lib-libX11-devel
-Requires:      xorg-lib-libXcursor-devel
-Requires:      xorg-lib-libXext-devel
-Requires:      xorg-lib-libXpm-devel
-Requires:      xorg-lib-libXxf86vm-devel
-Obsoletes:     allegro-static
-
-%description static
-Allegro is a cross-platform library intended for use in computer games
-and other types of multimedia programming.
-
-This package contains static libraries for linking with allegro
-applications.
-
-%description static -l pl.UTF-8
-Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
-grach komputerowych i innych rodzajach oprogramowania multimedialnego.
-
-Ten pakiet zawiera biblioteki statyczne do konsolidacji z aplikacjami
-wykorzystującymi allegro.
-
 %package debug
 Summary:       liballd - debug version of shared allegro library
 Summary(pl.UTF-8):     liballd - wersja debug dzielonej biblioteki allegro
@@ -166,21 +141,6 @@ symbols and other information).
 liballd - wersja debug dzielonej biblioteki allegro (zawierająca
 symbole i inne informacje potrzebne przy odpluskwianiu).
 
-%package debug-static
-Summary:       liballd - debug version of static allegro library
-Summary(pl.UTF-8):     liballd - wersja debug statycznej biblioteki allegro
-Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}-%{release}
-Obsoletes:     allegro-debug-statix
-
-%description debug-static
-liballd - debug version of static allegro library (contains debugging
-symbols and other information).
-
-%description debug-static -l pl.UTF-8
-liballd - wersja debug statycznej biblioteki allegro (zawierająca
-symbole i inne informacje potrzebne przy odpluskwianiu).
-
 %package profile
 Summary:       liballp - profiling version of shared allegro library
 Summary(pl.UTF-8):     liballp - wersja dzielonej biblioteki allegro służąca do profilowania
@@ -194,20 +154,6 @@ liballp - profiling version of shared allegro library.
 %description profile -l pl.UTF-8
 liballp - wersja dzielonej biblioteki allegro służąca do profilowania.
 
-%package profile-static
-Summary:       liballp - profiling version of static allegro library
-Summary(pl.UTF-8):     liballp - wersja statycznej biblioteki allegro służąca do profilowania
-Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}-%{release}
-Obsoletes:     allegro-static
-
-%description profile-static
-liballp - profiling version of static allegro library.
-
-%description profile-static -l pl.UTF-8
-liballp - wersja statycznej biblioteki allegro służąca do
-profilowania.
-
 %package svgalib
 Summary:       A game programming library - svgalib module
 Summary(pl.UTF-8):     Biblioteka do programowania gier - moduł dla svgalib
@@ -474,13 +420,8 @@ biblioteki allegro.
 install -d build
 cd build
 %cmake .. \
-       -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
-       -DCMAKE_INSTALL_PREFIX=%{_prefix} \
        -DMANDIR=%{_mandir} \
-       -DINFODIR=%{_infodir} \
-%if "%{_lib}" == "lib64"
-       -DLIB_SUFFIX=64
-%endif
+       -DINFODIR=%{_infodir}
 
 %{__make}
 
@@ -508,8 +449,8 @@ find build/examples -maxdepth 1 -perm 755 -name "ex*" -exec install {} $RPM_BUIL
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-#%%post        -p /sbin/ldconfig
-#%%postun      -p /sbin/ldconfig
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
 
 #%%post devel  -p      /sbin/postshell
 #-/usr/sbin/fix-info-dir -c %{_infodir}
@@ -519,53 +460,32 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README.txt docs/html/refman
-#%%attr(755,root,root) %{_libdir}/liballeg-%{version}.so
-#%%dir %{_libdir}/allegro
-#%%dir %{_libdir}/allegro/%{version}
-#%%{_libdir}/allegro/%{version}/modules.lst
+%doc CHANGES-5.0.txt README.txt docs/html/refman
+%attr(755,root,root) %{_libdir}/liballegro.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/liballegro.so.5.0
 
 %files devel
 %defattr(644,root,root,755)
 #%%attr(755,root,root) %{_bindir}/allegro5-config
 #%%{_libdir}/liballeg_unsharable.a
+%{_libdir}/liballegro.so
 %{_includedir}/*
 #%%{_aclocaldir}/allegro.m4
 #%%{_mandir}/man3/*
 #%%{_infodir}/*.info*
 
-#%%if %{with static}
-#%%files static
-#%%defattr(644,root,root,755)
-#%%{_libdir}/liballeg.a
-#%%endif
-
 #%%if %{with dbglib}
 #%%files debug
 #%%defattr(644,root,root,755)
 #%%attr(755,root,root) %{_libdir}/liballd-%{version}.so
 #%%{_libdir}/liballd_unsharable.a
 
-#%%if %{with static}
-#%%files debug-static
-#%%defattr(644,root,root,755)
-#%%{_libdir}/liballd.a
-#%%endif
-#%%endif
-
 #%%if %{with proflib}
 #%%files profile
 #%%defattr(644,root,root,755)
 #%%attr(755,root,root) %{_libdir}/liballp-%{version}.so
 #%%{_libdir}/liballp_unsharable.a
 
-#%%if %{with static}
-#%%files profile-static
-#%%defattr(644,root,root,755)
-#%%{_libdir}/liballp.a
-#%%endif
-#%%endif
-
 #%%if %{with svga}
 #%%files svgalib
 #%%defattr(644,root,root,755)
@@ -631,7 +551,7 @@ rm -rf $RPM_BUILD_ROOT
 #%%attr(755,root,root) %{_bindir}/dat2s
 #%%attr(755,root,root) %{_bindir}/grabber
 #%%attr(755,root,root) %{_bindir}/pat2dat
-#%attr(755,root,root) %{_bindir}/setup-allegro
+#%%attr(755,root,root) %{_bindir}/setup-allegro
 
 #%%files tests
 #%%defattr(644,root,root,755)
@@ -664,6 +584,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/ex_blend_test
 %attr(755,root,root) %{_bindir}/ex_blit
 %attr(755,root,root) %{_bindir}/ex_clip
+%attr(755,root,root) %{_bindir}/ex_color
 %attr(755,root,root) %{_bindir}/ex_config
 %attr(755,root,root) %{_bindir}/ex_convert
 %attr(755,root,root) %{_bindir}/ex_dir
@@ -674,20 +595,24 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/ex_drawpixels
 %attr(755,root,root) %{_bindir}/ex_dualies
 %attr(755,root,root) %{_bindir}/ex_expose
+%attr(755,root,root) %{_bindir}/ex_filter
 %attr(755,root,root) %{_bindir}/ex_font
 %attr(755,root,root) %{_bindir}/ex_fs_resize
 %attr(755,root,root) %{_bindir}/ex_fs_window
 %attr(755,root,root) %{_bindir}/ex_get_path
 %attr(755,root,root) %{_bindir}/ex_gldepth
 %attr(755,root,root) %{_bindir}/ex_glext
+%attr(755,root,root) %{_bindir}/ex_haiku
 %attr(755,root,root) %{_bindir}/ex_icon
 %attr(755,root,root) %{_bindir}/ex_joystick_events
+%attr(755,root,root) %{_bindir}/ex_joystick_hotplugging
+%attr(755,root,root) %{_bindir}/ex_font_justify
 %attr(755,root,root) %{_bindir}/ex_kcm_direct
 %attr(755,root,root) %{_bindir}/ex_keyboard_events
 %attr(755,root,root) %{_bindir}/ex_keyboard_focus
 %attr(755,root,root) %{_bindir}/ex_lines
 %attr(755,root,root) %{_bindir}/ex_lockbitmap
-%attr(755,root,root) %{_bindir}/ex_lockscreen
+%attr(755,root,root) %{_bindir}/ex_logo
 %attr(755,root,root) %{_bindir}/ex_membmp
 %attr(755,root,root) %{_bindir}/ex_memfile
 %attr(755,root,root) %{_bindir}/ex_mixer_chain
@@ -699,12 +624,15 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/ex_mouse_focus
 %attr(755,root,root) %{_bindir}/ex_multisample
 %attr(755,root,root) %{_bindir}/ex_multiwin
+%attr(755,root,root) %{_bindir}/ex_native_filechooser
+%attr(755,root,root) %{_bindir}/ex_nodisplay
 %attr(755,root,root) %{_bindir}/ex_noframe
 %attr(755,root,root) %{_bindir}/ex_opengl
 %attr(755,root,root) %{_bindir}/ex_opengl_pixel_shader
 %attr(755,root,root) %{_bindir}/ex_path
 %attr(755,root,root) %{_bindir}/ex_path_test
 %attr(755,root,root) %{_bindir}/ex_pixelformat
+%attr(755,root,root) %{_bindir}/ex_premulalpha
 %attr(755,root,root) %{_bindir}/ex_prim
 %attr(755,root,root) %{_bindir}/ex_resize
 %attr(755,root,root) %{_bindir}/ex_resize2
@@ -714,11 +642,13 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/ex_stream_file
 %attr(755,root,root) %{_bindir}/ex_stream_seek
 %attr(755,root,root) %{_bindir}/ex_subbitmap
+%attr(755,root,root) %{_bindir}/ex_synth
 %attr(755,root,root) %{_bindir}/ex_threads
 %attr(755,root,root) %{_bindir}/ex_threads2
 %attr(755,root,root) %{_bindir}/ex_timedwait
 %attr(755,root,root) %{_bindir}/ex_timer
 %attr(755,root,root) %{_bindir}/ex_transform
+%attr(755,root,root) %{_bindir}/ex_ttf
 %attr(755,root,root) %{_bindir}/ex_user_events
 %attr(755,root,root) %{_bindir}/ex_utf8
 %attr(755,root,root) %{_bindir}/ex_vsync
This page took 0.101276 seconds and 4 git commands to generate.