]> git.pld-linux.org Git - packages/allegro5.git/blobdiff - allegro-opt.patch
- don't use %{without ...}, it may not work after inverting bcond
[packages/allegro5.git] / allegro-opt.patch
index b706d4876233d5d1e9549026a8363368437c3e0c..cb2231140a66eecc78ae6f0e437ee0c9cd777839 100644 (file)
@@ -1,28 +1,57 @@
---- allegro-4.1.9/configure.in.orig    Thu Jan 30 00:04:22 2003
-+++ allegro-4.1.9/configure.in Thu Jan 30 00:04:47 2003
-@@ -177,6 +177,7 @@
-   else
-     WFLAGS="-Wall"
+--- aa/allegro-4.1.15/configure.in     2004-04-27 13:53:02.000000000 +0200
++++ allegro-4.1.15/configure.in        2004-05-23 21:18:36.478313632 +0200
+@@ -720,38 +720,7 @@
+ dnl How to compile C and asm files.
+ if test -n "$GCC"; then
+-  if test "X$allegro_strict_warnings" = "Xyes"; then
+-    WFLAGS="-Wall -W -Wstrict-prototypes -Wno-unused-parameter -Werror"
+-  else
+-    WFLAGS="-Wall -Wno-unused"
+-  fi
+-  if test "X$allegro_cv_processor_type" = "Xi386"; then
+-    if test "$allegro_exclusive_optimizations" != none; then
+-      TARGET_ARCH="-march=$allegro_exclusive_optimizations"
+-    elif test "X$allegro_cv_support_i386_mtune" = "Xyes"; then
+-      TARGET_ARCH="-mtune=$allegro_optimizations"
+-    else
+-      TARGET_ARCH="-mcpu=$allegro_optimizations"
+-    fi
+-  elif test "X$allegro_cv_processor_type" = "Xamd64"; then
+-    dnl Change default pentium->athlon64
+-    if test "X$allegro_optimizations" = "Xpentium"; then
+-      allegro_optimizations="k8"
+-    fi
+-    if test "$allegro_exclusive_optimizations" != none; then
+-      TARGET_ARCH="-march=$allegro_exclusive_optimizations"
+-    elif test "X$allegro_cv_support_amd64_mtune" = "Xyes"; then
+-      TARGET_ARCH="-mtune=$allegro_optimizations"
+-    else
+-      TARGET_ARCH="-mcpu=$allegro_optimizations"
+-    fi
+-  else
+-    TARGET_ARCH=
+-  fi
+-  dnl Allow to specify additional flags.
+-  CFLAGS="$CFLAGS $XCFLAGS"
+-  WFLAGS="$WFLAGS $WCFLAGS"
+-  dnl In this order...
++  WFLAGS="-Wall -Wno-unused"
+   ALLEGRO_DEBUG_CFLAGS="$CFLAGS -g $WFLAGS -DDEBUGMODE"
+   if test "X$allegro_debug_with_fortify" = "Xyes"; then
+      ALLEGRO_DEBUG_CFLAGS="$ALLEGRO_DEBUG_CFLAGS -DFORTIFY"
+@@ -759,12 +728,8 @@
+   if test "X$allegro_debug_with_dmalloc" = "Xyes"; then
+      ALLEGRO_DEBUG_CFLAGS="$ALLEGRO_DEBUG_CFLAGS -DDMALLOC"
    fi
-+  if test "$TARGET_ARCH" = "" ; then
-   if test "$allegro_cv_support_asm" = i386; then
-     if test "$allegro_exclusive_optimizations" != none; then
-       TARGET_ARCH="-march=$allegro_exclusive_optimizations"
-@@ -186,13 +187,14 @@
-   else
-     TARGET_ARCH=
-   fi
-+  fi
-   if test "X$allegro_cv_support_fomit_frame_pointer" = "Xyes"; then
--    CFLAGS="$TARGET_ARCH -O2 -funroll-loops -ffast-math -fomit-frame-pointer $WFLAGS"
-+    CFLAGS="$TARGET_ARCH -funroll-loops -ffast-math -fomit-frame-pointer $WFLAGS"
-   else
--    CFLAGS="$TARGET_ARCH -O2 -funroll-loops -ffast-math $WFLAGS"
-+    CFLAGS="$TARGET_ARCH -funroll-loops -ffast-math $WFLAGS"
-   fi
-   ALLEGRO_DEBUG_CFLAGS="-g $WFLAGS -DDEBUGMODE"
--  ALLEGRO_PROFILE_CFLAGS="-pg $TARGET_ARCH -O2 -funroll-loops -ffast-math $WFLAGS"
-+  ALLEGRO_PROFILE_CFLAGS="-pg $TARGET_ARCH -funroll-loops -ffast-math $WFLAGS"
-   if test "X$allegro_cv_can_use_pipe" = "Xyes"; then
-     CFLAGS="-pipe $CFLAGS"
-     ALLEGRO_DEBUG_CFLAGS="-pipe $ALLEGRO_DEBUG_CFLAGS"
+-  ALLEGRO_PROFILE_CFLAGS="$CFLAGS -pg $TARGET_ARCH -O2 -funroll-loops -ffast-math $WFLAGS"
+-  if test "X$allegro_cv_support_fomit_frame_pointer" = "Xyes"; then
+-    CFLAGS="$CFLAGS $TARGET_ARCH -O2 -funroll-loops -ffast-math -fomit-frame-pointer $WFLAGS"
+-  else
+-    CFLAGS="$CFLAGS $TARGET_ARCH -O2 -funroll-loops -ffast-math $WFLAGS"
+-  fi
++  CFLAGS="$CFLAGS $TARGET_ARCH"
++  ALLEGRO_PROFILE_CFLAGS="$CFLAGS -pg $WFLAGS"
+   ALLEGRO_SFLAGS="-x assembler-with-cpp"
+   ALLEGRO_SHAREDLIB_CFLAGS="-fPIC -DALLEGRO_SHARED"
+ else
This page took 0.252886 seconds and 4 git commands to generate.