]> git.pld-linux.org Git - packages/allegro5.git/blobdiff - allegro-opt.patch
- don't use %{without ...}, it may not work after inverting bcond
[packages/allegro5.git] / allegro-opt.patch
index 2b1fa3687f5ae1c2205dc4d7adb3d36848931147..cb2231140a66eecc78ae6f0e437ee0c9cd777839 100644 (file)
@@ -1,40 +1,48 @@
---- allegro-4.1.12/configure.in.orig   2003-11-11 21:59:10.385928944 +0100
-+++ allegro-4.1.12/configure.in        2003-11-11 22:02:54.074923048 +0100
-@@ -645,41 +645,16 @@
- AC_CHECK_FUNCS(memcmp mkstemp stricmp strlwr strupr)
- dnl Tweak header files for library build
--CFLAGS="$CFLAGS -DALLEGRO_LIB_BUILD"
-+CFLAGS="$CFLAGS $TARGET_ARCH -DALLEGRO_LIB_BUILD"
+--- aa/allegro-4.1.15/configure.in     2004-04-27 13:53:02.000000000 +0200
++++ allegro-4.1.15/configure.in        2004-05-23 21:18:36.478313632 +0200
+@@ -720,38 +720,7 @@
  
  dnl How to compile C and asm files.
- if test -n "GCC"; then
+ if test -n "$GCC"; then
 -  if test "X$allegro_strict_warnings" = "Xyes"; then
--    WFLAGS="-Wall -W -Wstrict-prototypes -Wno-unused -Werror"
+-    WFLAGS="-Wall -W -Wstrict-prototypes -Wno-unused-parameter -Werror"
 -  else
 -    WFLAGS="-Wall -Wno-unused"
 -  fi
 -  if test "X$allegro_cv_processor_type" = "Xi386"; then
 -    if test "$allegro_exclusive_optimizations" != none; then
 -      TARGET_ARCH="-march=$allegro_exclusive_optimizations"
+-    elif test "X$allegro_cv_support_i386_mtune" = "Xyes"; then
+-      TARGET_ARCH="-mtune=$allegro_optimizations"
+-    else
+-      TARGET_ARCH="-mcpu=$allegro_optimizations"
+-    fi
+-  elif test "X$allegro_cv_processor_type" = "Xamd64"; then
+-    dnl Change default pentium->athlon64
+-    if test "X$allegro_optimizations" = "Xpentium"; then
+-      allegro_optimizations="k8"
+-    fi
+-    if test "$allegro_exclusive_optimizations" != none; then
+-      TARGET_ARCH="-march=$allegro_exclusive_optimizations"
+-    elif test "X$allegro_cv_support_amd64_mtune" = "Xyes"; then
+-      TARGET_ARCH="-mtune=$allegro_optimizations"
 -    else
 -      TARGET_ARCH="-mcpu=$allegro_optimizations"
 -    fi
 -  else
 -    TARGET_ARCH=
 -  fi
--  if test "X$allegro_cv_can_use_pipe" = "Xyes"; then
--    CFLAGS="$CFLAGS -pipe"
--  fi
 -  dnl Allow to specify additional flags.
 -  CFLAGS="$CFLAGS $XCFLAGS"
 -  WFLAGS="$WFLAGS $WCFLAGS"
 -  dnl In this order...
--  ALLEGRO_DEBUG_CFLAGS="$CFLAGS -g $WFLAGS -DDEBUGMODE"
 +  WFLAGS="-Wall -Wno-unused"
-+  ALLEGRO_DEBUG_CFLAGS="-g $WFLAGS -DDEBUGMODE"
+   ALLEGRO_DEBUG_CFLAGS="$CFLAGS -g $WFLAGS -DDEBUGMODE"
    if test "X$allegro_debug_with_fortify" = "Xyes"; then
       ALLEGRO_DEBUG_CFLAGS="$ALLEGRO_DEBUG_CFLAGS -DFORTIFY"
+@@ -759,12 +728,8 @@
+   if test "X$allegro_debug_with_dmalloc" = "Xyes"; then
+      ALLEGRO_DEBUG_CFLAGS="$ALLEGRO_DEBUG_CFLAGS -DDMALLOC"
    fi
 -  ALLEGRO_PROFILE_CFLAGS="$CFLAGS -pg $TARGET_ARCH -O2 -funroll-loops -ffast-math $WFLAGS"
 -  if test "X$allegro_cv_support_fomit_frame_pointer" = "Xyes"; then
@@ -42,6 +50,7 @@
 -  else
 -    CFLAGS="$CFLAGS $TARGET_ARCH -O2 -funroll-loops -ffast-math $WFLAGS"
 -  fi
++  CFLAGS="$CFLAGS $TARGET_ARCH"
 +  ALLEGRO_PROFILE_CFLAGS="$CFLAGS -pg $WFLAGS"
    ALLEGRO_SFLAGS="-x assembler-with-cpp"
    ALLEGRO_SHAREDLIB_CFLAGS="-fPIC -DALLEGRO_SHARED"
This page took 0.090998 seconds and 4 git commands to generate.