]> git.pld-linux.org Git - packages/allegro5.git/blob - allegro5.spec
flac rebuild
[packages/allegro5.git] / allegro5.spec
1 #
2 # TODO:
3 # - check if it's usable now
4 #
5 # Conditional build:
6 %bcond_without  alsa            # ALSA support in allegro_audio library
7 %bcond_with     curl            # cURL example
8 %bcond_without  doc             # rebuild HTML and texinfo documentation
9 %bcond_without  dumb            # MOD support in allegro_acodec library
10 %bcond_without  gtk             # (GTK+ 2.x based) native dialog library
11 %bcond_without  openal          # OpenAL support in allegro_audio library
12 %bcond_without  physfs          # PhysFS addon library
13 %bcond_without  pulseaudio      # PulseAudio support in allegro_audio library
14 %bcond_without  python          # Python wrapper
15 %bcond_with     sse             # SSE instructions usage
16 #
17 %ifarch pentium3 pentium4 %{x8664}
18 %define with_sse        1
19 %endif
20
21 # No ghc, thus no pandoc on x32
22 %ifarch x32
23 %undefine with_doc
24 %endif
25 Summary:        A game programming library
26 Summary(de.UTF-8):      Eine Bibliothek zur Programmierung von Spielen
27 Summary(es.UTF-8):      Una biblioteca de programación de juegos
28 Summary(fr.UTF-8):      Une librairie de programmation de jeux
29 Summary(it.UTF-8):      Una libreria per la programmazione di videogiochi
30 Summary(pl.UTF-8):      Biblioteka do programowania gier
31 Name:           allegro5
32 Version:        5.2.0
33 Release:        2
34 License:        Giftware
35 Group:          Libraries
36 Source0:        http://download.gna.org/allegro/allegro/5.2.0/allegro-%{version}.tar.gz
37 # Source0-md5:  9cf444aae63d51de65deb57704372fec
38 Patch0:         %{name}-glx.patch
39 URL:            http://liballeg.org/
40 %{?with_openal:BuildRequires:   OpenAL-devel}
41 BuildRequires:  OpenGL-GLU-devel
42 BuildRequires:  OpenGL-devel
43 %{?with_alsa:BuildRequires:     alsa-lib-devel}
44 BuildRequires:  cmake >= 2.6
45 %{?with_curl:BuildRequires:     curl-devel}
46 BuildRequires:  dumb-devel
47 BuildRequires:  flac-devel
48 BuildRequires:  freetype-devel >= 2
49 %{?with_gtk:BuildRequires:      glib2-devel >= 2.0}
50 %{?with_gtk:BuildRequires:      gtk+2-devel >= 2.0}
51 BuildRequires:  libjpeg-devel
52 BuildRequires:  libogg-devel
53 BuildRequires:  libpng-devel
54 BuildRequires:  libvorbis-devel
55 %{?with_physfs:BuildRequires:   physfs-devel}
56 BuildRequires:  pkgconfig
57 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel >= 0.9.15}
58 BuildRequires:  rpmbuild(macros) >= 1.605
59 BuildRequires:  xorg-lib-libX11-devel
60 BuildRequires:  xorg-lib-libXcursor-devel
61 BuildRequires:  xorg-lib-libXext-devel
62 BuildRequires:  xorg-lib-libXinerama-devel
63 BuildRequires:  xorg-lib-libXpm-devel
64 BuildRequires:  xorg-lib-libXrandr-devel
65 BuildRequires:  xorg-lib-libXxf86vm-devel
66 BuildRequires:  zlib-devel
67 %if %{with python}
68 BuildRequires:  python
69 BuildRequires:  python-modules
70 BuildRequires:  rpm-pythonprov
71 %endif
72 %if %{with doc}
73 BuildRequires:  ctags
74 BuildRequires:  pandoc >= 1.5
75 BuildRequires:  texinfo
76 BuildRequires:  texlive-latex
77 %endif
78 Obsoletes:      allegro5-tools
79 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81 %description
82 Allegro is a cross-platform library intended for use in computer games
83 and other types of multimedia programming.
84
85 %description -l de.UTF-8
86 Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
87 Computerspielen und anderen Formen von Multinediaprogrammierung.
88
89 %description -l es.UTF-8
90 Allegro es una librería multi-plataforma creada para ser usada en la
91 programación de juegos u otro tipo de programación multimedia.
92
93 %description -l fr.UTF-8
94 Allegro est une librairie multi-plateforme destinée à être utilisée
95 dans les jeux vidéo ou d'autres types de programmation multimédia.
96
97 %description -l it.UTF-8
98 Allegro è una libreria multipiattaforma dedicata all'uso nei
99 videogiochi ed in altri tipi di programmazione multimediale.
100
101 %description -l pl.UTF-8
102 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
103 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
104
105 %package devel
106 Summary:        A game programming library - header files
107 Summary(es.UTF-8):      Archivos de inclusión
108 Summary(pl.UTF-8):      Biblioteka do programowania gier - pliki nagłówkowe
109 Group:          Development/Libraries
110 Requires:       %{name} = %{version}-%{release}
111
112 %description devel
113 Allegro is a cross-platform library intended for use in computer games
114 and other types of multimedia programming.
115
116 This package contains header files neccessary for compiling
117 applications using allegro library.
118
119 %description devel -l de.UTF-8
120 Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
121 Computerspielen und anderen Formen von Multinediaprogrammierung.
122 Dieses Paket wird benötigt, um Programme zu bauen, die Allegro
123 verwenden.
124
125 %description devel -l es.UTF-8
126 Allegro es una librería multi-plataforma creada para ser usada en la
127 programación de juegos u otro tipo de programación multimedia. Este
128 paquete es necesario para compilar los programas que usen Allegro.
129
130 %description devel -l fr.UTF-8
131 Allegro est une librairie multi-plateforme destinée à être utilisée
132 dans les jeux vidéo ou d'autres types de programmation multimédia. Ce
133 package est nécessaire pour compiler les programmes utilisant Allegro.
134
135 %description devel -l it.UTF-8
136 Allegro è una libreria multipiattaforma dedicata all'uso nei
137 videogiochi ed in altri tipi di programmazione multimediale. Questo
138 pacchetto è necessario per compilare programmi scritti con Allegro.
139
140 %description devel -l pl.UTF-8
141 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
142 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
143
144 Ten pakiet zawiera pliki nagłówkowe niezbędne do kompilowania
145 aplikacji wykorzystujących bibliotekę allegro.
146
147 %package acodec
148 Summary:        Allegro acodec addon library
149 Summary(pl.UTF-8):      Biblioteka dodatkowa Allegro acodec
150 Group:          Libraries
151 Requires:       %{name}-audio = %{version}-%{release}
152
153 %description acodec
154 Allegro acodec addon library.
155
156 %description acodec -l pl.UTF-8
157 Biblioteka dodatkowa Allegro acodec.
158
159 %package acodec-devel
160 Summary:        Header files for Allegro acodec addon library
161 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki dodatkowej Allegro acodec
162 Group:          Libraries
163 Requires:       %{name}-acodec = %{version}-%{release}
164 Requires:       %{name}-audio-devel = %{version}-%{release}
165
166 %description acodec-devel
167 Header files for Allegro acodec addon library.
168
169 %description acodec-devel -l pl.UTF-8
170 Pliki nagłówkowe biblioteki dodatkowej Allegro acodec.
171
172 %package audio
173 Summary:        Allegro audio addon library
174 Summary(pl.UTF-8):      Biblioteka dodatkowa Allegro audio
175 Group:          Libraries
176 Requires:       %{name} = %{version}-%{release}
177
178 %description audio
179 Allegro audio addon library.
180
181 %description audio -l pl.UTF-8
182 Biblioteka dodatkowa Allegro audio.
183
184 %package audio-devel
185 Summary:        Header files for Allegro audio addon library
186 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki dodatkowej Allegro audio
187 Group:          Libraries
188 Requires:       %{name}-audio = %{version}-%{release}
189 Requires:       %{name}-devel = %{version}-%{release}
190
191 %description audio-devel
192 Header files for Allegro audio addon library.
193
194 %description audio-devel -l pl.UTF-8
195 Pliki nagłówkowe biblioteki dodatkowej Allegro audio.
196
197 %package dialog
198 Summary:        Allegro dialog addon library
199 Summary(pl.UTF-8):      Biblioteka dodatkowa Allegro dialog
200 Group:          Libraries
201 Requires:       %{name} = %{version}-%{release}
202
203 %description dialog
204 Allegro dialog addon library.
205
206 %description dialog -l pl.UTF-8
207 Biblioteka dodatkowa Allegro dialog.
208
209 %package dialog-devel
210 Summary:        Header files for Allegro dialog addon library
211 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki dodatkowej Allegro dialog
212 Group:          Libraries
213 Requires:       %{name}-dialog = %{version}-%{release}
214 Requires:       %{name}-devel = %{version}-%{release}
215
216 %description dialog-devel
217 Header files for Allegro dialog addon library.
218
219 %description dialog-devel -l pl.UTF-8
220 Pliki nagłówkowe biblioteki dodatkowej Allegro dialog.
221
222 %package image
223 Summary:        Allegro image addon library
224 Summary(pl.UTF-8):      Biblioteka dodatkowa Allegro image
225 Group:          Libraries
226 Requires:       %{name} = %{version}-%{release}
227
228 %description image
229 Allegro image addon library.
230
231 %description image -l pl.UTF-8
232 Biblioteka dodatkowa Allegro image.
233
234 %package image-devel
235 Summary:        Header files for Allegro image addon library
236 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki dodatkowej Allegro image
237 Group:          Libraries
238 Requires:       %{name}-image = %{version}-%{release}
239 Requires:       %{name}-devel = %{version}-%{release}
240
241 %description image-devel
242 Header files for Allegro image addon library.
243
244 %description image-devel -l pl.UTF-8
245 Pliki nagłówkowe biblioteki dodatkowej Allegro image.
246
247 %package physfs
248 Summary:        Allegro physfs addon library
249 Summary(pl.UTF-8):      Biblioteka dodatkowa Allegro physfs
250 Group:          Libraries
251 Requires:       %{name} = %{version}-%{release}
252
253 %description physfs
254 Allegro physfs addon library.
255
256 %description physfs -l pl.UTF-8
257 Biblioteka dodatkowa Allegro physfs.
258
259 %package physfs-devel
260 Summary:        Header files for Allegro physfs addon library
261 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki dodatkowej Allegro physfs
262 Group:          Libraries
263 Requires:       %{name}-physfs = %{version}-%{release}
264 Requires:       %{name}-devel = %{version}-%{release}
265
266 %description physfs-devel
267 Header files for Allegro physfs addon library.
268
269 %description physfs-devel -l pl.UTF-8
270 Pliki nagłówkowe biblioteki dodatkowej Allegro physfs.
271
272 %package ttf
273 Summary:        Allegro ttf addon library
274 Summary(pl.UTF-8):      Biblioteka dodatkowa Allegro ttf
275 Group:          Libraries
276 Requires:       %{name} = %{version}-%{release}
277
278 %description ttf
279 Allegro ttf addon library.
280
281 %description ttf -l pl.UTF-8
282 Biblioteka dodatkowa Allegro ttf.
283
284 %package ttf-devel
285 Summary:        Header files for Allegro ttf addon library
286 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki dodatkowej Allegro ttf
287 Group:          Libraries
288 Requires:       %{name}-ttf = %{version}-%{release}
289 Requires:       %{name}-devel = %{version}-%{release}
290
291 %description ttf-devel
292 Header files for Allegro ttf addon library.
293
294 %description ttf-devel -l pl.UTF-8
295 Pliki nagłówkowe biblioteki dodatkowej Allegro ttf.
296
297 %package examples
298 Summary:        A game programming library - examples
299 Summary(pl.UTF-8):      Biblioteka do programowania gier - programy przykładowe
300 Group:          Development/Libraries
301 Requires:       %{name} = %{version}-%{release}
302
303 %description examples
304 This package contains example programs which demonstrate allegro
305 features.
306
307 %description examples -l pl.UTF-8
308 Pakiet zawiera programy przykładowe demonstrujące możliwości
309 biblioteki allegro.
310
311 %package -n python-%{name}
312 Summary:        Python wrapper for Allegro library
313 Summary(pl.UTF-8):      Pythonowy interfejs do biblioteki Allegro
314 Group:          Development/Languages/Python
315 Requires:       %{name} = %{version}-%{release}
316 Requires:       python-modules
317
318 %description -n python-%{name}
319 Python wrapper for Allegro library.
320
321 %description -n python-%{name} -l pl.UTF-8
322 Pythonowy interfejs do biblioteki Allegro.
323
324 %prep
325 %setup -q -n allegro-%{version}.0
326 %patch0 -p1
327
328 %build
329 install -d build
330 cd build
331 %cmake .. \
332         -DMANDIR=%{_mandir} \
333         -DINFODIR=%{_infodir} \
334         -DWANT_TTF=ON \
335         %{!?with_sse:-DWANT_ALLOW_SSE=OFF} \
336         %{!?with_alsa:-DWANT_ALSA=OFF} \
337         %{?with_curl:-DWANT_CURL_EXAMPLE=ON} \
338         %{!?with_dumb:-DWANT_MODAUDIO=OFF} \
339         %{!?with_gtk:-DWANT_NATIVE_DIALOG=OFF} \
340         %{!?with_openal:-DWANT_OPENAL=OFF} \
341         %{!?with_physfs:-DWANT_PHYSFS=OFF} \
342         %{!?with_pulseaudio:-DWANT_PULSEAUDIO=OFF} \
343         %{?with_python:-DWANT_PYTHON_WRAPPER=ON}
344
345 %{__make}
346
347 %install
348 rm -rf $RPM_BUILD_ROOT
349 install -d $RPM_BUILD_ROOT%{_bindir}
350
351 %{__make} install -C build \
352         DESTDIR=$RPM_BUILD_ROOT
353
354 %if %{with python}
355 install -d $RPM_BUILD_ROOT%{py_sitescriptdir}
356 install build/python/allegro.py $RPM_BUILD_ROOT%{py_sitescriptdir}
357 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
358 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
359 %py_postclean
360 %endif
361
362 install -d $RPM_BUILD_ROOT%{_mandir}/man3
363 cp -p docs/man/*.3 $RPM_BUILD_ROOT%{_mandir}/man3
364
365 # install examples
366 find build/examples -maxdepth 1 -perm 755 -name "ex*" -exec install {} $RPM_BUILD_ROOT%{_bindir} \;
367
368 %clean
369 rm -rf $RPM_BUILD_ROOT
370
371 %post   -p /sbin/ldconfig
372 %postun -p /sbin/ldconfig
373
374 %post   acodec -p /sbin/ldconfig
375 %postun acodec -p /sbin/ldconfig
376
377 %post   audio -p /sbin/ldconfig
378 %postun audio -p /sbin/ldconfig
379
380 %post   dialog -p /sbin/ldconfig
381 %postun dialog -p /sbin/ldconfig
382
383 %post   image -p /sbin/ldconfig
384 %postun image -p /sbin/ldconfig
385
386 %post   physfs -p /sbin/ldconfig
387 %postun physfs -p /sbin/ldconfig
388
389 %post   ttf -p /sbin/ldconfig
390 %postun ttf -p /sbin/ldconfig
391
392 %files
393 %defattr(644,root,root,755)
394 %doc CHANGES-5.0.txt CHANGES-5.1.txt CHANGES-5.2.txt README.txt docs/html/refman
395 %attr(755,root,root) %{_libdir}/liballegro.so.*.*.*
396 %attr(755,root,root) %ghost %{_libdir}/liballegro.so.5.2
397 %attr(755,root,root) %{_libdir}/liballegro_color.so.*.*.*
398 %attr(755,root,root) %ghost %{_libdir}/liballegro_color.so.5.2
399 %attr(755,root,root) %{_libdir}/liballegro_font.so.*.*.*
400 %attr(755,root,root) %ghost %{_libdir}/liballegro_font.so.5.2
401 %attr(755,root,root) %{_libdir}/liballegro_main.so.*.*.*
402 %attr(755,root,root) %ghost %{_libdir}/liballegro_main.so.5.2
403 %attr(755,root,root) %{_libdir}/liballegro_memfile.so.*.*.*
404 %attr(755,root,root) %ghost %{_libdir}/liballegro_memfile.so.5.2
405 %attr(755,root,root) %{_libdir}/liballegro_primitives.so.*.*.*
406 %attr(755,root,root) %ghost %{_libdir}/liballegro_primitives.so.5.2
407 %attr(755,root,root) %{_libdir}/liballegro_video.so.*.*.*
408 %attr(755,root,root) %ghost %{_libdir}/liballegro_video.so.5.2
409
410 %files devel
411 %defattr(644,root,root,755)
412 %attr(755,root,root) %{_libdir}/liballegro.so
413 %attr(755,root,root) %{_libdir}/liballegro_color.so
414 %attr(755,root,root) %{_libdir}/liballegro_font.so
415 %attr(755,root,root) %{_libdir}/liballegro_main.so
416 %attr(755,root,root) %{_libdir}/liballegro_memfile.so
417 %attr(755,root,root) %{_libdir}/liballegro_primitives.so
418 %attr(755,root,root) %{_libdir}/liballegro_video.so
419 %{_includedir}/allegro5
420 %exclude %{_includedir}/allegro5/allegro_acodec.h
421 %exclude %{_includedir}/allegro5/allegro_audio.h
422 %exclude %{_includedir}/allegro5/allegro_image.h
423 %{?with_gtk:%exclude %{_includedir}/allegro5/allegro_native_dialog.h}
424 %{?with_physfs:%exclude %{_includedir}/allegro5/allegro_physfs.h}
425 %exclude %{_includedir}/allegro5/allegro_ttf.h
426 %{_pkgconfigdir}/allegro-5.pc
427 %{_pkgconfigdir}/allegro_color-5.pc
428 %{_pkgconfigdir}/allegro_font-5.pc
429 %{_pkgconfigdir}/allegro_main-5.pc
430 %{_pkgconfigdir}/allegro_memfile-5.pc
431 %{_pkgconfigdir}/allegro_primitives-5.pc
432 %{_pkgconfigdir}/allegro_video-5.pc
433 %{_mandir}/man3/ALLEGRO_*.3*
434 %{_mandir}/man3/al_*.3*
435
436 %files acodec
437 %defattr(644,root,root,755)
438 %attr(755,root,root) %{_libdir}/liballegro_acodec.so.*.*.*
439 %attr(755,root,root) %ghost %{_libdir}/liballegro_acodec.so.5.2
440
441 %files acodec-devel
442 %defattr(644,root,root,755)
443 %attr(755,root,root) %{_libdir}/liballegro_acodec.so
444 %{_includedir}/allegro5/allegro_acodec.h
445 %{_pkgconfigdir}/allegro_acodec-5.pc
446
447 %files audio
448 %defattr(644,root,root,755)
449 %attr(755,root,root) %{_libdir}/liballegro_audio.so.*.*.*
450 %attr(755,root,root) %ghost %{_libdir}/liballegro_audio.so.5.2
451
452 %files audio-devel
453 %defattr(644,root,root,755)
454 %attr(755,root,root) %{_libdir}/liballegro_audio.so
455 %{_includedir}/allegro5/allegro_audio.h
456 %{_pkgconfigdir}/allegro_audio-5.pc
457
458 %if %{with gtk}
459 %files dialog
460 %defattr(644,root,root,755)
461 %attr(755,root,root) %{_libdir}/liballegro_dialog.so.*.*.*
462 %attr(755,root,root) %ghost %{_libdir}/liballegro_dialog.so.5.2
463
464 %files dialog-devel
465 %defattr(644,root,root,755)
466 %attr(755,root,root) %{_libdir}/liballegro_dialog.so
467 %{_includedir}/allegro5/allegro_native_dialog.h
468 %{_pkgconfigdir}/allegro_dialog-5.pc
469 %endif
470
471 %files image
472 %defattr(644,root,root,755)
473 %attr(755,root,root) %{_libdir}/liballegro_image.so.*.*.*
474 %attr(755,root,root) %ghost %{_libdir}/liballegro_image.so.5.2
475
476 %files image-devel
477 %defattr(644,root,root,755)
478 %attr(755,root,root) %{_libdir}/liballegro_image.so
479 %{_includedir}/allegro5/allegro_image.h
480 %{_pkgconfigdir}/allegro_image-5.pc
481
482 %if %{with physfs}
483 %files physfs
484 %defattr(644,root,root,755)
485 %attr(755,root,root) %{_libdir}/liballegro_physfs.so.*.*.*
486 %attr(755,root,root) %ghost %{_libdir}/liballegro_physfs.so.5.2
487
488 %files physfs-devel
489 %defattr(644,root,root,755)
490 %attr(755,root,root) %{_libdir}/liballegro_physfs.so
491 %{_includedir}/allegro5/allegro_physfs.h
492 %{_pkgconfigdir}/allegro_physfs-5.pc
493 %endif
494
495 %files ttf
496 %defattr(644,root,root,755)
497 %attr(755,root,root) %ghost %{_libdir}/liballegro_ttf.so.5.2
498 %attr(755,root,root) %{_libdir}/liballegro_ttf.so.*.*.*
499
500 %files ttf-devel
501 %defattr(644,root,root,755)
502 %attr(755,root,root) %{_libdir}/liballegro_ttf.so
503 %{_includedir}/allegro5/allegro_ttf.h
504 %{_pkgconfigdir}/allegro_ttf-5.pc
505
506 %files examples
507 %defattr(644,root,root,755)
508 %attr(755,root,root) %{_bindir}/ex_acodec
509 %attr(755,root,root) %{_bindir}/ex_acodec_multi
510 %attr(755,root,root) %{_bindir}/ex_audio_chain
511 %attr(755,root,root) %{_bindir}/ex_audio_props
512 %attr(755,root,root) %{_bindir}/ex_audio_simple
513 %attr(755,root,root) %{_bindir}/ex_audio_timer
514 %attr(755,root,root) %{_bindir}/ex_bitmap
515 %attr(755,root,root) %{_bindir}/ex_bitmap_flip
516 %attr(755,root,root) %{_bindir}/ex_blend
517 %attr(755,root,root) %{_bindir}/ex_blend2
518 %attr(755,root,root) %{_bindir}/ex_blend_bench
519 %attr(755,root,root) %{_bindir}/ex_blend_test
520 %attr(755,root,root) %{_bindir}/ex_blit
521 %attr(755,root,root) %{_bindir}/ex_camera
522 %attr(755,root,root) %{_bindir}/ex_clip
523 %attr(755,root,root) %{_bindir}/ex_clipboard
524 %attr(755,root,root) %{_bindir}/ex_color
525 %attr(755,root,root) %{_bindir}/ex_compressed
526 %attr(755,root,root) %{_bindir}/ex_config
527 %attr(755,root,root) %{_bindir}/ex_convert
528 %attr(755,root,root) %{_bindir}/ex_cpu
529 %{?with_curl:%attr(755,root,root) %{_bindir}/ex_curl}
530 %attr(755,root,root) %{_bindir}/ex_depth_mask
531 %attr(755,root,root) %{_bindir}/ex_dir
532 %attr(755,root,root) %{_bindir}/ex_disable_screensaver
533 %attr(755,root,root) %{_bindir}/ex_display_events
534 %attr(755,root,root) %{_bindir}/ex_display_options
535 %attr(755,root,root) %{_bindir}/ex_draw
536 %attr(755,root,root) %{_bindir}/ex_draw_bitmap
537 %attr(755,root,root) %{_bindir}/ex_drawpixels
538 %attr(755,root,root) %{_bindir}/ex_dualies
539 %attr(755,root,root) %{_bindir}/ex_expose
540 %attr(755,root,root) %{_bindir}/ex_file
541 %attr(755,root,root) %{_bindir}/ex_file_slice
542 %attr(755,root,root) %{_bindir}/ex_filter
543 %attr(755,root,root) %{_bindir}/ex_font
544 %attr(755,root,root) %{_bindir}/ex_font_justify
545 %attr(755,root,root) %{_bindir}/ex_font_multiline
546 %attr(755,root,root) %{_bindir}/ex_fs_resize
547 %attr(755,root,root) %{_bindir}/ex_fs_window
548 %attr(755,root,root) %{_bindir}/ex_get_path
549 %attr(755,root,root) %{_bindir}/ex_gldepth
550 %attr(755,root,root) %{_bindir}/ex_glext
551 %attr(755,root,root) %{_bindir}/ex_haiku
552 %attr(755,root,root) %{_bindir}/ex_haptic
553 %attr(755,root,root) %{_bindir}/ex_haptic2
554 %attr(755,root,root) %{_bindir}/ex_icon
555 %attr(755,root,root) %{_bindir}/ex_icon2
556 %attr(755,root,root) %{_bindir}/ex_inject_events
557 %attr(755,root,root) %{_bindir}/ex_joystick_events
558 %attr(755,root,root) %{_bindir}/ex_joystick_hotplugging
559 %attr(755,root,root) %{_bindir}/ex_kcm_direct
560 %attr(755,root,root) %{_bindir}/ex_keyboard_events
561 %attr(755,root,root) %{_bindir}/ex_keyboard_focus
562 %attr(755,root,root) %{_bindir}/ex_lines
563 %attr(755,root,root) %{_bindir}/ex_loading_thread
564 %attr(755,root,root) %{_bindir}/ex_lockbitmap
565 %attr(755,root,root) %{_bindir}/ex_logo
566 %attr(755,root,root) %{_bindir}/ex_membmp
567 %attr(755,root,root) %{_bindir}/ex_memfile
568 %attr(755,root,root) %{_bindir}/ex_menu
569 %attr(755,root,root) %{_bindir}/ex_mixer_chain
570 %attr(755,root,root) %{_bindir}/ex_mixer_pp
571 %attr(755,root,root) %{_bindir}/ex_monitorinfo
572 %attr(755,root,root) %{_bindir}/ex_mouse
573 %attr(755,root,root) %{_bindir}/ex_mouse_cursor
574 %attr(755,root,root) %{_bindir}/ex_mouse_events
575 %attr(755,root,root) %{_bindir}/ex_mouse_focus
576 %attr(755,root,root) %{_bindir}/ex_mouse_warp
577 %attr(755,root,root) %{_bindir}/ex_multisample
578 %attr(755,root,root) %{_bindir}/ex_multiwin
579 %attr(755,root,root) %{_bindir}/ex_native_filechooser
580 %attr(755,root,root) %{_bindir}/ex_nodisplay
581 %attr(755,root,root) %{_bindir}/ex_noframe
582 %attr(755,root,root) %{_bindir}/ex_opengl
583 %attr(755,root,root) %{_bindir}/ex_opengl_pixel_shader
584 %attr(755,root,root) %{_bindir}/ex_palette
585 %attr(755,root,root) %{_bindir}/ex_path
586 %attr(755,root,root) %{_bindir}/ex_path_test
587 %{?with_physfs:%attr(755,root,root) %{_bindir}/ex_physfs}
588 %attr(755,root,root) %{_bindir}/ex_pixelformat
589 %attr(755,root,root) %{_bindir}/ex_polygon
590 %attr(755,root,root) %{_bindir}/ex_premulalpha
591 %attr(755,root,root) %{_bindir}/ex_prim
592 %attr(755,root,root) %{_bindir}/ex_prim_shader
593 %attr(755,root,root) %{_bindir}/ex_projection
594 %attr(755,root,root) %{_bindir}/ex_projection2
595 %attr(755,root,root) %{_bindir}/ex_record
596 %attr(755,root,root) %{_bindir}/ex_record_name
597 %attr(755,root,root) %{_bindir}/ex_reparent
598 %attr(755,root,root) %{_bindir}/ex_resample_test
599 %attr(755,root,root) %{_bindir}/ex_resize
600 %attr(755,root,root) %{_bindir}/ex_resize2
601 %attr(755,root,root) %{_bindir}/ex_rotate
602 %attr(755,root,root) %{_bindir}/ex_saw
603 %attr(755,root,root) %{_bindir}/ex_scale
604 %attr(755,root,root) %{_bindir}/ex_shader
605 %attr(755,root,root) %{_bindir}/ex_shader_multitex
606 %attr(755,root,root) %{_bindir}/ex_shader_target
607 %attr(755,root,root) %{_bindir}/ex_stream_file
608 %attr(755,root,root) %{_bindir}/ex_stream_seek
609 %attr(755,root,root) %{_bindir}/ex_subbitmap
610 %attr(755,root,root) %{_bindir}/ex_synth
611 %attr(755,root,root) %{_bindir}/ex_threads
612 %attr(755,root,root) %{_bindir}/ex_threads2
613 %attr(755,root,root) %{_bindir}/ex_timedwait
614 %attr(755,root,root) %{_bindir}/ex_timer
615 %attr(755,root,root) %{_bindir}/ex_timer_pause
616 %attr(755,root,root) %{_bindir}/ex_touch_input
617 %attr(755,root,root) %{_bindir}/ex_transform
618 %attr(755,root,root) %{_bindir}/ex_ttf
619 %attr(755,root,root) %{_bindir}/ex_user_events
620 %attr(755,root,root) %{_bindir}/ex_utf8
621 %attr(755,root,root) %{_bindir}/ex_vertex_buffer
622 %attr(755,root,root) %{_bindir}/ex_video
623 %attr(755,root,root) %{_bindir}/ex_vsync
624 %attr(755,root,root) %{_bindir}/ex_window_constraints
625 %attr(755,root,root) %{_bindir}/ex_windows
626 %attr(755,root,root) %{_bindir}/ex_window_title
627 %attr(755,root,root) %{_bindir}/ex_winfull
628
629 %if %{with python}
630 %files -n python-%{name}
631 %defattr(644,root,root,755)
632 %{py_sitescriptdir}/allegro.py[co]
633 %endif
This page took 0.109004 seconds and 3 git commands to generate.