]> git.pld-linux.org Git - packages/allegro.git/blobdiff - allegro.spec
- now we have svgalib on all supported archs
[packages/allegro.git] / allegro.spec
index c7a3a6408bf8f544fad4af0e018b9261e6874298..2af23ed467b9e5446416f0809fcc841fd037f5ff 100644 (file)
@@ -1,34 +1,64 @@
+#
+# Conditional build:
+%bcond_without alsa    # without ALSA modules
+%bcond_without arts    # without aRts module
+%bcond_without jack    # without JACK module
+%bcond_without dbglib  # don't build debug versions of library
+%bcond_without proflib # don't debug profiling versions of library
+%bcond_without svga    # without svgalib module
+%bcond_without sse     # build without sse (valgrind doesn't support it yet)
+#
 Summary:       A game programming library
+Summary(de):   Eine Bibliothek zur Programmierung von Spielen
+Summary(es):   Una libreria de programacion de juegos
+Summary(fr):   Une librairie de programmation de jeux
+Summary(it):   Una libreria per la programmazione di videogiochi
 Summary(pl):   Biblioteka do programowania gier
 Name:          allegro
-Version:       4.1.0
-Release:       0.1
+Version:       4.1.14
+Release:       1
 License:       Giftware
-Group:         X11/Libraries
-Source0:       http://belnet.dl.sourceforge.net/sourceforge/alleg/%{name}-%{version}.tar.gz
-Patch0:                %{name}-makefile.patch
-Patch1:                %{name}-info.patch
-#Patch2:       %{name}-alsa9.patch
-Patch3:                %{name}-examples.patch
-URL:           http://alleg.sourceforge.net
+Group:         Libraries
+Source0:       http://dl.sourceforge.net/alleg/%{name}-%{version}.tar.gz
+# Source0-md5: f91225cfd2429b8f0ba01f026981b681
+Patch0:                %{name}-info.patch
+Patch1:                %{name}-examples.patch
+Patch2:                %{name}-opt.patch
+Patch3:                %{name}-ldflags.patch
+Patch4:                %{name}-frame-pointer.patch
+Patch5:                %{name}-alsa-1_0.patch
+URL:           http://alleg.sourceforge.net/
 BuildRequires: XFree86-devel
+%{?with_alsa:BuildRequires:    alsa-lib-devel}
+%{?with_arts:BuildRequires:    arts-devel}
+BuildRequires: autoconf >= 2.53
+BuildRequires: automake
 BuildRequires: esound-devel
-%ifnarch sparc sparc64
-BuildRequires: alsa-lib-devel
-%endif
-%ifarch %{ix86} alpha
-BuildRequires: svgalib-devel
-%endif
+%{?with_jack:BuildRequires:    jack-audio-connection-kit-devel}
+%{?with_svga:BuildRequires:    svgalib-devel}
 BuildRequires: texinfo
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _prefix         /usr/X11R6
-%define                _mandir         %{_prefix}/man
-
 %description
 Allegro is a cross-platform library intended for use in computer games
 and other types of multimedia programming.
 
+%description -l de
+Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
+Computerspielen und anderen Formen von Multinediaprogrammierung.
+
+%description -l es
+Allegro es una librería multi-plataforma creada para ser usada en la
+programación de juegos u otro tipo de programación multimedia.
+
+%description -l fr
+Allegro est une librairie multi-plateforme destinée à être utilisée dans
+les jeux vidéo ou d'autres types de programmation multimédia.
+
+%description -l it
+Allegro è una libreria multipiattaforma dedicata all'uso nei videogiochi
+ed in altri tipi di programmazione multimediale.
+
 %description -l pl
 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
@@ -36,8 +66,8 @@ grach komputerowych i innych rodzajach oprogramowania multimedialnego.
 %package devel
 Summary:       A game programming library - header files
 Summary(pl):   Biblioteka do programowania gier - pliki nag³ówkowe
-Group:         X11/Development/Libraries
-Requires:      %{name} = %{version}
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
 
 %description devel
 Allegro is a cross-platform library intended for use in computer games
@@ -46,6 +76,27 @@ and other types of multimedia programming.
 This package contains header files neccessary for compiling
 applications using allegro library.
 
+%description devel -l de
+Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
+Computerspielen und anderen Formen von Multinediaprogrammierung.
+Dieses Paket wird benötigt, um Programme zu bauen, die Allegro
+verwenden.
+
+%description devel -l es
+Allegro es una librería multi-plataforma creada para ser usada en la
+programación de juegos u otro tipo de programación multimedia. Este
+paquete es necesario para compilar los programas que usen Allegro.
+
+%description devel -l fr
+Allegro est une librairie multi-plateforme destinée à être utilisée dans
+les jeux vidéo ou d'autres types de programmation multimédia. Ce package
+est nécessaire pour compiler les programmes utilisant Allegro.
+
+%description devel -l it
+Allegro è una libreria multipiattaforma dedicata all'uso nei videogiochi
+ed in altri tipi di programmazione multimediale. Questo pacchetto è
+necessario per compilare programmi scritti con Allegro.
+
 %description devel -l pl
 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
@@ -53,36 +104,11 @@ grach komputerowych i innych rodzajach oprogramowania multimedialnego.
 Ten pakiet zawiera pliki nag³ówkowe niezbêdne do kompilowania
 aplikacji wykorzystuj±cych bibliotekê allegro.
 
-%package tests
-Summary:       A game programming library - test programs
-Summary(pl):   Biblioteka do programowania gier - programy testuj±ce
-Group:         X11/Development/Libraries
-Requires:      %{name} = %{version}
-
-%description tests
-This package contains programs for testing allegro library.
-
-%description tests -l pl
-Pakiet zawiera programy testuj±ce bibliotekê allegro.
-
-%package examples
-Summary:       A game programming library - examples
-Summary(pl):   Biblioteka do programowania gier - programy przyk³adowe
-Group:         X11/Development/Libraries
-Requires:      %{name} = %{version}
-
-%description examples
-This package contains example programs which are showing
-allegro features.
-
-%description examples -l pl
-Pakiet zawiera programy przyk³adowe demonstruj±ce mo?liwo¶ci biblioteki allegro.
-
 %package static
 Summary:       A game programming library - static libraries
 Summary(pl):   Biblioteka do programowania gier - biblioteki statyczne
-Group:         X11/Development/Libraries
-Requires:      %{name}-devel = %{version}
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 Allegro is a cross-platform library intended for use in computer games
@@ -95,14 +121,67 @@ applications.
 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
 
-Ten pakiet zawiera biblioteki statyczne do linkowania z aplikacjami
+Ten pakiet zawiera biblioteki statyczne do konsolidacji z aplikacjami
 wykorzystuj±cymi allegro.
 
+%package debug
+Summary:       liballd - debug version of shared allegro library
+Summary(pl):   liballd - wersja debug dzielonej biblioteki allegro
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
+
+%description debug
+liballd - debug version of shared allegro library (contains debugging
+symbols and other information).
+
+%description debug -l pl
+liballd - wersja debug dzielonej biblioteki allegro (zawieraj±ca
+symbole i inne informacje potrzebne przy odpluskwianiu).
+
+%package debug-static
+Summary:       liballd - debug version of static allegro library
+Summary(pl):   liballd - wersja debug statycznej biblioteki allegro
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
+
+%description debug-static
+liballd - debug version of static allegro library (contains debugging
+symbols and other information).
+
+%description debug-static -l pl
+liballd - wersja debug statycznej biblioteki allegro (zawieraj±ca
+symbole i inne informacje potrzebne przy odpluskwianiu).
+
+%package profile
+Summary:       liballp - profiling version of shared allegro library
+Summary(pl):   liballp - wersja dzielonej biblioteki allegro s³u¿±ca do profilowania
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
+
+%description profile
+liballp - profiling version of shared allegro library.
+
+%description profile -l pl
+liballp - wersja dzielonej biblioteki allegro s³u¿±ca do profilowania.
+
+%package profile-static
+Summary:       liballp - profiling version of static allegro library
+Summary(pl):   liballp - wersja statycznej biblioteki allegro s³u¿±ca do profilowania
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
+
+%description profile-static
+liballp - profiling version of static allegro library.
+
+%description debug-static -l pl
+liballp - wersja statycznej biblioteki allegro s³u¿±ca do
+profilowania.
+
 %package svgalib
 Summary:       A game programming library - svgalib module
 Summary(pl):   Biblioteka do programowania gier - modu³ dla svgalib
-Group:         X11/Libraries
-PreReq:                %{name} = %{version}
+Group:         Libraries
+PreReq:                %{name} = %{version}-%{release}
 
 %description svgalib
 Allegro is a cross-platform library intended for use in computer games
@@ -119,8 +198,8 @@ Ten pakiet zawiera modu
 %package dga2
 Summary:       A game programming library - DGA2 module
 Summary(pl):   Biblioteka do programowania gier - modu³ dla DGA2
-Group:         X11/Libraries
-PreReq:                %{name} = %{version}
+Group:         Libraries
+PreReq:                %{name} = %{version}-%{release}
 
 %description dga2
 Allegro is a cross-platform library intended for use in computer games
@@ -137,8 +216,8 @@ Ten pakiet zawiera modu
 %package esd
 Summary:       A game programming library - esound module
 Summary(pl):   Biblioteka do programowania gier - modu³ dla esound
-Group:         X11/Libraries
-PreReq:                %{name} = %{version}
+Group:         Libraries
+PreReq:                %{name} = %{version}-%{release}
 
 %description esd
 Allegro is a cross-platform library intended for use in computer games
@@ -152,11 +231,66 @@ grach komputerowych i innych rodzajach oprogramowania multimedialnego.
 
 Ten pakiet zawiera modu³ do wykorzystania z demonem ESound.
 
+%package arts
+Summary:       A game programming library - aRts module
+Summary(pl):   Biblioteka do programowania gier - modu³ dla aRts
+Group:         Libraries
+PreReq:                %{name} = %{version}-%{release}
+
+%description arts
+Allegro is a cross-platform library intended for use in computer games
+and other types of multimedia programming.
+
+This package contains a esound module for use with aRts.
+
+%description arts -l pl
+Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
+grach komputerowych i innych rodzajach oprogramowania multimedialnego.
+
+Ten pakiet zawiera modu³ do wykorzystania z aRts.
+
+%package fbcon
+Summary:       A game programming library - framebuffer module
+Summary(pl):   Biblioteka do programowania gier - modu³ dla framebuffera
+Group:         Libraries
+PreReq:                %{name} = %{version}-%{release}
+
+%description fbcon
+Allegro is a cross-platform library intended for use in computer games
+and other types of multimedia programming.
+
+This package contains a esound module for use with framebuffer.
+
+%description fbcon -l pl
+Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
+grach komputerowych i innych rodzajach oprogramowania multimedialnego.
+
+Ten pakiet zawiera modu³ do wykorzystania z framebufferem.
+
+%package vga
+Summary:       A game programming library - vga module
+Summary(pl):   Biblioteka do programowania gier - modu³ dla vga
+Group:         Libraries
+PreReq:                %{name} = %{version}-%{release}
+
+%description vga
+Allegro is a cross-platform library intended for use in computer games
+and other types of multimedia programming.
+
+This package contains a esound module for use with vga.
+
+%description vga -l pl
+Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
+grach komputerowych i innych rodzajach oprogramowania multimedialnego.
+
+Ten pakiet zawiera modu³ do wykorzystania z vga.
+
 %package alsa
 Summary:       A game programming library - ALSA modules
 Summary(pl):   Biblioteka do programowania gier - modu³y dla ALSA
-Group:         X11/Libraries
-PreReq:                %{name} = %{version}
+Group:         Libraries
+PreReq:                %{name} = %{version}-%{release}
+Obsoletes:     allegro-alsa9
 
 %description alsa
 Allegro is a cross-platform library intended for use in computer games
@@ -171,11 +305,34 @@ grach komputerowych i innych rodzajach oprogramowania multimedialnego.
 Ten pakiet zawiera modu³y do wykorzystania z bibliotek± d¼wiêkow±
 ALSA.
 
+%package jack
+Summary:       A game programming library - JACK module
+Summary(pl):   Biblioteka do programowania gier - modu³ dla JACK
+Group:         Libraries
+PreReq:                %{name} = %{version}-%{release}
+
+%description jack
+Allegro is a cross-platform library intended for use in computer games
+and other types of multimedia programming.
+
+This package contains module for use with JACK sound library.
+
+%description alsa -l pl
+Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
+grach komputerowych i innych rodzajach oprogramowania multimedialnego.
+
+Ten pakiet zawiera modu³ do wykorzystania z bibliotek± d¼wiêkow±
+JACK.
+
 %package tools
 Summary:       A game programming library - tools
+Summary(de):   Zusätzliche Hilfprogramme für die Allegro Bibliothek
+Summary(es):   Herramientas adicionales para la librería de programación Allegro
+Summary(fr):   Outils supplémentaires pour la librairie de programmation Allegro
+Summary(it):   Programmi di utilità aggiuntivi per la libreria Allegro
 Summary(pl):   Biblioteka do programowania gier - narzêdzia
-Group:         X11/Libraries
-PreReq:                %{name} = %{version}
+Group:         Libraries
+PreReq:                %{name} = %{version}-%{release}
 
 %description tools
 Allegro is a cross-platform library intended for use in computer games
@@ -183,32 +340,93 @@ and other types of multimedia programming.
 
 This package contains tools.
 
+%description tools -l de
+Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
+Computerspielen und anderen Formen von Multinediaprogrammierung.
+Dieses Paket enthält Programme, die für die Entwicklung von
+Allegro Programmen hilfreich sind.
+
+%description tools -l es
+Allegro es una librería multi-plataforma creada para ser usada en la
+programación de juegos u otro tipo de programación multimedia. Este
+paquete contiene herramientas adicionales que son útiles para
+desarrollar programas que usen Allegro.
+
+%description tools -l fr
+Allegro est une librairie multi-plateforme destinée à être utilisée dans
+les jeux vidéo ou d'autres types de programmation multimédia. Ce package
+contient des outils supplémentaires qui sont utiles pour le développement
+de programmes avec Allegro.
+
+%description tools -l it
+Allegro è una libreria multipiattaforma dedicata all'uso nei videogiochi
+ed in altri tipi di programmazione multimediale. Questo pacchetto
+contiene programmi di utilità aggiuntivi utili allo sviluppo di programmi
+con Allegro.
+
 %description tools -l pl
 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
 
 Ten pakiet zawiera narzêdzia.
 
+%package tests
+Summary:       A game programming library - test programs
+Summary(pl):   Biblioteka do programowania gier - programy testuj±ce
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
+
+%description tests
+This package contains programs for testing allegro library.
+
+%description tests -l pl
+Pakiet zawiera programy testuj±ce bibliotekê allegro.
+
+%package examples
+Summary:       A game programming library - examples
+Summary(pl):   Biblioteka do programowania gier - programy przyk³adowe
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
+
+%description examples
+This package contains example programs which demonstrate allegro
+features.
+
+%description examples -l pl
+Pakiet zawiera programy przyk³adowe demonstruj±ce mo¿liwo¶ci
+biblioteki allegro.
+
 %prep
-%setup  -q
-%patch3 -p1
+%setup -q
 %patch0 -p1
 %patch1 -p1
-#%patch2 -p1
+%patch2 -p1
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
 
 %build
-aclocal
+%{__aclocal}
+%{__autoheader} configure.in > include/allegro/platform/alunixac.hin
 %{__autoconf}
+TARGET_ARCH="%{rpmcflags}" export TARGET_ARCH
+# dbglib & proflib are compiled besides normlib, so it's ok to have them here
 %configure \
        --enable-static \
-       --enable-dbglib \
-       --enable-proflib \
-%ifnarch %{ix86} alpha
-       --disable-vga \
-       --disable-linux
+       %{!?with_svga:--disable-svgalib} \
+       %{?with_dbglib:--enable-dbglib} \
+       %{?with_proflib:--enable-proflib} \
+       %{!?with_arts:--disable-artsdigi} \
+       %{!?with_sse:--disable-sse} \
+       %{!?with_sse:--disable-asm} \
+%ifnarch %{ix86}
+       --disable-asm \
+       --disable-mmx \
+       --disable-sse
 %endif
-       
-%{__make} MAKEINFO=makeinfo
+
+%{__make} \
+       MAKEINFO=makeinfo
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -216,82 +434,135 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install install-man install-info install-lib \
        DESTDIR=$RPM_BUILD_ROOT
 
-echo -e "# List of modules to be loaded by the Unix version of Allegro.\n" \
-       > $RPM_BUILD_ROOT%{_libdir}/allegro/4.1/modules.lst
+install modules.lst $RPM_BUILD_ROOT%{_libdir}/allegro/4.1
+
+mv $RPM_BUILD_ROOT%{_bindir}/demo{,-allegro}
+mv $RPM_BUILD_ROOT%{_bindir}/play{,-allegro}
+mv $RPM_BUILD_ROOT%{_bindir}/setup{,-allegro}
+mv $RPM_BUILD_ROOT%{_bindir}/test{,-allegro}
+
+# help rpm to find reqs for ELF objects
+chmod 755 $RPM_BUILD_ROOT%{_libdir}/{*.so,allegro/*/*.so}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
+
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS CHANGES THANKS
 %attr(755,root,root) %{_libdir}/liballeg-%{version}.so
-%dir %{_libdir}/allegro/
+%dir %{_libdir}/allegro
+%dir %{_libdir}/allegro/4.1
 %{_libdir}/allegro/4.1/modules.lst
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/liballd-%{version}.so
-%attr(755,root,root) %{_libdir}/liballp-%{version}.so
-%{_includedir}/*
 %attr(755,root,root) %{_bindir}/allegro-config
+%{_libdir}/liballeg_unsharable.a
+%{_includedir}/*
 %{_mandir}/man3/*
-%{_infodir}/*
-%{_libdir}/*_unsharable.a
+%{_infodir}/*.info*
 
-%files tools
+%files static
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/colormap
-%attr(755,root,root) %{_bindir}/exedat
-%attr(755,root,root) %{_bindir}/pack
-%attr(755,root,root) %{_bindir}/rgbmap
-%attr(755,root,root) %{_bindir}/textconv
-%attr(755,root,root) %{_bindir}/dat
-%attr(755,root,root) %{_bindir}/dat2s
-%attr(755,root,root) %{_bindir}/grabber
-%attr(755,root,root) %{_bindir}/pat2dat
+%{_libdir}/liballeg.a
 
-%files static
+%if %{with dbglib}
+%files debug
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/liballd-%{version}.so
+%{_libdir}/liballd_unsharable.a
+
+%files debug-static
 %defattr(644,root,root,755)
 %{_libdir}/liballd.a
-%{_libdir}/liballeg.a
+%endif
+
+%if %{with proflib}
+%files profile
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/liballp-%{version}.so
+%{_libdir}/liballp_unsharable.a
+
+%files profile-static
+%defattr(644,root,root,755)
 %{_libdir}/liballp.a
+%endif
 
-%ifarch %{ix86} alpha
+%if %{with svga}
 %files svgalib
 %defattr(644,root,root,755)
-%{_libdir}/allegro/4.1/alleg-svgalib.so
+%attr(755,root,root) %{_libdir}/allegro/4.1/alleg-svgalib.so
 %endif
 
 %files dga2
 %defattr(644,root,root,755)
-%{_libdir}/allegro/4.1/alleg-dga2.so
+%attr(755,root,root) %{_libdir}/allegro/4.1/alleg-dga2.so
 
 %files esd
 %defattr(644,root,root,755)
-%{_libdir}/allegro/4.1/alleg-esddigi.so
+%attr(755,root,root) %{_libdir}/allegro/4.1/alleg-esddigi.so
+
+%if %{with arts}
+%files arts
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/allegro/4.1/alleg-artsdigi.so
+%endif
+
+%files fbcon
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/allegro/4.1/alleg-fbcon.so
+
+%ifarch %{ix86}
+%files vga
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/allegro/4.1/alleg-vga.so
+%endif
 
-%if %{?_without_alsa:0}%{!?_without_alsa:1}
-%ifnarch sparc sparc64
+%if %{with alsa}
 %files alsa
 %defattr(644,root,root,755)
-%{_libdir}/allegro/4.1/alleg-alsadigi.so
-%{_libdir}/allegro/4.1/alleg-alsamidi.so
+%attr(755,root,root) %{_libdir}/allegro/4.1/alleg-alsadigi.so
+%attr(755,root,root) %{_libdir}/allegro/4.1/alleg-alsamidi.so
 %endif
+
+%if %{with jack}
+%files jack
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/allegro/4.1/alleg-jackdigi.so
 %endif
 
+%files tools
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/colormap
+%attr(755,root,root) %{_bindir}/exedat
+%attr(755,root,root) %{_bindir}/pack
+%attr(755,root,root) %{_bindir}/rgbmap
+%attr(755,root,root) %{_bindir}/textconv
+%attr(755,root,root) %{_bindir}/dat
+%attr(755,root,root) %{_bindir}/dat2c
+%attr(755,root,root) %{_bindir}/dat2s
+%attr(755,root,root) %{_bindir}/grabber
+%attr(755,root,root) %{_bindir}/pat2dat
+%attr(755,root,root) %{_bindir}/setup-allegro
+%attr(755,root,root) %{_bindir}/keyconf
+
 %files tests
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/afinfo
 %attr(755,root,root) %{_bindir}/akaitest
+%attr(755,root,root) %{_bindir}/demo-allegro
 %attr(755,root,root) %{_bindir}/digitest
 %attr(755,root,root) %{_bindir}/filetest
 %attr(755,root,root) %{_bindir}/gfxinfo
 %attr(755,root,root) %{_bindir}/mathtest
 %attr(755,root,root) %{_bindir}/miditest
-%attr(755,root,root) %{_bindir}/play
+%attr(755,root,root) %{_bindir}/play-allegro
 %attr(755,root,root) %{_bindir}/playfli
-%attr(755,root,root) %{_bindir}/test
+%attr(755,root,root) %{_bindir}/test-allegro
 %attr(755,root,root) %{_bindir}/vesainfo
 
 %files examples
@@ -299,9 +570,14 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/ex12bit
 %attr(755,root,root) %{_bindir}/ex3buf
 %attr(755,root,root) %{_bindir}/ex3d
+%attr(755,root,root) %{_bindir}/exaccel
 %attr(755,root,root) %{_bindir}/exalpha
 %attr(755,root,root) %{_bindir}/exbitmap
 %attr(755,root,root) %{_bindir}/exblend
+%attr(755,root,root) %{_bindir}/excamera
+%attr(755,root,root) %{_bindir}/excolmap
+%attr(755,root,root) %{_bindir}/exconfig
+%attr(755,root,root) %{_bindir}/excustom
 %attr(755,root,root) %{_bindir}/exdata
 %attr(755,root,root) %{_bindir}/exdbuf
 %attr(755,root,root) %{_bindir}/exdodgy
@@ -322,13 +598,19 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/exquat
 %attr(755,root,root) %{_bindir}/exrgbhsv
 %attr(755,root,root) %{_bindir}/exsample
+%attr(755,root,root) %{_bindir}/exscale
+%attr(755,root,root) %{_bindir}/exscn3d
+%attr(755,root,root) %{_bindir}/exscroll
 %attr(755,root,root) %{_bindir}/exshade
 %attr(755,root,root) %{_bindir}/exspline
 %attr(755,root,root) %{_bindir}/exsprite
 %attr(755,root,root) %{_bindir}/exstars
 %attr(755,root,root) %{_bindir}/exstream
+%attr(755,root,root) %{_bindir}/exswitch
 %attr(755,root,root) %{_bindir}/extimer
 %attr(755,root,root) %{_bindir}/extrans
+%attr(755,root,root) %{_bindir}/extruec
+%attr(755,root,root) %{_bindir}/exunicod
 %attr(755,root,root) %{_bindir}/exupdate
 %attr(755,root,root) %{_bindir}/exxfade
 %attr(755,root,root) %{_bindir}/exzbuf
This page took 0.118253 seconds and 4 git commands to generate.