]> git.pld-linux.org Git - packages/allegro.git/blobdiff - allegro.spec
- svga is no more - bcond disabled
[packages/allegro.git] / allegro.spec
index 487405705f5e49862547a342d2b01bbccc1e07ac..191d86b5d573500b87d6b1ae0f1406f3935b966c 100644 (file)
@@ -1,83 +1,89 @@
 #
-# TODO: Handle situations when there are no modules (most bconds turned off)
-#
 # Conditional build:
 %bcond_without alsa    # without ALSA modules
-%bcond_without arts    # without aRts module
 %bcond_without dga2    # without DGA2 module
-%bcond_without dbglib  # don't build debug versions of library
-%bcond_without esd     # without esound module
-%bcond_without fbcon   # without framebuffer module
 %bcond_without jack    # without JACK module
-%bcond_without proflib # don't debug profiling versions of library
-%bcond_without sse     # build without sse
-%bcond_without static  # don't build static versions of library
-%bcond_without svga    # without svgalib module
-%bcond_without vga     # without vga module
+%bcond_with    svga    # without svgalib module
+%bcond_without vga     # without vga module (x86-only)
 #
+%ifnarch %{ix86}
+# x86_64 too?
+%undefine      with_vga
+%endif
 Summary:       A game programming library
-Summary(de):   Eine Bibliothek zur Programmierung von Spielen
-Summary(es):   Una biblioteca de programación de juegos
-Summary(fr):   Une librairie de programmation de jeux
-Summary(it):   Una libreria per la programmazione di videogiochi
-Summary(pl):   Biblioteka do programowania gier
+Summary(de.UTF-8):     Eine Bibliothek zur Programmierung von Spielen
+Summary(es.UTF-8):     Una biblioteca de programación de juegos
+Summary(fr.UTF-8):     Une librairie de programmation de jeux
+Summary(it.UTF-8):     Una libreria per la programmazione di videogiochi
+Summary(pl.UTF-8):     Biblioteka do programowania gier
 Name:          allegro
-Version:       4.2.0
-Release:       1
+Version:       4.4.1.1
+Release:       2
 License:       Giftware
 Group:         Libraries
-Source0:       http://dl.sourceforge.net/alleg/%{name}-%{version}.tar.gz
-# Source0-md5: a8b2c85c58b16345fe735f72763f3a6e
+Source0:       http://downloads.sourceforge.net/alleg/%{name}-%{version}.tar.gz
+# Source0-md5: 0f1cfff8f2cf88e5c91a667d9fd386ec
 Patch0:                %{name}-info.patch
-Patch1:                %{name}-examples.patch
-Patch2:                %{name}-opt.patch
-Patch3:                %{name}-ldflags.patch
-Patch4:                %{name}-frame-pointer.patch
+Patch1:                %{name}-config.patch
 URL:           http://alleg.sourceforge.net/
-BuildRequires: X11-devel
+BuildRequires: OpenGL-GLU-devel
+BuildRequires: OpenGL-devel
 %{?with_alsa:BuildRequires:    alsa-lib-devel}
-%{?with_arts:BuildRequires:    artsc-devel}
-BuildRequires: autoconf >= 2.53
-BuildRequires: automake
-%{?with_esd:BuildRequires:     esound-devel}
-%if %{with jack}
+BuildRequires: cmake >= 2.6
 BuildRequires: jack-audio-connection-kit-devel
+BuildRequires: libogg-devel
+BuildRequires: libpng-devel
+BuildRequires: libstdc++-devel
+BuildRequires: libvorbis-devel
 BuildRequires: pkgconfig
-%endif
+BuildRequires: rpmbuild(macros) >= 1.577
+BuildRequires: sed >= 4.0
 %{?with_svga:BuildRequires:    svgalib-devel}
 BuildRequires: texinfo
+BuildRequires: xorg-lib-libX11-devel
+BuildRequires: xorg-lib-libXcursor-devel
+BuildRequires: xorg-lib-libXext-devel
+BuildRequires: xorg-lib-libXpm-devel
+BuildRequires: xorg-lib-libXxf86dga-devel
+BuildRequires: xorg-lib-libXxf86vm-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 Allegro is a cross-platform library intended for use in computer games
 and other types of multimedia programming.
 
-%description -l de
-Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
+%description -l de.UTF-8
+Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
 Computerspielen und anderen Formen von Multinediaprogrammierung.
 
-%description -l es
-Allegro es una librería multi-plataforma creada para ser usada en la
-programación de juegos u otro tipo de programación multimedia.
+%description -l es.UTF-8
+Allegro es una librería multi-plataforma creada para ser usada en la
+programación de juegos u otro tipo de programación multimedia.
 
-%description -l fr
-Allegro est une librairie multi-plateforme destinée à être utilisée
-dans les jeux vidéo ou d'autres types de programmation multimédia.
+%description -l fr.UTF-8
+Allegro est une librairie multi-plateforme destinée à être utilisée
+dans les jeux vidéo ou d'autres types de programmation multimédia.
 
-%description -l it
-Allegro è una libreria multipiattaforma dedicata all'uso nei
+%description -l it.UTF-8
+Allegro è una libreria multipiattaforma dedicata all'uso nei
 videogiochi ed in altri tipi di programmazione multimediale.
 
-%description -l pl
-Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
+%description -l pl.UTF-8
+Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
 
 %package devel
 Summary:       A game programming library - header files
-Summary(es):   Archivos de inclusión
-Summary(pl):   Biblioteka do programowania gier - pliki nag³ówkowe
+Summary(es.UTF-8):     Archivos de inclusión
+Summary(pl.UTF-8):     Biblioteka do programowania gier - pliki nagłówkowe
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
+Requires:      xorg-lib-libX11-devel
+Requires:      xorg-lib-libXcursor-devel
+Requires:      xorg-lib-libXext-devel
+Requires:      xorg-lib-libXpm-devel
+Requires:      xorg-lib-libXxf86vm-devel
+Obsoletes:     allegro-static
 
 %description devel
 Allegro is a cross-platform library intended for use in computer games
@@ -86,128 +92,37 @@ and other types of multimedia programming.
 This package contains header files neccessary for compiling
 applications using allegro library.
 
-%description devel -l de
-Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
+%description devel -l de.UTF-8
+Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
 Computerspielen und anderen Formen von Multinediaprogrammierung.
-Dieses Paket wird benötigt, um Programme zu bauen, die Allegro
+Dieses Paket wird benötigt, um Programme zu bauen, die Allegro
 verwenden.
 
-%description devel -l es
-Allegro es una librería multi-plataforma creada para ser usada en la
-programación de juegos u otro tipo de programación multimedia. Este
+%description devel -l es.UTF-8
+Allegro es una librería multi-plataforma creada para ser usada en la
+programación de juegos u otro tipo de programación multimedia. Este
 paquete es necesario para compilar los programas que usen Allegro.
 
-%description devel -l fr
-Allegro est une librairie multi-plateforme destinée à être utilisée
-dans les jeux vidéo ou d'autres types de programmation multimédia. Ce
-package est nécessaire pour compiler les programmes utilisant Allegro.
+%description devel -l fr.UTF-8
+Allegro est une librairie multi-plateforme destinée à être utilisée
+dans les jeux vidéo ou d'autres types de programmation multimédia. Ce
+package est nécessaire pour compiler les programmes utilisant Allegro.
 
-%description devel -l it
-Allegro è una libreria multipiattaforma dedicata all'uso nei
+%description devel -l it.UTF-8
+Allegro è una libreria multipiattaforma dedicata all'uso nei
 videogiochi ed in altri tipi di programmazione multimediale. Questo
-pacchetto è necessario per compilare programmi scritti con Allegro.
-
-%description devel -l pl
-Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
-grach komputerowych i innych rodzajach oprogramowania multimedialnego.
-
-Ten pakiet zawiera pliki nag³ówkowe niezbêdne do kompilowania
-aplikacji wykorzystuj±cych bibliotekê allegro.
-
-%package static
-Summary:       A game programming library - static libraries
-Summary(pl):   Biblioteka do programowania gier - biblioteki statyczne
-Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}-%{release}
-
-%description static
-Allegro is a cross-platform library intended for use in computer games
-and other types of multimedia programming.
-
-This package contains static libraries for linking with allegro
-applications.
-
-%description static -l pl
-Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
-grach komputerowych i innych rodzajach oprogramowania multimedialnego.
-
-Ten pakiet zawiera biblioteki statyczne do konsolidacji z aplikacjami
-wykorzystuj±cymi allegro.
-
-%package debug
-Summary:       liballd - debug version of shared allegro library
-Summary(pl):   liballd - wersja debug dzielonej biblioteki allegro
-Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}-%{release}
-
-%description debug
-liballd - debug version of shared allegro library (contains debugging
-symbols and other information).
-
-%description debug -l pl
-liballd - wersja debug dzielonej biblioteki allegro (zawieraj±ca
-symbole i inne informacje potrzebne przy odpluskwianiu).
-
-%package debug-static
-Summary:       liballd - debug version of static allegro library
-Summary(pl):   liballd - wersja debug statycznej biblioteki allegro
-Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}-%{release}
-
-%description debug-static
-liballd - debug version of static allegro library (contains debugging
-symbols and other information).
-
-%description debug-static -l pl
-liballd - wersja debug statycznej biblioteki allegro (zawieraj±ca
-symbole i inne informacje potrzebne przy odpluskwianiu).
-
-%package profile
-Summary:       liballp - profiling version of shared allegro library
-Summary(pl):   liballp - wersja dzielonej biblioteki allegro s³u¿±ca do profilowania
-Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}-%{release}
-
-%description profile
-liballp - profiling version of shared allegro library.
-
-%description profile -l pl
-liballp - wersja dzielonej biblioteki allegro s³u¿±ca do profilowania.
-
-%package profile-static
-Summary:       liballp - profiling version of static allegro library
-Summary(pl):   liballp - wersja statycznej biblioteki allegro s³u¿±ca do profilowania
-Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}-%{release}
-
-%description profile-static
-liballp - profiling version of static allegro library.
+pacchetto è necessario per compilare programmi scritti con Allegro.
 
-%description profile-static -l pl
-liballp - wersja statycznej biblioteki allegro s³u¿±ca do
-profilowania.
-
-%package svgalib
-Summary:       A game programming library - svgalib module
-Summary(pl):   Biblioteka do programowania gier - modu³ dla svgalib
-Group:         Libraries
-Requires:      %{name} = %{version}-%{release}
-
-%description svgalib
-Allegro is a cross-platform library intended for use in computer games
-and other types of multimedia programming.
-
-This package contains module for use with allegro and svgalib.
-
-%description svgalib -l pl
-Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
+%description devel -l pl.UTF-8
+Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
 
-Ten pakiet zawiera modu³ do wykorzystania allegro z svgalibem.
+Ten pakiet zawiera pliki nagłówkowe niezbędne do kompilowania
+aplikacji wykorzystujących bibliotekę allegro.
 
 %package dga2
 Summary:       A game programming library - DGA2 module
-Summary(pl):   Biblioteka do programowania gier - modu³ dla DGA2
+Summary(pl.UTF-8):     Biblioteka do programowania gier - moduł dla DGA2
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
 
@@ -217,69 +132,51 @@ and other types of multimedia programming.
 
 This package contains module for use with DGA.
 
-%description dga2 -l pl
-Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
-grach komputerowych i innych rodzajach oprogramowania multimedialnego.
-
-Ten pakiet zawiera modu³ do wykorzystania z DGA.
-
-%package esd
-Summary:       A game programming library - esound module
-Summary(pl):   Biblioteka do programowania gier - modu³ dla esound
-Group:         Libraries
-Requires:      %{name} = %{version}-%{release}
-
-%description esd
-Allegro is a cross-platform library intended for use in computer games
-and other types of multimedia programming.
-
-This package contains a esound module for use with ESound daemon.
-
-%description esd -l pl
-Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
+%description dga2 -l pl.UTF-8
+Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
 
-Ten pakiet zawiera modu³ do wykorzystania z demonem ESound.
+Ten pakiet zawiera moduł do wykorzystania z DGA.
 
-%package arts
-Summary:       A game programming library - aRts module
-Summary(pl):   Biblioteka do programowania gier - modu³ dla aRts
+%package fbcon
+Summary:       A game programming library - FrameBuffer module
+Summary(pl.UTF-8):     Biblioteka do programowania gier - moduł dla FrameBuffera
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
 
-%description arts
+%description fbcon
 Allegro is a cross-platform library intended for use in computer games
 and other types of multimedia programming.
 
-This package contains a esound module for use with aRts.
+This package contains module for use with Linux FrameBuffer.
 
-%description arts -l pl
-Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
+%description fbcon -l pl.UTF-8
+Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
 
-Ten pakiet zawiera modu³ do wykorzystania z aRts.
+Ten pakiet zawiera moduł do wykorzystania z linuksowym FrameBufferem.
 
-%package fbcon
-Summary:       A game programming library - framebuffer module
-Summary(pl):   Biblioteka do programowania gier - modu³ dla framebuffera
+%package svgalib
+Summary:       A game programming library - svgalib module
+Summary(pl.UTF-8):     Biblioteka do programowania gier - moduł dla svgalib
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
 
-%description fbcon
+%description svgalib
 Allegro is a cross-platform library intended for use in computer games
 and other types of multimedia programming.
 
-This package contains a esound module for use with framebuffer.
+This package contains module for use with allegro and svgalib.
 
-%description fbcon -l pl
-Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
+%description svgalib -l pl.UTF-8
+Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
 
-Ten pakiet zawiera modu³ do wykorzystania z framebufferem.
+Ten pakiet zawiera moduł do wykorzystania allegro z svgalibem.
 
 %package vga
 Summary:       A game programming library - vga module
-Summary(pl):   Biblioteka do programowania gier - modu³ dla vga
+Summary(pl.UTF-8):     Biblioteka do programowania gier - moduł dla vga
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
 
@@ -289,15 +186,15 @@ and other types of multimedia programming.
 
 This package contains a esound module for use with vga.
 
-%description vga -l pl
-Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
+%description vga -l pl.UTF-8
+Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
 
-Ten pakiet zawiera modu³ do wykorzystania z vga.
+Ten pakiet zawiera moduł do wykorzystania z vga.
 
 %package alsa
 Summary:       A game programming library - ALSA modules
-Summary(pl):   Biblioteka do programowania gier - modu³y dla ALSA
+Summary(pl.UTF-8):     Biblioteka do programowania gier - moduły dla ALSA
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
 Obsoletes:     allegro-alsa9
@@ -308,16 +205,16 @@ and other types of multimedia programming.
 
 This package contains modules for use with ALSA sound library.
 
-%description alsa -l pl
-Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
+%description alsa -l pl.UTF-8
+Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
 
-Ten pakiet zawiera modu³y do wykorzystania z bibliotek± d¼wiêkow±
+Ten pakiet zawiera moduły do wykorzystania z biblioteką dźwiękową
 ALSA.
 
 %package jack
 Summary:       A game programming library - JACK module
-Summary(pl):   Biblioteka do programowania gier - modu³ dla JACK-a
+Summary(pl.UTF-8):     Biblioteka do programowania gier - moduł dla JACK-a
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
 
@@ -327,19 +224,52 @@ and other types of multimedia programming.
 
 This package contains module for use with JACK sound library.
 
-%description jack -l pl
-Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
+%description jack -l pl.UTF-8
+Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
 
-Ten pakiet zawiera modu³ do wykorzystania z bibliotek± d¼wiêkow± JACK.
+Ten pakiet zawiera moduł do wykorzystania z biblioteką dźwiękową JACK.
+
+%package addons
+Summary:       Allegro addon libraries
+Summary(pl.UTF-8):     Dodatkowe biblioteki Allegro
+Group:         Libraries
+Requires:      %{name} = %{version}-%{release}
+Obsoletes:     allegro-gl
+
+%description addons
+Allegro addon libraries: AllegroGL, JPGAlleg, loadpng, logg.
+
+%description addons -l pl.UTF-8
+Dodatkowe biblioteki Allegro: AllegroGL, JPGAlleg, loadpng, logg.
+
+%package addons-devel
+Summary:       Header files for Allegro addon libraries
+Summary(pl.UTF-8):     Pliki nagłówkowe dodatkowych bibliotek Allegro
+Group:         Development/Libraries
+Requires:      %{name}-addons = %{version}-%{release}
+Requires:      %{name}-devel = %{version}-%{release}
+Requires:      OpenGL-GLU-devel
+Requires:      OpenGL-devel
+Requires:      libpng-devel
+Requires:      libvorbis-devel
+Obsoletes:     allegro-gl-devel
+
+%description addons-devel
+Header files for Allegro addon libraries: AllegroGL, JPGAlleg,
+loadpng, logg.
+
+%description addons-devel -l pl.UTF-8
+Pliki nagłówkowe dodatkowych bibliotek Allegro: AllegroGL, JPGAlleg,
+loadpng, logg.
 
 %package tools
 Summary:       A game programming library - tools
-Summary(de):   Zusätzliche Hilfprogramme für die Allegro Bibliothek
-Summary(es):   Herramientas adicionales para la librería de programación Allegro
-Summary(fr):   Outils supplémentaires pour la librairie de programmation Allegro
-Summary(it):   Programmi di utilità aggiuntivi per la libreria Allegro
-Summary(pl):   Biblioteka do programowania gier - narzêdzia
+Summary(de.UTF-8):     Zusätzliche Hilfprogramme für die Allegro Bibliothek
+Summary(es.UTF-8):     Herramientas adicionales para la librería de programación Allegro
+Summary(fr.UTF-8):     Outils supplémentaires pour la librairie de programmation Allegro
+Summary(it.UTF-8):     Programmi di utilità aggiuntivi per la libreria Allegro
+Summary(pl.UTF-8):     Biblioteka do programowania gier - narzędzia
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
 
@@ -349,51 +279,51 @@ and other types of multimedia programming.
 
 This package contains tools.
 
-%description tools -l de
-Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
+%description tools -l de.UTF-8
+Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
 Computerspielen und anderen Formen von Multinediaprogrammierung.
-Dieses Paket enthält Programme, die für die Entwicklung von Allegro
+Dieses Paket enthält Programme, die für die Entwicklung von Allegro
 Programmen hilfreich sind.
 
-%description tools -l es
-Allegro es una librería multi-plataforma creada para ser usada en la
-programación de juegos u otro tipo de programación multimedia. Este
-paquete contiene herramientas adicionales que son útiles para
+%description tools -l es.UTF-8
+Allegro es una librería multi-plataforma creada para ser usada en la
+programación de juegos u otro tipo de programación multimedia. Este
+paquete contiene herramientas adicionales que son útiles para
 desarrollar programas que usen Allegro.
 
-%description tools -l fr
-Allegro est une librairie multi-plateforme destinée à être utilisée
-dans les jeux vidéo ou d'autres types de programmation multimédia. Ce
-package contient des outils supplémentaires qui sont utiles pour le
-développement de programmes avec Allegro.
+%description tools -l fr.UTF-8
+Allegro est une librairie multi-plateforme destinée à être utilisée
+dans les jeux vidéo ou d'autres types de programmation multimédia. Ce
+package contient des outils supplémentaires qui sont utiles pour le
+développement de programmes avec Allegro.
 
-%description tools -l it
-Allegro è una libreria multipiattaforma dedicata all'uso nei
+%description tools -l it.UTF-8
+Allegro è una libreria multipiattaforma dedicata all'uso nei
 videogiochi ed in altri tipi di programmazione multimediale. Questo
-pacchetto contiene programmi di utilità aggiuntivi utili allo sviluppo
+pacchetto contiene programmi di utilità aggiuntivi utili allo sviluppo
 di programmi con Allegro.
 
-%description tools -l pl
-Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
+%description tools -l pl.UTF-8
+Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
 
-Ten pakiet zawiera narzêdzia.
+Ten pakiet zawiera narzędzia.
 
 %package tests
 Summary:       A game programming library - test programs
-Summary(pl):   Biblioteka do programowania gier - programy testuj±ce
+Summary(pl.UTF-8):     Biblioteka do programowania gier - programy testujące
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 
 %description tests
 This package contains programs for testing allegro library.
 
-%description tests -l pl
-Pakiet zawiera programy testuj±ce bibliotekê allegro.
+%description tests -l pl.UTF-8
+Pakiet zawiera programy testujące bibliotekę allegro.
 
 %package examples
 Summary:       A game programming library - examples
-Summary(pl):   Biblioteka do programowania gier - programy przyk³adowe
+Summary(pl.UTF-8):     Biblioteka do programowania gier - programy przykładowe
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 
@@ -401,67 +331,49 @@ Requires: %{name} = %{version}-%{release}
 This package contains example programs which demonstrate allegro
 features.
 
-%description examples -l pl
-Pakiet zawiera programy przyk³adowe demonstruj±ce mo¿liwo¶ci
+%description examples -l pl.UTF-8
+Pakiet zawiera programy przykładowe demonstrujące możliwości
 biblioteki allegro.
 
 %prep
 %setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
-%patch3 -p1
-%patch4 -p1
+
+sed -i -e 's/ADDON_LINKAGE STATIC/ADDON_LINKAGE SHARED/' CMakeLists.txt
 
 %build
-%{__aclocal}
-%{__autoheader} configure.in > include/allegro/platform/alunixac.hin
-%{__autoconf}
-TARGET_ARCH="%{rpmcflags}" export TARGET_ARCH
-# dbglib & proflib are compiled besides normlib, so it's ok to have them here
-%configure \
-       %{?with_static:--enable-static} \
-       %{?with_dbglib:--enable-dbglib} \
-       %{?with_proflib:--enable-proflib} \
-%if %{without alsa}
-       --disable-alsadigi \
-       --disable-alsamidi \
-%endif
-       %{!?with_arts:--disable-artsdigi} \
-       %{!?with_dga2:--disable-xwin-dga2} \
-       %{!?with_esd:--disable-esddigi} \
-       %{!?with_fbcon:--disable-fbcon} \
-       %{!?with_jack:--disable-jackdigi} \
-       %{!?with_svga:--disable-svgalib} \
-       %{!?with_vga:--disable-vga} \
-%if %{without sse}
-       --disable-sse \
-       --disable-asm \
-%endif
-%ifnarch %{ix86}
-       --disable-asm \
-       --disable-mmx \
-       --disable-sse
-%endif
+install -d build
+cd build
+%cmake .. \
+       -DINFODIR=%{_infodir} \
+       -DPLATFORM_LIBS=-ldl \
+       -DWANT_LINUX_CONSOLE=1 \
+       %{!?with_vga:-DWANT_LINUX_VGA=off} \
+       %{!?with_svga:-DWANT_LINUX_SVGALIB=off}
 
-%{__make} \
-       MAKEINFO=makeinfo
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_mandir}/man3
 
-%{__make} install install-man install-info install-lib \
+%{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install modules.lst $RPM_BUILD_ROOT%{_libdir}/allegro/4.2
+install modules.lst $RPM_BUILD_ROOT%{_libdir}/allegro/%{version}
+
+# install examples and tests
+find build/examples -maxdepth 1 -perm 755 -name "ex*" -exec install {} $RPM_BUILD_ROOT%{_bindir} \;
+find build/tests -maxdepth 1 -perm 755 ! -name CMakeFiles -exec install {} $RPM_BUILD_ROOT%{_bindir} \;
+
+# force install man pages
+cp build/docs/man/* $RPM_BUILD_ROOT%{_mandir}/man3
 
-mv $RPM_BUILD_ROOT%{_bindir}/demo{,-allegro}
 mv $RPM_BUILD_ROOT%{_bindir}/play{,-allegro}
-mv $RPM_BUILD_ROOT%{_bindir}/setup{,-allegro}
 mv $RPM_BUILD_ROOT%{_bindir}/test{,-allegro}
 
-# help rpm to find reqs for ELF objects
-chmod 755 $RPM_BUILD_ROOT%{_libdir}/{*.so,allegro/*/*.so}
+%{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc/allegro-4.4.1
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -469,112 +381,99 @@ rm -rf $RPM_BUILD_ROOT
 %post  -p /sbin/ldconfig
 %postun        -p /sbin/ldconfig
 
-%post devel
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
+%post  devel -p /sbin/postshell
+-/usr/sbin/fix-info-dir -c %{_infodir}
 
-%postun devel
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
+%postun        devel -p /sbin/postshell
+-/usr/sbin/fix-info-dir -c %{_infodir}
+
+%post  addons -p /sbin/ldconfig
+%postun        addons -p /sbin/ldconfig
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS CHANGES THANKS readme.txt
-%attr(755,root,root) %{_libdir}/liballeg-%{version}.so
+%doc AUTHORS CHANGES THANKS readme.txt todo.txt
+%attr(755,root,root) %{_libdir}/liballeg.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/liballeg.so.4.4
 %dir %{_libdir}/allegro
-%dir %{_libdir}/allegro/4.2
-%{_libdir}/allegro/4.2/modules.lst
+%dir %{_libdir}/allegro/4.4.1
+%{_libdir}/allegro/4.4.1/modules.lst
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/allegro-config
-%{_libdir}/liballeg_unsharable.a
-%{_includedir}/*
-%{_aclocaldir}/allegro.m4
-%{_mandir}/man3/*
-%{_infodir}/*.info*
-
-%if %{with static}
-%files static
-%defattr(644,root,root,755)
-%{_libdir}/liballeg.a
-%endif
-
-%if %{with dbglib}
-%files debug
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/liballd-%{version}.so
-%{_libdir}/liballd_unsharable.a
-
-%if %{with static}
-%files debug-static
-%defattr(644,root,root,755)
-%{_libdir}/liballd.a
-%endif
-%endif
-
-%if %{with proflib}
-%files profile
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/liballp-%{version}.so
-%{_libdir}/liballp_unsharable.a
-
-%if %{with static}
-%files profile-static
-%defattr(644,root,root,755)
-%{_libdir}/liballp.a
-%endif
-%endif
-
-%if %{with svga}
-%files svgalib
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/allegro/4.2/alleg-svgalib.so
-%endif
+%attr(755,root,root) %{_libdir}/liballeg.so
+%{_includedir}/allegro
+%{_includedir}/allegro.h
+%{_includedir}/linalleg.h
+%{_includedir}/xalleg.h
+# XXX: aren't some names too generic?
+%{_mandir}/man3/*.3*
+%{_infodir}/allegro.info*
+%{_pkgconfigdir}/allegro.pc
 
 %if %{with dga2}
 %files dga2
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/allegro/4.2/alleg-dga2.so
+%attr(755,root,root) %{_libdir}/allegro/4.4.1/alleg-dga2.so
 %endif
 
-%if %{with esd}
-%files esd
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/allegro/4.2/alleg-esddigi.so
-%endif
-
-%if %{with arts}
-%files arts
+%files fbcon
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/allegro/4.2/alleg-artsdigi.so
-%endif
+%attr(755,root,root) %{_libdir}/allegro/4.4.1/alleg-fbcon.so
 
-%if %{with fbcon}
-%files fbcon
+%if %{with svga}
+%files svgalib
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/allegro/4.2/alleg-fbcon.so
+%attr(755,root,root) %{_libdir}/allegro/4.4.1/alleg-svgalib.so
 %endif
 
-%ifarch %{ix86}
 %if %{with vga}
 %files vga
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/allegro/4.2/alleg-vga.so
-%endif
+%attr(755,root,root) %{_libdir}/allegro/4.4.1/alleg-vga.so
 %endif
 
 %if %{with alsa}
 %files alsa
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/allegro/4.2/alleg-alsadigi.so
-%attr(755,root,root) %{_libdir}/allegro/4.2/alleg-alsamidi.so
+%attr(755,root,root) %{_libdir}/allegro/4.4.1/alleg-alsadigi.so
+%attr(755,root,root) %{_libdir}/allegro/4.4.1/alleg-alsamidi.so
 %endif
 
 %if %{with jack}
 %files jack
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/allegro/4.2/alleg-jackdigi.so
+%attr(755,root,root) %{_libdir}/allegro/4.4.1/alleg-jack.so
 %endif
 
+%files addons
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/liballeggl.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/liballeggl.so.4.4
+%attr(755,root,root) %{_libdir}/libjpgalleg.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libjpgalleg.so.4.4
+%attr(755,root,root) %{_libdir}/libloadpng.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libloadpng.so.4.4
+%attr(755,root,root) %{_libdir}/liblogg.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/liblogg.so.4.4
+
+%files addons-devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/liballeggl.so
+%attr(755,root,root) %{_libdir}/libjpgalleg.so
+%attr(755,root,root) %{_libdir}/libloadpng.so
+%attr(755,root,root) %{_libdir}/liblogg.so
+%{_includedir}/allegrogl
+%{_includedir}/alleggl.h
+%{_includedir}/jpgalleg.h
+%{_includedir}/loadpng.h
+%{_includedir}/logg.h
+%{_pkgconfigdir}/allegrogl.pc
+%{_pkgconfigdir}/jpgalleg.pc
+%{_pkgconfigdir}/loadpng.pc
+%{_pkgconfigdir}/logg.pc
+
 %files tools
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/colormap
@@ -582,21 +481,16 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/pack
 %attr(755,root,root) %{_bindir}/rgbmap
 %attr(755,root,root) %{_bindir}/textconv
-%attr(755,root,root) %{_bindir}/xkeymap
-%attr(755,root,root) %{_bindir}/xf2pcx
 %attr(755,root,root) %{_bindir}/dat
 %attr(755,root,root) %{_bindir}/dat2c
 %attr(755,root,root) %{_bindir}/dat2s
 %attr(755,root,root) %{_bindir}/grabber
 %attr(755,root,root) %{_bindir}/pat2dat
-%attr(755,root,root) %{_bindir}/setup-allegro
 
 %files tests
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/afinfo
 %attr(755,root,root) %{_bindir}/akaitest
-%attr(755,root,root) %{_bindir}/cpptest
-%attr(755,root,root) %{_bindir}/demo-allegro
 %attr(755,root,root) %{_bindir}/digitest
 %attr(755,root,root) %{_bindir}/filetest
 %attr(755,root,root) %{_bindir}/gfxinfo
@@ -640,6 +534,8 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/expat
 %attr(755,root,root) %{_bindir}/exquat
 %attr(755,root,root) %{_bindir}/exrgbhsv
+%attr(755,root,root) %{_bindir}/exrotscl
+%attr(755,root,root) %{_bindir}/extrans2
 %attr(755,root,root) %{_bindir}/exsample
 %attr(755,root,root) %{_bindir}/exsyscur
 %attr(755,root,root) %{_bindir}/exscale
This page took 0.114574 seconds and 4 git commands to generate.