]> git.pld-linux.org Git - packages/allegro-gl.git/commitdiff
- obsolete (merged into allegro 4.4+) master
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 15 Oct 2010 05:51:13 +0000 (05:51 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    allegro-gl-libpthread.patch -> 1.2
    allegro-gl-link.patch -> 1.2
    allegro-gl-mouse.patch -> 1.2
    allegro-gl.spec -> 1.14

allegro-gl-libpthread.patch [deleted file]
allegro-gl-link.patch [deleted file]
allegro-gl-mouse.patch [deleted file]
allegro-gl.spec [deleted file]

diff --git a/allegro-gl-libpthread.patch b/allegro-gl-libpthread.patch
deleted file mode 100644 (file)
index 1e25f46..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
---- alleggl/include/alleggl.h~ 2007-07-21 12:02:43.000000000 +0200
-+++ alleggl/include/alleggl.h  2007-08-19 14:24:57.000000000 +0200
-@@ -72,10 +72,10 @@
- #   ifndef HAVE_LIBPTHREAD
- #      error AllegroGL requires Allegro to have pthread support enabled!
- #   endif
--#else
-+/*#else
- #   ifndef ALLEGRO_HAVE_LIBPTHREAD
- #      error AllegroGL requires Allegro to have pthread support enabled!
--#   endif
-+#   endif*/
- #endif
- #include <alleggl_config.h>
- #endif
diff --git a/allegro-gl-link.patch b/allegro-gl-link.patch
deleted file mode 100644 (file)
index 3a1a619..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- alleggl/make/makefile.unx.orig     2007-01-06 21:39:09.000000000 +0100
-+++ alleggl/make/makefile.unx  2007-06-17 20:53:09.174389001 +0200
-@@ -147,7 +147,7 @@
-       $(foreach link, $(LIB_LINKS_U), - ln -sf $(notdir $(LIB_PATH_U)) $(link)
-       )
-    endef
--      $(LIB_BUILDER) $@ $^
-+      $(LIB_BUILDER) $@ $^ $(LDFLAGS) $(LIBS)
-       - $(MAKE_LINKS)
- $(EXAMPLE_DIR)/%: $(EXAMPLE_DIR)/%.c
diff --git a/allegro-gl-mouse.patch b/allegro-gl-mouse.patch
deleted file mode 100644 (file)
index eef17a4..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
---- alleggl/src/gui.c.orig     2007-05-15 14:57:40.000000000 +0200
-+++ alleggl/src/gui.c  2007-06-17 20:22:51.754820163 +0200
-@@ -189,7 +189,7 @@
-       AGL_LOG(2, "allegro_gl_draw_mouse\n");
-       /* don't draw the mouse if it's not in our window */
--      if (!_mouse_on || allegro_gl_mouse.hidden) return;
-+      if (allegro_gl_mouse.hidden) return;
-       if (__algl_user_draw_mouse) {
---- alleggl/src/x.c.orig       2007-02-16 12:18:24.000000000 +0100
-+++ alleggl/src/x.c    2007-06-17 20:43:28.201281231 +0200
-@@ -186,11 +186,6 @@
-               _xwin.cursor = None;
-       }
--      if (_xwin.xcursor_image != None) {
--              XcursorImageDestroy(_xwin.xcursor_image);
--              _xwin.xcursor_image = None;
--      }
--
-       pixmap = XCreatePixmap(_xwin.display, _xwin.window, 1, 1, 1);
-       if (pixmap != None) {
-               GC temp_gc;
-@@ -211,7 +206,7 @@
-               XFreePixmap(_xwin.display, pixmap);
-       }
-       else {
--              _xwin.cursor = XCreateFontCursor(_xwin.display, _xwin.cursor_shape);
-+              _xwin.cursor = XCreateFontCursor(_xwin.display, 0 /* ??? */);
-               XDefineCursor(_xwin.display, _xwin.window, _xwin.cursor);
-       }
- }
-@@ -1298,7 +1293,7 @@
-                       XFreePixmap(_xwin.display, pixmap);
-               }
-               else {
--                      _xwin.cursor = XCreateFontCursor(_xwin.display, _xwin.cursor_shape);
-+                      _xwin.cursor = XCreateFontCursor(_xwin.display, 0 /* ??? */);
-                       XDefineCursor(_xwin.display, _xwin.window, _xwin.cursor);
-               }
-       }
diff --git a/allegro-gl.spec b/allegro-gl.spec
deleted file mode 100644 (file)
index 0535e1b..0000000
+++ /dev/null
@@ -1,94 +0,0 @@
-Summary:       The Allegro game programming library GL backend
-Summary(pl.UTF-8):     Wsparcie GL dla biblioteki do programowania gier Allegro
-Name:          allegro-gl
-Version:       0.4.3
-Release:       1
-License:       GPL v2 or zlib
-Group:         Libraries
-Source0:       http://dl.sourceforge.net/allegrogl/alleggl-%{version}.tar.bz2
-# Source0-md5: de84c6ab982499501940854893ea0dbd
-Patch0:                %{name}-mouse.patch
-Patch1:                %{name}-link.patch
-Patch2:                %{name}-libpthread.patch
-URL:           http://sourceforge.net/projects/allegrogl/
-BuildRequires: OpenGL-GLU-devel
-BuildRequires: allegro-devel >= 4.3.1
-BuildRequires: autoconf >= 2.53
-BuildRequires: automake
-Requires:      allegro >= 4.3.1
-BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
-
-%define                specflags       -fomit-frame-pointer
-
-%description
-AllegroGL is a cross-platform GL backend for the Allegro library.
-
-%description -l pl.UTF-8
-AllegroGL jest przenośną biblioteką dodającą wsparcie GL
-w aplikacjach używających biblioteki Allegro.
-
-%package devel
-Summary:       A game programming library - header files
-Summary(pl.UTF-8):     Biblioteka do programowania gier - pliki nagłówkowe
-Group:         Development/Libraries
-Requires:      %{name} = %{version}-%{release}
-Requires:      allegro-devel >= 4.3.1
-
-%description devel
-AllegroGL is a cross-platform GL backend for the Allegro library.
-
-This package contains header files neccessary for compiling
-applications using AllegroGL library.
-
-%description devel -l pl.UTF-8
-AllegroGL jest przenośną biblioteką dodającą wsparcie GL
-w aplikacjach używających biblioteki Allegro.
-
-Ten pakiet zawiera pliki nagłówkowe niezbędne do kompilowania
-aplikacji wykorzystujących bibliotekę AllegroGL.
-
-%prep
-%setup -q -n alleggl
-%patch0 -p1
-%patch1 -p1
-%patch2 -p1
-
-%build
-%{__aclocal}
-%{__autoconf}
-%configure \
-       --enable-static \
-%ifnarch %{ix86}
-       --disable-asm \
-       --disable-mmx \
-       --disable-sse
-%endif
-
-%{__make} lib \
-       CFLAGS="%{rpmcflags} -Wall -ffast-math"
-
-%install
-rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}/allegrogl/GLext}
-
-install include/alleggl*.h $RPM_BUILD_ROOT%{_includedir}
-install include/allegrogl/*.h $RPM_BUILD_ROOT%{_includedir}/allegrogl
-install include/allegrogl/GLext/*.h $RPM_BUILD_ROOT%{_includedir}/allegrogl/GLext
-install lib/unix/libagl.so $RPM_BUILD_ROOT%{_libdir}
-
-%clean
-rm -rf $RPM_BUILD_ROOT
-
-%post  -p /sbin/ldconfig
-%postun        -p /sbin/ldconfig
-
-%files
-%defattr(644,root,root,755)
-%doc bugs.txt readme.txt todo.txt zlib.txt
-%attr(755,root,root) %{_libdir}/libagl.so
-
-%files devel
-%defattr(644,root,root,755)
-%doc howto.txt
-%{_includedir}/alleggl*.h
-%{_includedir}/allegrogl
This page took 0.112693 seconds and 4 git commands to generate.