]> git.pld-linux.org Git - packages/alienarena2007.git/blame_incremental - alienarena2007.spec
- TODO added
[packages/alienarena2007.git] / alienarena2007.spec
... / ...
CommitLineData
1# TODO:
2# - package files and install them
3# - strip spaces from filenames in docs
4%define relyear 2007
5%define dateversion 20070613
6#
7Summary: Alien Arena - freeware online deathmatch FPS game
8Summary(pl.UTF-8): Alien Arena - darmowa gra sieciowa typu FPS deathmatch
9Name: alienarena%{relyear}
10Version: 6.10
11Release: 0.1
12License: GPL
13Group: X11/Applications/Games
14Source0: http://gd.tuwien.ac.at/opsys/linux/gentoo/distfiles/%{name}-%{dateversion}-linux.zip
15# Source0-md5: 65d2948fa636cbc28c82da2264df2fea
16URL: http://red.planetarena.org/
17BuildRequires: OpenGL-GLU-devel
18BuildRequires: SDL-devel
19BuildRequires: dos2unix
20BuildRequires: libjpeg-devel
21BuildRequires: rpmbuild(macros) >= 1.228
22BuildRequires: unzip
23BuildRequires: xorg-lib-libX11-devel
24BuildRequires: xorg-lib-libXext-devel
25BuildRequires: xorg-lib-libXxf86dga-devel
26BuildRequires: xorg-lib-libXxf86vm-devel
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%description
30ALIEN ARENA is a standalone 3D first person online deathmatch shooter
31crafted from the original source code of Quake II and Quake III,
32released by id Software under the GPL license. With features including
3332-bit graphics, new particle engine and effects, light blooms,
34reflective water, hi resolution textures and skins, hi poly models,
35stain maps, ALIEN ARENA pushes the envelope of graphical beauty
36rivaling today's top games.
37
38The game features 37 levels, which can be played online against other
39players, or against the built in CodeRED bots.
40
41Alien Arena offers CTF, AOA (All Out Assault) mode, in which players
42can climb into vehicles to do battle, Deathball, and Team Core
43Assault. Simply go into the multiplayer menu to start a server, change
44the game rules, and choose a map to play on. You can also select from
45five different mutators (instagib, rocket arena, excessive, low grav,
46regen, and vampire) to further customize your game experience.
47
48%description -l pl.UTF-8
49ALIEN ARENA to samodzielna trójwymiarowa strzelanina online FPP z
50trybem deathmatch, wywodząca się z oryginalnego kodu źródłowego Quake
51II i Quake III, wydanego przez id Software na licencji GPL. Z cechami
52obejmującymi 32-bitową grafikę, nowy silnik i efekty, światła,
53odbijającą wodę, wysokiej rozdzielczości tekstury i skórki, modele z
54dużej liczby wielokątów, mapy plam ALIEN ARENA dorównuje graficznemu
55pięknu dzisiejszych wiodących gier.
56
57Gra zawiera 37 poziomów, w które można grać online przeciwko innym
58graczom lub wbudowanym botom CodeRED.
59
60Alien Arena ofertuje tryby: CTF, AOA (All Out Assault), w którym
61gracze mogą wchodzić na pojazdy uczestnicząc w bitwach, Deathball i
62Team Core Assault. Wystarczy w menu gry dla wielu graczy uruchomić
63serwer, zmienić zasady gry i wybrać mapę. Można także wybrać jedną z
64pięciu różnych modyfikacji (instagib, rocket arena, excessive, low
65grav, regen i vampire) aby jeszcze bardziej zmieniać doznania graczy.
66
67%package server
68Summary: Alien Arena - server
69Summary(pl.UTF-8): Alien Arena - serwer
70Group: X11/Applications/Games
71Requires(post,preun): /sbin/chkconfig
72
73%description server
74The dedicated server for Alien Arena.
75
76%description server -l pl.UTF-8
77Dedykowany serwer dla gry Alien Arena.
78
79%package data
80Summary: Alien Arena - the data, botinfo, and arena files
81Summary(pl.UTF-8): Alien Arena - pliki danych i botinfo
82Group: X11/Applications/Games
83
84%description data
85This package installs the data, botinfo, and arena files needed to run
86Alien Arena.
87
88%description data -l pl.UTF-8
89Ten pakiet instaluje pliki danych i botinfo potrzebne do uruchomienia
90gry Alien Arena.
91
92%prep
93%setup -q -n %{name}
94rm -f ../GH3D.txt ../GamersHell.url
95
96for file in lst cfg txt html lng h c ; do
97 find ./ -noleaf -type f -name \*.$file -exec dos2unix '{}' \;
98done
99
100%build
101%{__make} \
102 CC="%{__cc}" \
103 RELEASE_CFLAGS='$(BASE_CFLAGS) %{rpmcflags}' \
104 X11BASE=%{_prefix} \
105 LOCALBASE=%{_prefix} \
106 _LIB=%{_lib}
107
108%install
109rm -rf $RPM_BUILD_ROOT
110
111%{__make} install \
112 DESTDIR=$RPM_BUILD_ROOT
113
114%clean
115rm -rf $RPM_BUILD_ROOT
116
117%post server
118/sbin/chkconfig --add %{name}
119%service %{name} restart
120
121%preun server
122if [ "$1" = "0" ]; then
123 %service -q %{name} stop
124 /sbin/chkconfig --del %{name}
125fi
126
127%files
128%defattr(644,root,root,755)
129#%doc changelog README
130#%lang(nl) %doc docs/AA Dutch.txt
131#%lang(fr) %doc docs/AA French.txt
132#%lang(de) %doc docs/AA German.txt
133#%lang(el) %doc docs/AA Greek.txt
134#%lang(hu) %doc docs/AA Hungarian.txt
135#%lang(it) %doc docs/AA Italian.txt
136#%lang(pl) %doc docs/AA Polish.txt
137#%lang(pt) %doc docs/AA Portuguese.txt
138#%lang(ru) %doc docs/AA Russian.txt
139#%lang(es) %doc docs/AA_ES.txt
140#%attr(755,root,root) %{_bindir}/alien-arena
141#%{_desktopdir}/alien-arena.desktop
142#%{_pixmapsdir}/alien-arena.xpm
143
144%files data
145%defattr(644,root,root,755)
146
147%files server
148%defattr(644,root,root,755)
149#%attr(754,root,root) /etc/rc.d/init.d/%{name}
150#%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
151#%attr(755,root,root) %{_bindir}/alien-arena-server
152#alien-arena/crded
153#alien-arena/kill-runaway-crded
154#alien-arena/launch-server
155#alien-arena/rcon
156#alien-arena/svstat
157#%{_mandir}/man6/alien-arena-server.6*
This page took 0.075998 seconds and 4 git commands to generate.