]> git.pld-linux.org Git - packages/al.git/blob - al.spec
- tabs in preamble
[packages/al.git] / al.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 %bcond_with     tests           # perform "make check" (segfaults after tests)
5 #
6 Summary:        OSSP al - Assembly Line
7 Summary(pl.UTF-8):      OSSP al - biblioteka Assembly Line ("linii montażowej")
8 Name:           al
9 Version:        0.9.3
10 Release:        0.1
11 Epoch:          0
12 License:        distributable (see README)
13 Group:          Libraries
14 Source0:        ftp://ftp.ossp.org/pkg/lib/al/%{name}-%{version}.tar.gz
15 # Source0-md5:  ef943a29d1fb89ed4fd5556844cbc542
16 Patch0:         %{name}-ac.patch
17 URL:            http://www.ossp.org/pkg/lib/al/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  ex-devel
21 BuildRequires:  libtool
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 OSSP al defines an abstract data type of a data buffer that can
26 assemble, move and truncate chunks of data in a stream but avoids
27 actual copying. It was built to deal efficiently with communication
28 streams between software modules. It especially provides flexible
29 semantical data attribution through by-chunk labeling. It also has
30 convenient chunk traversal methods and optional OSSP ex based
31 exception handling.
32
33 %description -l pl.UTF-8
34 OSSP al definiuje abstrakcyjne typy danych dla bufora danych, który
35 może łączyć, przemieszczać i ucinać porcje danych w strumieniu, ale
36 unika samego kopiowania. Została stworzona, aby obsługiwać wydajnie
37 strumienie komunikacyjne pomiędzy modułami oprogramowania. Udostępnia
38 w szczególności elastyczne semantyczne przypisywanie danych poprzez
39 oznaczanie porcji. Ma także wygodne metody przechodzenia porcji i
40 opcjonalną obsługę wyjątków w oparciu o OSSP ex.
41
42 %package devel
43 Summary:        OSSP al - Assembly Line - header files and development libraries
44 Summary(pl.UTF-8):      OSSP al - biblioteka Assembly Line - pliki nagłówkowe i biblioteki dla deweloperów
45 Group:          Development/Libraries
46 Requires:       %{name} = %{epoch}:%{version}-%{release}
47
48 %description devel
49 OSSP al - Assembly Line - header files and development libraries.
50
51 %description devel -l pl.UTF-8
52 OSSP al - biblioteka Assembly Line - pliki nagłówkowe i biblioteki dla
53 deweloperów.
54
55 %package static
56 Summary:        OSSP al - Assembly Line - static libraries
57 Summary(pl.UTF-8):      OSSP al - biblioteka Assembly Line - biblioteki statyczne
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
60
61 %description static
62 OSSP al - Assembly Line - static libraries.
63
64 %description static -l pl.UTF-8
65 OSSP al - biblioteka Assembly Line - biblioteki statyczne.
66
67 %prep
68 %setup -q
69 %patch0 -p1
70
71 %build
72 mv -f aclocal.m4 acinclude.m4
73 %{__libtoolize}
74 %{__aclocal}
75 %{__autoconf}
76 %configure \
77         %{?debug:--enable-debug} \
78         --with-ex \
79         --enable-static=%{?with_static_libs:yes}%{!?with_static_libs:no}
80 %{__make}
81
82 %{?with_tests:%{__make} check}
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86
87 %{__make} install \
88         DESTDIR=$RPM_BUILD_ROOT
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post   -p /sbin/ldconfig
94 %postun -p /sbin/ldconfig
95
96 %files
97 %defattr(644,root,root,755)
98 %doc AUTHORS ChangeLog README THANKS TODO
99 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
100
101 %files devel
102 %defattr(644,root,root,755)
103 %attr(755,root,root) %{_bindir}/*
104 %attr(755,root,root) %{_libdir}/lib*.so
105 %{_libdir}/lib*.la
106 %{_includedir}/*
107 %{_mandir}/man3/*
108
109 %if %{with static_libs}
110 %files static
111 %defattr(644,root,root,755)
112 %attr(755,root,root) %{_libdir}/lib*.a
113 %endif
This page took 0.078554 seconds and 3 git commands to generate.