- updated to 2.0.1
[packages/akode.git] / akode.spec
index 58c3ed93e2fc567f2c5cc5ad4a78bf182f387be8..cdf0bef1bcac2fd59b5bb194ad37d46904914792 100644 (file)
@@ -2,12 +2,13 @@
 Summary:       Audio-decoding framework library
 Summary(pl):   Biblioteka szkieletu dekodowania d¼wiêku
 Name:          akode
-Version:       2.0
+Version:       2.0.1
 Release:       1
 License:       LGPL
 Group:         Libraries
-Source0:       http://www.kde-apps.org/content/files/30375-%{name}-%{version}.tar.gz
-# Source0-md5: 04f79cda65c8e9966fa462eaaaa282dc
+Source0:       http://www.kde-apps.org/content/files/30375-%{name}-%{version}.tar.bz2
+# Source0-md5: 94a10e7729b20b669bc5c7721f62e162
+Patch0:                %{name}-pulseaudio.patch
 URL:           http://www.carewolf.com/akode/
 BuildRequires: alsa-lib-devel
 BuildRequires: autoconf
@@ -15,14 +16,16 @@ BuildRequires:      automake
 BuildRequires: ffmpeg-devel >= 0.4.9-3.20050806.5
 BuildRequires: flac-devel >= 1.1.1
 BuildRequires: jack-audio-connection-kit-devel >= 0.90
+BuildRequires: faad2-devel
 BuildRequires: libltdl-devel
 BuildRequires: libmad-devel
 BuildRequires: libogg-devel
 BuildRequires: libsamplerate-devel
 BuildRequires: libstdc++-devel
 BuildRequires: libvorbis-devel >= 1:1.0
+BuildRequires: libx264-devel
 BuildRequires: pkgconfig
-BuildRequires: polypaudio-devel >= 0.7
+BuildRequires: pulseaudio-devel >= 0.9.2
 BuildRequires: rpmbuild(macros) >= 1.129
 BuildRequires: speex-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -34,10 +37,10 @@ Audio-decoding framework library.
 Biblioteka szkieletu dekodowania d¼wiêku.
 
 %package devel
-Summary:        Header files for akode library
-Summary(pl):    Pliki nag³ówkowe biblioteki akode
-Group:          Development/Libraries
-Requires:       %{name} = %{version}-%{release}
+Summary:       Header files for akode library
+Summary(pl):   Pliki nag³ówkowe biblioteki akode
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
 Requires:      libltdl-devel
 Requires:      libstdc++-devel
 
@@ -49,6 +52,7 @@ Pliki nag
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 cp -f /usr/share/automake/config.sub admin
@@ -64,7 +68,7 @@ USER_INCLUDES="-I%{_includedir}/speex" \
        --with-libmad \
        --with-libsamplerate \
        --with-jack \
-       --with-polypaudio \
+       --with-pulseaudio \
        --with-ffmpeg \
        --with-oss \
        --with-alsa \
This page took 0.096023 seconds and 4 git commands to generate.