]> git.pld-linux.org Git - packages/agg.git/blob - agg.spec
- cxx fixes for gcc 8
[packages/agg.git] / agg.spec
1 Summary:        A High Quality Rendering Engine for C++
2 Summary(pl.UTF-8):      Silnik renderujący wysokiej jakości dla C++
3 Name:           agg
4 Version:        2.5
5 Release:        7
6 License:        GPL v2+
7 Group:          Libraries
8 Source0:        http://www.antigrain.com/%{name}-%{version}.tar.gz
9 # Source0-md5:  ddc67cbdc7d51e1ec984c2ac2724c08a
10 Patch0:         %{name}-depends.patch
11 Patch1:         ac.patch
12 URL:            http://www.antigrain.com/
13 BuildRequires:  SDL-devel
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  freetype-devel
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  libtool
19 BuildRequires:  pkgconfig
20 BuildRequires:  xorg-lib-libX11-devel
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 # Unresolved symbol: _Z8agg_mainiPPc
24 %define         skip_post_check_so      libaggplatformsdl.so.*.*.* libaggplatformX11.so.*.*.* libaggplatformsdl.so.*.*.*
25
26 %description
27 Anti-Grain Geometry (AGG) is a general purpose graphical toolkit
28 written completely in standard and platform independent C++. It can be
29 used in many areas of computer programming where high quality 2D
30 graphics is an essential part of the project.
31
32 AGG uses only C++ and standard C runtime functions, such as memcpy,
33 sin, cos, sqrt, etc. The basic algorithms don't even use C++ Standard
34 Template Library. Thus, AGG can be used in a very large number of
35 applications, including embedded systems.
36
37 %description -l pl.UTF-8
38 Anti-Grain Geometry (AGG) to toolkit graficzny ogólnego przeznaczenia
39 napisany całkowicie w standardowym i niezależnym od platformy C++.
40 Może być używany w wielu zastosowaniach z zakresu programowania gdzie
41 zasadniczą częścią projektu jest wysokiej jakości grafika 2D.
42
43 AGG używa tylko C++ i standardowych funkcji C, takich jak memcpy, sin,
44 cos, sqrt itp. Podstawowe algorytmy nie używają nawet standardowej
45 biblioteki C++. W ten sposób AGG może być używany w bardzo wielu
46 zastosowaniach, także na systemach wbudowanych.
47
48 %package devel
49 Summary:        Support files necessary to compile applications with agg
50 Summary(pl.UTF-8):      Pliki potrzebne do kompilowania aplikacji z użyciem agg
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       libstdc++-devel
54 # libaggfontfreetype R: freetype-devel
55 # libaggplatformX11 R: xorg-lib-libX11-devel
56 # libaggplatformsdl R: SDL-devel
57
58 %description devel
59 Header and support files necessary to compile applications using agg.
60
61 %description devel -l pl.UTF-8
62 Pliki nagłówkowe i pomocnicze potrzebne do kompilowania aplikacji z
63 użyciem agg.
64
65 %package static
66 Summary:        Static agg library
67 Summary(pl.UTF-8):      Statyczna biblioteka agg
68 Group:          Development/Libraries
69 Requires:       %{name}-devel = %{version}-%{release}
70
71 %description static
72 Static agg library.
73
74 %description static -l pl.UTF-8
75 Statyczna biblioteka agg.
76
77 %prep
78 %setup -q
79 %patch0 -p1
80 %patch1 -p1
81
82 %build
83 %{__libtoolize}
84 %{__aclocal}
85 %{__autoheader}
86 %{__autoconf}
87 %{__automake}
88 %configure \
89         --disable-gpc
90
91 %{__make} -j1
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %post   -p /sbin/ldconfig
103 %postun -p /sbin/ldconfig
104
105 %files
106 %defattr(644,root,root,755)
107 %doc authors copying readme
108 %attr(755,root,root) %{_libdir}/libagg.so.*.*.*
109 %ghost %{_libdir}/libagg.so.2
110 %attr(755,root,root) %{_libdir}/libaggfontfreetype.so.*.*.*
111 %ghost %{_libdir}/libaggfontfreetype.so.2
112 %attr(755,root,root) %{_libdir}/libaggplatformX11.so.*.*.*
113 %ghost %{_libdir}/libaggplatformX11.so.2
114 %attr(755,root,root) %{_libdir}/libaggplatformsdl.so.*.*.*
115 %ghost %{_libdir}/libaggplatformsdl.so.2
116
117 %files devel
118 %defattr(644,root,root,755)
119 %{_libdir}/libagg.so
120 %{_libdir}/libaggfontfreetype.so
121 %{_libdir}/libaggplatformX11.so
122 %{_libdir}/libaggplatformsdl.so
123 %{_libdir}/libagg.la
124 %{_libdir}/libaggfontfreetype.la
125 %{_libdir}/libaggplatformX11.la
126 %{_libdir}/libaggplatformsdl.la
127 %{_includedir}/agg2
128 %{_pkgconfigdir}/libagg.pc
129 %{_aclocaldir}/libagg.m4
130
131 %files static
132 %defattr(644,root,root,755)
133 %{_libdir}/libagg.a
134 %{_libdir}/libaggfontfreetype.a
135 %{_libdir}/libaggplatformX11.a
136 %{_libdir}/libaggplatformsdl.a
This page took 0.066561 seconds and 3 git commands to generate.