]> git.pld-linux.org Git - packages/afpfs-ng.git/blob - afpfs-ng.spec
7cff508807a3b11b6bf0f478977e6df837cadfc8
[packages/afpfs-ng.git] / afpfs-ng.spec
1 #
2 # Conditional build:
3 %bcond_without  fuse            # FUSE driver for AFP filesystem
4
5 Summary:        Apple Filing Protocol client
6 Name:           afpfs-ng
7 Version:        0.8.1
8 Release:        1
9 License:        GPL+
10 Group:          Base
11 Source0:        http://downloads.sourceforge.net/afpfs-ng/%{name}-%{version}.tar.bz2
12 # Source0-md5:  1bdd9f8a06e6085ea4cc38ce010ef60b
13 URL:            https://sites.google.com/site/alexthepuffin/
14 Patch0:         overflows.patch
15 Patch1:         pointer.patch
16 Patch2:         formatsec.patch
17 BuildRequires:  gmp-devel
18 BuildRequires:  libgcrypt-devel
19 BuildRequires:  readline-devel
20 %if %{with fuse}
21 BuildRequires:  libfuse-devel
22 Suggests:       fuse-afp
23 %endif
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 A command line client to access files exported from Mac OS system via
28 Apple Filing Protocol.
29
30 %package -n fuse-afp
31 Summary:        FUSE driver for AFP filesystem
32 Group:          Base
33
34 %description -n fuse-afp
35 A FUSE file system server to access files exported from Mac OS system
36 via AppleTalk or TCP using Apple Filing Protocol. The command line
37 client for AFP is in fuse-afp package
38
39 %package devel
40 Summary:        Development files for afpfs-ng
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}
43
44 %description devel
45 Library for dynamic linking and header files of afpfs-ng.
46
47 %prep
48 %setup -q
49 %patch0 -p1
50 %patch1 -p1
51 %patch2 -p1
52
53 # make would rebuild the autoconf infrastructure due to the following:
54 # Prerequisite `configure.ac' is newer than target `Makefile.in'.
55 # Prerequisite `aclocal.m4' is newer than target `Makefile.in'.
56 # Prerequisite `configure.ac' is newer than target `aclocal.m4'.
57 touch --reference aclocal.m4 configure.ac Makefile.in
58
59 %build
60 %configure \
61         %{!?with_fuse:--disable-fuse} \
62         --disable-static
63 %{__make}
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 %{__make} install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libafpclient.la
71
72 install -d $RPM_BUILD_ROOT%{_includedir}/afpfs-ng
73 cp -p include/* $RPM_BUILD_ROOT%{_includedir}/afpfs-ng
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %post   -p /sbin/ldconfig
79 %postun -p /sbin/ldconfig
80
81 %files
82 %defattr(644,root,root,755)
83 %doc COPYING AUTHORS ChangeLog docs/README docs/performance docs/FEATURES.txt docs/REPORTING-BUGS.txt
84 %attr(755,root,root) %{_bindir}/afpcmd
85 %attr(755,root,root) %{_bindir}/afpgetstatus
86 %{_mandir}/man1/afpcmd.1*
87 %{_mandir}/man1/afpgetstatus.1*
88 %attr(755,root,root) %{_libdir}/libafpclient.so.0.0.0
89 %ghost %{_libdir}/libafpclient.so.0
90
91 %files devel
92 %defattr(644,root,root,755)
93 %{_includedir}/afpfs-ng
94 %{_libdir}/libafpclient.so
95
96 %if %{with fuse}
97 %files -n fuse-afp
98 %defattr(644,root,root,755)
99 %doc COPYING AUTHORS ChangeLog
100 %attr(755,root,root) %{_bindir}/afp_client
101 %attr(755,root,root) %{_bindir}/afpfs
102 %attr(755,root,root) %{_bindir}/afpfsd
103 %attr(755,root,root) %{_bindir}/mount_afp
104 %{_mandir}/man1/afp_client.1*
105 %{_mandir}/man1/afpfsd.1*
106 %{_mandir}/man1/mount_afp.1*
107 %endif
This page took 0.111698 seconds and 2 git commands to generate.