]> git.pld-linux.org Git - packages/afpfs-ng.git/blob - afpfs-ng.spec
undefine __cxx not to require gcc-c++
[packages/afpfs-ng.git] / afpfs-ng.spec
1 #
2 # Conditional build:
3 %bcond_without  fuse            # FUSE driver for AFP filesystem
4
5 Summary:        Apple Filing Protocol client
6 Name:           afpfs-ng
7 Version:        0.8.1
8 Release:        1
9 License:        GPL+
10 Group:          Base
11 Source0:        http://downloads.sourceforge.net/afpfs-ng/%{name}-%{version}.tar.bz2
12 # Source0-md5:  1bdd9f8a06e6085ea4cc38ce010ef60b
13 URL:            https://sites.google.com/site/alexthepuffin/
14 Patch0:         overflows.patch
15 Patch1:         pointer.patch
16 Patch2:         formatsec.patch
17 BuildRequires:  gmp-devel
18 BuildRequires:  libgcrypt-devel
19 BuildRequires:  readline-devel
20 %if %{with fuse}
21 BuildRequires:  libfuse-devel
22 Suggests:       fuse-afp
23 %endif
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %undefine       __cxx
27
28 %description
29 A command line client to access files exported from Mac OS system via
30 Apple Filing Protocol.
31
32 %package -n fuse-afp
33 Summary:        FUSE driver for AFP filesystem
34 Group:          Base
35
36 %description -n fuse-afp
37 A FUSE file system server to access files exported from Mac OS system
38 via AppleTalk or TCP using Apple Filing Protocol. The command line
39 client for AFP is in fuse-afp package
40
41 %package devel
42 Summary:        Development files for afpfs-ng
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}
45
46 %description devel
47 Library for dynamic linking and header files of afpfs-ng.
48
49 %prep
50 %setup -q
51 %patch0 -p1
52 %patch1 -p1
53 %patch2 -p1
54
55 # make would rebuild the autoconf infrastructure due to the following:
56 # Prerequisite `configure.ac' is newer than target `Makefile.in'.
57 # Prerequisite `aclocal.m4' is newer than target `Makefile.in'.
58 # Prerequisite `configure.ac' is newer than target `aclocal.m4'.
59 touch --reference aclocal.m4 configure.ac Makefile.in
60
61 %build
62 %configure \
63         %{!?with_fuse:--disable-fuse} \
64         --disable-static
65 %{__make}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 %{__make} install \
70         DESTDIR=$RPM_BUILD_ROOT
71
72 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libafpclient.la
73
74 install -d $RPM_BUILD_ROOT%{_includedir}/afpfs-ng
75 cp -p include/* $RPM_BUILD_ROOT%{_includedir}/afpfs-ng
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post   -p /sbin/ldconfig
81 %postun -p /sbin/ldconfig
82
83 %files
84 %defattr(644,root,root,755)
85 %doc COPYING AUTHORS ChangeLog docs/README docs/performance docs/FEATURES.txt docs/REPORTING-BUGS.txt
86 %attr(755,root,root) %{_bindir}/afpcmd
87 %attr(755,root,root) %{_bindir}/afpgetstatus
88 %{_mandir}/man1/afpcmd.1*
89 %{_mandir}/man1/afpgetstatus.1*
90 %attr(755,root,root) %{_libdir}/libafpclient.so.0.0.0
91 %ghost %{_libdir}/libafpclient.so.0
92
93 %files devel
94 %defattr(644,root,root,755)
95 %{_includedir}/afpfs-ng
96 %{_libdir}/libafpclient.so
97
98 %if %{with fuse}
99 %files -n fuse-afp
100 %defattr(644,root,root,755)
101 %doc COPYING AUTHORS ChangeLog
102 %attr(755,root,root) %{_bindir}/afp_client
103 %attr(755,root,root) %{_bindir}/afpfs
104 %attr(755,root,root) %{_bindir}/afpfsd
105 %attr(755,root,root) %{_bindir}/mount_afp
106 %{_mandir}/man1/afp_client.1*
107 %{_mandir}/man1/afpfsd.1*
108 %{_mandir}/man1/mount_afp.1*
109 %endif
This page took 0.09399 seconds and 3 git commands to generate.