]> git.pld-linux.org Git - packages/afpfs-ng.git/blame - afpfs-ng.spec
undefine __cxx not to require gcc-c++
[packages/afpfs-ng.git] / afpfs-ng.spec
CommitLineData
017a8877
ER
1#
2# Conditional build:
3%bcond_without fuse # FUSE driver for AFP filesystem
4
5Summary: Apple Filing Protocol client
6Name: afpfs-ng
7Version: 0.8.1
8Release: 1
9License: GPL+
10Group: Base
11Source0: http://downloads.sourceforge.net/afpfs-ng/%{name}-%{version}.tar.bz2
12# Source0-md5: 1bdd9f8a06e6085ea4cc38ce010ef60b
13URL: https://sites.google.com/site/alexthepuffin/
14Patch0: overflows.patch
15Patch1: pointer.patch
16Patch2: formatsec.patch
17BuildRequires: gmp-devel
18BuildRequires: libgcrypt-devel
19BuildRequires: readline-devel
20%if %{with fuse}
21BuildRequires: libfuse-devel
22Suggests: fuse-afp
23%endif
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
6b3e789e
ER
26%undefine __cxx
27
017a8877
ER
28%description
29A command line client to access files exported from Mac OS system via
30Apple Filing Protocol.
31
32%package -n fuse-afp
33Summary: FUSE driver for AFP filesystem
34Group: Base
35
36%description -n fuse-afp
37A FUSE file system server to access files exported from Mac OS system
38via AppleTalk or TCP using Apple Filing Protocol. The command line
39client for AFP is in fuse-afp package
40
41%package devel
42Summary: Development files for afpfs-ng
43Group: Development/Libraries
44Requires: %{name} = %{version}
45
46%description devel
47Library for dynamic linking and header files of afpfs-ng.
48
49%prep
50%setup -q
51%patch0 -p1
52%patch1 -p1
53%patch2 -p1
54
55# make would rebuild the autoconf infrastructure due to the following:
56# Prerequisite `configure.ac' is newer than target `Makefile.in'.
57# Prerequisite `aclocal.m4' is newer than target `Makefile.in'.
58# Prerequisite `configure.ac' is newer than target `aclocal.m4'.
59touch --reference aclocal.m4 configure.ac Makefile.in
60
61%build
62%configure \
63 %{!?with_fuse:--disable-fuse} \
64 --disable-static
65%{__make}
66
67%install
68rm -rf $RPM_BUILD_ROOT
69%{__make} install \
70 DESTDIR=$RPM_BUILD_ROOT
71
72%{__rm} $RPM_BUILD_ROOT%{_libdir}/libafpclient.la
73
74install -d $RPM_BUILD_ROOT%{_includedir}/afpfs-ng
75cp -p include/* $RPM_BUILD_ROOT%{_includedir}/afpfs-ng
76
77%clean
78rm -rf $RPM_BUILD_ROOT
79
80%post -p /sbin/ldconfig
81%postun -p /sbin/ldconfig
82
83%files
84%defattr(644,root,root,755)
85%doc COPYING AUTHORS ChangeLog docs/README docs/performance docs/FEATURES.txt docs/REPORTING-BUGS.txt
86%attr(755,root,root) %{_bindir}/afpcmd
87%attr(755,root,root) %{_bindir}/afpgetstatus
88%{_mandir}/man1/afpcmd.1*
89%{_mandir}/man1/afpgetstatus.1*
90%attr(755,root,root) %{_libdir}/libafpclient.so.0.0.0
91%ghost %{_libdir}/libafpclient.so.0
92
93%files devel
94%defattr(644,root,root,755)
95%{_includedir}/afpfs-ng
96%{_libdir}/libafpclient.so
97
98%if %{with fuse}
99%files -n fuse-afp
100%defattr(644,root,root,755)
101%doc COPYING AUTHORS ChangeLog
102%attr(755,root,root) %{_bindir}/afp_client
103%attr(755,root,root) %{_bindir}/afpfs
104%attr(755,root,root) %{_bindir}/afpfsd
105%attr(755,root,root) %{_bindir}/mount_afp
106%{_mandir}/man1/afp_client.1*
107%{_mandir}/man1/afpfsd.1*
108%{_mandir}/man1/mount_afp.1*
109%endif
This page took 0.119702 seconds and 4 git commands to generate.