]> git.pld-linux.org Git - packages/aethera.git/blame - aethera.spec
- tabs in preamble
[packages/aethera.git] / aethera.spec
CommitLineData
4a10f63d 1# TODO: optflags
3f159b08 2%define _rel 0.3
a35c751f 3Summary: Aethera - Email and PIM application
8c6389d4 4Summary(pl.UTF-8): Aethera - aplikacja poczty elektronicznej i zarządcy informacji osobistej (PIM)
a35c751f
ER
5Name: aethera
6Version: 1.2.1
7Release: 050331.%{_rel}
8License: GPL
9Group: X11/Applications
10Source0: %{name}-%{version}.tar.gz
05391902
ER
11Patch0: %{name}-libs.patch
12Patch1: %{name}-includes.patch
66af7acc 13Patch2: %{name}-install.patch
e0dc9350 14Patch3: %{name}-fpic.patch
3f159b08 15Patch4: %{name}-typo.patch
a35c751f
ER
16# Source0-md5: f3efd064b5e9884bd7adf49bf763e213
17URL: http://www.thekompany.com/projects/aethera/
05391902 18BuildRequires: korelib-devel
4a10f63d 19BuildRequires: qmake
a35c751f
ER
20BuildRequires: qt-devel
21#Requires: thekompany-support
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
25Aethera is a pim application, i.e. it handles all kinds of personal
26information: email, contacts, notes, tasks, todos, journals.
27
b7e5ab34
JR
28%description -l pl.UTF-8
29Aethera jest aplikacją zarządcy informacji osobistej (PIM). Obsługuje
30wszystkie rodzaje informacji osobistych: pocztę elektroniczną,
31kontakty, notatki, zadania, sprawy do załatwienia, dzienniki.
5c1a71e8 32
66af7acc 33%package devel
4a10f63d 34Summary: Header files for Aethera libraries
8c6389d4 35Summary(pl.UTF-8): Pliki nagłówkowe bibliotek Aethery
66af7acc
ER
36Group: Development/Libraries
37Requires: %{name} = %{version}-%{release}
38
39%description devel
4a10f63d
JB
40Header files for Aethera libraries.
41
b7e5ab34
JR
42%description devel -l pl.UTF-8
43Pliki nagłówkowe bibliotek Aethery.
66af7acc 44
a35c751f
ER
45%prep
46%setup -q
05391902
ER
47%patch0 -p1
48%patch1 -p1
66af7acc 49%patch2 -p1
1099c26c 50%ifarch %{x8664}
e0dc9350 51%patch3 -p1
1099c26c 52%endif
3f159b08 53%patch4 -p1
66af7acc
ER
54
55mkdir -p include/aethera
56ln -sf ../../aethera/libs/clientskel/clientrmi.h include/aethera
57ln -sf ../../aethera/libs/clientskel/vfsmodule.h include/aethera
a35c751f
ER
58
59%build
9c8844fb 60export QTDIR=/usr
66af7acc
ER
61export QMAKE_STRIP=:
62
a35c751f
ER
63# Use the new libraries in building process
64export LD_LIBRARY_PATH=$dir/lib:$LD_LIBRARY_PATH
65dir=$(pwd)
66
67# Compile tkcBase
68cd tkcbase
66af7acc
ER
69cat <<EOF > defines.pri
70TKCBASE_LIB=%{_libdir}
71TKCBASE_INCLUDE=%{_includedir}/tkcbase
72CONFIG += release thread
73EOF
9c8844fb 74qmake desktop.pro
a35c751f
ER
75%{__make}
76
77# Compile tkcSSL
78cd ../tkcssl
66af7acc
ER
79cat <<EOF > defines.pri
80TKCSSL_LIB=%{_libdir}
81TKCSSL_INCLUDE=%{_includedir}/tkcssl
82INCLUDEPATH += $dir/tkcbase
83DEPENDPATH += $dir/tkcbase
84CONFIG += release thread
85EOF
9c8844fb 86qmake tkcssl.pro
a35c751f
ER
87%{__make}
88
89# Compile webdav
90cd ../webdav
66af7acc
ER
91cat <<EOF > defines.pri
92WEBDAV_LIB=%{_libdir}
93WEBDAV_INCLUDE=%{_includedir}/tkcbase
94CONFIG += release thread
95EOF
9c8844fb 96qmake webdav.pro
a35c751f
ER
97%{__make}
98
99# Compile Aethera
100cd ../aethera
66af7acc
ER
101cat <<EOF > defines.pri
102AETHERA_DIR=%{_libdir}/aethera
103AETHERA_BIN=%{_bindir}
104AETHERA_LIB=%{_libdir}
105AETHERA_INCLUDE=%{_includedir}/aethera
106TINO_LIB=%{_libdir}
107TINO_INCLUDE=%{_includedir}/tino
108INCLUDEPATH += $dir/include
109INCLUDEPATH += $dir/tkcbase
110DEPENDPATH += $dir/tkcbase
111INCLUDEPATH += $dir/tkcssl
112DEPENDPATH += $dir/tkcssl
113
114CONFIG += qt warn_on release thread
115EOF
a35c751f 116
9c8844fb 117qmake aethera.pro
a35c751f
ER
118%{__make}
119
120# Compile KOrganizer plugin
121cd ../koplugin
66af7acc
ER
122cat <<EOF > defines.pri
123AETHERA_DIR = %{_libdir}/aethera
124
125INCLUDEPATH += $dir/include
126INCLUDEPATH += $dir/tkcbase
127DEPENDPATH += $dir/tkcbase
128
129INCLUDEPATH += $dir/tkcssl
130DEPENDPATH += $dir/tkcssl
131
132INCLUDEPATH += $dir/aethera/libs
133DEPENDPATH += $dir/aethera/libs
134
135INCLUDEPATH += $dir/aethera/libs/aethera
136DEPENDPATH += $dir/aethera/libs/aethera
137
138INCLUDEPATH += $direbdav/webdav
139DEPENDPATH += $dir/webdav/webdav
140
141INCLUDEPATH += $dir/aethera/libs/clientskel
142DEPENDPATH += $dir/aethera/libs/clientskel
143
144INCLUDEPATH += $dir/include/aethera/libs/plugins/kommailplugin
145DEPENDPATH += $dir/include/aethera/libs/plugins/kommailplugin
146
147INCLUDEPATH += $dir/include/aethera/libs/plugins/komcontactsplugin
148DEPENDPATH += $dir/include/aethera/libs/plugins/komcontactsplugin
149
150INCLUDEPATH += $dir/include/tino
151DEPENDPATH += $dir/include/tino
152
153CONFIG += qt warn_on release thread
154DEFINES += AETHERA_KOLAB
155EOF
a35c751f 156
9c8844fb 157qmake KOPlugin.pro
a35c751f
ER
158%{__make}
159
160%install
161rm -rf $RPM_BUILD_ROOT
66af7acc
ER
162install -d $RPM_BUILD_ROOT%{_libdir}/aethera
163
05391902
ER
164export QTDIR=/usr
165%{__make} -C tkcbase install \
166 INSTALL_ROOT=$RPM_BUILD_ROOT
167%{__make} -C tkcssl install \
168 INSTALL_ROOT=$RPM_BUILD_ROOT
169%{__make} -C webdav install \
170 INSTALL_ROOT=$RPM_BUILD_ROOT
171%{__make} -C aethera install \
172 INSTALL_ROOT=$RPM_BUILD_ROOT
66af7acc
ER
173%{__make} -C koplugin install \
174 INSTALL_ROOT=$RPM_BUILD_ROOT
a35c751f 175
dd7fe118
ER
176# x86 binary
177rm $RPM_BUILD_ROOT%{_libdir}/aethera/bin/sox
178# unneccessary wrappers
179rm $RPM_BUILD_ROOT%{_libdir}/aethera/bin/aethera_sound
180rm $RPM_BUILD_ROOT%{_prefix}/local/bin/aethera
181
a35c751f
ER
182%clean
183rm -rf $RPM_BUILD_ROOT
184
4a10f63d
JB
185%post -p /sbin/ldconfig
186%postun -p /sbin/ldconfig
dd7fe118 187
a35c751f
ER
188%files
189%defattr(644,root,root,755)
66af7acc 190%attr(755,root,root) %{_bindir}/aethera
dd7fe118
ER
191%attr(755,root,root) %{_libdir}/libaethera.so.1.0.1
192%attr(755,root,root) %{_libdir}/libfilebrowser.so.1.0.0
193%attr(755,root,root) %{_libdir}/libtino.so.1.0.0
194%attr(755,root,root) %{_libdir}/libtkcbase.so.1.0.0
195%attr(755,root,root) %{_libdir}/libtkcssl.so.1.0.0
196%dir %{_libdir}/aethera
197%dir %{_libdir}/aethera/plugins
198%attr(755,root,root) %{_libdir}/aethera/plugins/libhomeplugin.so.1.0.0
199%attr(755,root,root) %{_libdir}/aethera/plugins/libkomcontactsplugin.so.1.0.0
66af7acc
ER
200%attr(755,root,root) %{_libdir}/aethera/plugins/libkommailplugin.so.1.0.0
201%attr(755,root,root) %{_libdir}/aethera/plugins/libkomnotesplugin.so.1.0.0
202%attr(755,root,root) %{_libdir}/aethera/plugins/libkorganizer.so.1.0.0
dd7fe118 203%attr(755,root,root) %{_libdir}/aethera/plugins/libmailimport.so.1.0.0
66af7acc
ER
204%{_libdir}/aethera/help
205%{_libdir}/aethera/pics
206%{_libdir}/aethera/sound
207%{_libdir}/aethera/data
208%dir %{_libdir}/aethera/i18n
4a10f63d 209# XXX: are *.ts (translation sources) needed in binary package?
66af7acc
ER
210%lang(de) %{_libdir}/aethera/i18n/aethera_de.qm
211%lang(de) %{_libdir}/aethera/i18n/aethera_de.ts
212%lang(de) %{_libdir}/aethera/i18n/koplugin_de.ts
213%lang(en) %{_libdir}/aethera/i18n/aethera_en.ts
214%lang(en) %{_libdir}/aethera/i18n/koplugin_en.ts
215%lang(fr) %{_libdir}/aethera/i18n/aethera_fr.qm
216%lang(fr) %{_libdir}/aethera/i18n/aethera_fr.ts
217%lang(fr) %{_libdir}/aethera/i18n/koplugin_fr.qm
218%lang(fr) %{_libdir}/aethera/i18n/koplugin_fr.ts
219%lang(pt) %{_libdir}/aethera/i18n/aethera_pt.qm
220%lang(pt) %{_libdir}/aethera/i18n/aethera_pt.ts
221%lang(pt) %{_libdir}/aethera/i18n/koplugin_pt.qm
222%lang(pt) %{_libdir}/aethera/i18n/koplugin_pt.ts
223%lang(pt) %{_libdir}/aethera/i18n/qt_pt.qm
224%lang(pt) %{_libdir}/aethera/i18n/qt_pt.ts
225%lang(ru) %{_libdir}/aethera/i18n/aethera_ru.qm
226%lang(ru) %{_libdir}/aethera/i18n/aethera_ru.ts
227%{_desktopdir}/aethera.desktop
228%{_iconsdir}/hicolor/*/apps/aethera.png
229%{_pixmapsdir}/*.png
230
231%files devel
232%defattr(644,root,root,755)
dd7fe118
ER
233%{_libdir}/libtkwidgets.a
234%{_libdir}/libwebdav.a
66af7acc
ER
235%{_includedir}/aethera
236%{_includedir}/tino
237%{_includedir}/tkcbase
238%{_includedir}/tkcssl
This page took 0.103854 seconds and 4 git commands to generate.