]> git.pld-linux.org Git - packages/adobe-flash.git/blame - adobe-flash.spec
up to 32.0.0.465
[packages/adobe-flash.git] / adobe-flash.spec
CommitLineData
d8f8df8e
ER
1# NOTES:
2# - release archives: http://helpx.adobe.com/flash-player/kb/archived-flash-player-versions.html
5e166df9
AF
3# TODO: package kde4 component
4#
aa3cbbce 5# Conditional build:
6%bcond_with license_agreement # generates package
5e166df9 7
e6d2385a 8%ifarch %{ix86}
e6d2385a
ER
9%define libmark %{nil}
10%endif
e0aacdca 11%ifarch %{x8664}
e6d2385a 12%define libmark ()(64bit)
b18d4034 13%endif
19d7e29f 14
fdeb48aa 15%define base_name adobe-flash
34f4f422 16%define rel 1
079932db
JB
17Summary: Flash (NPAPI based) plugin for Netscape-compatible WWW browsers
18Summary(pl.UTF-8): Wtyczka Flash oparta na NPAPI dla przeglądarek WWW zgodnych z Netscape
aa3cbbce 19%if %{with license_agreement}
20Name: %{base_name}
21%else
22Name: %{base_name}-installer
23%endif
0ce00974 24Version: 32.0.0.465
5e11dd18 25Release: %{rel}%{?with_license_agreement:wla}
4ec0200b 26Epoch: 1
53f15d83 27License: Free to use, non-distributable
01b5e1fb 28Group: X11/Applications/Multimedia
aa3cbbce 29%if %{with license_agreement}
20dd4477 30Source0: https://fpdownload.adobe.com/get/flashplayer/pdc/%{version}/flash_player_npapi_linux.i386.tar.gz?/flash-%{version}.i386.tar.gz
0ce00974 31# NoSource0-md5: d5630852001c5ddabdb2fa1915728e3a
364b3cd0 32NoSource: 0
20dd4477 33Source1: https://fpdownload.adobe.com/get/flashplayer/pdc/%{version}/flash_player_npapi_linux.x86_64.tar.gz?/flash-%{version}.x86_64.tar.gz
0ce00974 34# NoSource1-md5: 86a40a0464fbd3ae85b6376aa794e79a
e0aacdca 35NoSource: 1
18284157 36%else
63f88470 37Source3: http://svn.pld-linux.org/svn/license-installer/license-installer.sh
aee17b98 38# Source3-md5: 39dd73d36280769d0f74d642c7b0c6d3
aa3cbbce 39%endif
e7f111c3 40Source2: mms.cfg
fc9828eb
JR
41#URL: http://www.adobe.com/products/flashplayer/
42URL: http://labs.adobe.com/downloads/flashplayer.html
df5ca9b7 43Patch0: desktop.patch
b68eb59b 44%if %{with license_agreement}
df79ad5e 45BuildRequires: rpmbuild(macros) >= 1.357
5f855dbc 46BuildRequires: sed >= 4.0
df79ad5e 47Requires: browser-plugins >= 2.0
df5ca9b7 48Requires: hicolor-icon-theme
15b3da69 49# dlopened by player
b18d4034
AM
50Requires: libasound.so.2%{libmark}
51Requires: libcurl.so.4%{libmark}
94ae04b2 52%else
1fe695bf 53Requires: rpm-build-tools >= 4.4.37
9377eeca 54Requires: rpmbuild(macros) >= 1.544
533db319 55%endif
4608d459 56Requires: cpuinfo(sse2)
bcccd50e 57Provides: browser(flash)
5f855dbc 58Provides: macromedia-flash
533db319 59Obsoletes: flash-plugin
533db319 60Obsoletes: konqueror-plugin-macromedia-flash
5891b1a0 61Obsoletes: macromedia-flash
a00d2cc2
ER
62Obsoletes: mozilla-firefox-plugin-macromedia-flash
63Obsoletes: mozilla-plugin-macromedia-flash
e0aacdca 64ExclusiveArch: %{ix86} %{x8664}
01b5e1fb
PG
65BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
ed1085d2
ER
67%define _sysconfdir /etc/adobe
68
0fa08e0e
ER
69# So that building package on AC system won't write package name dep that Th system can't understand (libstdc++4)
70%define _noautoreqdep libstdc++.so.6
71
1fe30e9c
ER
72# No debuginfo to be stored
73%define _enable_debug_packages 0
74
01b5e1fb 75%description
65fff478 76Adobe(R) Flash(R) Player for Linux - the next-generation client
e338620c 77runtime for engaging with Flash content and applications on Linux.
53f15d83 78
079932db
JB
79This package contains NPAPI based plugin.
80
5f2286aa
JR
81%description -l pl.UTF-8
82Adobe(R) Flash(R) Player - środowisko nowej generacji do obsługi
83treści i aplikacji we Flashu pod Linuksem.
53f15d83 84
079932db
JB
85Ten pakiet zawiera wtyczkę opartą na NPAPI.
86
01b5e1fb 87%prep
aa3cbbce 88%if %{with license_agreement}
b18d4034
AM
89%ifarch %{x8664}
90%setup -q -T -c -b 1
91%else
3170126a 92%setup -q -T -c -b 0
b18d4034 93%endif
df5ca9b7 94%patch0 -p1
d4052f7c
ER
95
96%build
361299b8
JP
97s=$(echo '%{version}' | tr . ,)
98v=$(strings libflashplayer.so | grep -m 1 'LNX ' | sed 's/.*LNX //')
d4052f7c
ER
99if [ "$v" != "$s" ]; then
100 : wrong version
101 exit 1
102fi
3a950945 103%endif
d6511d55 104
01b5e1fb
PG
105%install
106rm -rf $RPM_BUILD_ROOT
ed1085d2 107%if %{without license_agreement}
aa3cbbce 108install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
109
18284157
ER
110sed -e '
111 s/@BASE_NAME@/%{base_name}/g
112 s/@TARGET_CPU@/%{_target_cpu}/g
113 s-@VERSION@-%{version}-g
114 s-@RELEASE@-%{release}-g
115 s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
03482652 116 s,@DATADIR@,%{_datadir}/%{base_name},g
77a494ed 117 s,@COPYSOURCES@,mms.cfg desktop.patch,g
63f88470 118' %{SOURCE3} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
aa3cbbce 119
63f88470 120cp -p %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
8524ac1d
ER
121cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/%{base_name}
122cp -p %{PATCH0} $RPM_BUILD_ROOT%{_datadir}/%{base_name}
aa3cbbce 123
124%else
125
5e166df9 126install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_browserpluginsdir},%{_bindir},%{_desktopdir},%{_iconsdir}}
63f88470
ER
127cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/mms.cfg
128install -p *.so $RPM_BUILD_ROOT%{_browserpluginsdir}
8524ac1d
ER
129install -p usr/bin/flash-player-properties $RPM_BUILD_ROOT%{_bindir}
130cp -p usr/share/applications/flash-player-properties.desktop $RPM_BUILD_ROOT%{_desktopdir}/flash-player-properties.desktop
8fb4d8b7 131cp -a usr/share/icons/* $RPM_BUILD_ROOT%{_iconsdir}
aa3cbbce 132%endif
133
01b5e1fb
PG
134%clean
135rm -rf $RPM_BUILD_ROOT
136
df79ad5e 137%if %{without license_agreement}
ae33c71b 138%post
18284157 139%{_bindir}/%{base_name}.install
533db319 140%else
df79ad5e
ER
141%post
142%update_browser_plugins
5e166df9 143%update_icon_cache hicolor
533db319 144
df79ad5e
ER
145%postun
146if [ "$1" = 0 ]; then
147 %update_browser_plugins
148fi
5e166df9 149%update_icon_cache hicolor
533db319
ER
150%endif
151
aa3cbbce 152%files
153%defattr(644,root,root,755)
df79ad5e 154%if %{without license_agreement}
aa3cbbce 155%attr(755,root,root) %{_bindir}/%{base_name}.install
156%{_datadir}/%{base_name}
aa3cbbce 157%else
baac248d 158%doc readme.txt
ed1085d2
ER
159%dir %{_sysconfdir}
160%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mms.cfg
8fb4d8b7 161%attr(755,root,root) %{_bindir}/flash-player-properties
079932db 162%attr(755,root,root) %{_browserpluginsdir}/libflashplayer.so
8fb4d8b7 163%{_desktopdir}/flash-player-properties.desktop
079932db 164%{_iconsdir}/hicolor/*/apps/flash-player-properties.png
aa3cbbce 165%endif
This page took 0.077938 seconds and 4 git commands to generate.