]> git.pld-linux.org Git - packages/adns.git/blame - adns.spec
- DESTDIR fixes.
[packages/adns.git] / adns.spec
CommitLineData
6aa67a8e 1# (fg) 20010103 Library stuff
2%define libmajor 1
3%define libname libadns%{libmajor}
4
5Name: adns
6Summary: Advanced, easy to use, asynchronous-capable DNS client library
7Version: 1.0
8Release: 6mdk
9License: GPL
10Group: Networking/Other
11URL: http://www.chiark.greenend.org.uk/~ian/adns/
12Source: ftp://ftp.chiark.greenend.org.uk/users/ian/adns/%{name}-%{version}.tar.bz2
13BuildRoot: %{_tmppath}/%{name}-%{version}
14Prefix: %{_prefix}
15Requires: %{libname} = %{version}
16
17%description
18adns is a resolver library for C (and C++) programs. In contrast with
19the existing interfaces, gethostbyname et al and libresolv, it has the
20following features:
21 * It is reasonably easy to use for simple programs which just want
22 to translate names to addresses, look up MX records, etc.
23 * It can be used in an asynchronous, non-blocking, manner. Many
24 queries can be handled simultaneously.
25 * Responses are decoded automatically into a natural representation
26 for a C program - there is no need to deal with DNS packet
27 formats.
28 * Sanity checking (eg, name syntax checking, reverse/forward
29 correspondence, CNAME pointing to CNAME) is performed
30 automatically.
31 * Time-to-live, CNAME and other similar information is returned in
32 an easy-to-use form, without getting in the way.
33 * There is no global state in the library; resolver state is an
34 opaque data structure which the client creates explicitly. A
35 program can have several instances of the resolver.
36 * Errors are reported to the application in a way that distinguishes
37 the various causes of failure properly.
38 * Understands conventional resolv.conf, but this can overridden by
39 environment variables.
40 * Flexibility. For example, the application can tell adns to: ignore
41 environment variables (for setuid programs), disable sanity checks
42 eg to return arbitrary data, override or ignore resolv.conf in
43 favour of supplied configuration, etc.
44 * Believed to be correct ! For example, will correctly back off to
45 TCP in case of long replies or queries, or to other nameservers if
46 several are available. It has sensible handling of bad responses
47 etc.
48
49%package -n %{libname}
50Group: System/Libraries
51Summary: Libraries needed to run applications using adns.
52
53%description -n %{libname}
54adns is a resolver library for C (and C++) programs. In contrast with
55the existing interfaces, gethostbyname et al and libresolv, it has the
56following features:
57 * It is reasonably easy to use for simple programs which just want
58 to translate names to addresses, look up MX records, etc.
59 * It can be used in an asynchronous, non-blocking, manner. Many
60 queries can be handled simultaneously.
61 * Responses are decoded automatically into a natural representation
62 for a C program - there is no need to deal with DNS packet
63 formats.
64 * Sanity checking (eg, name syntax checking, reverse/forward
65 correspondence, CNAME pointing to CNAME) is performed
66 automatically.
67 * Time-to-live, CNAME and other similar information is returned in
68 an easy-to-use form, without getting in the way.
69 * There is no global state in the library; resolver state is an
70 opaque data structure which the client creates explicitly. A
71 program can have several instances of the resolver.
72 * Errors are reported to the application in a way that distinguishes
73 the various causes of failure properly.
74 * Understands conventional resolv.conf, but this can overridden by
75 environment variables.
76 * Flexibility. For example, the application can tell adns to: ignore
77 environment variables (for setuid programs), disable sanity checks
78 eg to return arbitrary data, override or ignore resolv.conf in
79 favour of supplied configuration, etc.
80 * Believed to be correct ! For example, will correctly back off to
81 TCP in case of long replies or queries, or to other nameservers if
82 several are available. It has sensible handling of bad responses
83 etc.
84
85This package contains all of adns libraries.
86
87%package -n %{libname}-devel
88Summary: Advanced, easy to use, asynchronous-capable DNS client library
89Group: Development/C
90Requires: %{libname} = %{version}
91Provides: libadns-devel
92Obsoletes: adns-devel
93
94%description -n %{libname}-devel
95adns is a resolver library for C (and C++) programs. In contrast with
96the existing interfaces, gethostbyname et al and libresolv, it has the
97following features:
98 * It is reasonably easy to use for simple programs which just want
99 to translate names to addresses, look up MX records, etc.
100 * It can be used in an asynchronous, non-blocking, manner. Many
101 queries can be handled simultaneously.
102 * Responses are decoded automatically into a natural representation
103 for a C program - there is no need to deal with DNS packet
104 formats.
105 * Sanity checking (eg, name syntax checking, reverse/forward
106 correspondence, CNAME pointing to CNAME) is performed
107 automatically.
108 * Time-to-live, CNAME and other similar information is returned in
109 an easy-to-use form, without getting in the way.
110 * There is no global state in the library; resolver state is an
111 opaque data structure which the client creates explicitly. A
112 program can have several instances of the resolver.
113 * Errors are reported to the application in a way that distinguishes
114 the various causes of failure properly.
115 * Understands conventional resolv.conf, but this can overridden by
116 environment variables.
117 * Flexibility. For example, the application can tell adns to: ignore
118 environment variables (for setuid programs), disable sanity checks
119 eg to return arbitrary data, override or ignore resolv.conf in
120 favour of supplied configuration, etc.
121 * Believed to be correct ! For example, will correctly back off to
122 TCP in case of long replies or queries, or to other nameservers if
123 several are available. It has sensible handling of bad responses
124 etc.
125
126This package contains static libraries and header files need for development.
127
128%prep
129
130%setup -q
131
132%build
133%configure
134#CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix %{_prefix}
135%make
136
137%install
138mkdir -p $RPM_BUILD_ROOT%{_bindir}
139mkdir -p $RPM_BUILD_ROOT%{_includedir}
140mkdir -p $RPM_BUILD_ROOT%{_libdir}
141
142%makeinstall
143
144#make prefix=$RPM_BUILD_ROOT%{_prefix} install
145(set -e
146 cd $RPM_BUILD_ROOT%{_libdir}
147 ln -s libadns.so.? libadns.so
148)
149
150%post -n %{libname} -p /sbin/ldconfig
151
152%postun -n %{libname} -p /sbin/ldconfig
153
154%clean
155rm -fr $RPM_BUILD_ROOT
156
157%files
158%defattr(-,root,root,0755)
159%doc README TODO changelog
160%{_bindir}/*
161
162%files -n %{libname}
163%defattr(-,root,root,755)
164%{_libdir}/*.so.*
165
166%files -n %{libname}-devel
167%defattr(-,root,root,0755)
168%{_includedir}/*
169%{_libdir}/*.so
170%{_libdir}/*.a
171
172%changelog
173
174* Wed Jul 18 2001 Francis Galiegue <fg@mandrakesoft.com> 1.0-6mdk
175
176- Submit SRPM this time...
177- Changes in -5mdk were:
178 * recompile to get correct distrib tag
179 * use -p in %%post{,un}
180 * s,Copyright,License,
181 * fixed summary-too-long error
182
183* Thu Jan 04 2001 Francis Galiegue <fg@mandrakesoft.com> 1.0-4mdk
184
185- libadns1-devel obsoletes adns-devel - lart me again
186
187* Wed Jan 03 2001 Francis Galiegue <fg@mandrakesoft.com> 1.0-3mdk
188
189- Gee, what a crotch! Forgot to submit the source RPM...
190
191* Wed Jan 03 2001 Francis Galiegue <fg@mandrakesoft.com> 1.0-2mdk
192
193- Follow policy for libraries
194- Don't use macros when not needed
195
196* Mon Nov 13 2000 Geoffrey Lee <snailtalk@mandrakesoft.com> 1.0-1mdk
197- new and shiny release.
198
199* Fri Jul 21 2000 Warly <warly@mandrakesoft.com> 0.8-1mdk
200- new release
201
202* Tue May 23 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 0.7-4mdk
203- Definitively remove the make check (stupid).
204
205* Sun May 21 2000 David BAUDENS <baudens@mandrakesoft.com> 0.7-3mdk
206- Work around for i486
207- Fix prefix
208- Use %%{_tmppath} for BuildRoot
209
210* Thu Mar 23 2000 Florent Villard <warly@mandrakesoft.com> 0.7-2mdk
211- rebuild
212
213* Fri Mar 3 2000 Frederic Lepied <flepied@mandrakesoft.com> 0.7-1mdk
214- 0.7.
215- clean spec and split in 2 packages.
216
217* Mon Feb 07 2000 Lenny Cartier <lenny@mandrakesoft.com>
218- new in contribs
219- used srpm provided by Vincent Danen <vdanen@linux-mandrake.com>
220
221* Sun Jan 30 2000 Vincent Danen <vdanen@linux-mandrake.com>
222- initial specfile
223- bzip sources
This page took 0.25435 seconds and 4 git commands to generate.