]> git.pld-linux.org Git - packages/acx.git/blobdiff - acx.spec
- new version of ACX driver.
[packages/acx.git] / acx.spec
index 39612c3b0f76f41a20a22a8aab8f035cce900244..c252e64858333df97c868a6403d786b4b6cbb36c 100644 (file)
--- a/acx.spec
+++ b/acx.spec
@@ -1,25 +1,27 @@
+# TODO:
+# - add firmware download?
 #
 # Conditional build:
 %bcond_without dist_kernel     # without distribution kernel
 %bcond_without smp             # don't build SMP module
 #
-# TODO:
-# - add firmware download?
+%ifarch sparc
+%undefine      with_smp
+%endif
 #
 Summary:       Linux driver for WLAN card base on ACX100
 Summary(pl):   Sterownik dla Linuksa do kart bezprzewodowych na ukĀ³adzie ACX100
-Name:          acx100
-Version:       0.2.0pre8_plus_fixes_40
+Name:          acx
+Version:       20060215
 %define        _rel    1
 Release:       %{_rel}
 License:       MPL or GPL
 Group:         Base/Kernel
-Source0:       http://rhlx01.fht-esslingen.de/~andi/acx100/%{name}-%{version}.tar.bz2
-# Source0-md5: 5b206a75cd2372bb2c822e74f971bdfb
+Source0:       http://195.66.192.167/linux/acx_patches/%{name}-%{version}.tar.bz2
+# Source0-md5: 95bcd5df2365dfcfc78169b0331f69a2
 URL:           http://acx100.sourceforge.net/
 %{?with_dist_kernel:BuildRequires:     kernel-module-build >= 2.6.3}
-BuildRequires: %{kgcc_package}
-BuildRequires: rpmbuild(macros) >= 1.118
+BuildRequires: rpmbuild(macros) >= 1.286
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -57,35 +59,51 @@ Linux SMP driver for WLAN card base on ACX100.
 Sterownik dla Linuksa SMP do kart bezprzewodowych na ukĀ³adzie ACX100.
 
 %prep
-%setup -q
+#setup -q -n %{name}-%{version}
+cd $RPM_BUILD_DIR
+install -d %{name}-%{version}
+cd %{name}-%{version}
+tar xfj %{SOURCE0}
+/bin/chmod -Rf a+rX,u+w,g-w,o-w .
 
 %define buildconfigs %{?with_dist_kernel:%{?with_smp:smp} up}%{!?with_dist_kernel:nondist}
 
 %build
-mv src/Makefile2.6 src/Makefile
-for cfg in %{buildconfigs}; do
-       mkdir -p modules/$cfg
-       if [ ! -r "%{_kernelsrcdir}/config-$cfg" ]; then
-               exit 1
-       fi
-       rm -f include/asm
-       chmod 000 modules
-       install -d include/{linux,config}
-       %{__make} -C %{_kernelsrcdir} clean \
-               SUBDIRS=$PWD/src \
-               O=$PWD \
-               %{?with_verbose:V=1}
-       install -d include/config
-       chmod 700 modules
-       ln -sf %{_kernelsrcdir}/config-$cfg .config
-       ln -sf %{_kernelsrcdir}/include/linux/autoconf-${cfg}.h include/linux/autoconf.h
-       ln -sf %{_kernelsrcdir}/include/asm-%{_target_base_arch} include/asm #FIXME
-       touch include/config/MARKER
-       %{__make} -C %{_kernelsrcdir} modules \
-               SUBDIRS=$PWD/src \
-               O=$PWD \
-               %{?with_verbose:V=1}
-       mv src/*.ko modules/$cfg/
+# kernel module(s)
+cd %{name}-%{version}
+#cd src
+for cfg in %{?with_dist_kernel:%{?with_smp:smp} up}%{!?with_dist_kernel:nondist}; do
+        if [ ! -r "%{_kernelsrcdir}/config-$cfg" ]; then
+                exit 1
+        fi
+        install -d o/include/linux
+        ln -sf %{_kernelsrcdir}/config-$cfg o/.config
+        ln -sf %{_kernelsrcdir}/Module.symvers-$cfg o/Module.symvers
+        ln -sf %{_kernelsrcdir}/include/linux/autoconf-$cfg.h o/include/linux/autoconf.h
+%if %{with dist_kernel}
+        %{__make} -C %{_kernelsrcdir} O=$PWD/o prepare scripts
+%else
+        install -d o/include/config
+        touch o/include/config/MARKER
+        ln -sf %{_kernelsrcdir}/scripts o/scripts
+%endif
+#
+#       patching/creating makefile(s) (optional)
+#
+        %{__make} -C %{_kernelsrcdir} clean \
+                RCS_FIND_IGNORE="-name '*.ko' -o" \
+                SYSSRC=%{_kernelsrcdir} \
+                SYSOUT=$PWD/o \
+                M=$PWD O=$PWD/o \
+                %{?with_verbose:V=1}
+        %{__make} -C %{_kernelsrcdir} modules \
+                CC="%{__cc}" CPP="%{__cpp}" \
+                SYSSRC=%{_kernelsrcdir} \
+                SYSOUT=$PWD/o \
+                M=$PWD O=$PWD/o \
+                %{?with_verbose:V=1}
+
+        mv MODULE_NAME{,-$cfg}.ko
 done
 
 %install
This page took 0.097641 seconds and 4 git commands to generate.