]> git.pld-linux.org Git - packages/acroread.git/commitdiff
- use new cvs layout
authorpawelz <pawelz@pld-linux.org>
Mon, 26 Oct 2009 07:42:03 +0000 (07:42 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- BR rpm-build-tools >= 0:4.4.35 (needs builder.sh that uses new cvs layout)

Changed files:
    acroread.spec -> 1.96
    license-installer.sh -> 1.13

acroread.spec
license-installer.sh

index 9bc05fbb7671ae78cf6612c08aca0ab6fdb034ac..2a53f7dceebf48284675c6aca846c64fe5263216 100644 (file)
@@ -37,7 +37,7 @@ BuildRequires:        rpmbuild(macros) >= 1.357
 Requires:      openldap-libs < 2.5
 Requires:      openldap-libs >= 2.4
 %else
-Requires:      rpm-build-tools
+Requires:      rpm-build-tools >= 0:4.4.35
 %endif
 ExclusiveArch: %{ix86}
 ExcludeArch:   i386
index 1ec624aceffc41e63028d85c6464e273b20c09e7..110c73a4a14279ba432d64c96ed90233511e1bf6 100644 (file)
@@ -1,12 +1,11 @@
 #!/bin/sh
 if [ "$1" = "--with" -a "$2" = "license_agreement" ]; then
        tmp=$(mktemp -d)
-       SPECDIR=`rpm --define "_topdir $tmp" --eval "%{_specdir}"`
        SRPMDIR=`rpm --define "_topdir $tmp" --eval "%{_srcrpmdir}"`
-       SOURCEDIR=`rpm --define "_topdir $tmp" --eval "%{_sourcedir}"`
        BUILDDIR=`rpm --define "_topdir $tmp" --eval "%{_builddir}"`
        RPMDIR=`rpm --define "_topdir $tmp" --eval "%{_rpmdir}"`
-       mkdir -p $SPECDIR $SRPMDIR $RPMDIR $SOURCEDIR $BUILDDIR
+       PACKAGEDIR="$tmp/packages/acroread"
+       mkdir -p $SRPMDIR $RPMDIR $BUILDDIR $PACKAGEDIR
 
        if echo "$3" | grep '\.src\.rpm$' >/dev/null; then
                (
@@ -16,20 +15,20 @@ if [ "$1" = "--with" -a "$2" = "license_agreement" ]; then
                else
                        cp -f "$3" $SRPMDIR
                fi
-               rpm2cpio `basename "$3"` | ( cd $SPECDIR; cpio -i @BASE_NAME@.spec )
+               rpm2cpio `basename "$3"` | ( cd $PACKAGEDIR; cpio -i @BASE_NAME@.spec )
                if [ '@COPYSOURCES@' != '@'COPYSOURCES'@' ]; then
-                       rpm2cpio `basename "$3"` | ( cd $SOURCEDIR; cpio -i @COPYSOURCES@ )
+                       rpm2cpio `basename "$3"` | ( cd $PACKAGEDIR; cpio -i @COPYSOURCES@ )
                fi
                )
        else
-               cp -i "$3" $SPECDIR || exit 1
+               cp -i "$3" $PACKAGEDIR || exit 1
                if [ '@COPYSOURCES@' != '@'COPYSOURCES'@' ]; then
                        for i in @COPYSOURCES@; do
-                               cp -i @DATADIR@/$i $SOURCEDIR/$i || exit 1
+                               cp -i @DATADIR@/$i $PACKAGEDIR/$i || exit 1
                        done
                fi
        fi
-       ( cd $SPECDIR
+       ( cd $PACKAGEDIR
        nd=
        if [ '@USE_DISTFILES@' = 'no' ]; then
                nd=-nd
This page took 0.088441 seconds and 4 git commands to generate.