]> git.pld-linux.org Git - packages/acroread.git/blobdiff - license-installer.sh
- one $SRPMDIR is enough
[packages/acroread.git] / license-installer.sh
index 46041626853219190d8b3c9c0ef1242c5584d813..1ec624aceffc41e63028d85c6464e273b20c09e7 100644 (file)
@@ -1,42 +1,45 @@
 #!/bin/sh
 if [ "$1" = "--with" -a "$2" = "license_agreement" ]; then
-       TMPDIR=`rpm --eval "%{tmpdir}"`; export TMPDIR
-       SPECDIR=`rpm --eval "%{_specdir}"`; export SPECDIR
-       SRPMDIR=`rpm --eval "%{_srcrpmdir}"`; export SRPMDIR
-       SOURCEDIR=`rpm --eval "%{_sourcedir}"`; export SOURCEDIR
-       BUILDDIR=`rpm --eval "%{_builddir}"`; export BUILDDIR
-       RPMDIR=`rpm --eval "%{_rpmdir}"`; export RPMDIR
-       BACKUP=0
-       mkdir -p $TMPDIR $SPECDIR $SRPMDIR $RPMDIR $SRPMDIR $SOURCEDIR $BUILDDIR
-       if [ -f $SPECDIR/@BASE_NAME@.spec ]; then
-               BACKUP=1
-               mv -f $SPECDIR/@BASE_NAME@.spec $SPECDIR/@BASE_NAME@.spec.prev
-       fi
+       tmp=$(mktemp -d)
+       SPECDIR=`rpm --define "_topdir $tmp" --eval "%{_specdir}"`
+       SRPMDIR=`rpm --define "_topdir $tmp" --eval "%{_srcrpmdir}"`
+       SOURCEDIR=`rpm --define "_topdir $tmp" --eval "%{_sourcedir}"`
+       BUILDDIR=`rpm --define "_topdir $tmp" --eval "%{_builddir}"`
+       RPMDIR=`rpm --define "_topdir $tmp" --eval "%{_rpmdir}"`
+       mkdir -p $SPECDIR $SRPMDIR $RPMDIR $SOURCEDIR $BUILDDIR
+
        if echo "$3" | grep '\.src\.rpm$' >/dev/null; then
-               ( cd $SRPMDIR
+               (
                if echo "$3" | grep '://' >/dev/null; then
+                       cd $SRPMDIR
                        wget --passive-ftp -t0 "$3"
                else
-                       cp -f "$3" .
+                       cp -f "$3" $SRPMDIR
+               fi
+               rpm2cpio `basename "$3"` | ( cd $SPECDIR; cpio -i @BASE_NAME@.spec )
+               if [ '@COPYSOURCES@' != '@'COPYSOURCES'@' ]; then
+                       rpm2cpio `basename "$3"` | ( cd $SOURCEDIR; cpio -i @COPYSOURCES@ )
                fi
-               rpm2cpio `basename "$3"` | ( cd $TMPDIR; cpio -i @BASE_NAME@.spec )
-               )
-               cp -i $TMPDIR/@BASE_NAME@.spec $SPECDIR/@BASE_NAME@.spec || exit 1
+               )
        else
                cp -i "$3" $SPECDIR || exit 1
+               if [ '@COPYSOURCES@' != '@'COPYSOURCES'@' ]; then
+                       for i in @COPYSOURCES@; do
+                               cp -i @DATADIR@/$i $SOURCEDIR/$i || exit 1
+                       done
+               fi
        fi
        ( cd $SPECDIR
-       /usr/bin/builder -nm -nc -ncs --with license_agreement --opts --target=@TARGET_CPU@ @BASE_NAME@.spec
+       nd=
+       if [ '@USE_DISTFILES@' = 'no' ]; then
+               nd=-nd
+       fi
+       /usr/bin/builder --define _topdir $tmp $nd -nm -nc -ncs --with license_agreement --target @TARGET_CPU@ @BASE_NAME@.spec
        if [ "$?" -ne 0 ]; then
                exit 2
        fi
        RPMNAMES="$RPMDIR/@BASE_NAME@-@VERSION@-@RELEASE@wla.@TARGET_CPU@.rpm"
        rpm -Uhv $RPMNAMES || echo -e "Install manually the file(s):\n   $RPMNAMES" )
-       if [ "$BACKUP" -eq 1 ]; then
-               if [ -f $SPECDIR/@BASE_NAME@.spec.prev ]; then
-                       mv -f $SPECDIR/@BASE_NAME@.spec.prev $SPECDIR/@BASE_NAME@.spec
-               fi
-       fi
 else
        if [ "@LICENSE@" != '@'LICENSE'@' ]; then
                cat @LICENSE@
This page took 0.075118 seconds and 4 git commands to generate.