]> git.pld-linux.org Git - packages/acroread.git/blobdiff - license-installer.sh
- support for disabling distfiles
[packages/acroread.git] / license-installer.sh
index 7dcd443d9cd36a8eecda071c56a9acbad74ca8f6..07b3cb1db5ac904a33b7d86461871382f32eb696 100644 (file)
@@ -1,48 +1,57 @@
 #!/bin/sh
 if [ "$1" = "--with" -a "$2" = "license_agreement" ]; then
-       TMPDIR=`rpm --eval "%{tmpdir}"`; export TMPDIR
-       SPECDIR=`rpm --eval "%{_specdir}"`; export SPECDIR
-       SRPMDIR=`rpm --eval "%{_srcrpmdir}"`; export SRPMDIR
-       SOURCEDIR=`rpm --eval "%{_sourcedir}"`; export SOURCEDIR
-       BUILDDIR=`rpm --eval "%{_builddir}"`; export BUILDDIR
-       RPMDIR=`rpm --eval "%{_rpmdir}"`; export RPMDIR
-       BACKUP=0
-       mkdir -p $TMPDIR $SPECDIR $SRPMDIR $RPMDIR $SRPMDIR $SOURCEDIR $BUILDDIR
-       if [ -f $SPECDIR/@BASE_NAME@.spec ]; then
-               BACKUP=1
-               mv -f $SPECDIR/@BASE_NAME@.spec $SPECDIR/@BASE_NAME@.spec.prev
-       fi
+       tmp=$(mktemp -d)
+       SPECDIR=`rpm --define "_topdir $tmp" --eval "%{_specdir}"`
+       SRPMDIR=`rpm --define "_topdir $tmp" --eval "%{_srcrpmdir}"`
+       SOURCEDIR=`rpm --define "_topdir $tmp" --eval "%{_sourcedir}"`
+       BUILDDIR=`rpm --define "_topdir $tmp" --eval "%{_builddir}"`
+       RPMDIR=`rpm --define "_topdir $tmp" --eval "%{_rpmdir}"`
+       mkdir -p $SPECDIR $SRPMDIR $RPMDIR $SRPMDIR $SOURCEDIR $BUILDDIR
+
        if echo "$3" | grep '\.src\.rpm$' >/dev/null; then
-               ( cd $SRPMDIR
+               (
                if echo "$3" | grep '://' >/dev/null; then
+                       cd $SRPMDIR
                        wget --passive-ftp -t0 "$3"
                else
-                       cp -f "$3" .
+                       cp -f "$3" $SRPMDIR
+               fi
+               rpm2cpio `basename "$3"` | ( cd $SPECDIR; cpio -i @BASE_NAME@.spec )
+               if [ '@COPYSOURCES@' != '@'COPYSOURCES'@' ]; then
+                       rpm2cpio `basename "$3"` | ( cd $SOURCEDIR; cpio -i @COPYSOURCES@ )
                fi
-               rpm2cpio `basename "$3"` | ( cd $TMPDIR; cpio -i @BASE_NAME@.spec )
-               )
-               cp -i $TMPDIR/@BASE_NAME@.spec $SPECDIR/@BASE_NAME@.spec || exit 1
+               )
        else
                cp -i "$3" $SPECDIR || exit 1
+               if [ '@COPYSOURCES@' != '@'COPYSOURCES'@' ]; then
+                       for i in @COPYSOURCES@; do
+                               cp -i @DATADIR@/$i $SOURCEDIR/$i || exit 1
+                       done
+               fi
        fi
        ( cd $SPECDIR
-       /usr/bin/builder -nc -ncs --with license_agreement --opts --target=@TARGET_CPU@ @BASE_NAME@.spec
+       nd=
+       if [ '@USE_DISTFILES@' = 'no' ]; then
+               nd=-nd
+       fi
+       /usr/bin/builder --define _topdir $tmp $nd -nm -nc -ncs --with license_agreement --target @TARGET_CPU@ @BASE_NAME@.spec
        if [ "$?" -ne 0 ]; then
                exit 2
        fi
        RPMNAMES="$RPMDIR/@BASE_NAME@-@VERSION@-@RELEASE@wla.@TARGET_CPU@.rpm"
-       rpm -U $RPMNAMES || echo -e "Install manually the file(s):\n   $RPMNAMES" )
-       if [ "$BACKUP" -eq 1 ]; then
-               if [ -f $SPECDIR/@BASE_NAME@.spec.prev ]; then
-                       mv -f $SPECDIR/@BASE_NAME@.spec.prev $SPECDIR/@BASE_NAME@.spec
-               fi
-       fi
+       rpm -Uhv $RPMNAMES || echo -e "Install manually the file(s):\n   $RPMNAMES" )
 else
-       echo "
+       if [ "@LICENSE@" != '@'LICENSE'@' ]; then
+               cat @LICENSE@
+               echo "
+If you accept the above license rebuild the package using:
+"
+       else
+               echo "
 License issues made us not to include inherent files into
 this package by default. If you want to create full working
 package please build it with the following command:
-
-$0 --with license_agreement @SPECFILE@
 "
+       fi
+       echo "$0 --with license_agreement @SPECFILE@"
 fi
This page took 0.043409 seconds and 4 git commands to generate.